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C H A P T E R 1

Introducing Optimal Trace Enterprise Server

Optimal Trace Enterprise Server provides access to a centralized repository of Optimal Trace
projects and manages communication between multiple Optimal Trace Enterprise users. A
computer that hosts the server software is referred to as a repository server.
Optimal Trace Enterprise Server controls access to the database, manages concurrent editing
of projects by multiple users and ensures the integrity of data being written to the database. If
you wish to make use of the collaboration features in Optimal Trace, you will need at least one
repository server on your network.
Optimal Trace Enterprise Server requires a dedicated server machine on your network to act as
the repository server. This machine should be connected to the network in such a way as to be
accessible from every workstation on which you will be running Optimal Trace. Optimal Trace
Enterprise Server connects to a database (Oracle, Microsoft SQL Server, or MySQL) running
locally on the repository server or on another machine available on the network.

Who Should Read This Guide
This document is intended for database administrators (DBAs) who are responsible for the
installation and maintenance of Optimal Trace Enterprise Server.

Getting Help
If ever you have any problems or you would like additional technical information or advice,
there are several sources. In some countries, product support from Micro Focus may be available
only to customers who have maintenance agreements.
If you obtained this product directly from Micro Focus, contact us as described below. If you
obtained it from another source, such as an authorized distributor, contact them for help first.
If they are unable to help, contact us as described below.
However you contact us, please try to include the information below, if you have it. The more
information you can give, the better Product Support can help you. But if you don't know all
the answers, or you think some are irrelevant to your problem, please give whatever information
you have.
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• The name, release (version), and build number of the product.

• Installation information, including installed options, whether the product uses local or network
databases, whether it is installed in the default directories, whether it is a standalone or
network installation, and whether it is a client or server installation.

• Environment information, such as the operating system and release on which the product is
installed, memory, hardware/network specifications, and the names and releases of other
applications that were running.

• The location of the problem in the product software, and the actions taken before the problem
occurred.

• The exact product error message, if any.

• The exact application, licensing, or operating system error messages, if any.

• Your Micro Focus client, office, or site number, if available.

Contact

Our web site gives up-to-date details of contact numbers and addresses. To connect, enter
www.microfocus.com in your browser to go to the Micro Focus home page, or go to
http://supportline.microfocus.com.
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C H A P T E R 2

Running Optimal Trace Enterprise Server

This section describes how to run Optimal Trace Enterprise Server. For instructions regarding
licensing and upgrading Optimal Trace Enterprise Server, refer to the Optimal Trace Installation
Guide.

Running Optimal Trace Enterprise Server
To run Optimal Trace Enterprise Server:

1. Click Start>Programs>Micro Focus>Optimal Trace Enterprise>Optimal Trace
Server>Optimal Trace Server.
The Optimal Trace Server dialog box appears.

2. Enter the database connection information.
3. Click Start.

The Starting Server dialog box appears and displays a message stating the server has
started successfully.

4. Click OK.
The Starting Server dialog box closes and the Optimal Trace Server dialog box displays
a Stop button. You must keep this dialog box open while the Optimal Trace Enterprise
Server is running.

Checking the Connection
After the server is started, check that the Optimal Trace Enterprise client can connect to and
use the Optimal Trace Enterprise Server. To check the connection:

1. Open Optimal Trace Enterprise client.
2. Click Tools>General Options. The General Options dialog box appears.
3. Click the Server Settings tab.
4. Type the host name where your Optimal Trace Enterprise Server is installed.
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5. Accept the default port and polling interval settings.
6. Click Save.
7. Create a new projectn the repository by selecting Create a new remote project in the

repository.
8. Add some data and save. There will be no error messages if everything is installed and

configured correctly. If there are problems, click Test Connection to test the connection
and send the results to your network administrator.

Stopping the Server
To stop the server, click Stop. This will stop all server processes started by the Optimal Trace
Enterprise Server.

Configure as a Service
Optimal Trace Server is automatically registered as a Windows service during installation.
Before starting the service you must run through the steps in Running Optimal Trace Enterprise
Server [p. 7] to ensure that the server can be started with the specified options. To start or stop
the service from the Microsoft Management Console:

1. Ensure that Optimal Trace Server is not already running.
2. Click Start>Settings>Control Panel>Administrative Tools>Services.
3. Right-click Optimal Trace Server and choose Start or Stop.

Stopping the Service
To stop the Optimal Trace Windows service:

1. Navigate to the Control Panel and click Administrative Tools>Services.
2. Navigate to Micro Focus Optimal Trace Server <RELEASE_NUM>.
3. Right-click and choose Properties.
4. Click Stop to stop the service if it is running.
5. Change the Startup type to Manual.

Email Configuration
The Optimal Trace Email Settings are used to configure access to an SMTP server. Optimal
Trace notification emails are sent to registered users by the Optimal Trace Server using the
SMTP server details you provide. Your mail server administrator should ensure that the Optimal
Trace Email Settings that you use will allow sending mail to all of your Optimal Trace users'
email addresses. It is best to discuss the Email Settings that Optimal Trace Server uses with
your company email Administrator. It is best practice to create a dedicated email account for
use by Optimal Trace Server. See the Optimal Trace Enterprise Help for more information on
the Notifications feature.
Your email administrator will provide:

• The name of your company's mail server (SMTP server)
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• The email user name that Optimal Trace Server will use (Username)

• The password for the Optimal Trace Server user name (Password)

• Whether or not the email server requires a Secure Connection (SSL).

When you have finished entering the email configuration, you can test that it's working by
clicking Test Email Settings(and enter your own email address to receive the test message).
Note also that some spam filters may block this message, so you will need to work through this
process with your email Administrator. Sample values would be something as follows:
SMTP Server: WidgetCoSMTPMailServer
Username: <Optimal Trace server user>@widgetcodomain.widgetco.com
Password: <password>
The test email that you receive will simply contain Optimal Trace Email Settings Test in the
subject line. If you do not receive a mail, you may need to check your email servers spam filter
as the message may have been blocked (e.g. if you do not specify a domain in your user name,
some spam filters may block the message).

NOTE
Optimal Trace supports SMTP authentication (RFC 2554 - http://www.ietf.org/rfc/rfc2554.txt)
mechanisms LOGIN and PLAIN.

Example Email Configuration Using GMail
Google's GMail can be configured to be used by Optimal Trace Server as the mail notifier. This
can be useful if you are evaluating Optimal Trace Server and don't want to set up a dedicated
Optimal Trace user on your company's email system. Enter the following settings if you want
Optimal Trace Server to use your GMail mail account to send notifications from:

• SMTP Server: smtp.gmail.com

• Username: <you>@gmail.com

• Password: <your gmail password>

• Use Secure Connection: checked

Setting Up Windows Integrated Authentication
Optimal Trace supports two types of authentication modes:

Basic Authentication
User authentication for accessing Optimal Trace projects is managed at the product-level
by Optimal Trace. When using basic authentication, user credentials are manually created,
saved, and managed using Optimal Trace Administrator.

Windows Integrated Authentication
User authentication for accessing Optimal Trace projects is delegated to using existing
user credentials stored on a domain controller on a network. Using Windows Integrated
Authentication allows you to suppress a login prompt when accessing Optimal Trace
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projects provided users have a valid Windows user account name and password and are
currently logged into the domain controller.

NOTE
When using either type of authentication mode, you must configure user permissions in
Optimal Trace Administrator to open, modify, and delete Optimal Trace projects . For
more information, refer to the Optimal Trace Administrator User Guide.

This topic describes the steps required to set up Windows Integrated Authentication using NTLM
or Kerberos authentication protocols.

NOTE
Optimal Trace supports other types of authentication protocols, however, only the configuration
files for NTLM and Kerberos are installed with Optimal Trace.

1. On the Advanced tab of the Optimal Trace Server dialog box, select Use Windows
Integrated Authentication, and then restart the server.
Selecting this option applies Windows Integrated Authentication to all security enabled
projects in the Optimal Trace repository being accessed from this server.

2. Configure the Kerberos initialization file (krb5.ini).
This file specifies the default realm and key distribution center. This file is installed with
Optimal Trace Enterprise in the following location:
<OS_DIR>\krb5.ini (for example: C:\WINXP\krb5.ini)
Configure the file to use the desired realm and key distribution center as in the following
example:
[libdefaults]

default_realm = EXAMPLE.COM

[realms]

EXAMPLE.COM = {

kdc = dc-01.example.com:88

}

NOTE
This file must be installed on every Optimal Trace Enterprise client computer.

3. Optionally, configure the Java Authentication and Authorization Service (JAAS) file
(ot_jaas.config).
This file specifies the type of authentication protocol login module and sets parameter
values for the module. This file is installed in the following location of the Optimal Trace
Enterprise client installation folder:
<PRODUCT_INSTALL_DIR>\Program Files\Micro Focus\Optimal Trace\Optimal Trace

Enterprise Edition\ot_jaas.config

By default, the JAAS file specifies NTLM and Kerberos login modules and their parameters
as follows:
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OTAuthentication{

com.sun.security.auth.module.NTLoginModule required debug=false debugNative=false;

com.sun.security.auth.module.Krb5LoginModule required client=true debug=false

useTicketCache=true tryFirstPass=true;}

NOTE
You can add additional login modules in this file. The login module specification must
appear between the brackets after OTAuthentication and be terminated with a semi-colon.
This file must be installed on every Optimal Trace Enterprise client computer.

About Migrating an Optimal Trace Database
When upgrading to the current release of Optimal Trace, you may need to migrate your Optimal
Trace database depending on which Optimal Trace release it was created in. The list below
describes the different considerations for migrating an Optimal Trace database.

Prior to Optimal Trace 5.0
When migrating databases created in an Optimal Trace release prior to 5.0, you must
perform an incremental migration. For more information, see Migrating Databases Created
Prior to 5.0 [p. 11].

Optimal Trace 5.0
If your database was created in Optimal Trace 5.0, you must use the Migration utility.
For more information, see Migrating Databases from 5.0 [p. 11].

Optimal Trace 5.1
If your database was created in Optimal Trace 5.1, you are prompted to migrate the
database when you start Optimal Trace Enterprise Server. For more information, see
Migrating Databases from 5.1 to 5.3 [p. 13].

Optimal Trace 5.2
For SQL Server databases created in Optimal Trace 5.2, you are prompted to migrate the
database when you start Optimal Trace Enterprise Server. You do not have to migrate an
Oracle or MySQL database created in Optimal Trace 5.2.

Migrating Databases Created Prior to 5.0
To migrate remote projects stored in a database created in an Optimal Trace release prior to 5.0,
you must perform an incremental migration. First, you must migrate the projects or databases
to 5.0, and then proceed with the migration from 5.0 to the current release of Optimal Trace.
For more information, see Migrating Databases from 5.0 [p. 11], and Migrating Databases from
5.1 to 5.3 [p. 13].

Migrating Databases from 5.0
To migrate remote projects stored in an Optimal Trace 5.0 database to work with the current
release of Optimal Trace, you must use the Migration utility. Prior to migrating your existing
database, you must create a new database in which to migrate data.
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NOTE
Depending on the size of your database, it may take several hours to migrate your data from
5.0. Additionally, the database transaction log may grow to approximately 5 times the size of
the database. Make sure you allocate enough space for the database transaction log. For SQL
Server databases, you can reduce the size of the transaction log. For more information, see
Reducing the Transaction Log Size for a SQL Server Database [p. 12].

This topic describes how to use the Migration utility to migrate a 5.0 database to work with
the current release of Optimal Trace.

1. Stop your Optimal Trace server. For more information, see Stopping the Server [p. 14].
2. Back up your database. For more information, see Backing Up an Optimal Trace Database

[p. 13].
3. Create a new database in which to migrate your data. Click Start>Programs>Micro

Focus>Optimal Trace Enterprise>Optimal Trace Server>Optimal Trace Migration
Utility. The Optimal Trace Migration Utility appears.

4. In the Database Host Name box, type the database host name.
5. Select the database type (MySQL, SQLSERVER, or Oracle) from the Database Type list.
6. Type the database port number if not using the default port in the Database Port box.
7. Under Source Database, type the name of the database to migrate and specify the user

name and password in the appropriate boxes.
8. UnderDestinationDatabase, type the new name of the database and specify the user name

and password in the appropriate boxes.
9. Click Migrate.

The Migration utility runs and migrates remote projects stored in the database to work with
the current release.

Reducing the Transaction Log Size for a SQL Server Database
To reduce the size of the transaction log created during the migration of a SQL Server database,
perform the following steps prior to starting the Optimal Trace Migration utility:

1. Open the server.properties file from the following location:
<INSTALL_DIR>\Program Files\Micro Focus\Optimal Trace\Optimal Trace Server

Edition\

2. Change the value of useSingleTransaction to false.
3. Save and close the file.
4. In SQL Server EnterpriseManager, openDatabase Properties set theRecovery model

option to Simple.
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5. Start the Optimal Trace Migration utility.

NOTE
After migrating your database, remember to reset the Recovery model option to its original
value.

Migrating Databases from 5.1 to 5.3
To migrate remote projects stored in an Optimal Trace 5.1 database to work with the current
release of Optimal Trace, perform the following steps:

1. Back up your database. For more information, see Backing Up an Optimal Trace Database
[p. 13].

2. Install the current release of Optimal Trace Enterprise Server.
3. Start Optimal Trace Enterprise Server and open your existing Optimal Trace 5.1 database.

A message box appears prompting you to migrate your database.

4. Click Yes to migrate the database.

Migrating Local Projects
When attempting to open an Optimal Trace local project created prior to the current release,
you will receive a message asking you to confirm that you want to migrate your project to the
current release. Click Yes to open the project. When you click Save or you choose File>Save,
the project is migrated to the current release of Optimal Trace.

Backing Up an Optimal Trace Database
Before upgrading from a previous release, Micro Focus recommends backing up your database.
This is recommended to safeguard your data in the rare case where an error occurs during the
migration process that leaves your data in a half-migrated state.

Backing up a MySQL Database
To backup a MySQL database:

1. Open a command prompt.
2. Change directory to c:\mysql\bin or wherever MySQL is installed.
3. Type mysqldump -q optimaltrace > c:\temp\OptimalTrace-data-backup.sql. You

may need user/password included in the command line for this.

This creates a backup file called OptimalTrace-data-backup.sql in the c:\temp\ directory.
You can move this somewhere else for safe keeping.

Backing up an Oracle Database
Creating a backup of the tablespace which contains the Optimal Trace schema is beyond the
scope of this document. Please contact your Oracle Database Administrator or refer to Oracle
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documentation. To avoid a potential problem with Oracle's OPEN_CURSORS setting that you
may encounter when migrating, it is best to set this Oracle setting now. To do this, change the
value of OPEN_CURSORS to 20000 in the following files:

• init.ora in <oracle_install_dir>\admin\OEMREP\pfile

• init.ora in <oracle_install_dir>\admin\Oracle\pfile

• init.ora in <oracle_install_dir>\admin\prod\pfile

And then reboot the machine. For more information on this Oracle issue, see:
http://www.praetoriate.com/oracle_tips_mamt_parameter_file.htm.

Backing up a MS SQL Server 2005/2008 Database
To backup a SQL Server database:

1. Start Microsoft SQL Server Management Studio.
2. Navigate to the Optimal Trace database to back up, and then right-click.

A context-sensitive menu appears.

3. Select Tasks>Back Up.
The Back Up Database dialog box appears.

4. Enter the required information, and then click OK.

Stopping the Server
If the server is running from the GUI, click Stop. If the server is running as a windows service,
stop it as follows:

1. Open the Windows Control Panel and launch Administrative Tools>Services.
2. Navigate to Micro Focus Optimal Trace Server <RELEASE_NUM>.
3. Right-click and choose Properties from the menu.
4. Select Stop.
5. Change the Startup type to Manual.

Advanced Configuration Options
The Advanced tab of the Optimal Trace Server dialog box contains options from which you
can modify the behavior of Optimal Trace Enterprise Server.
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Figure 1. Advanced Tab of the Optimal Trace Server Dialog Box

Table 1. Optimal Trace Server Advanced Configuration Options

DescriptionOption

An Optimal Trace server maintains a connection to its Optimal Trace clients so
that it can monitor these client processes to ensure that the connection between

Server Monitor
Interval

them is valid. The interval specified here is the number of seconds between each
message. This message is a ping that is sent from the Optimal Trace clients to
the Optimal Trace server. This interval specifies how often this message should
be sent, specified in seconds.

This is the TCP/IP port that an Optimal Trace server runs on. If you are running
a firewall on your machine, ensure that this port is left open for inbound
connections to the srver.

Server Listener Port

The Optimal Trace server will disconnect any Optimal Trace clients that have
not 'pinged' it after this specified number of attempts. As part of this disconnect

Server Disconnect
Attempts

process, all locks held by the client will be released and other clients will be free
to work on the Projects that may have been locked by the client. By default, if
the Optimal Trace server does not get any pings from a client after 5 minutes (60
seconds * 5 attempts), the client will be disconnected and any locks on any projects
it may have held will be released.

Sets the type of user authentication used by Optimal Trace Enterprise Server to
Windows Integrated Authentication. This option is not set by default. For more
information, see Setting Up Windows Integrated Authentication [p. 9].

Use Windows
Integrated
Authentication

Enables project security as the default security setting for all new projects created
in Optimal Trace. This option is not set by default.

Enable New Project
Security
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