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Introduction
�  Who Should Read This Guide

�  Related Publications

�  World Wide Web Information

�  Getting Help
.

Who Should Read This Guide
This guide is intended for administrators who are installing or configur-
ing QACenter products; it does not contain reference or usage informa-
tion. You can find that information in the online Help for your product.

Compuware assumes that you are familiar with basic Microsoft Windows 
navigation. If this is not the case, familiarize yourself with the documen-
tation for Microsoft Windows before reading this guide.

Related Publications
The Distributed License Management Installation Guide, which contains 
instructions for licensing your QACenter product, is available in PDF 
format. Access this guide from the Compuware FrontLine Customer 
Support Web site at http://frontline.compuware.com. See “World Wide 
Web Information” on page 8 for specific details.

Because PDF is based on PostScript, a PostScript printer is the most 
reliable way to print online books. In most cases, you can also print PDF 
files to PCL printers. If you cannot print the PDF files to your printer, 
refer to Adobe’s Web site at http://www.adobe.com for troubleshooting 
information.
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World Wide Web Information 
To access Compuware Corporation’s site on the World Wide Web, point 
your browser at http://www.compuware.com. The Compuware site 
provides a variety of product and support information.

FrontLine Support Web Site: You can access online customer support for 
Compuware products via the FrontLine support Web site. FrontLine 
provides fast access to critical information about your QACenter product. 
You can read or download documentation, frequently asked questions, 
and product fixes, or e-mail your questions or comments. To access 
FrontLine, follow these steps:

1 Open a Web browser and go to: http://frontline.compuware.com 
The Welcome to FrontLine page appears.

2 On the right side of the page, enter your login ID and password and 
click Login.

Note: If you are a first-time visitor, click Register to receive your free 
password to access FrontLine. After you complete the registration 
form, your login ID and password will be e-mailed to you and your 
account will be activated.

3 From the list in the center of the page, select a product and click Go. 
You will see the product’s FrontLine home page, where you can 
access documentation, technical information, fixes, and other sup-
port items.

Getting Help
At Compuware, we strive to make our products and documentation the 
best in the industry. Feedback from our customers helps us maintain our 
quality standards. If you need support services, please obtain the follow-
ing information before calling Compuware’s 24-hour product support 
hotline:

� The name, release (version), and build number of the QACenter prod-
uct. This information is displayed when you select the About com-
mand from your product’s Help menu. The name and release are also 
on the covers of the product documentation.

� Installation information, including installed options, whether the 
product uses local or network databases, whether it is installed in the 
default directories, whether it is a client or server installation.

� Environment information, such as the operating system and release 
on which the product is installed, memory, hardware/network speci-
8     QADirector-QACenter Portal Installation and Configuration Guide
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fications, and the names and releases of other applications that were 
running.

� The location of the problem in the QACenter product software, and 
the actions taken before the problem occurred.

� The exact product error message, if any.

� The exact application, licensing, or operating system error messages, 
if any.

� Your Compuware client, office, or site number, if available.

Compuware Customer Support

Compuware Corporation 
One Campus Martius 
Detroit, MI 48226-5099 
1-800-538-7822
 Introduction     9
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Chapter 1

Getting Started
� Overview

� Before You Install

� Viewing Online Books

� System Requirements

� Integrated Products Requirements

Overview
QACenter is a suite of automated software quality products for enterprise 
and e-business applications. QACenter offers a comprehensive solution 
for IT organizations concerned with assuring quality and performance, 
while keeping pace with faster development cycles. QACenter includes:

QADirector:  Coordinates the entire testing process by organizing, track-
ing, and executing automated and manual tests. QADirector integrates 
with Compuware’s testing, program analysis, defect tracking, and 
requirements management tools. 

The QADirector Test Management Server reads job submissions 
from the database, manages jobs, tracks available test execution 
machines, and manages the licenses for manual test Web execution. 
It also reports on the status of jobs in progress. 

The QADirector Test Execution Server is installed on the local 
machine. The Test Execution Server allows jobs to run on a computer, 
however you do not need a Test Execution Server to run jobs via 
QACenter Portal.

QACenter Portal: Provides a comprehensive reporting facility that is 
consistent among the QACenter point products. It enables users with 
various roles and responsibilities to create and view detail, summary, and 
 11



cross-product reports. QACenter Portal ties together requirements 
planning, test planning, test execution, and defect tracking to provide 
users with a centralized view of application quality. It also integrates with 
Reconcile and QADirector and provides QADirector web functionality.

TrackRecord: Records and reports information about products being 
developed or supported. An object-oriented database contains recorded 
information on team members, testers, schedules, and defect reports 
retrievable using TrackRecord’s query and reporting features.

Reconcile: Helps create and control project requirements. It stores the 
project requirements in a relational database. You can view the require-
ments through Microsoft Word, a reporting view (grid), and the Web. Use 
Reconcile to help you manage project development from conception 
through delivery.

TestPartner: Tests Web- and Windows-based applications that use 
Microsoft technologies. You can record user sessions with the applica-
tion, add validation functions, and replay the sessions later to ensure 
that the application works as expected. TestPartner’s scripting language is 
Visual Basic for Applications (VBA); it supports testing of Java, Visual 
Basic, and Visual C++ applications; browser-based Web applications; and 
COM components including both ActiveX controls and automation 
objects.

QAHiperstation+: Works with mainframe QAHiperstation to test host-
based applications directly from your Windows desktop. This integrated, 
workstation-based interface tool uses 32-bit code that provides improved 
performance and better stability on 32-bit Windows platforms.

QARun: Tests enterprise client/server applications. QARun creates and 
runs test scripts that support a wide variety of development tools and the 
diverse components of today’s corporate environments. QARun couples 
advanced verification facilities with error-recovery mechanisms to 
reliably test local and remote applications. 

Changepoint Request Management:  Tracks defects managed using a built-
in report designer. Allows testers to submit a defect from QADirector into 
Changepoint’s Request Management system. Relevant information from 
QADirector is stored as a change request, while Changepoint’s request 
management capability provides powerful workflow features allowing 
you make sure the defect is correctly assigned. 

QALoad: Load tests enterprise client/server systems and associated 
networks. Can stress systems by simulating thousands of users simulta-
neously performing different operations. Creates and runs test scripts 
that simulate application transactions on systems without involving end 
users or their equipment.
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QACenter Additional CD Contents: In addition to the QADirector suite of 
products, the QACenter CD includes Adobe Acrobat Reader, Microsoft 
Internet Explorer, Java 2 Development Kit, and Microsoft Virtual 
Machine installation programs. To install one or more of these products 
from the QACenter CD, click Install 3rd Party Software, then click on 
the product installation you would like to perform.

Before You Install
Review this section before you install QADirector or QACenter Portal.

Installation Types

The following installation options are available when you install 
QADirector and QACenter Portal: 

Basic Installation: Installing QADirector and QACenter Portal on one 
machine from the CD using the default settings. See “Basic Installation” 
on page 19. In a Basic Installation the MSDE database is installed along 
with all other components on a single machine.

Enterprise Installation Including Integrated Products: Installing QADirector 
and QACenter Portal in a distributed environment and customizing the 
install. See “Installing in an Enterprise Environment” on page 25. In an 
Enterprise Installation, the SQL or Oracle database is usually installed on 
a separate machine which is set up as a database server.

If you purchased an integrated product refer to that product’s Installation 
and Configuration Guide for information. There are some products with 
which QADirector and QACenter Portal integrate that require some 
configuration. 

Release Notes

Review the Release Notes for information about new features, technical 
notes, and known issues that may enhance or impact your product’s 
performance. Release Notes contain recent changes that may not be 
included in your QACenter product documentation. 

View Release Notes from the QACenter product CD or on FrontLine, 
Compuware’s product support Web site. The Release Notes on FrontLine 
are periodically updated as new information becomes available.
 Getting Started     13



Accessing the Release Notes from the QACenter CD

1 Insert the QACenter CD into the CD-ROM drive. If the CD browser 
does not start automatically, navigate to the CD’s root directory and 
run setup.exe.

2 Click View QACenter Release Notes. The Release Notes open in your 
default Web browser.

3 Read the Release Notes online, or print the document.

4 After reading or printing the Release Notes, close the document to 
return to the CD browser.

Accessing the Release Notes on FrontLine

1 Open a Web browser and go to http://frontline.compuware.com 
where the Welcome to FrontLine page appears.

2 On the right side of the page, enter your login ID and password and 
click Login.

Note: If you are a first-time visitor, click Register to receive your free 
password to access FrontLine. After you complete the registration 
form, your login ID and password will be e-mailed to you and your 
account will be activated.

3 From the list in the center of the page, select a product and click Go. 
You will see the product’s FrontLine home page, where you can 
access documentation, technical information, fixes, and other sup-
port items.

Installing the License

A trial license is supplied with your QACenter product. During this 30-
day trial period, you will be informed of how much evaluation time 
remains. 

Install a permanent license at any time during the evaluation period. 
When the evaluation period expires, you must install a license to 
successfully run this product. Information about permanent license 
installation can be found in the Distributed License Management Installa-
tion Guide. Access this guide by clicking Start>Programs>Compu-
ware>QADirector/QACenter Portal>Documentation.

Viewing Online Books
Download Adobe Acrobat 6.0 or Acrobat Reader (provided on the 
QACenter CD) to view the online books in PDF format.
14     QADirector-QACenter Portal Installation and Configuration Guide
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System Requirements
System requirements exist for each QACenter component. Those require-
ments are listed below.

QADirector/QACenter Portal Database Server

Hardware

� 1 GHz processor with 512 MB RAM (2 GHz with 1 GB RAM recom-
mended)

� Minimum 450 MB of free disk space

Operating System

� Microsoft Windows 2000 Professional SP 4

� Microsoft Windows 2000 Server SP 4

� Microsoft Windows 2000 Advanced Server SP 4

� Microsoft Windows XP Professional SP 1, 1a, or 2 

� Microsoft Windows Server 2003 Standard SP 1

� Microsoft Windows Server 2003 Enterprise SP 1 

Database Management System

� Microsoft SQL Server 7.0 SP 3 or later

� Microsoft SQL Server 2000 SP 3 or later

� Oracle 8.1.7, 9i, 10g

QADirector Client and Test Execution and Test Management Servers

Hardware

� Mid-level Pentium III PC with 512 MB of RAM (minimum)

� Minimum 450 MB of free disk space

Operating System

� Microsoft Windows 2000 Professional SP 4

� Microsoft Windows 2000 Server SP 4 

� Microsoft Windows 2000 Advanced Server SP 4
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� Microsoft Windows XP Professional SP 1, 1a, or 2

� Microsoft Windows Server 2003 Standard SP 1

� Microsoft Windows Server 2003 Enterprise

Software

� Oracle Client 8.1.7, 9i, 10g, if using an Oracle database

Network

� TCP/IP protocol installed on all computers

� Four ports within the range of ports 1024 through 5000 must remain 
open. QADirector randomly selects four ports to use when executing 
jobs. 

Windows Environment

In order to use QADirector in a Windows environment, users must have 
specific permission and rights. 

Registry Ensure that users have update access to the following registry keys:

� HKEY_CURRENT_USER\Software\

� HKEY_LOCAL_MACHINE\SOFTWARE\

Windows Directories Users must also have update access to the following directories:

� QADirector install directory (Example: \Program Files\Common 
Files\Compuware)

� System32

MDAC � SQLSRV32.DLL driver provided with the MDAC installation must be 
installed and configured on workstation. 

Browser

Microsoft Internet Explorer 6.0 SP 1. 

QACenter Portal Client Machine

Browser

Microsoft Internet Explorer 6.0 SP 1
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QACenter Portal Web Server

Hardware

� 1 GHz processor with 512 MB RAM (2 GHz with 1 GB RAM recom-
mended)

� Minimum 450 MB of free disk space

Operating System

� Microsoft Windows 2000 Professional SP 4 

� Microsoft Windows 2000 Server SP 4 

� Microsoft Windows 2000 Advanced Server SP 4 

� Microsoft Windows XP Professional SP 1, 1a, or 2 

� Microsoft Windows Server 2003 Web

� Microsoft Windows Server 2003 Standard SP 1 

� Microsoft Windows Server 2003 Enterprise SP 1

Web Server

� Microsoft Windows 2000 IIS 5.0 

� Microsoft Windows XP IIS 5.1 

� Microsoft Windows Server 2003 IIS 6.0

Software

Oracle Client 8.1.7, 9i, 10g, if using an Oracle database

Browser

Microsoft Internet Explorer 6.0 SP 1

Integrated Products Requirements
QADirector and QACenter Portal integrate with many Compuware 
automated testing, analysis, defect tracking, and requirements manage-
ment tools. The QACenter Portal version must be the same as the 
QADirector version. If you intend to use QADirector or QACenter Portal 
with any of these tools, please note the minimum version requirements:
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� File-AID/CS (Compare, Converter) Release 03.00.02 or later 

� QAHiperstation Release 07.04.00 or later 

� QAHiperstation+ Release 02.00.00 or later 

� QALoad Release 05.02.00 or later

� QARun Release 04.09.01 or later 

� Reconcile 02.00 or later

� TestPartner 05.03.00 or later

� TrackRecord Release 06.02.00 or later

� Changepoint Request Management 10.00.00
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Chapter 2

Completing a Basic Installation
� Basic Installation

� Installing QACenter Portal

� Installing QADirector

� Configuring QACenter Portal and QADirector

Basic Installation
The following example provides the basic installation sequence for 
QACenter Portal and QADirector using the default database (MSDE) on 
one machine. 

An example of full or enterprise installation in a distributed environment 
appears in “Completing an Enterprise Installation Including Integrated 
Products” on page 25. 
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Before You Begin

1 Exit all non-essential Windows programs. Some Windows programs 
may interfere with the installation process. 

2 Do one of the following:

� If you are migrating from an earlier version see “Upgrading and 
Migrating Previous Versions of QADirector and QACenter Portal” 
on page 49.

� If this is a new installation, continue. 

Installing QACenter Portal 

1 Log in as a user with administrator permissions. 

2 Insert the QACenter CD into the CD-ROM drive. 

3 Click Install QACenter Products.

4 Click Install QACenter Portal. The Welcome dialog box appears.

5 Click Next. The License Agreement dialog box appears. 

6 Click Yes. The Customer Information dialog box appears.

7 Type your name and company in the User Name and Company 
Name fields. 

8 Click Next. The Choose Destination Location dialog box appears.

9 Choose the location in which to install QACenter Portal. 

By default, QACenter Portal installs in the Windows folder in 
Program Files\Compuware\QACenter Portal. Click Browse to select 
an existing folder or type the path name in the Path field. 

10 Click OK. An MSDE Install dialog appears.

11 Click Yes. The Choose Database Location screen appears. 

12 Specify a database location by typing a folder name or selecting one 
from the existing folders list. 

13 Click Next. The Start Copying Files dialog box appears.

14 Click Next. The Setup Status dialog box appears. 

15 Click Next. The components are installed. 

16 (Optional) Select the Display Release Notes check box when the 
Setup Complete dialog box appears. 

17 Click Finish. The computer is restarted.
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Installing QADirector

Follow these steps to install QADirector: 

1 Insert the QACenter CD into the CD-ROM drive. 

2 Click Install QACenter Products.

3 Click Install QADirector. The Welcome dialog box appears.

4 Click Next. The License Agreement dialog box appears. 

5 Click Yes. The Customer Information dialog box appears.

6 Type your name and company in the User Name and Company 
Name fields. 

7 Click Next. The Choose Destination Location dialog box appears.

8 Choose the location in which to install QADirector. 

By default, QADirector installs in the Windows folder in Program 
Files\Compuware\QADirector. Click Browse to select an existing 
folder or type the path name in the Path field. Click OK. 

9 Click Next. The Select Components dialog box appears. 

10 Clear the database server selection. 

11 Click Next. The Select Program Folder dialog box appears.

12 Specify a location for the QADirector program shortcuts by typing a 
new folder name or selecting one from the existing folders list. 

13 Click Next. The Start Copying Files dialog box appears.

14 Click Next. The programs are installed. 

15 (Optional) Select the Display Release Notes check box when the 
Setup Complete dialog box appears. 

16 Click Finish. The computer is restarted.

Configuring QACenter Portal and QADirector

Setting Up an ODBC Data Source

Create a Windows ODBC DSN. Use the following MSDE information, 
which was installed previously:

� DSN Name: QADirector (recommended)
� Server Name: <Machine Name>\QACenter
� User Name: sa
� Password: Do not enter a password
� DB Name: QACenter
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For more information see Appendix B, “Setting Up an ODBC Data 
Source”.

Configuring QADirector

1 Shut down the Test Management Server and the Test Execution 
Server if they are running on the computer.

2 Open the database configuration by clicking Start>Program 
Files>Compuware>QADirector>Database Configuration Utility.

The path to the software may vary slightly depending on your 
operating system.

3 Select SQL Server\MSDE.

4 Select the DSN created in “Setting Up an ODBC Data Source” on page 
21 and type the following in the appropriate locations:

� DB Name: QACenter
� Schema: Default
� User Name: sa
� Password: Do not enter a password

5 Click OK.

To determine the port number see “Determining the Port Number” on 
page 65.

Configuring QACenter Portal

1 Open the configuration utility by clicking Start>Program 
Files>Compuware>QACenter Portal>Database Configuration Util-
ity.

The path to the software may vary slightly depending on your 
operating system.

2 Verify the configuration information that appears.

3 Click OK.

To determine the port number see “Determining the Port Number” on 
page 65.

Verifying the Installation

1 Click Start>Program Files>Compuware>QADirector>QADirector.

The path to the software may vary slightly depending on your 
operating system.

2 Type admin for both the user name and password
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3 Create a project (Example: Test1).

4 Click Start>Programs>Compuware>QACenter Portal.

The path to the software may vary slightly depending on your 
operating system.

5 Type admin for both the user name and password.

6 Verify that the project created in step 3 above exists.
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Chapter 3

Completing an Enterprise 
Installation Including 
Integrated Products 
� Installing in an Enterprise Environment

� Installing the QACenter Database on the Database Server 
Machine

� Installing QACenter Portal on the Web Server Machine

� Installing QADirector

� Configuring QACenter Portal

� Configuring QADirector

� Configuring the Test Management and Execution Servers

� Configuring the Windows XP SP2 Firewall for QADirector

� Disconnecting QACenter Portal from the Database

� Configuring Compuware Open Server

� Installing TrackRecord on the Web Server

� Configuring Changepoint

� Integrating With Other Compuware Products

Installing in an Enterprise Environment
The following example provides the installation sequence for QACenter 
Portal and QADirector in a distributed environment and includes instruc-
tions for customizing the associated database. 
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Before You Begin

1 Exit all non-essential Windows programs before running this setup 
program. Some Windows programs may interfere with the installa-
tion process. 

2 Do one of the following:

� If you are migrating from an earlier version see “Upgrading and 
Migrating Previous Versions of QADirector and QACenter Portal” 
on page 49. 

� If this is a new installation, continue.

Figure 3-1. The graphic above depicts a recommended Enterprise installation. For 
further information, refer to each of the product’s online help and Installation and 
Configuration Guide. 

IIS Web Server

Web Apps QACenter Portal: Enables users to create and view reports and provides 
QADirector web functionality. 
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Compuware Open Server (COS): Compuware Open Server (COS) is 
Compuware’s server-side framework for managing product and integra-
tion services. 

Publisher/Subscriber Services: COS message routing services.

OptimalView: Integration portal used to integrate applications into a 
single point of access. 

TrackRecord Web Server: Defect and project tracking tool used to record 
and report information about products being developed or supported. 

Reconcile Reporting Web Server: Reconcile Reporting is a web-based 
reporting utility modeled on QACenter Portal technology. Used by 
Reconcile to publish reports to QACenter Portal. 

Web Services File-AID/CS: Provides an integration between QACenter Portal/QADirec-
tor and File-AID/CS repository, and script information.

QACenter Integration Server: Allows the user to directly integrate 
testing with their requirements management solution in order to align 
testing efforts with business objectives, and provide traceability from 
requirements to testing results. For installation information go to the 
FrontLine support Web site and select QADirector. Click QACenter Add-
ins.

Services/Processes Report Scheduler: Used to publish information via COS to Changepoint 
and move QACenter data to the QACenter reporting database. This 
supports ad hoc reporting within Changepoint using the Changepoint 
Report Designer.

QACenter Subscriber: Service used for File-AID/CS integration. Uses File-
AID/CS with services and COS messaging services.

Win32 Apps TrackRecord: Defect and project tracking tool used to record and report 
information about products being developed or supported. 

Application Server

Windows Service Test Management Server (TMS): Reads job submissions from the 
database, manages jobs, tracks available test execution machines, and 
manages the licenses for manual test Web execution. It also reports on 
the status of jobs in progress. 

Compuware License Server: Allows you to run all the Compuware 
products. 
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Changepoint

Databases/Web 
Server/Web Services

Changepoint: Manages client data in one place via a client portal used to 
initiate work requests, and track activity and status. For additional 
Changepoint installation and configuration information, refer to the 
Changepoint documentation. 

QACenter Reporting Database: Used to integrate QACenter with 
Changepoint Report Designer. 

Oracle Database Server

Databases QACenter: Central repository which holds all QACenter Portal/QADirec-
tor assets. 

Reconcile: Central repository which holds all Reconcile assets. 

QARun/TestPartner/File-AID/CS: Central repository which holds all 
assets for these products. 

TrackRecord: Central repository which holds all TrackRecord assets. 

Clients

Win32 Apps QADirector: Test management solution designed to help testers, devel-
opers, and managers deliver thoroughly tested applications. Integrates 
with Compuware’s testing, program analysis, defect tracking, and 
requirements management tools. 

TrackRecord: Defect and project tracking tool used to record and report 
information about products being developed or supported. 

QARun: Tests enterprise client/server applications.

TestPartner: Tests Web- and Windows-based applications that use 
Microsoft technologies. 

File-AID/CS: Data management tool designed to help developers manage 
and prepare data for testing.

Reconcile: Helps create and control project requirements. It stores the 
project requirements in a relational database. 

3rd Party RM Tools: Helps create and control project requirements. 

Services/Processes Test Execution Server: Allows jobs to run on a computer, however you 
do not need a Test Execution Server to run jobs via QACenter Portal. 

Thin Client App IE Browser: For the correct browser version, see “Windows Environ-
ment” on page 16.
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Installing the QACenter Database on the Database Server 
Machine

Create a QACenter database manually or using the installation CD. 
Manually creating and configuring a database consists of a series of 
procedures. To manually create and configure the database, refer to 
Appendix A, “Manually Creating and Configuring a Database”.

To simplify this process, Compuware provides a database installation 
directly from the product CD. This section provides information about 
installing a QACenter SQL Server or Oracle database using the Database 
Install on the installation CD. 

Note: Compuware recommends using the database installation from the 
CD if you have no database administration experience. 

Installing a SQL Server Database

Requirements

� An existing database server instance that runs a supported version of 
SQL Server. See “System Requirements” on page 15.

� The following specifics used to configure the database instance:

� The SQL Server must be case insensitive at the time of installa-
tion.

� If the database instance is defined, you must specify code page 
1252 and sort order 52 (also known as ISO 8859-1). 

� If you are using SQL Server 2000, specify the 
SQL_Latin1_General_CP1_C1_AS collation.

� An SQL Server user ID and password to allow the administrator to set 
up the database. 

Installing the Database

1 Log on as a user with administrator permissions. 

2 Insert the QACenter CD into the CD-ROM drive. The QACenter CD 
browser should automatically appear. If it does not, navigate to the 
root directory and run the setup.exe file.

3 Click Install QACenter Products.

4 Click Install Database. The Welcome dialog box appears.

5 Click Next. The License Agreement dialog box appears. 
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6 Click Yes. The Database Management System dialog box appears.

7 Select Microsoft SQL Server 2000\7.0 and click Next. The SQL 
Server Login Information dialog box appears. 

8 Type the following information in the Server Login Information 
dialog box fields:

� Server field: Database server name.
� Login field: Database user name (must have sufficient permis-

sions) Example: sa.
� Password field: User password.

9 Click Next. The Database Selection dialog box appears.

10 Select the QADirector database to install and clear the Reconcile 
selection.

11 Click Next. The Database Information dialog box appears. 

12 Type the following information in the Database Information dialog 
box fields:

� Database: Database name.
� Login: Database User name for new database (optional). New 

user account is created.
� Password: Password for new user (optional).

13 Click Next. The Review Settings dialog box appears displaying infor-
mation specified in the previous setup screens. To change any of the 
settings, click Back.

14 Click Next to begin creating the database. This may take a few min-
utes. The Command Results dialog box appears. 

At the end of the installation, this dialog box displays a log contain-
ing all commands executed during the database creation. To save the 
log, select the text, copy and paste it into a text file, and save it.

15 Click Finish to complete the database installation.

Installing an Oracle Database

Requirements

� An existing database server instance that runs supported versions of 
Oracle. Refer to “System Requirements” on page 15 for details.

� The following specifics used to configure the database instance:

� When the Oracle database instance is defined, you must specify 
the Storage Character Set as iso 8859-1 West European. 
30     QADirector-QACenter Portal Installation and Configuration Guide



� The NLS_LANGUAGE parameter should be set in the parameter file 
as:

NLS_LANGUAGE = 'AMERICAN'

If you are using Windows 2000, set the NLS_LANGUAGE 
parameter to AMERICAN_AMERICA.WE8ISO8859P1 in the 
following locations:

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\NLS_LANG
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES\IDO\NLS_LANG
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME-\NLS_LANG

� You must know the Oracle user ID and password to allow the 
QADirector administrator to set up the Oracle.

� An Oracle Net Service created before installing an Oracle database. 
For further information see Appendix B, “Setting Up an ODBC Data 
Source”.

Installing the Oracle Database

To install the QACenter Oracle database:

1 Log on as a user with administrator permissions. 

2 Insert the QACenter CD into the CD-ROM drive. The QACenter CD 
browser should automatically appear. If it does not, navigate to the 
root directory and run the setup.exe file.

3 Click Install QACenter Products.

4 Click Run Install Database. The Welcome dialog box appears.

5 Click Next. The License Agreement dialog box appears. 

6 Click Yes. The Database Management System dialog box appears.

7 Select Oracle 8.1.7\9i\10g and click Next. The Oracle Login Infor-
mation dialog box appears. 

8 Type the following information in the Oracle Login Information 
dialog box fields:

� Service: Service name.
� Login: User/schema name (must have sufficient permissions) 

Example: sys.
� Password: User password.

9 Click Next. The Database Selection dialog box appears.

10 Select the QADirector database and clear the Reconcile selection.
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11 Click Next. The Review Settings dialog box appears displaying infor-
mation specified in the previous setup screens. To change anything, 
click Back.

12 Click Next to begin creating the database. The Command Results 
dialog box appears.

At the end of the installation, this dialog box displays a log contain-
ing all commands that were executed during the database creation. 
To save the log, select the text, copy and paste it into a text file, and 
save it.

13 Click Finish to complete the database installation.

Installing QACenter Portal on the Web Server Machine
1 Log on as a user with administrator permissions. 

2 Insert the QACenter CD into the CD-ROM drive. 

3 Click Install QACenter Products.

4 Click Install QACenter Portal. The Welcome dialog box appears.

5 Click Next. The License Agreement dialog box appears. 

6 Click Yes. The Customer Information dialog box appears.

7 Type your name and company in the User Name and Company 
Name fields. 

8 Click Next. The Choose Destination Location dialog box appears.

9 Choose the location in which to install QACenter Portal. 

By default, QACenter Portal installs in the Windows folder in 
Program Files\Compuware\QACenter Portal. Click Browse to select 
an existing folder or type the path name in the Path field. 

10 Click OK. An MSDE Install dialog appears. 

Note: If you want to install MSDE, click Cancel and see “Completing a 
Basic Installation” on page 19.

11 Click No. The Choose Database Location screen appears. 

12 Specify a database location by typing a folder name or selecting one 
from the existing folders list. 

13 Click Next or specify a location. The Start Copying Files dialog box 
appears.

14 Click Next. The Setup Status dialog box appears. 
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15 Click Next. The components are installed. 

16 (Optional) Select the Display Release Notes check box when the 
Setup Complete dialog box appears.

17 Click Finish. The computer is restarted.

Installing QADirector

Installing QADirector on a Client Machine

Use this process to install QADirector on a client machine and repeat the 
process for every client in an Enterprise environment.

1 Log on as a user with administrator permissions. 

2 Insert the QACenter CD into the CD-ROM drive. 

3 Click Install QACenter Products.

4 Click Install QADirector. The Welcome dialog box appears.

5 Click Next. The License Agreement dialog box appears. 

6 Click Yes. The Customer Information dialog box appears.

7 Type your name and company in the User Name and Company 
Name fields. 

8 Click Next. The Choose Destination Location dialog box appears.

9 Choose the location in which to install QADirector. 

By default, QADirector installs in the Windows folder in Program 
Files\Compuware\QADirector. Click Browse to select an existing 
folder or type the path name in the Path field. 

10 Click OK and click Next. The Select Components dialog box 
appears. Components to install appear as follows:

� Database Server: Do not select this component. 

Note: To install MSDE, click Cancel and see “Completing a Basic 
Installation” on page 19.

� Test Management Server: Installs the Test Management Server 
on the local machine. 

� Test Execution Server: Installs the Test Execution Server on the 
local machine. 

Note: Select these to install them on the same machine. To install 
them on separate machines, deselect these options and see 
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“Installing the Test Management and Test Execution Servers” 
on page 34.

� Windows Client: Installs QADirector on the local machine.

� IBM S/390 Support: Includes the QA 3270 Emulator Server, a 
utility program used to manage communications between your 
3270 IBM mainframe emulator and QADirector. The QA 3270 
Emulator Server includes the TN3270 Mainframe Emulator, a free 
emulator you can use for mainframe testing. If you prefer to use 
your own emulator, refer to the QA 3270 Emulator Server Readme 
file for a list of supported emulators. After installing QADirector, 
you can view the Readme file by clicking Start>Programs>Com-
puware>QADirector>QA 3270 Emulator Server>Readme.

11 Specify a location. Type a folder name, or select one from the existing 
folders list. The Start Copying Files dialog box appears.

12 Click Next. The Setup Status dialog box appears. 

13 Click Next. The components are installed. 

14 (Optional) Select the Display Release Notes check box when the 
Setup Complete dialog box appears.

15 Click Finish. The computer is restarted. 

Installing the Test Management and Test Execution Servers

Installing the Test Management Server

To install a Test Management Server, follow steps 1–11 of Installing 
QADirector. Select to install the Test Management Server only and 
continue with the process.

Installing the Test Execution Server

To install a Test Execution Server, follow steps 1–11 of Installing QADirec-
tor. Select to install the Test Execution Server only and continue with the 
process.

Configuring QACenter Portal

Configuring QACenter Portal For Oracle

Once the QACenter Portal application and database are installed, the 
portal must be configured to communicate with the database.
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Creating an ODBC Data Source on the Web Server

1 Create an Oracle Net Service name using the Oracle Net Configura-
tion Assistant.

2 Create a System DSN with exactly the same name as the Net Service 
Name created in Step 1. 

Note: Compuware recommends that you use the Oracle driver instead of 
the Microsoft driver when connecting to the QACenter Portal 
database.

For more information, see Appendix B, “Setting Up an ODBC Data 
Source”.

Completing the Configuration

1 Run the Database Configuration Utility located in Start>Pro-
grams>Compuware>QACenter Portal>Database Configuration 
Utility.

2 Select Oracle from the Database options and type the following 
information in the appropriate fields:

� Server Name: Type the server name.
� Database Name: Type the database instance.
� DSN/Service Name: Type the DSN created above.
� User Name: Type the user name.
� Password: Type the user password.

3 In the Port field, type a port number. The default value is 1521.

4 Click Test to validate the configuration. The Test Status dialog box 
appears.

5 Click OK.

6 Review the default values in the Publish Message Router field and 
change as necessary. 

7 Click Test to verify the web service at the address.

8 Review the default values in the Subscribe Message Router field and 
change as necessary. 

9 Click Test to verify the web service at the address.

10 Click OK to exit the configuration utility.

11 If using the Oracle 9.2 Client and above:
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a Locate the Oracle Install folder in the Oracle installation direc-
tory.

b Right-click on the folder and select Properties. The Properties 
dialog box appears.

c Click Security. If the Security tab is not visible, navigate to Win-
dows Explorer and click Tools>FolderOptions>View and clear 
the Use Simple File Sharing Option.

d Click Add. The Select Users or Groups dialog box appears.

e Add the following users with full permissions: IWAM_<Machine-
Name>, IUSR_<MachineName>, ASPNET, and Everyone.

f Click OK and then click Advanced.

g Select Allow inheritable permissions from parent to propagate 
to this object.

h Click OK to exit.

Configuring QACenter Portal for SQL Server

To configure QACenter Portal for SQL Server on the Web server:

1 Run the Database Configuration Utility located in Start>Pro-
grams>Compuware>QACenter Portal>Database Configuration 
Utility.

2 Select SQL Server from the Database options and type the following 
information in the appropriate fields:

� Server Name: Type the server name.
� Database Name: Type the database name.
� Port: Enter a port value. The default value is 1433.
� User Name: Type the user ID.
� Password: Type the user password.

Note: The DSN server name defaults to QACenter. This is a fixed value 
and cannot be changed.

3 Click Test to validate the configuration. The Test Status dialog box 
appears. 

4 Click OK.

5 Review the default values in the Publish Message Router field and 
change as necessary. Click Test to verify the web service at the 
address.

6 Review the default values in the Subscribe Message Router field and 
change as necessary. Click Test to verify the web service at the 
address.
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7 Click OK to exit the configuration utility.

Configuring Windows Permissions for QACenter Portal on 
Non-English Operating Systems

Configure the following directories to allow permissions to the Everyone 
user. In non-English versions of Windows, use the language equivalent of 
the English “Everyone”.

� \QACenter Portal\UI\qacenterportal\temp\imports

� \QACenter Portal\UI\qacenterportal\temp\upload\

� \QACenter Portal\planning\templates

Repeat these steps for each directory:

1 Right-click the appropriate directory.

2 Select Properties from the menu. The Properties dialog box appears.

3 Click the Security tab.

4 Click Add. The Select Users dialog box appears.

5 Type Everyone or the language equivalent in the Users field. For 
example, in the German version of Windows, type Jeder.

6 Click OK.

7 Select Everyone or the language equivalent from the Group or User 
Names list.

8 Select Full Control in the Allow column of the Permissions for list.

9 Click OK.

Configuring IIS on a Windows 2003 Server

Windows 2003 requires additional steps in order to use the Internet 
Information Service (IIS) Web server with QACenter Portal.

To configure IIS on the Windows 2003 server:

1 Open the Internet Information Service Manager. For more informa-
tion, refer to the Microsoft Windows documentation.

2 Select the Web Service Extensions option.

3 Select Allow from the All Unknown ISAPI extensions list.

4 If the ASP.NET v1.1.4322 option exists, select Allow and continue 
with step 6.

5 If ASP.NET v1.1.4322 option does not exist:
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a Open the Windows Add/Remove Programs utility.

b Click Add/Remove Windows Components. The Windows Com-
ponent Wizard opens.

c Select Application Servers from the Components list and click 
Details.

d Select ASP.NET from the Subcomponents list and click OK.

e Click Next.

f Open the Internet Information Service Manager.

g Select Web Service Extensions option.

h Select Allow for ASP.NET v1.1.4322 option.

6 Click OK.

Configuring QADirector
To configure QADirector Client, first shut down the Test Execution Server 
(TES) and the Test Management Server (TMS). 

Database connection information can be changed from within QADirec-
tor in the System Administration Center (See “Connecting from Within 
QADirector” on page 40.)

Configuring QADirector for Oracle

To configure QADirector for Oracle, ensure that you have an Oracle Net 
Service and that you create a Windows ODBC data source for the Oracle 
database. For information see Appendix B, “Setting Up an ODBC Data 
Source”. 

Creating an ODBC Data Source

1 Create an Oracle Net Service name using the Oracle Net Configura-
tion Assistant.

2 Create a System DSN.

Completing the Configuration

1 Run the Database Configuration Utility located in Start>Pro-
grams>Compuware >QADirector>Database Configuration Utility.

2 Select Oracle.

3 Click the list and select the data source name you created previously.
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4 Type the schema name and the Oracle database user name and pass-
word.

5 Click OK. 

For more information see Appendix B, “Setting Up an ODBC Data 
Source”.

Configuring QADirector Client For SQL Server

To connect to the database before logging in to QADirector, create a data 
source and SQL Server DSN. Follow these steps:

Creating an ODBC Data Source

Create an ODBC DSN. For more information see Appendix B, “Setting Up 
an ODBC Data Source”. 

Completing the Configuration

1 Click Start>Program Files>Compuware>QADirector>Database 
Configuration Utility. The Select Database Connection dialog box 
appears.

2 Select SQL Server / MSDE.

3 Click the list and select the data source name you created previously.

4 Type the database name, schema name, and the SQL Server database 
user name and password.

Configuring the Test Management and Execution Servers

Multiple Test Management Servers can be created and configured with 
different priorities. The prioritized Test Management Server list appears 
in the TM Server List panel in the System Administration Center. These 
Test Management Servers will start according to priority. 

Only one Test Management Server is the active Test Management Server 
at any particular time even though other Test Management Servers may 
be running. For example, if a Test Management Server with the priority 
of 1 fails to start, the Test Management Server with the priority of 2 will 
start in its place.

Completing the Configuration

Follow the steps for “Configuring QADirector for Oracle” on page 38 or 
“Configuring QADirector Client For SQL Server” on page 39.
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Connecting from Within QADirector

To connect to the database from within QADirector, follow these steps:

1 Navigate to the System Administration Center.

2 From the Datasource panel click Actions>Change. The Select Data-
base Connection dialog box appears. 

3 Follow the steps for “Configuring QADirector for Oracle” on page 38 
or “Configuring QADirector Client For SQL Server” on page 39.

Configuring the QA3270 Emulator Server

If you installed the optional IBM S/390 Support component, you may 
need to configure the QA 3270 Emulator Server to work with your 
mainframe emulator. To access the QA 3270 Emulator Server readme file, 
click Start>Programs>Compuware>QADirector>QA 3270 Emulator 
Server>Readme. 

Using the QADirector Tutorial

To complete the QADirector tutorial, install TestPartner. The tutorial 
database is located in Program Files\Compuware\QADirec-
tor\Tutorial\MIBQADB\QAD4.MDB. For detailed instructions on using the 
tutorial, refer to the QADirector Tutorial, which can be accessed through 
online Help. 

Configuring the Windows XP SP2 Firewall for QADirector 
With the release of Windows XP, Microsoft introduced a set of security 
technologies to improve the ability of Windows XP-based computers to 
withstand malicious attacks from viruses and worms. The Windows 
Firewall prevents unsolicited, inbound TCP/IP connections. Therefore, 
the Test Management Server, Test Execution Server, and various other test 
execution components may not communicate with each other while the 
Windows Firewall is active. 

Consider the following when configuring QADirector:

� Networking should be configured to use the TCP/IP protocol with a 
static port of 1433.

� By default, SQL Server allows network connections using port 1433. 

� The SQL Server machine should have the latest MS Data Access Com-
ponents (MDAC2.71a). These are available with SQL Server Service 
Pack 3a or later. Without this version of MDAC, it is not possible to 
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connect to the SQL Server 2000 installed on a Windows XP with Ser-
vice Pack 2 operating system.

� By default the Web Server (IIS) Port 80 is blocked. Enable the port 
using the Windows Firewall dialog box. 

Use this process in conjunction with Microsoft Windows XP Service Pack 
2 to ensure that QADirector 05.01.00 works properly when the Windows 
Firewall is active:

1 Click Start>Control Panel>Windows Firewall. The Windows Fire-
wall dialog box appears.

2 Click the Exceptions tab.

3 Click Add Program. The Add a Program dialog box appears.

4 Browse to the directory where QADirector is installed.

5 Select the following programs from the list of available programs: 

"QC_TESRV.EXE, QC_TMSRV.EXE, TDRV.EXE 

"TENG.EXE 

If necessary, select the programs one at a time. It may be necessary to go 
back to the Exceptions tab each time a program is selected. Make sure 
the check box is selected for each of the QADirector programs. 

Obtaining the Correct Port Number For the Firewall

The correct port number must be used for SQL Server to properly set up 
the Firewall. After the port number is obtained, you will return to the 
Exceptions tab to complete the setup.

1 Click Start>Programs>MicroSoft SQL Server>Server Network Util-
ity. The SQL Server Network Utility dialog box appears:

2 Select TCP/IP and click Properties. The Properties dialog box 
appears. The default port number is displayed in the Default port 
field. 

3 Click Start>Control Panel>Windows Firewall. The Windows Fire-
wall dialog box appears

4 Select the Exceptions tab. 

5 Click Add Port. The Add a Port dialog box appears.

6 In the Port number field, type the port number from the SQL Server 
Network Utility. 

7 Select the TCP option.

8 In the Name field, type a meaningful name. 
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9 Click OK. The Windows Firewall dialog box appears.

10 Click OK.

Disconnecting QACenter Portal from the Database
Only one Web server can access the database at a time. In order to 
connect to another database or to access an existing database from a 
different Web server machine, disconnect the Web server from the 
current database.

To disconnect from a SQL or Oracle database:

1 Run the Database Configuration Utility located in Start>Pro-
grams>Compuware>QACenter Portal>Database Configuration 
Utility.

2 Click Disconnect.

3 Click Cancel.

Configuring Compuware Open Server
The Compuware Open Server (COS) must be configured to work with the 
Changepoint integration for QACenter. COS is Compuware’s server-side 
framework for managing product and integration services. The COS 
Administration utility enables you to set up and to configure core 
components used by Compuware for product integration.

Integrating QACenter with Changepoint Using COS Locally

Follow these instructions for integrating QACenter with Changepoint 
using COS installed locally.

Configuring the Data Source

1 Navigate to COS the installation directory. Example: C:\Program 
Files\Common Files\Compuware\CWJBoss.

2 Use Notepad to open the file CWChangepoint-ds.xml located within 
the \server\cpwr\deploy directory.

3 Locate the following line and change server/database to reflect 
your actual Changepoint database installation: 

<connection-url>jdbc:jtds:sqlserver://server/database 
</connection-url> 
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4 Locate the following line and change user to an actual user with 
database access: 

<user-name>user</user-name> 

5 Locate the following line and change password to an actual pass-
word for the user account: 

<password>password</password>

6 Click Save and then Close.

Completing the Configuration

1 Launch Internet Explorer. 

2 In the address field, type http://localhost:18080/CWAdmin. If 
necessary, change the port number (18080) to the current COS port.

3 Open the COS page.

4 Click the Message SQL link. The Message SQL Service page displays. 

5 Replace the filter with CPMessageSource = ‘QACenter’.

6 Click On in the In Service State field. 

7 Click Submit. The SQL Service is enabled. 

Integrating QACenter with Changepoint Using COS on a Separate Server

Follow these instructions for integrating QACenter with Changepoint 
using COS installed on a separate server.

Updating the COS Installation

1 Open Windows Explorer.

2 Insert the QACenter CD and navigate to the <root>\cpwr\cosup-
date\ directory.

3 Navigate to the COS installation directory. Example: C:\Program 
Files\Common Files\Compuware\CWJBoss.

4 Copy the CWChangepoint-ds.xml file from the Installation CD direc-
tory to the \server\cpwr\deploy directory.

5 Copy the CWChangepoint.sar file from the Installation CD directory 
to the \server\cpwr\deploy directory.

6 Copy the AAFault.xslt file from the Installation CD directory to the 
\CWJBoss\server\cpwr\data\CWMsgSQL\xslt directory. Create this 
directory if it does not exist.
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Configuring the Data Source

1 Navigate to the COS installation directory. Example: C:\Program 
Files\Common Files\Compuware\CWJBoss.

2 Use Notepad to open the CWChangepoint-ds.xml file located within 
the \server\cpwr\deploy directory.

3 Locate the following line and replace server/database with your 
Changepoint database installation:

<connection-url>jdbc:jtds:sqlserver://server/database</
connection-url> 

4 Locate the following line and change user to the actual user with 
database access:

<user-name>user</user-name>

5 Locate the following line and change password to the one set for the 
SQL User account: 

<password>password</password>

6 Click Save and then Close.

Completing the Configuration

1 Launch Internet Explorer. 

2 In the Address field, type http://<MachineName>:18080/CWAd-
min. If necessary, change the port number (1080) to the current COS 
port. 

3 Open the COS page.

4 Click the Message SQL link. The Message SQL Service page displays. 

5 Replace the filter with CPMessageSource = ‘QACenter’.

6 Click On in the In Service State field. 

7 Open DBConfig from the QACenter Web Server. 

8 Change the Publisher URL to point to the new server.

Installing TrackRecord on the Web Server
If you purchased TrackRecord and plan to install it using the Web Server 
option from the QACenter CD, refer to the TrackRecord Installation and 
Configuration Guide.
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Configuring Changepoint
This section details the steps necessary to prepare and configure Change-
point for use with QACenter. For additional Changepoint installation 
and configuration information, refer to the Changepoint documenta-
tion. 

Note: Changepoint should be set up using NTLM Authentication.

Preparing Changepoint for QACenter Portal Integration

Follow these steps to prepare Changepoint for QACenter Portal integra-
tion:

1 Ensure the Changepoint application is already installed. See the 
online help and documentation for Changepoint for information 
regarding creating reports from Data Providers.

2 Insert the QACenter CD and navigate to the Changepoint Integration 
Update utility.

3 Type the following information used to create the Reporting database 
in the appropriate fields:

� Database Server Name: The same server name as the Change-
point Database Server name.

� Changepoint Database Name: The actual Changepoint database 
which is installed.

� Login
� Password

Configuring QACenter Portal for Changepoint Report Designer

Follow these steps to configure QACenter Portal for ad-hoc reporting 
from Changepoint: 

QACenter Portal 1 Open the QACenter Portal homepage and click Administra-
tion>Application Configuration Page.

2 Type the Scheduler Interval time.

3 Type the following information:

� Database Server Name
� DB Name (read only)
� User ID
� Password

Changepoint 4 Log in to Changepoint and click Administration>System Man-
ager>Reporting>Data Provider Configuration>Actions>Import 
Providers Page. 
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5 Navigate to the QACP_CP_ReportandProviderXMLS folder.

6 Following the instructions in the Changepoint documentation, 
import the following to create data providers: 

� QAC_CP_DP_AssetRequirementMap.xml
� QAC_CP_DP_AssetScriptMap.xml
� QAC_CP_DP_Classes.xml
� QAC_CP_DP_ExecutionResults.xml
� QAC_CP_DP_FunctionalRequirements.xml
� QAC_CP_DP_Jobs.xml
� QAC_CP_DP_Procedures.xml
� QAC_CP_DP_Projects.xml
� QAC_CP_DP_ResultFolders.xml
� QAC_CP_DP_Scripts.xml
� QAC_CP_DP_Sites.xml
� QAC_CP_DP_Suites.xml
� QAC_CP_DP_TestRequirements.xml

7 Repeat Step 4. Re-importing will create the data provider relation-
ships.

8 Provide access to the QACenter data providers from Administra-
tion>System Manager>Reporting>Data Provider Access page. 
QACenter data providers will start with the letters “QAC_” 

For further information on importing and configuring data providers for 
reporting purposes, refer to the Changepoint documentation.

Configuring Defect Reports for a New Changepoint Database

Follow these steps to configure Changepoint if you are using a new 
database:

Log in to CARS and click Administration>System Manager>Report-
ing>Data Provider Configuration>Actions>Import Providers Page.

1 Browse to the folder QAC_CP_ReportandProviderXMLS on the 
QACenter CD and import the data provider 
QAC_CP_DP_DefectTrend.xml.

2 Click Administration>System Manager>Reporting>Data Provider 
Access. Give user’s access to the CARS_Report_Provider.

3 Click My Applications>Report Designer>Import Report.

4 Browse to the folder QAC_CP_ReportandProviderXMLS on the 
QACenter CD and import the following reports:

� QAC_CP_RPTS_Defect Report Status by Priority.xml
� QAC_CP_RPTS_Defect Trend by Priority.xml
� QAC_CP_RPTS_Overall Defect Trend.xml
46     QADirector-QACenter Portal Installation and Configuration Guide



Configuring Defect Reports for an Existing Changepoint Database

Follow these steps to configure Changepoint if you are using an existing 
database:

1 Click My Applications>Report Designer>Import Report. 

2 Navigate to the QAC_CP_ReportandProviderXMLS folder on the 
QACenter CD and import the following reports:

� QAC_CP_RPTS_Defect Report Status by Priority-2.xml
� QAC_CP_RPTS_Defect Trend by Priority-2.xml
� QAC_CP_RPTS_Overall Defect Trend-2.xml

Integrating With Other Compuware Products
QADirector and QACenter Portal integrate with many Compuware 
automated testing, analysis, defect tracking, and requirements manage-
ment tools. If you purchased an integrated product refer to that product’s 
Installation and Configuration Guide for information.
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Chapter 4

Upgrading and Migrating 
Previous Versions of QADirector 
and QACenter Portal

� Upgrading QADirector and QACenter Po

� Migrating Databases from 04.05.00 to 05
rtal

.01.00

Upgrading QADirector and QACenter Portal
Upgrade QADirector after logging in as Admin. For QACenter Portal, you 
will be prompted to upgrade during configuration. 

Upgrading from Release 05.00.00 or 05.00.01 to 05.01.00

When upgrading QADirector from Release 05.00.00 or 05.00.01 to 
05.01.00, during database connection configuration, type DEFAULT in 
the Database Name and Schema/Owner Name field. This ensures a 
proper database upgrade to 05.01.00.

Upgrading from Release 04.05.01 to 05.01.00

When upgrading QADirector Release 04.05.01 to Release 05.01.00, you 
must upgrade to Release 05.00.00 or 05.00.01 first, and then upgrade 
again to Release 05.01.00:

When upgrading from QADirector Release 04.05.01 to Release 05.00.01, 
keep in mind the following:

User Defined Tools:  All user-defined tools will be removed when you 
uninstall QADirector 04.05.01. Manually recreate them in QADirector 
05.00.01. 

Test Servers:  Make sure the Test Management Server and the Test Execu-
tion Server are shut down. If necessary, stop or shut them down. 

Suites:  Each suite from QADirector 04.05.01 will be placed in its own 
project of the same name in QADirector 05.00.01. QADirector 04.04.00 
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suites and earlier must be upgraded to 04.05.01. All users with access to a 
suite will be added as testers to the project.

Permissions and Passwords:  All user names over 50 characters in length 
will be truncated. Spaces will be replaced with underscores. Passwords 
with fewer than five characters will be replaced with the qadirector 
password.

Scripts: Any user-defined scripts with duplicate names will be renamed 
with the original name plus the test ID number. All user-defined script 
names must be unique in QADirector 05.00.01. If a different naming 
convention is preferred, change all user-defined script names, as well as 
data, before uninstalling QADirector 04.05.01 and upgrading the 
database.

Databases:  

Note: Make a backup of the 04.05.01 database in the relevant DBMS (SQL 
Server or Oracle) before migrating.

� Create an ODBC connection to the new database on the machine 
where the migration will be performed (the machine must contain 
the current QADirector 05.00.01 release). Specify the desired database 
as the default database in the ODBC setup. 

� When migrating from Microsoft Access to MSDE/SQL Server, the 
04.05.01 database cannot be used. A new, blank MSDE/SQL Server 
database must be created. Therefore, ODBC connections are needed 
for both the 04.05.01 Access database and the new 05.00.01 MSDE/
SQL Server database. MSDE/SQL Server must be installed on the 
machine where the new database will be created.

� The database login and user name used during the migration process 
must have the proper settings. In SQL Server and MSDE, the database 
login should have privileges for the database being migrated (or for 
Access>MSDE, for the new MSDE database). This login should have 
“System Administrators” server role and “public” and “db_owner” 
database roles. The default database for this login should be the data-
base being migrated. Note that the login may have access to several 
databases. 

Note: The Test button on the Configuration screen does not work when 
QADirector is pointing to a 04.05.01 database. However, the migra-
tion can still execute successfully in spite of this. The Test button 
works properly when pointing to a 05.00.01 database.

Filters: Filter field names have changed in QADirector 05.00.01; some of 
the fields from 04.05.01 no longer have a counterpart field in 05.00.01. 
The fields that do not have a counterpart will remain intact in the Filter 
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definitions. In order for the Filters to function properly in 05.00.01, you 
may need to update your Filters to remove these fields.

The following table lists the filter fields in 04.05.01 and their counterpart 
fields in 05.00.01. These fields will be upgraded to the 05.00.01 format:

Migrating Databases from 04.05.00 to 05.01.00 
QADirector 05.00.00, 05.00.01 and 05.01.00 do not support Microsoft 
Access. If Access is the current database, migrate it to an MSDE database 
with the upgrade utility. You must migrate the Access database to Release 
05.00.00 or 05.00.01 first, then migrate it to Release 05.01.00. 

Note: To perform a migration you must be an Administrator. 

If the schema of the QADirector database is older than the client, the 
following message appears:

Current version of QADirector has schema version x whereas required 
schema version is x. Would you like to upgrade QADirector database 
to the required schema level? Before you upgrade the database please 
make sure that all the clients are logged out of QADirector database.

If the schema of the QADirector database is newer than the client, the 
following message appears:

Current version of QADirector has schema version x whereas required 
schema version is x. Please use appropriate release of QADirector to 
work with this schema of the database or change datasource.

Table 4-1. QADirector Filter Fields

04.05.01 05.00.01

QC_SUMMARY Summary

QC_NAME Name

QC_DEFECT_ID DefectIds

QC_EXP_RESULT ExpectedResult

QC_MANUAL IsManual

QC_CREATED_BY CreatedBy

QC_IS_CLASS IsClass

QC_IS_PROC IsProc

QC_RUN_IN_PARALLEL ParallelChildren
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To upgrade and migrate from an Access database to an MSDE/SQL Server 
database:

1 Create a blank MSDE database to serve as the destination for the data 
in the 04.05.01 Access database after the migration is finished. Refer 
to the MSDE Help system for information.

2 Create an ODBC connection to both the blank MSDE database you 
just created and to the Access database from which you are migrat-
ing.

3 At the QADirector Log In screen, click the Configure button to 
point to the Access database from which you will be migrating. The 
Select a Database dialog appears.

4 From the Data Source Type options, select Access.

5 In the Data Source Name field, select the exact name of the Access 
Database/ODBC connection you created in step 2.

6 Click OK. The QADirector Log In screen appears. 

7 At the QADirector Log In screen, type the User Name and Pass-
word.

8 Click OK. 

9 If necessary, click Yes to upgrade the database schema to the required 
schema level. The QADirector Data Migration Information dialog 
appears with the Datasoure Type, Datasoure Name, Database 
Name, and Schema/User Name fields filled in by default.

10 In the User Name and Password fields, type the user name and pass-
word for the blank MSDE database you created in step 1.

11 Click Test to verify that the information provided is correct. A test 
confirmation dialog appears.

12 Click OK to acknowledge the successful test. The QADirector Data 
Migration Information dialog appears. 

13 Click Continue to continue the upgrade process. The QADirector/
Portal Database Upgrade screen appears. 

14 Click Begin Upgrade. The Current Item Progress, Overall Progress, 
and Upgrade Item indicators will display the ongoing progress of the 
database migration.

15 When the upgrade is complete, click Close.

Note: If you plan to use QACenter Portal, refer to “Installing QACenter 
Portal on the Web Server Machine” on page 32 for details.
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Chapter 5

Maintaining the Installation
� Accessing Maintenance Mode

� Modifying an Installation

� Repairing an Installation

� Uninstalling QADirector

� Uninstalling QACenter Portal

� Uninstalling the QACenter MSDE Instance

Accessing Maintenance Mode
To access maintenance mode for QACenter products, Compuware recom-
mends using the Windows Control Panel.

Required: Compuware recommends that you exit all non-essential Windows 
programs before running this setup program. Some Windows 
programs may interfere with the installation process.

Accessing Maintenance Mode from the Windows Control 
Panel

1 Click the Windows Start button and select Settings>Control Panel. 
The Control Panel dialog box appears.

2 Select the Add/Remove Programs icon. The Add/Remove Programs 
dialog box appears. 

3 Select the QACenter product to maintain and click Change/Remove.

Three maintenance mode options display: modify, repair, and 
remove. For more information about these options, see the appropri-
ate section in this chapter.
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Modifying an Installation
For products with optional components, you may want to add or remove 
a component. Rather than uninstall and re-install the product, you can 
modify your installation.

Modifying Products With Optional Components

1 Access maintenance mode described at the beginning of this chapter.

2 Select the Modify option and click Next. The Select Components 
dialog box appears allowing you to add or remove components.

3 Click Next. Setup will add or remove the appropriate components.

4 After modifying, you may be prompted to restart your computer. If 
you are prompted to restart your computer, you may choose to restart 
it now (recommended) or to restart it later.

5 Click Finish to complete the maintenance.

Repairing an Installation
There may be times when you will need to repair a damaged QACenter 
product installation. This could be due to an inadvertent deletion or 
corruption of the program. To repair your QACenter product, follow 
these steps:

1 Access maintenance mode described at the beginning of this chapter.

2 Select the Repair option and click Next. Setup will repair the speci-
fied QACenter product. 

3 After repairing, you may be prompted to restart your computer. If 
you are prompted to restart your computer, you may choose to restart 
it now (recommended) or to restart it later.

4 Click Finish to complete the maintenance.

Uninstalling QADirector
If you want to remove QADirector, follow these steps:

1 Access maintenance mode as described at the beginning of this chap-
ter.

2 Select the Remove option and click Next. The Confirm File Dele-
tion dialog box appears. 
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3 Click OK. Setup will remove QADirector from your machine. 

4 After uninstalling, you may be prompted to restart your computer. If 
you are prompted to restart your computer, you may choose to restart 
it now (recommended) or to restart it later.

5 Click Finish to complete the maintenance.

Uninstalling QACenter Portal 
Because QACenter Portal uses several different Compuware applications, 
removing the product requires special steps. To uninstall QACenter 
Portal:

Note: To ensure a clean removal of the applications, uninstall the products 
in the exact order described in these steps.

1 Disconnect from the database. 

2 Access maintenance mode as described at the beginning of this chap-
ter.

3 Uninstall OptimalView 3.3. 

4 Uninstall QACenter Portal.

5 Delete the QACenter Portal installation folder on the machine. For 
example, the folder may be located in the x:\Program Files\Compu-
ware\QACenter Portal\ directory.

Uninstalling the QACenter MSDE Instance
To remove the QACenter MSDE instance, follow these steps:

Caution: All associated data will be lost when you uninstall the MSDE 
instance.

1 Access maintenance mode as described at the beginning of this chap-
ter and remove the Microsoft SQL Server Desktop Engine 
(QACENTER). 

2 Delete any remaining files from the installation directory.
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Appendix A

Manually Creating and 
Configuring a Database
� Manually Creating and Configuring an Oracle Database

� Manually Creating and Configuring a SQL Server Database

Manually Creating and Configuring an Oracle Database 
This section provides information about configuring QADirector to use 
an Oracle database. 

Oracle Server Requirements

� An existing database server that runs the supported versions of Ora-
cle. Refer to “System Requirements” on page 15 for details.

� Oracle ODBC drivers for a supported version of Oracle. Refer to “Sys-
tem Requirements” on page 15 for details.

� A database instance set up on the Oracle database server to store 
QADirector data. Use the following specifics to configure the data-
base instance:

� When the Oracle database instance is defined, you must specify 
the Storage Character Set as iso 8859-1 West European. 

� The NLS_LANGUAGE parameter should be set in the parameter file 
as:

NLS_LANGUAGE = 'AMERICAN'

If you are using Windows 2000, set the NLS_LANGUAGE 
parameter to AMERICAN_AMERICA.WE8ISO8859P1 in the 
following locations:

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\NLS_LANG
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES\IDO\NLS_LAN
G
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HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME-\NLS_LANG

� Access to a valid owner name (also known as a schema) on the Oracle 
database server for QADirector. This owner name is the user ID that 
will be associated with each of the product databases.

Creating Database Tables

Before any client machines can connect to the Oracle database, you must 
create the database and the database tables for QADirector. The SQL*Plus 
utility allows you to create the database tables. To create QADirector 
tables, perform the following for each database:

1 Do one of the following:

� On the Oracle server or client machine, open SQL*Plus Work-
sheet by clicking Start>Programs>OracleHome>Database 
Administration>SQL*Plus Worksheet, where OracleHome indi-
cates the home directory where your Oracle database was origi-
nally installed. 

� In Windows XP, click the Start menu and choose All Pro-
grams>OracleHome>Database Administration>SQL*Plus Work-
sheet, where OracleHome indicates the home directory where 
your Oracle database was originally installed

2 Select Connect Directly to a Database.

3 Type a user name in the Username field. This will be the name of the 
schema where the QADirector tables reside.

4 Type a password in the Password field.

5 Type the name of the service running the database in the Service 
field. 

6 On the database server from within SQL*Plus Worksheet, click Menu 
Worksheet and then click Run Local Script. The Run Local Script 
File dialog box appears.

7 Click the Look In list and navigate to \Cpwr\database\sql-
scripts\oracle on the installation CD.

8 Execute the following scripts in order:

� 1_orcl_qacenter.sql

� 2_orcl_procedures.sql

� 3_orcl_delete_procedures.sql

� 4_orcl_optimalview.sql

� 5_qacenter_appinserts.sql
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� 6_orcl_qacenter_appupdates.sql

� 7_orcl_optimalview_appinserts.sql

Manually Creating and Configuring a SQL Server Database
This section provides information about configuring QADirector to use a 
SQL Server database. 

SQL Server Requirements

� An existing database server that runs a supported version of SQL 
Server. Refer to “System Requirements” on page 15 for details.

� A database instance on the SQL Server database server to store QADi-
rector data. Use the following specifics to configure the database 
instance:

� If you are using SQL Server 7.0 and the database instance is 
defined, you must specify code page 1252 and sort order 52 (also 
known as ISO 8859-1). 

� If you are using SQL Server 2000, specify the 
SQL_Latin1_General_CP1_C1_AS collation.

� An SQL Server user ID and password to allow the QADirector admin-
istrator to set up the database server. 

Creating Database Tables

Once you have created the database, you can create the QADirector 
database tables. QADirector includes files that execute scripts and 
automatically create the tables for you.

1 To start the SQL Server Query Analyzer, select SQL Server Query 
Analyzer from the Tools menu in the SQL Server Enterprise Manager.

2 Select the database from the DB list.

3 Click File>Open. The Open Query File dialog box appears.

4 Click the Look In list and browse to <drive>:\cpwr\database\sql-
scripts\mssql on the installation CD.

5 Select one script at a time, click Open, and click the Run (green 
arrow) icon on the toolbar to run each script in the following order:

� 1_sql_qacenter.sql

� 2_sql_procedures.sql
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� 3_sql_delete_procedures.sql

� 4_sql_optimalview.sql

� 5_qacenter_appinserts.sql

� 6_sql_qacenter_appupdates.sql

� 7_sql_optimalview_appinserts.sql

Adding User Rights to the Database (optional)

Once the database and tables have been built, add users and give them 
access rights using SQL Server Enterprise Manager. Using SQL Server 
authentication login, create a new login ID and password specifically for 
SQL Server access. Use this option to create one convenient user name 
and password to access the QADirector database and have each QADirec-
tor user use the same user name and password to connect to the 
database. If preferred, create multiple SQL Server user names and 
passwords.

Note: The user name and password used to connect to the SQL Server 
database is not the same user name and password that is used to 
connect to QADirector.

To create a SQL Server authentication, follow these steps:

1 In the left pane of the SQL Server Enterprise Manager, expand the 
SQL Server Group, and expand the server machine name.

2 Expand the Security group.

3 Select the Add New User icon from the menu. The SQL Server Login 
Properties dialog box appears.

4 Select the General tab.

5 Type a user name in the Name field (for example, QATeam).

6 Select SQL Server Authentication.

7 Type the password in the Password field.

8 From the Database drop down menu, select the QADirector database.

9 Select the Database Access tab and permit the user to access the cre-
ated database.

10 Set up roles and permissions for the Login account:

� Option A: Ensure the Login account has the db_owner role.
� Option B: Ensure all privileges on all QACenter database objects 

are granted to the newly created Login account. The following is 
a sample script for granting all privileges on all objects to a user.
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Note: Compuware does not assume any responsibility for the use of this 
script.
USE <Database Name>

Go

DECLARE @ExecSQL varchar(255)

Declare @User varchar(64)

Set @User = <Login Account>

DECLARE curGrants CURSOR FOR

SELECT ‘GRANT ALL ON’ + NAME + ‘TP’ + rtrim(@User)

From SYSOBJECTS

WHERE TYPE = ‘U’ or TYPE = “P”

OPEN curGrants

FETCH NEXT FROM curGrants INTO @ExecSQL

WHILE @@FETCH_STATUS = 0

BEGIN

Exec(@ExecSQL)

FETCH NEXT FROM curGrants INTO @ExecSQL

END

CLOSE curGrants

DEALLOCATE curGrants
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Appendix B

Setting Up an ODBC Data 
Source
� Setting up an ODBC Data Source for Oracle

� Setting up an ODBC Data Source for SQL Server

Setting up an ODBC Data Source for Oracle

Setting Up a Net Service

1 Open the Oracle Net Configuration Assistant and click Next.

2 Click Local Net Service Name Configuration and click Next.

3 Click Add and click Next.

4 Click Oracle 8i or later and click Next.

5 Type the Service Name to which you are trying to connect. This may 
be the database name. 

6 Click Next.

7 Click TCP. 

8 Type the Host Name. This may be the machine name on which the 
Oracle server is installed.

9 Click Next. 

10 Click Perform A Test and click Next.

11 Change the user name and password to the user ID you want to use 
and test the connection. 

12 Click Next.

13 Type the Service Name and click Finish.
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Creating a System DSN

1 Do one of the following:

In Windows 2000:

a Click the Start menu and select Settings>Control Panel>Data 
Sources (ODBC). The ODBC Data Source Administrator opens. 

b Click the Drivers tab and select Oracle ODBC Driver.

In Windows XP:

a Select Control Panel>Administrative Tools>Data Sources 
(ODBC). The ODBC Data Source Administrator opens. 

b Click the Drivers tab and select Oracle ODBC Driver.

2 Click the System DSN tab.

3 Click Add.

4 Select Oracle from the Driver list.

5 Click Finish. The Create a New Data Source dialog box appears.

6 Type a Data Source Name (DSN) in the Data Source Name field.

7 Type a description in the Description field.

8 Type the database service name in the Service Name field. If the 
database is not local to the computer, type the full name, such as 
aqw.qaclab.

9 Type the user name in the UserID field.

10 Keep the default settings in the remaining fields and click OK.

Setting up an ODBC Data Source for SQL Server
At this point you have a database, tables, and users, but no connection to 
the database. You must set up an ODBC data source on the QADirector 
client machine:

1 Do one of the following:

In Windows 2000:

a Click the Start menu, and select Settings>Control Panel. 

b Double click the Data Sources (ODBC) icon. The ODBC Data 
Source Administrator opens.

In Windows XP:
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a Click the Start menu and select Control Panel>Administrative 
Tools>Data Sources (ODBC). 

b Skip to step 3.

2 Click the System DSN tab.

3 Click Add.

4 Select SQL Server from the Driver list.

5 Click Finish. The Create a New Data Source to SQL Server dialog 
box appears.

6 Type an ODBC connection name in the Name field.

7 Type a description for the ODBC connection in the Description field.

8 Type the server name in the Server field.

9 Click Next.

10 Select the With SQL Server Authentication using a login ID and 
password entered by a user option.

11 Type a user name in the Login field.

12 Type a password in the Password field.

13 Click Client Configure.

14 Verify that TCP/IP is selected under the network libraries.

15 Click OK.

16 Click Next.

17 Select the Change the Default Database to check box.

18 Select the QADirector database from the database menu.

19 Click Next.

20 Click Finish. The ODBC Microsoft SQL Server Setup dialog box 
appears.

21 Click Test Datasource.

22 Click OK to exit the ODBC Microsoft SQL Server Setup dialog box.

23 Click OK to exit the ODBC Data Source Administrator.

Determining the Port Number

To find the port number from the Registry:
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1 Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft 
SQL Server\<InstanceName>\MSSQLServer\SuperSocketNetLib\Tcp. 

You should see a folder with the same name as the instance that was 
created for MSDE. For example: 
HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL 
Server\QACenter\MSSQLServer\SuperSocketNetLib\Tcp

2 Remember the number for the Tcpport entry. 

To find the port number using SQL Enterprise Manager:

1 Open SQL Enterprise Manager.

2 Connect to the instance for the MSDE installation. Example: 
qacenter. 

3 Right click on the instance and select Properties.

4 Click Network Configuration. 

5 Select TCP/IP from the Enabled Protocols list and click Properties. 

The port number is located in the Default Port field. 
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Appendix C

Optional QACenter Portal 
Configuration
�  Configuring OptimalView for Load Handling on the Web 
Server

�  Changing the Default Ports

�  Preventing Frequent Logging Off During a Session

Configuring OptimalView for Load Handling on the Web Server 
To improve the performance when there are numerous concurrent users, 
configure the following settings according to the anticipated user load:

1 Open the COS Installation directory. 

For example, open the C:Program Files\Common Files\Compu-
ware\CWJboss directory. 

2 Open the server\cpwr\deploy\jbossweb-tomcat41.sar\META-INF\ 
jboss-service.xml file.

3 Locate the following section:

<Connector className="org.apache.coyote.tomcat4.CoyoteCon-
nector"

4 Change the number of the following areas according to the number 
of users working concurrently:

� minProcessors: The minimum number of threads that the server 
will attempt to maintain.

� maxProcessors: The maximum number of threads that are avail-
able to perform the requested processing. This is also the limit of 
the maximum number of concurrent clients.
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� acceptCount: The maximum queue length for incoming connec-
tions requests when all possible requests processing threads are in 
use. Any requests received when the queue is full will be refused.

For example:

<Connector className="org.apache.coyote.tomcat4.CoyoteCon-
nector"

port="8009" minProcessors="100" maxProcessors="200"

enableLookups="true" redirectPort="8443"

acceptCount="300" debug="0" connectionTimeout="20000"

useURIValidationHack="false"

protocolHandlerClassName="org.apache.jk.server.JkCoyote-
Handler"/>

5 Save the changes and close the file.

6 Open the COS Installation directory. 

For example, open the C:Program Files\Common Files\Compu-
ware\cwjboss directory. 

7 Do one of the following:

� If using SQL Server, open the Server\cpwr\Deploy\optimal-
view.war\web-inf\ovmssql.properties file.

� If using Oracle, open the Server\cpwr\Deploy\optimal-
view.war\web-inf\ovoracle.properties file.

8 Change the number of the following areas according to the number 
of users working concurrently on the server:

� JDBCMAXPOOL: The maximum number of connections Opti-
malView will attempt to open. Lowering the maximum connec-
tion number will increase the response time of OptimalView 
when the load is high.

� JDBCMINPOOL: The minimum number of connections Opti-
malView will maintain when the load is not high.

For example:

JDBCMAXPOOL=120

JDBCMINPOOL=50

9 Save the changes and close the file.

10 Restart the COS.
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Changing the Default Ports 
COS 1 Open the COS Installation directory. 

For example, open the C:Program Files\Common Files\Compu-
ware\cwjboss directory. 

2 Open the Server\CPWR\CONF\jboss_service.xml file.

3 Locate the following section:

service-configuration=”jboss.web:service=Webserver”.

4 Locate the <bindingport= > tag.

5 Insert the correct port and save your changes.

OptimalView 6 Within the COS Install directory, navigate to the 
Server\CPWR\Deploy\jbossweb-tomcat41.sar\META-
INF\worker.properties file and open it.

7 Take the port number from step 4 above and subtract 71 from this 
value.

8 Locate the following section:

worker.ajp13.port= 

9 Insert the value from step 7 and save your changes.

QACenter Portal 10 Locate the UI\QACenterportal\Web.config file.

11 Locate the following section:

add key=”orWebPort” value. 

12 Insert the value from step 7 and save your changes.

13 Restart IIS and COS from the Services Panel.

Preventing Frequent Logging Off During a Session
Some factors, such as virus scanners, can interfere with the session. 

Configuring the Virus Scanner

Some virus scanners interfere with IIS and may scan the configuration 
files which can cause IIS to be recycled. To prevent this, exclude the 
following files from the server’s virus scanner: 

� Machine.config in the .NET framework 1.1 Installation Folder. Exam-
ple: C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\CONFIG.
Appendix C� Optional QACenter Portal Configuration     69



� Web.Config in the QACenter Portal Installation Folder. Example: 
C:\Program Files\Compuware\QACenter Portal\UI\qacenterpor-
tal.

� Global.asax in the QACenter Portal Installation Folder. Example: 
C:\Program Files\Compuware\QACenter Portal\UI\qacenterpor-
tal.

Configuring Windows 2003 Server

Use the following to prevent unintentional logging off from QACenter 
Portal.

1 Open the Internet Information Service Manager. For more informa-
tion, refer to the Microsoft Windows documentation.

2 Click AppPool>Default AppPool. 

3 Click the Performance Tab. You will see the Shutdown Worker Pro-
cesses check box.

4 Do one of the following:

� Select this check box and increase the number of minutes to 1440 (24 
hours)

� Deselect this check box. This will disable worker process recycling. 
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