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Enterprise Analyzer Release Notes -
Version 3.6

These release notes contain a summary of the major features of Enterprise Analyzer Version 3.6, as well
as late-breaking information about the product.

Before using Enterprise Analyzer, please read the Getting Started manual located in the online help, or the
Documentation subfolder under the product installation folder, to gain an understanding of the user
interface and tool metaphor. For more detail on the behavior, usage and limitations of Enterprise Analyzer,
please refer to the online help and additional user manuals.
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What's New

Enterprise Analyzer Product Enhancements
Enterprise Analyzer product enhancements listed below include improvements to Change Analyzer for
more easily understandable results, a new advanced search query builder design, Change Analyzer
functionality in the web client interface for a single declaration, the ability for users to switch between
different workspaces in the web client, and more.

Micro Focus COBOL Compiler Integration
Enterprise Analyzer now uses the Micro Focus COBOL compiler for the COBOL/390, Enterprise COBOL
and Micro Focus COBOL dialects. Using the Micro Focus COBOL compiler in Enterprise Analyzer ensures
that the COBOL support in EA matches the version used in Enterprise Developer and Visual COBOL. This
makes the analysis you see in EA consistent with how your sources are supported in Enterprise Developer
and Visual COBOL. Also, adding support for features not previously included in EA, like object-oriented
COBOL, will be possible in upcoming versions.

Change Analyzer Improvements
The procedure to perform a field change analysis in Change Analyzer has been simplified, and the results
are now more readable with an explanation of the reason for the impact on synonyms and affected
variables. The change analysis now also continues through to called programs and includes impacted data
items in the called program as well.

Feature Name Changes
Two important features in Interactive Analysis have been given more meaningful names to try to better
convey their purpose to new users.

Clipper is now Code Search. This is the list manager and advanced search pane in Interactive Analysis.

Callie is now Program Control Flow. This pane is the diagrammatical view of the flow between
paragraphs in a COBOL file.

Redesigned Advanced Search Query Building Interface
The interface for creating advanced search queries (Clipper/Code Search) in Interactive Analysis has been
redesigned to make it easier to get started creating custom queries. A few of the main features of the new
interface are:

• Queries can be built directly in the query text without switching to separate dialogs.
• Search values and operators can be changed more quickly.
• Enumerated values are now selected from a dropdown list.
• Complex queries are easier to understand with better visualization of nesting levels.

The new query design interface is currently in a beta phase. The traditional query definition interface is still
shown by default, but you can switch to the new design at any time by selecting the "New definition" radio
button at the bottom left of the advanced search window.
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Change Analyzer Functionality in EA Web for a Single
Declaration
A new feature to perform a Change Analyzer-like impact analysis on a single declaration is now included in
EA Web, the web client for Enterprise Analyzer. Right-click a declaration in your search results and choose
Change Analysis to get a list of results showing the impacts from the instances of the declaration. The list
of results is the same as the new results view in Change Analyzer in the Enterprise Analyzer desktop
client. You can expand the synonym nodes to see how the item was impacted. Double-click the detail to
display the line of interest in the source to the right.

Client Switching to Different Workspaces in EA Web
In previous versions of Enterprise Analyzer, only one workspace was available in the web client at a time.
In EA 3.6, EA Web now provides a dropdown selection list in the top right corner of the page to switch to
any workspace configured for the EA Web Service.

Other Enhancements and Changes
• The Workspace Build Wizard can now be used to add sources to an existing workspace. Choose

Maintain Workspace from the Workspace menu in the Enterprise Analyzer main window to open the
Workspace Maintenance Wizard.

• New relationships for Assembler I/O operations toward QSAM files have been introduced. GET
commands will create a Program Reads File relationship. PUT commands will create a Program Writes
File relationship.

• PL/SQL source file verification now provides metrics for Blank Lines, Lines with Comments and Source
Lines.

• Possible data padding has been added as a new defect for statements in Interactive Analysis. The value
of Defects attribute is PADDING.

• Reports and diagrams can now be saved fromEA Web.
• A new report that tracks the access of users to EA Web has been added. Generate the report from

Enterprise Analyzer Administration by choosing Session Report from the Tools menu, select the dates
for the report, and click Refresh.

• The ability to open a source from query results by double-clicking the cell has been added in EA Web.
• The Choose Other Database button has been added to the Workspace Build Wizard to create a

workspace for databases other than SQL Server Express. Note however that the regular workspace
creation dialog will be used to create the workspace in this case and not the wizard.

• The EA open workspace dialog has been added to Enterprise Analyzer Administration to make the
selecting of workspaces when executing some functions easier.

• The open workspace dialog now has an Other Location button to make it possible to select .rwp files
on shared locations or mapped drives.

• The option to deselect Business Rule Manager in the Configuration Manager has been removed. The
ability to use the Rules pane in Enterprise Analyzer is now controlled by the Business Rule Manager
license only.

• The new batch script StartHCC.bj has been created to allow for easier automated runs of remote
Queue Processors for verification and loading work during BRP.

• The performance for applying PCF files has been improved by adding new indexes to the temporary
table brpPCF.

• · The Enable Extraction of Computation-Based Components and Enable Parameterization of
Components options in Project Options > Verification > COBOL File > Advanced Program
Analysis are now disabled by default to improve the stability when verifying large files. For existing
workspaces they will remain checked if they were checked prior to a workspace upgrade.
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• The default value for the Maximum Size of Variable to be Calculated option (Project Options >
Verification > COBOL File > Advanced Program Analysis) has been changed from 5000 to 1000 to
prevent COBOL files from failing during verification.

• The filtering options Search, Wildcard Search, Find All and Wildcard Find All have been removed
from the Filter dropdown menu in the Repository Browser.

Nonfunctional Changes
• Windows XP and Windows Server 2003 are no longer supported by Enterprise Analyzer. Please

contact Micro Focus SupportLine for more information.
• MSXML4 has been removed from EA and is replaced by MSXML6.

Installer
The Enterprise Analyzer installer has been redesigned as a single dialog that allows the user to change the
install location and select which optional packages will be installed. Start the installation by running
EnterpriseAnalyzer36.exe. The Packages folder contains the included pre-requisite software and
optional software - this folder must be present at the same level as the EnterpriseAnalyzer36.exe.

SQL Server Express is now an optional install. Apache Tomcat and the required JRE can also optionally be
installed if you plan on deploying EA Web on the machine. The Administration tool is also an optional install
for the scenario where you are installing on a client machine and administration features would not be
needed.

Note: This version of Enterprise Analyzer includes a new installer for the Micro Focus License
Manager with a restructured version number. If the Micro Focus License Manager from a previous
version of Enterprise Analyzer is already installed on the machine, it will need to be uninstalled from
the Windows Control Panel before installing Enterprise Analyzer3.6.

MFA
MFA is now included as an optional install with Enterprise Analyzer. If selected, MFA will be installed on the
machine. Start menu shortcuts to the executables and documentation are included in Micro Focus >
Enterprise Analyzer > Tools.

Note: This version of MFA requires Enterprise Analyzer 3.6 or later to be installed on the machine for
all features to work properly. The MFA installer included with EA 3.6 should not be used separately
from EA.
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Upgrades from Previous Versions
Enterprise Analyzer 3.6 supports upgrades of workspaces from Enterprise Analyzer version 3.3 with HotFix
13, version 3.4 with HotFix 10, version 3.5 with HotFix 9 or HotFix 10, and 3.5.2 GA or any HotFix level.

Note: If upgrading a workspace from version 3.2, you will need to uninstall the product first, install
version 3.4 HotFix 10 and upgrade the workspace, and then install version 3.5.2 GA and upgrade the
workspace before upgrading to version 3.6.

Important: All workspaces must be upgraded after installing EA 3.6. Before upgrading, we
recommend you contact SupportLine for the latest Enterprise Analyzer updates. SupportLine is also
available to give guidance on best practices for workspace upgrades. Before performing the upgrade
on important workspaces, be sure to backup the database and the workspace folder along with
the .rwp file. If you experience any issues or errors with the workspace upgrade process, please
contact SupportLine with a description of the problem and include the contents of the Upgrade folder
from the workspace as an attachment.
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Updating the EA Web Client
After installing Enterprise Analyzer 3.6, the following steps should be performed to continue using the EA
Web client. You will be able to use the new features of the 3.6 version after the final step is completed.

1. Stop the Apache Tomcat service.
2. Delete EAWeb.war and the EAWeb folder from C:\Program Files (x86)\Apache Software

Foundation\Tomcat\\webapps.
3. Delete everything in the ...\Tomcat\temp folder.
4. Delete everything in the …\Tomcat\work\Catalina\localhost folder.
5. Copy the EAWeb.war file from [EA installed directory]\Web Client into the …\Tomcat

\webapps folder.
6. Start the Apache Tomcat service.
7. In the properties for the Enterprise Analyzer Web Service, go to the Log On tab, choose This account

and enter the account of a user with access to EA and the workspace.
8. Restart the Enterprise Analyzer Web Service.

Note: The browser clients may need to hard refresh the EA Web page with Ctrl+R to get the latest
version.

Note: Due to an incompatibility between Java 8 and Tomcat 6.0, you might need to uninstall
Tomcat 6.0 and install the Apache Tomcat 7.0.62 that is included with the EA 3.6 installer.

Note: When using EA Web in Internet Explorer, compatibility mode should be disabled.
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Important Notes
• The Documentation Start menu shortcut to the EA PDF manuals has been replaced with a link to the

online help file. The PDF manuals are still available in the Docs folder in the Enterprise Analyzer
installation directory.

• The Developer Client license allows one user access to the workspace build and maintenance features
of EA. The Developer Client users access the workspace repository through the Web UI only and do not
install the EA desktop software.

• If installing an Analyst Client license on a machine that already has a Developer Client license, the
Developer Client license will need to be removed for the Analyst Client features to be available to the
user.

• EA 3.6 no longer includes a 30-day trial license for new installs. For an evaluation copy, please contact
Micro Focus SupportLine.

• All Enterprise Analyzer windows should be closed on the machine before uninstalling EA from the
Windows Control Panel.

• The option to install MFA with EA 3.6 on Windows 7 requires at least Service Pack 1. If MFA is needed
when installing on Windows 7 with no Service Pack, MFA will need to be installed separately from the
EnterpriseAnalyzer36.exe installer with the following instructions.

1. Install the VC++ 2012 redistributable first from either \Packages\vcredist_x64.110 or
\Packages\vcredist_x86.110.

2. Run the MFA.msi from \Packages\MFA.
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Resolved Issues
The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem
Incident (RPI) number (in parentheses).

• EA - Administration
• EA - Analysis - HyperView - Clipper
• EA - APM
• EA - Backend
• EA - Backend - Analysis
• EA - Backend - Analysis - Cobol
• EA - Backend - Analysis - DDL
• EA - Backend - Analysis - IMSAnalysis
• EA - Backend - Analysis - Java
• EA - Backend - Analysis - JCL
• EA - Backend - Analysis - PL1
• EA - Backend - Architecture Modeler
• EA - Backend - Parsing - Assembler
• EA - Backend - Parsing - BMS
• EA - Backend - Parsing - Cobol
• EA - Backend - Parsing - Cobol/ACU
• EA - Backend - Parsing - Cobol/Cobol 390
• EA - Backend - Parsing - Cobol/MicroFocus
• EA - Backend - Parsing - Cobol/Unisys MCP
• EA - Backend - Parsing - DDL
• EA - Backend - Parsing - EmbeddedCICS
• EA - Backend - Parsing - EmbeddedSQL
• EA - Backend - Parsing - JCL
• EA - Backend - Parsing - PL1
• EA - Backend - Verification
• EA - Batch Application Viewer
• EA - Batch Refresh Process
• EA - Business Rules
• EA - Change Analyzer
• EA - Common
• EA - Complexity Metrics
• EA - Diagrammer
• EA - Documentation
• EA - EAWeb
• EA - Homonyms
• EA - HyperView
• EA - HyperView - Clipper
• EA - IDE
• EA - IDE - Options
• EA - IDE - Project Operations
• EA - IDE - Repository Browser
• EA - IDE - Source Editor
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• EA - IDE - Workspace Operations
• EA - IMS Analysis
• EA - Plugins
• EA - Reports
• EA - Reports - Executive Report
• EA - Reports - Inventory
• EA - Reports - Portability Assessment
• EA - Reports - Verification Report
• EA - Search Assistant
• EA - Tag Manager
• EA - Upgrade
• EA - Wizard
• EA-ED Integration

EA - Administration

• Support has been added for the existing 3-role policy users.

2813539 (1098674)
• The "Drag-and-Drop" text was removed from the Add files for analysis step in the workspace build

wizard because drag-and-drop does not work with default User Account Control settings. However, if
the UAC is set to the lowest level, the Drag-and-Drop functionality will work for files and folders.

2810956 (1098592)
• The Workspace Queue Status now correctly includes the database load jobs in the count of Waiting

tasks.

(609886)

EA - Analysis - HyperView - Clipper

• SQL WHERE clause for PL/I is now supported in context view from Interactive Analysis.

2803921 (1097217)
• Defects when using CURRENT_DATE are now correctly populated.

2801264 (1097017)
• When you search for a constant literal in Clipper, it will now automatically add single quotation marks

around the string unless the string is a valid number literal. The single quotations marks will be saved in
the options file and will be visible upon subsequent viewing/modification of the criteria.

2676308 (1092194)

EA - APM

• Drilldown in dashboards to charts using objects is now correctly handled.

2825372 (1100111)
• An issue with trending metrics has been fixed.

2819487 (1099519)
• Imported metrics are now visible in the chart wizard.

2807164 (1097714)
• EV should now load without any delay.

2801671 (1097004)
• Showing decimal metrics in charts is now working correctly on French machines.

2783373 (1095072)
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EA - Backend

• Calling JCL files are no longer invalidated when the "Do not invalidate dependent files" option is
checked.

2801990 (1097353)
• There is no longer a problem when verifying a linkdeck file that defines a program entry that already

exists in the included program.

2798477 (1096643)
• An issue with verifying a PL/SQL file has been fixed.

(614912)

EA - Backend - Analysis

• A program entry point is no longer generated for empty COBOL programs (0 file size) and verification of
such programs now fails with error 8084 - Unexpected end of file. Such programs are no longer listed in
the generated reports.

2831355 (1100749)
• LinkDeck invalidation no longer removes resolutions toward entries created by LinkDeck.

2804676 (1097309)
• The default value for the "Maximum Size of Variable to be Calculated" option in Project Options >

Verification > COBOL File > Advanced Program Analysis has been changed from 5000 to 1000 to
prevent COBOL files from failing during verification.

2804210 (1097326)

EA - Backend - Analysis - Cobol

• The "Enable Extraction of Computation-Based Components" and "Enable Parameterization of
Components" options in Project Options > Verification > COBOL File > Advanced Program Analysis are
now disabled by default to improve stability when verifying large files. For existing workspaces they will
remain checked if they were checked prior to a workspace upgrade.

2810362 (1098250)

EA - Backend - Analysis - DDL

• Support has been added for the TIMEZONE keyword.

2827972 (1100360)

EA - Backend - Analysis - IMSAnalysis

• The logging information from IMS analysis has been significantly improved. Error severity ratings were
added with a recommendation on how to fix it.

2638303 (1094101)

EA - Backend - Analysis - Java

• Java files are no longer moved to the workspace Sources folder upon invalidation. Affected workspaces
(those with Java files re-verified in EA 3.5.2 or later) should delete and re-register all Java files.

(610508)

EA - Backend - Analysis - JCL

• -1 metric values are ignored when populating trending snapshot.
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2831372 (1100769)
• The issue with relationships to JCL procedures not resolving correctly with the Homonyms Search Path

options is now fixed.

2812781 (1098389)

EA - Backend - Analysis - PL1

• Host variable usages inside embedded SQL are now connected to the proper declaration in PL/I.

2804152 (1097246)
• Host variable usages inside embedded SQL are now connected to the proper declaration in PL/I.

2804152 (1097247)
• The Source view in Interactive Analysis now shows the correct position of the code that is inside

embedded SQL in PL/I.

2804152 (1097248)

EA - Backend - Architecture Modeler

• An issue that caused verification to fail when using a new Architecture Modeler plugin has been fixed.

2692037 (1093559)
• An issue with AM plugins causing verification errors has been fixed.

2692037 (1094338)

EA - Backend - Parsing - Assembler

• New relationships for Assembler I/O operations toward QSAM files have been introduced. GET
commands will create a Program Reads File relationship. PUT commands will create a Program Writes
File relationship.

2815005 (1098731)
• The Assembler relationship ‘Uses Macro File’ is now properly displayed when a macro is used inside a

macro.

2804103 (1097276)

EA - Backend - Parsing - BMS

• When EXTATTS=YES in a BMS file, DSATTS is set to (COLOR,HILIGHT,PS,VALIDN). Subsequent
DSATTS entry found in the BMS file containing incomplete set of attributes will not overwrite already set
DSATTS. This applies to map sets.

2786371 (1095276)

EA - Backend - Parsing - Cobol

• A new type, QUEUE, has been added to Legacy.xml Generic API for creating relationships.

2832452 (1100869)
• Log information is now generated when verifying COBOL programs that use Hogan.

2829126 (1100501)
• The COBOL parser now accepts code where the USING clause is not followed by identifiers and/or a

period.

2807098 (1097631)
• Decisions are now correctly resolved when setting "Use values from linkage section".

2657419 (1094678)
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EA - Backend - Parsing - Cobol/ACU

• There is no longer an error when the FUNCTION keyword is excluded in ACUCOBOL.

2833940 (1101052)
• The ACUCOBOL dialect parser now correctly resolves calls to program names containing subfolder

filepath elements in their string definitions.

2813110 (1098469)
• An issue in ACU COBOL sources that resulted in "Error 8078 - Incorrect SIZE ERROR phrase" has

been addressed.

2804215 (1097265)
• The INITIALIZE WITH FILLER syntax in ACU COBOL sources no longer returns Error 8053 -

Undeclared identifier.

2802814 (1097144)

EA - Backend - Parsing - Cobol/Cobol 390

• Parser support for CICS SPOOLOPEN REPORT, SPOOLCLOSE REPORT and SPOOLWRITE
REPORT statements has been added.

2814983 (1098763)
• An issue where the preprocessor required space after REPLACING in a COPY statement has been

fixed.

2814104 (1098606)
• Parameters to DLI SCHD statement can now appear in any order.

2784304 (1095052)
• The DLI ROLLB statement has been added as a synonym for the DLI ROLB statement. CICS PUT

CONTAINER LENGTH has been added as a synonym for CICS PUT CONTAINER FLENGTH.

2784304 (1095391)

EA - Backend - Parsing - Cobol/MicroFocus

• An issue in handling FREE and FIXED preprocessor directives in Micro Focus COBOL has been fixed.

2695295 (1094061)
• The hanging of the COBOL parser for cases of missing periods on some data item declarations has

been fixed.

2681600 (1092707)

EA - Backend - Parsing - Cobol/Unisys MCP

• EA no longer crashes when COM declarations in Unisys MCP85 are missing.

2822715 (1099743)
• Support has been added for the mnemonic values of COBOL MCP 85 Task attribute STATUS.

2797638 (1096515)
• Support has been added for searching declarations containing underscore.

2797633 (1096497)
• There is no longer an error when parsing EVALUATE statement which has a WHEN OTHER clause but

doesn't have WHEN clauses.

2797632 (1096500)
• Memory consumption while analyzing COBOL files has been improved.

2796936 (1096464)
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EA - Backend - Parsing - DDL

• The support for PARTITION clauses when partitioning on date values has been improved.

2788579 (1095535)
• Aliases and Synonyms are no longer marked as isView.

2650916 (1089949)

EA - Backend - Parsing - EmbeddedCICS

• The CICS GET statement has been modified to allow CHANNEL to appear before CONTAINER.

2827972 (1100358)

EA - Backend - Parsing - EmbeddedSQL

• SQL Fetch First no longer produces warnings.

2827972 (1100356)
• SQL---PLIST declaration has been added to DB2 copybook.

2827972 (1100357)
• The EXEC SQL VAR <host_variable> IS <datatype> syntax no longer produces verification errors.

Warning messages are now shown where appropriate.

2683110 (1092923)

EA - Backend - Parsing - JCL

• A literal string is no longer recognized as JCL symbol.

2788168 (1095494)

EA - Backend - Parsing - PL1

• Procedure input parameters are now pointing to the correct declaration.

2804519 (1097282)

EA - Backend - Verification

• Java packages no longer cause failures when creating or applying PCF files.

2815397 (1098751)
• The issue with the selection of code segments for rules in C/C++ and VB 6 files has been fixed.

2812939 (1099009)
• Blank Lines, Lines with Comments and Source Lines statistics are now collected for PL/SQL source

files.

2812497 (1098632)
• Performance of COBOL verification when having OCCURS over structures has been improved.

2811917 (1098440)
• When trying to register the same .NET files again, they are no longer registered in all capital letters.

2809299 (1097896)
• A number of improvements have been made to behavior when invalidating a C# .NET project:

1. When invalidating a C# .NET project, the .NET files included in the project are invalidated in the
Repository Browser. The circular icon (with color depending on a previous validation result) next to
the file name of each one of the files disappears, as it does for the project entry itself.
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2. Statistics for the .NET files are now cleared upon invalidation, as well as any relationships.
3. New relationship with the description string of "Included in .NET Project" is displayed for each of the

C# source files, pointing to the .NET project which includes the respective C# source file.
4. The .NET files now show verification icons corresponding to the verification status of each file.

2808326 (1097779)
• .NET projects no longer fail when duplicate methods are defined.

2807720 (1097692)
• The temporary files used when verifying COBOL files with the "Use Database Schema" option enabled

are now successfully deleted after use.

2804570 (1097295)
• The critical error during the verification of .NET projects due to duplicate method names found during

parsing (such as private and static default constructor) no longer appears.

2800163 (1096825)

EA - Batch Application Viewer

• ECL files are no longer shown in Batch Application Viewer.

2666564 (1091268)

EA - Batch Refresh Process

• The StartHCC.bj script has been added to allow for starting a certain number of Queue Processors.

Example for running it manually:

Brave.exe "StartHCC.bj" "log.txt" "ExtraHCC=1" "Workspace=MWTEST1"

Important:

If the workspace is configured with parallel verification, the actual number of started Queue Processors
is ExtraHCC x Number of CPU cores. Therefore, if you have 4 CPU cores and use ExtraHCC=1, the
actual number of Queue Processors to start will be 4x1=4.

2827481 (1100371)
• VerifyX now verifies all files in all projects if the project parameter is not set.

2818697 (1099141)
• The Oracle integrity constraint failure when updating Java files in BRP has been fixed.

2816134 (1098861)
• The performance of applying PCF files has been improved.

2815397 (1098973)
• An incorrect filter for ParseStatus when performing BRP verification commands has been fixed.

2809065 (1097856)
• The performance on AddNew.bj has been improved.

2803438 (1097292)
• The UpdateOnly parameter is now handled correctly.

2803401 (1097211)
• An issue with dropping indexes in BRP has been fixed.

2802363 (1097184)
• CreateDBSchema.bj has been created to generate the Database Schema diagram.

(608795)
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EA - Business Rules

• The "Triggers/Triggered By" column in the business rule report has been renamed to "Triggers RULE
SET/Triggered By RULE".

2831905 (1100815)
• Copy and Paste Control Conditions in BRM are now working.

2831530 (1100770)
• The time it takes to delete auto-generated rules has been halved.

2830013 (1100702)
• An informative message has been added to the activity log when importing business rules to explain the

reason for an unsuccessful import, and a message is now displayed in Interactive Analysis.

2807021 (1097852)
• Business Rules exported from EA 3.5 can now be imported into EA 3.5.2.

2806911 (1097651)
• Clicking on a link in the Business Rule Report now goes to the correct place in the document.

2802726 (1097111)
• Performance improvement has been implemented for loading business rules into the tree view.

2672476 (1092272)

EA - Change Analyzer

• The missing synonym is now found in the synonym search results.

(607804)

EA - Common

• Errors with Activity Log inserts in DB2 have been fixed.

2804758 (1097323)

EA - Complexity Metrics

• The OS390Cobol.cpy system copybook is always included but not visible which was causing the
discrepancy of 40 lines. The counting of lines for this copybook has been skipped.

2828277 (1100552)

EA - Diagrammer

• Diagrams showing relations from JCL to program entry points are now displayed correctly.

2806910 (1097612)
• The composite relationship "Refers to Data Store" is now displayed correctly for batch programs in the

Diagrammer.

2806042 (1097938)

EA - Documentation

• Information about the logon user has been added to the EA Web Installation Guide.

2667181 (1092563)
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EA - EAWeb

• The Object Name column in Code Search results has been changed to show the Program file name for
items from copybooks.

2800413 (1096861)
• The ability to open a source from query results by double clicking the cell has been added.

2800054 (1096799)
• The highlighted line is now shown at the top.

2799446 (1096738)
• The context menu depends on the intersection of menu items for each of the selected objects.

2691945 (1093441)
• The context menus when a mix of level 1 and level 2 objects have been selected, have been disabled.

The EA Web Query Repository menu now shows the intersection between all applicable queries for the
selected object types. The ED plugin now works with the new service implementation for
QueriesByObjectType method.

(602174)

EA - Homonyms

• The issue with shared paths in the Homonyms Search Path options not working has been fixed.

2808869 (1098285)

EA - HyperView

• The Clipper list is now correctly populated when performing an extraction with Logic Analyzer.

(608077)

EA - HyperView - Clipper

• The missing source code lines in Clipper Detailed Report have been added.

2817464 (1099001)
• Possible data paddings are now identified correctly in Interactive Analysis. The value of the Defects

attribute is PADDING.

2809565 (1097928)

EA - IDE

• Menu items are now correctly shown according to the active license.

2834865 (1101223)
• An issue where Chart Viewer displayed black cells instead of charts has been fixed.

2831432 (1100735)

EA - IDE - Options

• An issue with the project filter and missing selected projects that caused a crash with an XML error has
been fixed.

2816453 (1099449)
• CEE* and DSNTIAUL have been added to the System Program patterns list in the workspace options.

2803845 (1097440)
• The Include Resource Statements metric has been removed.
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(613933)

EA - IDE - Project Operations

• Project Options are now not available if Workspace project is selected.

2796738 (1096458)

EA - IDE - Repository Browser

• Double-clicking on SCREEN entity has been fixed to generate screen in Editor.

2820662 (1099418)
• The View option is no longer greyed for the Screen entity when listed under relationship.

2820662 (1099419)
• Include into Project is now enabled after selecting the Legacy Search tab.

2819361 (1099241)
• Relationships to files through decisions are now shown in the Repository Browser query "Data

Accessed" and the Query Repository "Direct References (outgoing)."

2814664 (1098948)
• The performance for displaying incoming relationships in the browser queries has been improved.

2813256 (1098461)
• Browser query performance has been improved.

2810061 (1098441)
• "Called By" in the Repository Browser tree now shows the Transaction code instead of the .PCT file.

2800962 (1096918)
• The Job Precedes Job relationship in the Job Predecessor diagram is now spelled correctly.

2795263 (1096257)
• The filtering options "Search", "Wildcard Search", "Find All" and "Wildcard Find All" have been removed

from the Filter drop-down menu.

2786882 (1095388)
• PROGRAM -> FILE relationships are now shown in Direct References (outgoing) results.

2676419 (1092289)

EA - IDE - Source Editor

• An issue that caused verification messages to display incorrectly in Japanese environments has been
fixed.

2810487 (608567)

EA - IDE - Workspace Operations

• Sources are now exported with the original directory structure.

2800071 (1096818)

EA - IMS Analysis

• Memory consumption during IMS analysis has been improved.

2812265 (1098442)
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EA - Plugins

• The source code of files marked with a green dot can now be opened in Clipper View.

2807027 (1097899)

EA - Reports

• Enterprise Analyzer now makes use of the list separator regional setting when generating reports.

2817591 (1099092)
• Batch reports now use the regional setting for the list separator.

2817591 (1100526)
• The message that asks for HyperCode indexes has been added to the required functions.

(603563)

EA - Reports - Executive Report

• Column headers of the Unresolved Report and Unreferred Report in the Executive Report are now
displayed correctly in Japanese environments.

(606998)

EA - Reports - Inventory

• Empty lines have been removed from the Inventory report.

2809259 (1097883)

EA - Reports - Portability Assessment

• There is no longer a warning message when applying a plugin that affects PAConfig.xml.

2807614 (1098261)
• Portability Assessment reports that should only show unique results no longer show duplicate records.

2800249 (1096835)
• The Portability Assessment Outbound Interface Files report no longer includes temporary files.

2800216 (1096823)
• Project name has been added to the PA and QA reports' titles.

2800164 (1096819)

EA - Reports - Verification Report

• The full source path is now shown in the Details pane in Verification Report.

2799986 (1096800)

EA - Search Assistant

• CRUD operations from decisions have been included in Is CRUD By query.

2816581 (1099343)
• The repository search results now include ADABAS file objects.

2815175 (1098733)
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EA - Tag Manager

• After removing and then adding the same object to the repository, previously assigned tags are now
properly retained.

2812642 (1099214)

EA - Upgrade

• Upgrading Diagrammer scopes no longer causes error due to duplicated Scopes/Relations information
from the user.

2820197 (1099357)
• The error during the "Upgrading options" step when upgrading some workspaces to EA 3.5.2 has been

fixed.

2806475 (1097517)
• Workspace upgrades from Enterprise Analyzer 3.5 now work correctly for workspaces that include

Enterprise View survey formulas.

2803631 (1097328)

EA - Wizard

• All missing files are now reported properly by EA Build Wizard.

2800901 (1096924)

EA-ED Integration

• The Search Assistant plugin for Enterprise Developer can be used with a remote Enterprise Analyzer
Web Service. This now works correctly after applying an upgrade.

2797547 (1096527)
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Updates and SupportLine
Our Web site gives up-to-date details of contact numbers and addresses.

Contacting Micro Focus
Micro Focus is committed to providing world-class technical support and consulting services. Micro Focus
provides worldwide support, delivering timely, reliable service to ensure every customer's business
success.

All customers who are under a maintenance and support contract, as well as prospective customers who
are evaluating products, are eligible for customer support. Our highly trained staff respond to your requests
as quickly and professionally as possible.

Visit http://supportline.microfocus.com/assistedservices.asp to communicate directly with Micro Focus
SupportLine to resolve your issues, or email supportline@microfocus.com.

Visit Micro Focus SupportLine at http://supportline.microfocus.com for up-to-date support news and access
to other support information. First time users may be required to register to the site.

Information Needed by Micro Focus SupportLine
When contacting Micro Focus SupportLine, please include the following information if possible. The more
information you can give, the better Micro Focus SupportLine can help you.

• The name and version number of all products that you think might be causing an issue.
• Your computer make and model.
• System information such as operating system name and version, processors, and memory details.
• Any detailed description of the issue, including steps to reproduce the issue.
• Exact wording of any error messages involved.
• Your serial number or works order (WO) number.

To find out these numbers, look in the subject line and body of your Electronic Product Delivery Notice
email that you received from Micro Focus, or on the box in which the product was supplied, and on the red
card supplied in the DVD case .
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Appendix I: Enterprise Analyzer Features
per Client

Support Level Key
Capability

Features Analyst Developer EA Web Business
Rule

Manager

Basic (level 1) System level
objects,
dependencies
and metrics

Workspace Build Wizard * *

Verification * *

Verification Report * *

Decision Resolution (w/o auto-
resolution)

* *

Search Assistant * * *

Repository Browser * *

Repository Browser (from search
results)

* * *

Reference Reports * *

Repository Queries * *

Diagrammer (project based) * *

Diagrammer (object based) * * *

CRUD Report (project based) *

CRUD Report (object based) *

Tag Manager * *

Inventory Report *

Complexity Metrics *

Effort Estimation *

Portability Assessment (without
Clipper queries)

*

Business Rule Manager -
manually entered rules

* *

Intermediate
(level 2)

AST -
syntactical
analysis within
source objects

Batch Application Viewer *

Source pane (with navigation) * *

Context view * *

Code Search * *

Advanced Search *

Objects Pane *

Program Control Flow *

Model Pane *

Bird's Eye view *
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Support Level Key
Capability

Features Analyst Developer EA Web Business
Rule

Manager

Flowchart *

Glossary *

Portability Assessment report
(Clipper queries)

*

Quality Assessment report *

Business Rule Manager - query-
based rules

* *

Advanced
(level 3)

Field-level data
dependencies

Change Analyzer *

Change Analysis (single data
item)

*

Impact pane *

Execution Path *

Data Flow pane *

Data View *

Animator *

Logic Analyzer (Dead Code &
other slices)

*

Advanced
(level 4)

Constant
Propagation

Constant propagation (e.g. used
for auto-resolution of dynamic
calls)

* *

IMS Analysis * *
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