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Introducing Enterprise View
Micro Focus Enterprise View (EV) is a Web server-based tool that offers IT executives "at-a-glance"
application portfolio management (APM). EV charts and tables provide powerful graphical insight into APM
trends and current status, on dashboards that make it easy to drill down from the "big picture" captured at
the highest level to the lower-level details that support it.

With EV you can:

• Create, distribute, and gather responses to surveys about your organization’s application portfolio and
business processes.

• Mine application complexity metrics from the Enterprise Analyzer (EA) repository.
• Track survey and repository metrics in EV's rich variety of interactive charts, displayed on dashboards

structured to show the rollup of data from lower to higher levels.

For users who need to drill down even deeper into an application portfolio, EV lets you search, filter, and
analyze EA repository data. You can:

• Query the repository for information about application objects.
• Search, browse, and edit business rules and triggers.

Understanding the EV Scheme
The metrics you chart in Enterprise View derive from two sources:

• Responses to the surveys you create and distribute in EV.
• Complexity metrics for application objects modeled in Enterprise Analyzer.

These metrics are categorized by the tag assigned to the survey questions or application objects you
measure in charts. If you are interested in determining how easy it is to change the Payroll application in
your enterprise's HR department, for example, your EV charts might graph:

• Responses to survey questions assigned the "Payroll" tag ("Is it easy to change the Payroll application?
3=always; 2=mostly; 1=sometimes; 0=not usually").

• Average values of the complexity metrics Maintainability Index and Cyclomatic Complexity for repository
objects marked with the "Payroll" tag.

Your charts can show current status, trends, and so forth. And, using a simple tag hierarchy, you can
design your dashboards to display charts in a way that makes drilldown accurate and easy.

Understanding Tag Hierarchies
You use a simple tag hierarchy to categorize survey questions and application objects in functional,
structural, or other types of groupings. After you set up these groupings, you can chart them in EV or
“black-box” them in the Enterprise Analyzer Diagrammer.

Each member of a grouping is identified by a tag, "Payroll," for example. Each grouping can, in turn,
reference a more inclusive grouping, "HR," for instance. The figure below shows the tag hierarchy for a
typical enterprise:
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In fact, this is the default tag structure that ships with Enterprise Analyzer. The "Enterprise" tag is the root
of the structure. The "Finance," "HR," and "Sales" tags represent departments in the enterprise. The
"Accounting," "Payroll," and "CRM" tags are the applications owned by each department.

How Tag Hierarchies Enable Drilldown
Given the EV default tag structure, as shown in "Understanding Tag Hierarchies," we can construct a
dashboard that shows survey data for the department tags "Finance," "HR," and "Sales." Say this
dashboard has a chart that shows the average number of change requests per month for each department:

The Change Requests metric derives from a survey answered for the application tags "Accounting,"
"Payroll," and "CRM." The values for these applications are rolled up in the chart at the department level, in
the "Enterprise" tag at the root of the tag hierarchy.

If we drill down in the chart by clicking the "Finance" bar, another dashboard opens with a chart displaying
the average change requests for each application in the Finance department. Of course, there is only one
Finance department application in our example, Accounting, but potentially there could be many more:
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If we drill down for a different department, say, Sales, we open the Sales dashboard with a chart showing
the average change requests for the CRM application tag:

As the examples show, EV charts are context-sensitive. They can accept any tag in the hierarchy as a
parameter.
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Using Enterprise View
This chapter describes how to access Enterprise View and how to create dashboards, application profiles,
and surveys.

Accessing Enterprise View
The Enterprise View administrator creates an account for each authorized Enterprise View user. Account
settings define your user name and password, the role to which you have been assigned, and the
workspaces you are permitted to access.

A default account for the administrator is supplied with the product. Edit the default login credentials for the
administrator and create additional users (see Enterprise View Configuration).

Important:

By default, the administrator's user name is administrator and the password is admin. Change
the password for the default administrator account immediately after the first login to prevent
unauthorized access.

1. In a Web browser (both Internet Explorer and Mozilla Firefox are supported), go to http://
ServerName:PortNumber/EV where ServerName is the name of the machine running Enterprise
View , and PortNumber is the port number.

• For Apache Tomcat, the port number is specified at installation. The default is 8080. For example:
http://localhost:8080/EV.

• For WebSphere Application Server, the port number is the HTTP transport port for the application
server profile. For example: http://localhost:9081/EV. You can find the HTTP transport port
in the file AboutThisProfile.txt in the logs folder for the application server profile.

Note: Make sure that EV is in all capital letters.

The Enterprise View Login page is shown.

2. Enter your user name in the Username field and your password in the Password field.

Note: The fields are case-sensitive. If your password has expired, you are prompted to enter a
new one. You can change your password in EV by clicking your user name in the upper right
corner of the page.

3. Click Login. The Enterprise default dashboards in the APM Dashboards area are displayed.

Note: Some menus may be unavailable depending on the user's access privileges.

Enterprise View Navigation
The APM Dashboards area, which displays Enterprise View default dashboards, is shown at login. The
EV GUI consists of the Navigation panel containing menu items for the different areas of EV, each with a
distinct set of tasks.The areas are:

• APM Dashboards
• Application Profiles
• Surveys
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• Configuration

Note:

Some buttons, areas, and menu items may not be visible, depending on a user's role. Roles
determine access privileges to Enterprise View features (see the section Managing Roles).

Navigation Panel
The Enterprise View Navigation panel contains shortcuts to the different parts of Enterprise View. You can
hide or show it using the arrows on top of the panel. This is the starting point of access to the features of
Enterprise View.

The links in the Navigation panel are grouped in four areas (APM Dashboards, Application Profiles,
Surveys and Configuration) and the content of each group is visible when it is expanded by clicking on
the head of each group.

Overview: APM Dashboards
The APM Dashboards part of the Navigation panel lets you view dashboards containing charts, graphs,
and tables. The charts display business data collected from survey results, and/or metrics collected from
Enterprise Analyzer workspaces. A single dashboard, which is specified in a configuration file, is displayed.
The Please select a dashboard to be displayed list lets you select a different dashboard.

Your default dashboard is displayed after you log in to Enterprise View.

Overview: Surveys
Surveys are used to collect business data about your enterprise for use in dashboards and charts. Survey
results, combined with metrics data collected from workspace repositories, can provide a powerful and
comprehensive representation of your enterprise's application portfolio.

The quality of the data you gather from surveys is determined by the questions you include, the range of
values you accept as valid responses, the set of users you assign to complete the survey, and the accuracy
of their responses.

The Surveys area contains the shortcuts to all parts of EV related to surveys.

Overview: Survey Inbox
The Survey Inbox shows a grid with all the surveys that have been sent to you for you to complete. The
grid contains the following columns:

Survey The name of the survey

Entry Status Shows the status of the survey (Completed, Not
Started, Started)

Anonymous Indicates if the survey allows anonymous entry or not (the
possible values are Y and N)

Start Date Survey start date

End Date Survey end date

Link Contains the link to the survey

Workspace Shows the workspace for which the survey was created

Overview: Questionnaire List
A questionnaire is a set of user-defined questions that can be combined and used in one or more surveys.
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The Questionnaires tabsheet has two parts - the tree that shows only questionnaires and the
Questionnaires List grid. The information displayed in the grid changes depending on the selection from
the tree.

When a folder that contains questionnaires is selected the grid in Questionnaires List shows information
about the questionnaires. You can see the Questionnaire Name and all available Actions (Edit or
Delete).

When you select a questionnaire from the tree, the information in the grid changes. The Questionnaire
Info section is displayed. It has three sections (Description, Questions List and Answers List) that let
you browse through the questionnaire, see its questions and the defined answers.

Overview: Survey List
This tabsheet has two parts. The Survey Tree is on the left. The contents of the right part of the tabsheet
depends on the selected item from the tree.

The Surveys tabsheet has two parts - the tree that shows only surveys and the Survey List grid. The
information displayed in the grid changes depending on the selection from the tree.

When a folder that contains surveys is selected the grid in Surveys List shows information about the
surveys. You can see the Title, Description, the date it was created, its Status, and all available Actions
(Edit, Delete, Create Delivery).

When you select a survey from the tree, the information in the grid changes. The Questions in Survey
section is displayed. It has a grid with two columns (Question Name and Actions) that let you browse the
questions that are assigned to each survey.

Overview: Survey Delivery List
This tabsheet has two parts. The Survey Tree is on the left. The Survey Delivery List is in the right part of
the tabsheet.

When you select a folder from the tree, the grid remains empty. You should select a survey and the grid will
show you all deliveries for the selected survey.

Overview: Monitoring
The Monitoring page gives detailed information on the survey deliveries. The information is split in two
tabsheets - Overview and Details.

You can view different types of charts and tables that summarize the results from the survey deliveries. You
can also access the Survey Delivery Statistics page and view detailed information about each survey
delivery, its questions and what answers have been submitted.

Monitoring > Overview

The Overview tab shows two charts:

• Survey Deliveries by Status
• Survey Delivery Statistics by Recipients' Entries

Survey Deliveries by Status

The chart shows information about survey deliveries, grouped by their status. The types of statuses are:

• Started - survey deliveries that have been started, but are not yet closed.
• Created - survey deliveries that have been created but are not yet started.
• Closed - survey deliveries that are created, started and then closed.
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Survey Delivery Statistics by Recipients' Entries

The chart shows information about survey deliveries grouped by recipients' entries. The sum of the survey
deliveries displayed in this chart is equal to the number of survey deliveries with status Started from the
Survey Deliveries by Status chart. The values for the entries are:

• Not Started - the recipients haven't started answering the survey deliveries.
• Incomplete - surveys that the recipients have started filling in, but are still not completed.
• Completed - survey deliveries that are completed by the recipients.

Monitoring > Details

The Details page shows information about survey deliveries in two ways. You can see the survey deliveries
by Surveys or by Tag.

When you select a survey from the Surveys/Tag tree, the Survey Delivery List grid on the right is
populated with a list of all the deliveries that the selected survey has. The columns of the grid are:

Survey The name of the survey. The name is a link that you can
click. The Survey Delivery Statistics page opens.

Tag The tag assigned to the survey delivery.

Start Date Start date of the survey.

End Date End date of the survey.

Status Shows the status of the survey delivery ( Closed or
Started).

Recipients Shows the number of recipients for the selected survey
delivery.

Started Shows the number (and percentage) of the recipients
who have started answering the survey.

Completed Shows the number (and percentage) of the recipients
who have completed the surveys.

When you select a survey delivery from the list, the grid below the Survey Delivery list is populated with
information about the questionnaires included in the selected survey delivery. The columns of the grid are:

Name The name of the questionnaire included in the selected
survey.

Description The description of the questionnaire.

Total Entries The number of recipients who have answered at least one
question.

Submitted The number of recipients who have submitted the
questionnaire.

Completed The number of recipients who have answered all the
questions without submitting it.

Incomplete Entries The number of recipients who have answered at least one
question.

Survey Delivery Statistics

This page shows more detailed information than the Monitoring page. Here you can see the statistics
about the deliveries on a questionnaire and question level. You are able to see how each of your recipients
has answered the questions.

There are two grids. The first one shows the questions included in the survey you have selected in the
Monitoring page. Questions are grouped in questionnaires. The columns of the grid are:
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Question Displays the question.

Type Shows the type of the question (Single Select, Multi
Select, Free Text, Free Value).

Weight The weight of the question.

Layout Shows the layout of the question (Radio button, checklist,
etc.).

Comments A flag that shows if comments are allowed for this
questionnaire.

When you select a question from the grid the second grid is populated with information about the answers.
The grid shows information about:

Answer Shows the answers of the selected question.

Total Answers Shows how many times the answer has been selected.

Users Contains the names of the users that gave this answer to
the selected question. If the survey allows anonymous
entries, the row has Anonymous flag.

You can filter the information in the answers grid using Filter by user.

The information from the answers grid is also available as a bar chart next to the grid. Each bar on the X
axis represents an answer, while the number of people that gave this answer is marked on the Y axis.

The Survey/Questionnaire Tree
The tree is one part of EV that is used for organizing your surveys (and their deliveries) and your
questionnaires. You can customize the tree by creating folders to organize the information stored in it.

Note:

The structure of the tree is the same for surveys and questionnaires. The tree is content sensitive, so
when you are using the surveys you will see only surveys in it. When you are working on the
questionnaires part of EV you will see only the questionnaires stored in the tree.

Overview: Application Profiles
The Application Profiles part of the Navigation panel lets you query, explore, and edit data in Enterprise
Analyzer workspaces.

Overview: Analysis Pages
On this tabsheet, authorized Enterprise View users can view pages generated by Enterprise Analyzer
tools, as well as Executive Reports previously generated via the Prepare menu in Enterprise Analyzer.

Overview: Query Repository
On this tabsheet, authorized Enterprise View users can specify entity types and relationships and query
one or more workspace repositories.

Overview: Business Rules
On this tabsheet, authorized Enterprise View users can browse or search business rules and triggers by
business function and rule set. Users with appropriate access privileges can edit business rules and save
their changes directly to the workspace repository.
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Overview: Configuration
The Configuration area of the Navigation panel contains the shortcuts to the Chart Definition and
Dashboard Definition parts of EV.

Global management tasks for Enterprise View (user accounts and workspace access and roles) are
accessed via the Configuration area. These tasks, as well as the configuration of dashboards, surveys,
and their respective components (charts and questions) should be restricted to Enterprise View
administrators.

From the Configuration area, you can:

• Manage Enterprise View’s access to workspace repositories
• Create and manage user accounts.
• View Enterprise View reports.
• Create and manage roles, each of which defines a default dashboard and a set of access privileges for

Enterprise View features. Every user must be assigned a role.
• Create and manage tags, which are used to store survey results and filter those results in charts.
• Configure questions and surveys.
• Configure charts and dashboards.
• Import and export Enterprise View content.

Important: We highly recommend changing the password for the default Administrator account
immediately after the first login to prevent unauthorized access.

Workspaces
Administrators specify which workspaces may be accessed by Enterprise View. Global workspace access
is set here, while individual users' workspace access privileges are set via the Manage User Accounts link.
For more information, see the section Managing Workspaces.

Roles
Roles are assigned to users. Each role specifies a default dashboard and a set of access privileges for
Enterprise View functions. Enterprise View ships with several predefined roles, and administrators can edit
these and/or create new roles. For more information, see the section Managing Roles.

Users
Administrators can manage user accounts and assign roles. For more information, see the section
Managing Users.

Tags
The metrics you chart in Enterprise View derive from two sources:

• Responses to the surveys you create and distribute in EV.
• Complexity metrics for application objects modeled in Enterprise Analyzer.

These metrics are categorized by the tag assigned to the survey questions or application objects you
measure in charts.

Tags are workspace-specific, which means any tags created for a workspace in Enterprise Analyzer are
available for use in Enterprise View, and vice-versa. Administrators can create new tags and manage tag
structure. For more information, see the section Managing Tags.
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Reports
Administrators can view the Access Log report to determine login frequency of specific users and from IP
addresses the logins came from.

Import
The Import tool lets you import new Enterprise View content from an XML file.

Export
The Export tool lets you export new Enterprise View content to an XML file.

Chart Definition
Administrators can configure various charts, tables, and graphs for use in Enterprise View dashboards. For
more information, see the section Defining Charts.

Dashboard Definition
An Enterprise View dashboard is a web page that displays charts of business and metrics data collected
from survey results and workspace repositories. Administrators can configure dashboards, determining
which charts are displayed. For more information, see the section Defining Dashboards.

Using APM Dashboards
An Enterprise View dashboard is a web page that contains interactive charts. When users log in to EV, the
default dashboards are displayed.

Each chart displays business data and/or application metrics collected from survey results and workspace
repositories. Chart elements (such as pie slices, data points on a graph, and rows in a table) may be
interactive. Clicking on elements in a chart lets you drill down further into the data.

Enterprise View supports a wide variety of chart types, enabling sophisticated representations of your
enterprise information.

Note:

The APM Dashboards area is view-only. Configuring dashboards and charts is done from the
Configuration > Dashboard Definition area. For more information, see the section Enterprise View
Configuration.

Using Application Profiles
The Application Profiles area lets you query, explore, and edit data in repository workspaces. From this
area, you can:

• Run queries to retrieve information about repository entities and relationships.
• Generate and view a set of predefined analysis pages.
• Search, browse, and edit business rules and triggers.

Querying the Repository
Use the Query Repository page to view the relationships between objects: files that depend on another
file, programs that call another program, and the like. You can define your own queries, or use predefined
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queries identical to the ones available in the Enterprise Analyzer Query Repository tool. Select multiple
workspaces to run the same query for each.

Note: Enterprise View populates the drop-down lists on the Query Repository page from a cache
used to store repository information. Make sure to clear the cache after a workspace has been
modified, so that the most recent workspace information is available in the lists.

1. From the Application Profiles area, click Query Repository. The Query Repository page is
displayed.

2. Select the workspace(s) you want to query in the Select Workspace drop-down list. To select multiple
workspaces, press and hold the Ctrl key while making selections.

Note: Each time you make a choice in a drop-down list on the Query Repository page a working

icon indicates that the remaining lists are being populated with available choices: 

3. Select the project you want to view in the Select Project list, or select (all projects).

Note: If you selected multiple workspaces, the Select Project list is disabled.

4. Select the type of object whose relationships you want to view in the Left Object Type list. 

• To view a list of all objects matching the selected type, click Show All.
• To view only objects whose names match a string, enter the string in the text box below the drop-

down list and click Search. The search is case-sensitive. Use an asterisk (*) to match 0 or more
characters, or a question mark (?) to match any single character.

5. Objects that match the search criteria are displayed in a list box below the Left Object Type drop-down
list. Select the objects whose relationships you want to view. To select multiple objects, press and hold
the Ctrl key while making selections. 

• Predefined queries appropriate for the selected object type are displayed in a list below the
Relationship field. To run a predefined query, click it in the list.

• To define a query, select the right object type for the relationship in the Right Object Type list.
Relationships appropriate for the selected left and right object types are displayed in the
Relationship list. Select the relationship you want to search for and click Query.

Alternatively, you can specify the relationship first, in which case the list of available right object
types is narrowed. If you prefer, you can omit the relationship or right object type entirely.

Note:

Queries perform better when you specify a value for at least two of the three fields. It is possible
to specify a value for only one field, but not recommended.

6. The page is updated and the Query Results table is displayed. The figure below shows the results for a
query where "Cobol File" is the left object, "Defines Program" is the relationship, and "Program" is the
right object.

7. Click Print to print the table, or Save to save the table as an HTML file. Click a column heading to sort
the table by that column.

Viewing Executive Reports
Executive reports offer HTML views of application inventories that a manager can use to assess the risks
and costs of supporting the application:

• The Application Summary view gives statistics for industry-standard metrics such as program volume,
maintainability, cyclomatic complexity, and number of defects.

• The Potential Code Anomalies view gives statistics for common defects that mark programs as
candidates for re-engineering — multiple exits, non-initialized usages, possible sign loss, and the like.

• The Repository Statistics view gives statistics for Enterprise Analyzer verification results and
unresolved or unreferenced application elements.
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• The Standard Deviations view displays graphs that plot the deviation of the programs in the application
from the means for six key industry-standard metrics.

1. From the Application Profiles area, click Analysis Pages. The View Analysis Pages opens.

Note:

Available analysis pages in the table are displayed as blue hyperlinks. If the entry you want is not
displayed, you need to save the related report in Enterprise Analyzer.

2. Click the Executive Report link for the workspace and project you want to view. The Statistical
Summary Report window opens.

3. The top page in each view displays the available statistics and graphs. Click the links to view the detail
for each type of statistic or graph.

4. In the statistic or graph detail page, click the link for a program to view the detail for that program.

Working with Business Rules
If your site is licensed to use Business Rule Manager, you can view, edit, and search business rules in
Enterprise View. You must have appropriate access privileges to use the Business Rules page.

A business rule is a named container that identifies and documents a code segment according to the task it
performs in a business process. A business rule named Calculate Date Difference, for example, might
consist of this segment:

COMPUTE WS-DATE-VARIANCE = 
WS-C-CARD-DATE-CCYYMM - WS-TODAYS-DATE-CCYYMM. 

Business rules are organized in “rule sets”. A rule set typically consists of rules executed together, such
that if one rule is executed, all are executed (the statements in a paragraph, for example). You can think of
a rule set as a business process, like Validate Input or Update File.

Rule sets are organized, in turn, in “business functions”. A business function typically defines the order in
which processes are triggered. Think of a business function as a use case, like Insert Customer or Update
Order.

Business rule “properties” define the characteristics of a rule: its name, type, audit status, business
description, and the like. You can use these properties to search for rules in Enterprise View.

Browsing and Editing Business Rule Information

1. Open Application Profiles > Business Rules. The Business Rules Manager page is displayed.

2. Select theBrowse tab if it is not already selected.

3. In the Business Function column, choose one of the following options:

• Locate a business function and click Edit. Go to step 7.
• Click the link for a business function to view its rule sets. Continue to the next step.

4. In the Rule Set column, choose one of the following options:

• Locate a rule set and click Edit. Go to step 7.
• Click the link for a rule set to view its rules and their properties. Continue to the next step.

5. The Rules List displays the rules defined for the selected rule set. Choose between:

• Locate a rule and click Edit. Go to step 7.
• Click the link for a rule to view its source code and properties. Continue to the next step.

6. The Rule Details page is shown. By default the General tab is selected, displaying the general
properties for the selected rule. Click Segments, I/O Data Elements, and Control Conditions tabs to
view more properties for the selected rule. On the right, a window displays the source code for the rule
with the relevant line(s) of code highlighted. Click Edit.
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7. On the Rule Details page, use the tabs to view and modify rule properties. Click :

• General (this tab opens by default) to modify the general properties of a rule. When you are satisfied
with your changes, click Save. A summary page displays the general properties of the rule.

• Segments to view the code segment assigned to the rule and related information.
• I/O Data Elements to view the rule's input/output data elements and related information.
• Control Conditions to view the conditions that control the rule's execution and related information.

Click links in the Path breadcrumb trail at the top of the page to navigate to other pages.

Browsing and Editing Triggering Rules

1. Open Application Profiles > Business Rules. The Business Rules Manager page is displayed.

2. Select the Triggering tab.

The Triggering page lists rules in a hierarchy of triggers, in which each triggering rule can be a parent
to triggering rules that depend on it in program logic.

3. The left pane contains the Triggering Rule List. Expand the hierarchy and click the link for a business
function, rule set, or rule to view its properties and source code in the right panes.

In the Properties pane on the right, the General tab opens by default.

4. Click the Segments, I/O Data Elements, and Control Conditions tabs to view more properties for the
selected item.

5. Scroll to the bottom and click Edit to modify the properties.

6. Click:

• General (this tab opens by default) to modify the general properties of the rule. When you are
satisfied with your changes, click Save. A summary page displays the general properties of the rule.

• Segments to view the code segment assigned to the rule and related information.
• I/O Data Elements to view the rule's input/output data elements and related information.
• Control Conditions to view the conditions that control the rule's execution and related information.

7. Click Save to store your changes.

Searching for Business Rules

1. Open Application Profiles > Business Rules. The Business Rule Manager page is displayed.

2. Click the Search tab.

3. Specify each property you want to search by and its value. Select:

• The property in the Name list.
• The operator for the property value comparison in the Operator list.
• The value of the property in the Values field. You can use wildcard patterns allowed in LIKE

statements by SQL-92.

4. Click Add. The search criteria is added to the list box below the drop-down lists.

5. Repeat step 4 for each property you want to search by.

6. When you are satisfied with your entries, click Find. Enterprise View returns the results of the search in
the Rule List field, where you can edit or view the properties of the returned rules.

Using Surveys
Administrators configure surveys about your organization's application portfolio, business processes, and
workspace data. Surveys are assigned to users, and responses (survey results) are collected by Enterprise
View for use in charts and dashboards.

From the Surveys area, you can:
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• view and submit responses to assigned surveys
• create questionnaires and questions
• view saved surveys and remove questions
• create a survey delivery and assign it to Enterprise View or anonymous users
• view the status of survey deliveries

Working with Survey Inbox
Surveys currently assigned to you are displayed in the Survey Inbox.

Tip: Click a column heading to resort the table.

The Survey Inbox contains the following information for each survey in the list:

• Survey: Survey title.
• Entry Status: Current status of the survey.
• Anonymous: An indicator specifying if anonymous participants are allowed.
• Start Date: The date the survey was placed in the inbox.
• End Date: The date the survey expires.
• Link: The link to the survey.
• Workspace: The workspace associated with the survey.

Responding to Surveys
You can view and respond to any survey in your Survey Inbox by clicking the corresponding Go to Survey
link. You can answer some or all questions in the survey. The answers you supply are logged as survey
results once you click Submit. Once you have submitted the survey, you cannot return to it and the Status
column in the inbox is updated to Completed.

You can also save your responses and return to the survey later if you are not ready to submit.

1. Log in to Enterprise View.
2. From the Surveys area, locate a survey in your Survey Inbox and click the Go to Survey link. The

survey is displayed in a new window.
3. Input your answers and click Submit to store the results, or click Save to record your answers in order

to return to the survey later.

Configuring Questions
Note:

Only users with appropriate access privileges can add, edit, and delete questionnaires and questions.

Questions, which are contained within questionnaires, are the building blocks for surveys. Administrators
can define questions and categories once and reuse them in multiple surveys. Enterprise View ships with
sample surveys and their associated questions and categories. For more information, see the section
Using Enterprise View Default Templates. You can edit the questions in the sample surveys, or create your
own.

Accessing the Questionnaire Page
To begin working with questions, click Surveys > Questionnaire List from the Navigation panel. The
Questionnaires List page is displayed.

If a main folder is selected in the second pane, a list of available questionnaires associated with that folder
are displayed in the Questionnaires List.

If a questionnaire is selected in the folder tree (expand a main folder by clicking the blue arrow), information
about the questionnaire is displayed. This includes a description for the questionnaire, a Questions List
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table that shows a list of all existing questions and their properties, and an Answers List table that shows
a list of all possible answers for a selected single-select or multi-select questions in the Question List.

Understanding Questions and Questionnaires
The data you collect from responses to surveys is only as useful as the questions you include. We
encourage you to review the key concepts described below before creating questions.

What are the key properties of a questionnaire?

A questionnaire is used to group a set of related questions into sections in a survey. Questions are created
within a questionnaire. When questions are added to a survey, they will be grouped by their parent
questionnaire.

Note: The questionnaire title is displayed as a section label in the List of Questionnaires in the
survey.

What are the key properties of a question?

All questions have a title (displayed in tables and drop-down lists); question text, (displayed in the body of
the survey), and a user input field (a text field, drop-down list, or list of radio buttons).

Questions are created within a questionnaire. When questions are added to a survey, they will be grouped
by their parent questionnaire.

Administration Tasks for Questionnaires
To begin configuring questions, log in to Enterprise View with an account with appropriate access
privileges. Select a task and follow the instructions below. 

Creating/Editing a Questionnaire

The Questionnaire Wizard is used to create questions and group them in a questionnaire.

1. Go to Surveys > Questionnaire List .

2. In the folder tree (second pane), click the New Main Folder button to create a main folder if one does
not already exist.

3. Select the main folder so that it is highlighted.

4. In the Questionnaires List (the third pane), click Add to create a new questionnaire, or click the Edit to
modify an existing questionnaire. The Questionnaire Wizard starts with the General info tab selected.

5. Enter/modify a name in the Questionnaire Name box.

6. Enter a brief description in the Questionnaire description box (optional).

7. Specify a number in the Questions per page field. This controls the final layout of the survey.

8. Click Next. The Create questions tab is selected. Here you create/modify the questions and define the
answers to the questions of your questionnaire. The window is separated in three parts:

• List of questions - contains a list of all questions for the current questionnaire
• Question name & text - contains general information about a selected question
• Answers - a list all possible answers for each question created.

9. Click the New Question button from the toolbar in the List of questions section. A new question
appears in the list of questions. 

Note: You can click the New Question button several times to create several questions and then
go back and define each question.

10.Make sure that the question you want to define is selected in the List of questions. This question will
be defined in the Question name & text pane.

11.In the Question name box, enter a name for the question.
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12.In the Question text box, enter the text of the question and any instructions. This is the text displayed to
the user in surveys and is limited to a maximum of 200 characters.

13.In the Selectable type list, click the type of question:

• Single Select - allows the user to select only one answer
• Multi Select- allows the user to select multiple answers

Note: For a Multi Select question, the average of the numeric values for all selected answers
is used as the final answer.

• Free Text - allows the user to freely type the answer in a text box
• Free Value - allows the user to freely type a numeric value

To create a Single Select or a Multi Select question:

a) In the Answers section, click the New answer button for each answer you want to create. A text box
is displayed.

Note: You can click the New answer button several times to create several answers and then
go back and define each answer later.

b) In each text box, type the text of the answers.

This text will be displayed to the user
c) If appropriate, change the numeric value for the answer.

This is the value that is stored for that selected answer.
d) Click the checkbox located to the right of one of the answers to make it the default selection on the

survey.

Note: Selecting a default is optional. You may not want to specify default selections in order to
prevent unanswered questions from inadvertently being answered by their default selections.

To create a Free Text question:

a) Leave the answer text box blank. The user will type the answer.

To create a Free Value question:

a) No further actions are required. The user will enter a number in the input field when responding to
this question on the survey.

14.In the Weight box, change the value if 1 is not appropriate. This weight will be used in the evaluation
process for the surveys.

15.Once all questions and answers have been defined, click Next. If no errors are detected, the message
The Questionnaire Wizard has completed successfully. Click Finish to save
and close. is displayed.

16.Click Finish. The Questionnaires List closes.

17.Click Refresh if you just created the questionnaire and it is not displayed in the Questionnaires List.

Deleting a Question

You can delete a question while editing the corresponding questionnaire.

1. Go to Surveys > Questionnaire List .

2. Expand a folder and select the desired questionnaire.

3. In the Actions column of the Questions List table, click the corresponding Delete button for the
question you want to delete.

4. Click Yes to permanently delete the question from the database, or No to return to the Questionnaire
page. The question is removed from the questionnaire.

Note: Deleting a question also deletes any survey results collected from user responses to the
question.
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Deleting a Questionnaire

1. Go to Surveys > Questionnaire List .

2. In the folder tree (second pane), select the folder that contains the questionnaire you want to delete. A
list of questionnaires appears in the Questionnaires List table.

3. Click the appropriate Delete button for the questionnaire you want to delete.

4. Click Yes to permanently delete the questionnaire from the database, or No to return to the
Questionnaire page. The questionnaire is removed from the Questionnaires List table.

Deleting a questionnaire also deletes any survey results collected from user responses to the questions
contained within the deleted questionnaire.

Configuring Surveys
Note:

Only users with appropriate access privileges can configure surveys.

Administrators can configure surveys about your organization's application portfolio, business processes,
and workspace data. After a survey is created, a survey delivery is assigned to users, and responses
(survey results) are collected by Enterprise View for use in charts and dashboards.

Enterprise View ships with sample surveys and their associated questions and categories. For more
information, see the section Using Enterprise View Default Templates. You can edit the sample surveys, or
create your own.

Accessing the Survey Page
To begin working with surveys, click Surveys > Survey List from the Navigation panel. The Surveys page
is displayed.

If a folder is selected in the folder tree (second pane), a list of available surveys associated with that folder
are displayed in the Surveys List.

If a survey is selected in the second pane (expand a folder by clicking the blue arrow), the Questions In
Survey table that shows a list of all existing questions.

Note: You can resort the table by clicking any column heading.

Understanding Surveys
Surveys are used to collect business data about your enterprise for use in dashboards and charts. Survey
results, combined with metrics data collected from workspace repositories, can provide a powerful and
comprehensive representation of your enterprise's application portfolio.

The quality of the data you gather from surveys is determined by the questions you include, the range of
values you accept as valid responses, the set of users you assign to complete the survey, and the accuracy
of their responses. The following topics answer key questions to help you build better surveys.

What is the workflow for building surveys?

1. Determine the scope of the survey.
2. Review existing questions and questionnaires to determine if any are appropriate to reuse in your

survey.
3. Create new questions and questionnaires to elicit the data you need.
4. Create the survey.
5. Create the survey delivery and assign it to users, designating appropriate tags under which results are

stored.
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6. If you find the survey results are consistently inaccurate, or the data you intended to elicit is not being
received, try the following steps:

• Rewrite the questions.
• Adjust the range of values displayed in user input fields.
• Re-assign the survey delivery to a more appropriate group of users.
• Verify the survey delivery is assigned to appropriate users and tags.

What is the recommended scope of a survey?

Survey deliveries can be assigned to any combination of users and tags. When you assign the survey
delivery to a user, you also designate a tag (such as "Sales") under which responses are stored.

Thus, we recommend you tailor the scope of each survey (and the questions you include) to the group of
users and tags to which it will be assigned.

How do I maximize the value of survey results?

You can improve the quality of survey results by following these tips when creating survey questions:

• Provide instructions in the text of the question to add clarity and guide the user. This improves the
chances of receiving an accurate and useful response.

• Limit the range of input choices available to the user. Whenever possible, use drop-down fields or radio
buttons instead of text fields to avoid unpredictable responses.

• Design drop-down list or radio button choices wisely, and keep the values associated with each choice
consistent across questions. For example, if you create a drop-down list in one question where user
choice "Low"= value 1, "Medium"=2, and "High"=3, reuse this schema in every question that offers the
choices Low/Medium/High.

• Last, but not least, assign surveys to knowledgeable users!

Administration Tasks for Surveys
To begin configuring surveys, log in to Enterprise View with an account with appropriate access privileges.
Select a task and follow the instructions.

Note:

Survey results are stored under a survey delivery, and can be accessed from the Survey Delivery
Statistics page.

Creating/Editing a Survey

1. Go to Surveys > Survey List .

2. To create a new survey, select a folder in the folder tree, and click Add. To modify a survey, click the
corresponding Edit button in the Survey List. The Survey fields are displayed.

3. Enter or change information as needed. 

• Survey Name: Chose a descriptive name for the survey.
• Description: Enter a brief description.
• Survey Formulas: Click the green plus sign button to add a new formula, or click the Edit Formula

button to modify an existing formula. You can create a formula definition for any of the questions on
your survey. For example, you can calculate the value of a survey question by adding the values of
other survey questions. Geometric and arithmetic formula types are supported.

Click the Add button to open the Formula Definition area, and select each survey question whose
value you want to calculate. The values for the question are added to the text box. Use standard
arithmetic notation to edit the formula manually.

4. In the Tree section, select a folder so that it is highlighted.
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All questionnaires within the highlighted folder will appear in the Categories and Questions tree. The
arrow next to a folder may need to be expanded so that nested folders can be selected.

All available questionnaires within the folder are displayed in the Categories and Questions tree
section.

5. In the Categories and Questions tree, click the triangle to the left of the questionnaire to display its
questions.

6. Check the box next to the questionnaire name to select all the questions in that questionnaire, or check
the boxes next to the questions you want to include.

7. Click the green right arrow to add the checked questions to the List of Questions list. The
questionnaire and all questions selected in the Categories and Questions tree section are listed in the
List of Questions section. These questions will become part of the survey and can be used in the
survey formulas.

Note: Click the green left arrow to remove checked questionnaires and questions listed in the List
of Questions from the survey. If you remove a questionnaire form the survey, all questions
contained in the questionnaire are removed.

8. Reorder the questions on the survey as appropriate by highlighting a question or questionnaire in the
List of Questions and then by using the Move up and Move down buttons to change the order the
questions will appear on the survey.

9. Click OK to close the window and save the survey.

10.Click Refresh if the survey you just created is not displayed in the Survey List. The survey you just
created is displayed in the Survey List.

Deleting a Survey

1. Go to Surveys > Survey List .

2. In the folder tree (second pane), select the folder that contains the survey you want to delete.

3. In the table on the Survey List pane, locate the survey you want to remove and click the corresponding
Delete button.

You are prompted to confirm deletion.

4. Click Yes to permanently delete the survey from the database, or No to return to the Surveys page.

Note: Deleting a survey will not delete previous survey results that have already been stored in the
repository.

Configuring Survey Deliveries
A survey delivery is a mechanism for users to send surveys to recipient survey inboxes and to track the
progress of survey completion. A survey can have multiple deliveries associated with it.

Survey results can be accessed from the Monitoring area. For more information, see the section To view
survey delivery statistics.

Note:

Only users with appropriate access privileges can create survey deliveries.

Accessing the Survey Delivery Page
To begin working with survey deliveries, click Surveys > Survey Delivery List from the Navigation panel.
The Survey Delivery page is displayed.

If a main folder is selected in the second pane, a list of available surveys deliveries associated with that
folder are displayed.

If a survey is selected in the second pane (expand a main folder by clicking the blue arrow), the Survey
Delivery List table that shows a list of all survey deliveries.

Using Enterprise View | 23



Note: You can resort the table by clicking any column heading.

Administration Tasks for Survey Deliveries
To begin configuring survey deliveries, log in to Enterprise View with an account with appropriate access
privileges. Select a task and follow the instructions.

Creating/Editing a Survey Delivery

1. Go to Surveys > Survey Delivery List .

2. To create a new survey delivery, select a survey in the folder tree (second pane), and click Create. To
modify a survey delivery, click the corresponding Edit button in the Survey Delivery List.

Note: The Survey Delivery List displays/will display all the survey deliveries that have been
created for the selected survey.

The Survey Delivery Wizard is displayed.

3. Enter or change information as needed. 

• Add e-mail: E-mail addresses of users who are assigned to the survey delivery. Click Browse and
select the names of all existing users who should complete the survey..

The e-mail addresses of those users appear in the E-mail List field.

Note: Responses from multiple users to the same survey delivery will be aggregated using the
average calculated before the values are stored in the database for the associated tag.

• Tag Assignments: Tags associated with the survey delivery. Click the add tags button, expand
items in the tag tree, and select all applicable child tags.

• Create a delivery for each tag: When this option is checked (it is checked by default) a separate
survey delivery will be created for each selected tag. When the option is unchecked, one survey
delivery will be used for all selected tags, meaning that the users will respond to the survey once and
their answers will be stored for all tags.

• End Date: The date the survey delivery expires. On this date, the survey is removed from the
recipient survey in-boxes.

• Allow Anonymous: If this checkbox is selected, the user's account and email address will not be
associated with their answers.

4. Click Next. The Summary tab is selected.

5. If you want to send the survey delivery to the assigned recipients, check the Launch checkbox.

6. Click Finish to save the survey delivery and close the Survey Delivery Wizard.

7. Click Refresh if you created a survey delivery and it is not displayed in the Survey Delivery List

8. If you want to send the survey delivery to the assigned recipients (because you did not do so
previously), click the green S (Launch) button. Click Refresh to view the Delivery Status change from
Created to Started.

Deleting a Survey Delivery

Deleting a survey delivery unassigns the survey from users.

1. Go to Surveys > Survey Delivery List .

2. In the folder tree (second pane), select the survey that contains the survey delivery you want to delete.

3. In the table on the Survey List pane, locate the survey delivery you want to remove and click the
corresponding Delete button. 

You are prompted to confirm deletion.

4. Click Yes to permanently delete the survey from the database, or No to return to the Survey Deliveries
page.
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Closing a Survey Delivery

Close a survey delivery when you are satisfied with the percentage of survey responses you have received.
To close a survey delivery, click on the survey in the folder tree, then click the red Stop button.

Note: You must close a survey delivery before survey answers can be displayed in charts.

Monitoring Survey Results
Administrators can access survey results from the Survey > Monitoring area.

Accessing the Monitoring Page
To track the status of survey deliveries, click Surveys > Monitoring from the Navigation panel. The
Monitoring page is displayed, with the Overview tab selected.

Two pie charts show the current status of your survey deliveries.

Administration Monitoring Tasks
To begin viewing survey results, log in to Enterprise View with an account with appropriate access
privileges. Select a task and follow the instructions.

Viewing Survey Delivery Statistics

1. Click Surveys > Monitoring . The Overview tab is selected by default.

2. Click the Details tab.

3. In the folder tree (second pane), expand a folder and select the survey you are interested in obtaining
statistics for. Information is populated in the first table in the Survey Delivery List pane.

4. Select the appropriate survey delivery. The Survey Delivery Statistics page appears.

5. Select questions as appropriate to view statistics.

Application Data View
The Application Data View is used when you want to see data for selected tags and external metrics. To
use it:

1. Open the Surveys panel in EV.
2. Click Application Data View.
3. Select one or more tags from the tree on the left.
4. Select the metrics from the list on the right and then click Apply Filters.

A grid containing the values of the selected metrics for each selected tag is displayed.

Enterprise View Configuration
Global management tasks for Enterprise View (user accounts, workspace access, and roles) are accessed
via the Configuration area. These tasks, as well as the configuration of dashboards, surveys, and their
respective components (charts and questions) should be restricted to Enterprise View administrators.

From the Configuration area, you can:

• Manage Enterprise View’s access to workspace repositories.
• Create and manage user accounts.
• View Enterprise View reports.
• Create and manage roles, each of which defines a default dashboard and a set of access privileges for

Enterprise View features. Every user must be assigned a role.
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• Create and manage tags, which are used to store survey results and filter those results in charts.
• Configure questions and surveys.
• Configure charts and dashboards.
• Import and export Enterprise View content.
• Refresh Tag Structure

Note: Perform this action when there are changes in the Tag Structure in EV or EA to update the
tag information displayed in the charts.

• Update Trending Snapshot

Note: Perform this action when objects in the repository have been added, deleted or changed,
when survey deliveries have been submitted and closed, or when external metric data has been
imported. Otherwise the changes to metrics are not visible in EV.

Important: We highly recommend changing the password for the default Administrator account
immediately after the first login to prevent unauthorized access.

Using Enterprise View Default Templates
Enterprise View ships with default templates for the following objects preinstalled:

• User Account

Administrator user account with full access privileges for all Enterprise View features. You cannot
change the username for this account.

• Roles

CIO, Manager, Analyst, and Developer. Each role can be assigned a default dashboard view and a
predefined set of access privileges.

• Tags

A default tag structure representing a typical enterprise. For more information, see the section
Understanding Tag Hierarchies.

• Sample Questionnaires and Surveys

Department and Application. These include default questions and questionnaires. The sample surveys
and questionnaires are included in the survey/questionnaire tree in the Samples folder.

• Sample Charts and Dashboards

A set of default charts used to populate the default dashboards and default dashboards including target
dashboards for drilldown. For more information, see the section Understanding Drilldown in Dashboards
and Charts. These dashboards only show data if the users respond to the sample surveys. The names
of the provided charts and dashboards contain the prefix sample.

• Dynamic Inventory Dashboards

The dashboards labeled Dynamic Inventory provide a view of the complexity metrics captured from
the parsing of source objects in the workspace repository. The metrics data is shown in the charts on
these dashboards without the need to apply tags or respond to surveys. The top level Dynamic
Inventory dashboard is displayed to a users upon logging in unless the role for their user accounts have
been assigned a different default dashboard. Default charts and dashboards do not contain the sample
prefix.

Each time you add a workspace to Enterprise View, the templates are imported and available for
immediate use.

Note: Default dashboards can be customized for role names that are different than those referenced
above.
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Managing Workspaces
Enterprise View collects and shares information with Enterprise Analyzer workspaces. The configuration
workspace is automatically set as a managed workspace. No further configuration is needed to begin using
EV for the configuration workspace.

Administration Tasks for Workspaces
To begin managing access to workspaces, log in to Enterprise View with an account with appropriate
access privileges. Select a task and follow the instructions below.

Note:

If you have problems accessing workspaces you've added in Enterprise View, see the section Why
can I not access a workspace?.

Changing the Designated Configuration Workspace

1. Click Configuration > Workspaces. The Manage Workspaces page is displayed.

2. At the bottom of the page, click the Change link next to the path to the configuration workspace.

You are prompted to enter the setup code.

3. On the Workspace tab, click Browse and specify the location of the .rwp file, and then click Save. A
confirmation message displays the path to the configuration workspace.

Configuration information from the previous configuration workspace is not copied to the new configuration
workspace.

Setting Administration Options

1. Click Configuration > Workspaces. The Manage Workspaces page is displayed.

2. At the bottom of the page, click the Change link next to the path to the configuration workspace.

You are prompted to enter the setup code.

3. Click the Options tab; set Post-Installation Administrative options for Enterprise View as desired.

Managing Roles
An Enterprise View role defines a class of users (such as "CIO," "Analyst," and "Developer"). Roles let you
provide different windows into your enterprise data based on the type of user accessing Enterprise View.
For example, while a CIO may want a "top-down" view, a developer is more likely to be interested in data at
the application level.

Note: Only users with appropriate access privileges can add, edit, and delete roles.

For each role you define, you can:

• Specify a default dashboard, and customize charts to provide a role-based view of your application
portfolio.

• Assign a class of users one common set of access privileges for Enterprise View features.

Enterprise View ships with a set of predefined roles and associated default dashboards. For more
information see the section Using Enterprise View Default Templates. You can edit the defaults, and/or
create new roles and dashboards that more closely match your enterprise model.

Accessing the Manage Roles Page
To begin working with roles, click Configuration > Roles . The Manage Roles page is displayed.
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The table shows a list of all existing roles and their properties. You can resort the table by clicking any
column heading. Use the links on the right and the Create link to perform various configuration tasks.

Administration Tasks for Roles
To begin managing roles, log in to Enterprise View Express with an account with appropriate access
privileges. Select a task and follow the instructions below.

Creating or Editing a Role

1. Click the Roles link from the Configuration area.

2. To create a new role, click the Create link. To modify a role, click the corresponding Edit link in the roles
table.

Note: Fields are populated with current details if you clicked Edit.

The Role fields are displayed.

3. Enter a name for the role in the Role field.

4. Select a Default Dashboard from the list.

When a user assigned to this role clicks the Show Dashboards button from APM Dashboards, the
dashboard you select here is displayed.

5. Make selections in the Set Access Privileges field to grant access to a set of Enterprise View pages.

Any user assigned to this role will have access to all features on the areas and pages you select.

6. Click Save to store your changes, or Cancel to return to the Manage Roles page without creating (or
modifying) the role.

Deleting a Role

1. Click the Roles link from the Configuration area.

2. In the table, locate the role you want to remove and click the corresponding Delete link.

3. You are prompted to confirm deletion. Click OK to remove the role, or Cancel to return to the Manage
Roles page.

Managing User Accounts
To enable Enterprise View access for users other than the default Administrator, you must configure
additional user accounts. A user account is comprised of login credentials, a role, and permissions for
accessing workspaces.

Note:

Only users with appropriate access privileges can add, edit, and delete user accounts.

Accessing the Manage User Accounts Page
To begin working with user accounts, click Configuration > Users. The Manage User Accounts page is
displayed.

The table shows a list of all existing user accounts and their properties. You can resort the table by clicking
any column heading. Use the links to perform various configuration tasks.

Administration Tasks for User Accounts
To begin managing user accounts, log in to Enterprise View with an account with appropriate access
privileges. Select a task and follow the instructions below.
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1. Click Configuration > Users.
2. In the table on the Manage User Accounts page, locate the user account you want to remove and click

the corresponding Delete link.

You are prompted to confirm deletion.
3. Click OK to remove the account, or Cancel to return to the Manage User Accounts page.

Creating or Editing a User Account

1. Click Configuration > Users.

2. To create a new user account, click the Create link. To modify a user account, click the corresponding
Edit link in the User Accounts table. The Manage User Account area that shows a table is displayed.

3. Enter or change user information as needed.

The fields in the table are described below:

• Username: Login ID, also displayed in various tables to identify the user.

Note:

You cannot change the username of the default Administrator account.
• Password: Login password. Passwords are case-sensitive, and may consist of 1-50 characters.
• Password: The user's password.
• Confirm Password: Login password confirmation.
• E-mail: The user's email address.
• Full Name: The user's full name.
• Role: Assigns the user to a role, which defines the default dashboard view and a set of access

privileges for Enterprise View areas and features. To view the properties of a role, or create a new
role, click Roles from the Configuration area.

• Locked: Checked when the user account is locked. Accounts are automatically locked when the
number of failed login attempts exceeds the number specified on the Enterprise View Setup Options
page. Check the box to lock an account even when the number of failed login attempts has not been
exceeded, or when no number has been specified. Uncheck the box to unlock an account.

• Password Can Expire: Visible only when the user account is subject to password expiration, as
specified on the Enterprise View Setup Options page. The box is checked by default. Uncheck the
box to make the user account not subject to password expiration.

• Password Expired. Check to validate/Password Not Expired. Check to expire: Visible only when
Password Can Expire is checked.

• Password Expired is displayed when the number of days the password has been used exceeds
the number specified on the Enterprise View Setup Options page. Users with expired passwords
are prompted to create new ones. You can also change an expired password manually in the
Password and Confirm Password fields. Unexpire a password manually by selecting Check to
validate.

• Password Not Expired is displayed when the number of days the password has been used does
not exceed the number specified on the Enterprise View Setup Options page. To force the user to
change the password on the first login attempt, expire the password manually by selecting Check
to expire.

• Workspace Access: Check the box for each workspace to which the user has access. Click Default
to specify the user's default workspace.

Tip:

Click Check All to check all the boxes. Click again to uncheck the boxes.

4. Click Save to store your changes. Click Cancel to return to the Manage User Accounts page without
creating (or modifying) the account.
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Deleting a User Account

1. Click Configuration > Users.
2. In the table within the Manage the User Accounts area, locate the user account you want to remove

and click the corresponding Delete link.
3. You are prompted to confirm deletion. Click OK to remove the account, or Cancel to return to the

Manage User Accounts page.

Managing Tags
The metrics you chart in Enterprise View derive from two sources:

• Responses to the surveys you create and distribute in EV.
• Complexity metrics for application objects modeled in Enterprise Analyzer.

These metrics are categorized by the tag assigned to the survey questions or application objects you
measure in charts. If you are interested in determining how easy it is to change the Payroll application in
your enterprise's HR department, for example, your EV charts might graph:

• Responses to survey questions assigned the "Payroll" tag ("Is it easy to change the Payroll application?
3=always; 2=mostly; 1=sometimes; 0=not usually").

• Average values of the complexity metrics Maintainability Index and Cyclomatic Complexity for repository
objects marked with the "Payroll" tag.

Your charts can show current status, trends, and so forth. And, using a simple tag hierarchy, you can
design your dashboards to display charts in a way that makes drilldown accurate and easy.

Tags are workspace-specific, which means any tags created for a workspace in Enterprise Analyzer are
available for use in Enterprise View, and vice-versa. Enterprise View ships with default tags, as described
in the section Using Enterprise View Default Templates. Administrators can create new tags and manage
tag structure.

Note: Only users with appropriate access privileges can manage tags.

Understanding Tag Hierarchies
You use a simple tag hierarchy to categorize survey questions and application objects in functional,
structural, or other types of groupings. After you set up these groupings, you can chart them in EV or
“black-box” them in the Enterprise Analyzer Diagrammer.

Each member of a grouping is identified by a tag, "Payroll," for example. Each grouping can, in turn,
reference a more inclusive grouping, "HR," for instance. The figure below shows the tag hierarchy for a
typical enterprise:
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In fact, this is the default tag structure that ships with Enterprise Analyzer. The "Enterprise" tag is the root
of the structure. The "Finance," "HR," and "Sales" tags represent departments in the enterprise. The
"Accounting," "Payroll," and "CRM" tags are the applications owned by each department.

How Tag Hierarchies Enable Drilldown
Given the EV default tag structure, as shown in "Understanding Tag Hierarchies," we can construct a
dashboard that shows survey data for the department tags "Finance," "HR," and "Sales." Say this
dashboard has a chart that shows the average number of change requests per month for each department:

The Change Requests metric derives from a survey answered for the application tags "Accounting,"
"Payroll," and "CRM." The values for these applications are rolled up in the chart at the department level, in
the "Enterprise" tag at the root of the tag hierarchy.

If we drill down in the chart by clicking the "Finance" bar, another dashboard opens with a chart displaying
the average change requests for each application in the Finance department. Of course, there is only one
Finance department application in our example, Accounting, but potentially there could be many more:

If we drill down for a different department, say, Sales, we open the Sales dashboard with a chart showing
the average change requests for the CRM application tag:
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As the examples show, EV charts are context-sensitive. They can accept any tag in the hierarchy as a
parameter.

Accessing the Manage Tags Page
To begin working with tags, click Configuration > Tags. The Manage Tags page is displayed.

The table shows a list of all existing tags and their properties. You can resort the table by clicking any
column heading. Use the links to perform various configuration tasks.

Creating and Deleting Tags
The procedures for creating, removing, and deleting tags are described below.

For more information, see the section Administration Tasks for Tags. To avoid unintended consequences
when removing tags, see the section Deleting Tags vs. Removing Tag References.

Deleting Tags vs. Removing Tag References
A repository workspace has a single tags database, which is shared by Enterprise View and Enterprise
Analyzer. It is important to understand the distinction between deleting a tag, and removing a reference to
a tag.

• Deleting a tag, either in Enterprise View or in Enterprise Analyzer, means the tag and all its
relationships are permanently deleted from the database and will no longer be available to either
application. This may adversely affect black-boxing in Diagrammer, and survey results in Enterprise
View. If you are sure you want to delete a tag, follow the instructions in the section To delete a tag.

• Removing a tag reference, either in Enterprise View or in Enterprise Analyzer, removes the relationship
between two tags, but the tag is not deleted from the database. In Enterprise View, for example, when
you remove "Payroll" from the list of tags contained by the "HR" tag, the tag "Payroll" (and any other
associated relationships) remain intact. To remove a tag reference, follow the instructions in the section
To remove relationships between tags.

Administration Tasks for Tags
To begin managing tags, log in to Enterprise View with an account with appropriate access privileges.

Note: You must perform a Refresh Tag Structure when there are changes in the Tag Structure in EV
or EA to update the tag information displayed in the charts.

Creating a New Tag

1. Click Configuration > Tags.

2. To create a new tag, click the Create button.

3. Enter a name for the tag and click Save
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4. The Manage Tags page is updated and the new tag is displayed in the list

Creating Relationships Between Tags

Follow these steps to add a tag reference to a tag. For example, if you have created a new Enterprise
Analyzer tag for an application called "ClientTracker", you can add the ClientTracker tag to the Sales tag,
creating a relationship between the tags.

1. Click Configuration > Tags link.

2. Select a tag and click the corresponding Structure link in the table. The Edit Tag Structure page is
displayed.

Note: The Path field shows the location of the selected tag in the tag structure. The table shows a
list of existing tag references (if any). You can navigate through the tag structure by clicking tag
names in either the Path field or the table. Each time you click a link, the page is updated to reflect
the new structure.

3. In the Add Tag drop-down list, select a tag to reference. The selected tag is added to the table.

4. Repeat to add more tag references if desired.

5. Click Finished to return to the Manage Tags page.

Removing Relationships Between Tags

Follow these steps to remove a tag reference from a tag. This does not delete the tag from the database
(see the section Deleting Tags vs. Removing Tag References).

1. Click Configuration > Tags.

2. Select a tag and click the corresponding Structure link in the table. The Edit Tag Structure page is
displayed.

Note: The Path field shows the location of the selected tag in the tag structure. The table shows a
list of existing tag references (if any). You can navigate through the tag structure by clicking tag
names in either the Path field or the table. Each time you click a link, the page is updated to reflect
the new structure.

3. In the table of tag references, click the Remove link for the desired tag. The reference is deleted from
the table, and the relationship between the tags is removed.

4. Repeat to remove more tag references if desired.

5. Click Finished to return to the Manage Tags page.

Changing the Name of a Tag

1. Click Configuration > Tags.

2. Locate the tag and click the corresponding View Details link in the table.

3. Modify the tag name and click Save. The name is updated on the Manage Tags page.

Deleting a Tag

1. Click Configuration > Tags.

2. In the table, locate the tag you want to remove and click the corresponding Delete link. You are
prompted to confirm deletion.

3. Click OK to permanently delete the tag from the database, or Cancel to return to the Manage Tags
page.
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Defining Charts
Charts are used in Enterprise View dashboards to display business data collected from surveys, and
metrics collected from workspaces. Enterprise View supports basic chart types (pie, line, bar, table) as well
as advanced charts (bubble) that provide far more sophisticated windows into your data.

Accessing the Charts List Page
To begin working with charts, click Configuration > Chart Definition . The Charts List page is displayed.

The table shows a list of all existing charts and their properties. You can resort the table by clicking any
column heading. Use the links on the right to perform various configuration tasks.

Planning a Chart
The Enterprise View Chart Definition Wizard guides you through the process of configuring a new chart.
It's helpful to understand some key concepts before you begin.

• Chart elements

Chart elements are the bars, pie slices, table rows, and so forth, displayed on the chart. You can group
data by tags, metrics, object types, or ranges.

• Filtering and data aggregation

By specifying a tag or object type as a filter in your chart, you can aggregate survey results and metrics
values stored under descendant tags (or objects of the selected type) using various aggregation
methods (that is sum, average, and so on). For example, you can "roll-up" survey results for all
descendants of the "Enterprise" tag, or aggregate metrics values for all objects of type "Cobol File". 

• Snapshot vs. Trending

The decisions you make about a chart's scope and filter parameters, and the number of results/metrics
included, determine the available chart types (such as pie, line, bubble, and table). The chart type
dictates whether you can display a snapshot using current values in the database, or a trend (line or
table) using historical values captured over time.

Chart Types in Enterprise View
Enterprise View is shipped with a variety of chart types. When creating and/or editing a chart, you select
from a list of available chart types. The types available for selection vary based on the number of survey
results and/or metrics included in the chart. For example:

• Pie chart: available when one metric is selected.
• Bar chart: available when one or more metrics are selected.
• Bubble chart: available when three or more metrics are selected.
• Line chart or table: available when the trending option is available and enabled.
• Heat Map chart: available when one or more metrics are selected.

Note:

New chart types are added frequently. Contact product support for information about additional chart
types.

Administration Tasks for Charts
To begin working with charts, log in to Enterprise View with an account with appropriate access privileges.
Select a task and follow the instructions below.
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Note: You must perform an Update Trending Snapshot when objects in the repository have been
added, deleted or changed, when survey deliveries have been submitted and closed, or when
external metric data has been imported. Otherwise the changes to metrics are not visible in EV.

Creating a New Chart Definition

1. Plan your chart.

2. Click Configuration > Chart Definition . The Chart List page is displayed.

3. Click the Create button to launch the Chart Definition Wizard. 

Note: The Chart Definition Wizard contains hints on each step to help you create the charts.

4. Specify a name for the chart.

5. Write a chart Description. (Optional.) 

Note: Charts have additional description property that can be assigned when adding or editing a
chart. Chart descriptions are displayed under each chart on the dashboard page.

6. Choose how you want to group the data:

• By Tag
• By Metric
• By Objects
• By Object Type
• By Range

7. Depending on the selected grouping criteria the next steps are different.

8. Make selections in the fields as they are shown. For example, you can choose to filter the chart for a
tag, decide to show child tags or all descendant tags in the chart, select an object type, select available
complexity metrics or survey results, choose to trend or not, select the chart type, edit chart options,
add horizontal or vertical line indicators in charts, and preview your chart.

Click Back to return to the previous field, and Cancel to return to the Chart List page.

Note:

• If you want to create a chart that contains text answers from a survey, check Show text
instead of numeric values when you select the metrics in the wizard.

• Use additional filters based on external metrics, to customize further the survey results in
charts. For example, if you have a survey question that asks which database an application
uses, you can show a chart that includes only data for tags specified as DB2 applications by
adding a filter for that database survey question.

9. Click Finish to save your chart and close the window.

Previewing a Chart or Editing its Definition

1. Click Configuration > Chart Definition . The Chart List page is displayed.

Tip: Click a column heading to sort the table by that column.

2. In the table, highlight the row for the chart you want to see and click the edit button. locate the chart you
want to see and click the View link.

3. In the Select Chart Type pane, click the Preview button.

The chart is dynamically generated and displayed using the latest information in the database.

4. Click the Previous button in your browser to view screens where you can make changes to the chart.

5. Return to the Chart List page by clicking Cancel or Finish to capture any changes made.
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Deleting a Chart Definition

1. Click Configuration > Chart Definition . The Chart List page is displayed.
2. In the table, locate the chart you want to modify and click the Delete link.

Tip:

Click a column heading to sort the table by that column.
3. You are prompted to confirm deletion. Click Yes to delete the chart or No to return to the Chart List

page.

Note: If the deleted chart definition is included on any dashboards, the chart will be removed. This
may leave an empty cell on affected dashboards.

Updating Data for Trending Charts

EV trending charts display complexity metrics data for workspace objects per monthly period. The metrics
information is stored in a database table for trending data. You need to update this table:

• After verifying a workspace for the first time.
• After reverifying updated objects in a workspace.

You can update trending data in online or batch mode:

• Choose Prepare > Update Trending Snapshot in Modernization Workbench to update the table in
online mode.

• Run the script UpdateTrendingSnapshot.bj to update the table in batch mode:

UpdateTrendingSnapshot C:\Workspaces\Training.rwp

The script is located in \<Modernization Workbench Home>\Scripts\BRP. For detailed information on batch
script execution, see Using the Batch Refresh Process in the Modernization Workbench documentation
set.

Defining Dashboards
An Enterprise View dashboard is a Web page that contains charts of business and metrics data collected
from survey results and workspace repositories. Administrators can configure dashboard pages,
determining which charts and graphs are displayed.

Note:

Only users with appropriate access privileges can configure dashboards.

Accessing the Dashboards Definition Page
To begin working with dashboards, click Configuration > Dashboard Definition . The Dashboard
Definition page is displayed.

The table shows a list of all existing dashboards and their properties. You can resort the table by clicking
any column heading. Use the links to perform various configuration tasks. 

Understanding Drilldown in Dashboards and Charts
In Enterprise View, you can navigate from an Enterprise-level dashboard down to a chart of complexity
metrics for a specific application. Navigating from one dashboard to another by clicking elements on a
chart is called "drilldown." Before you begin configuring dashboards, it is crucial to understand the way
drilldown works in Enterprise View. 

What happens during drilldown?

When you click an element on a chart (the "active" chart), the Dashboards page is refreshed and the
default drilldown (or "target") dashboard is displayed. The target dashboard is always the default drilldown
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dashboard, unless you have specified an alternative drilldown target for the active chart. For example, the
default drilldown dashboard for CIO Enterprise is CIO Departments.

Here's what happens during the drilldown process:

1. The chart element you click on the active chart determines a drilldown parameter.
2. The drilldown parameter is passed from the active chart to all charts on the target dashboard.
3. All charts on the target dashboard are updated using the drilldown parameter.

If the drilldown parameter type is incompatible with the native properties of a chart on the target
dashboard, that chart is not updated. For example, let's assume you click on an element in a chart showing
metrics data, and the drilldown parameter is the object ID for a COBOL file. Any business data charts on
the target dashboard are not updated, since they use tags (not object IDs) to filter data.

How does default drilldown vs. chart-specific drilldown work?

Every dashboard has a default drilldown target. This specifies which dashboard is shown when a user
clicks a chart. For example, when a user clicks any chart element on the CIO Enterprise dashboard, the
CIO Departments dashboard is shown. All charts on the CIO Departments dashboard are updated using
the drilldown parameter. (See the section What are drilldown parameters and how do they work?)

In some cases, you may want to override the dashboard default and designate a different drilldown target
for a specific chart. This lets you customize the navigation path through the dashboard structure.

What are drilldown parameters and how do they work?

When you click an element on a chart, the drilldown parameter is passed from the active chart to all charts
on the target dashboard. The drilldown parameter can be any one of the following:

• Tag: The tag assigned to the chart element (for example, "Sales"), or the tag filter you applied to the
entire chart (for example, "Include values for Enterprise and all descendant tags").

• Entity Type: "Program," or "COBOL File," for example.

All charts on the target dashboard receive and implement the drilldown parameter to retrieve new data,
provided the parameter is valid.

For example, if you click on a chart element that uses the tag "Sales," all charts that use tags on the target
dashboard will apply the "Sales" tag and refresh their data. For an example, see the section What happens
during drilldown?.

Note:

If the dashboard contains a chart which cannot apply the drilldown parameter, that chart is not
updated and will display its default data.

Administration Tasks for Dashboards
To begin configuring dashboards, log in to Enterprise View with an account with appropriate access
privileges. Select a task and follow the instructions below. 

Creating a Dashboard

1. Open Configuration > Dashboard Definition, and click Create. The Dashboard Definition wizard
starts.

2. Specify a Dashboard Title.

3. Add a Dashboard Description (optional). 

Note: Dashboards have additional description property that can be assigned when adding or
editing a dashboard. Dashboard descriptions are displayed at the bottom of the dashboard page.

4. If desired, select a Default Drill.
This is the default dashboard that the new one drills to.
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Note: If you use this feature for the first time the list may be empty.

5. Define the layout of the dashboard. By default there is a table with four cells in the wizard. You can
change the table by adding or removing columns using the buttons. Use Reset to get back to the default
table.

6. Select a chart from the list.

7. Select a dashboard from the Drill to list. (optional)

This is the dashboard that the chart will drill down to.

8. Repeat steps 6 and 7 as many times as needed to create a dashboard that meets your needs.

9. Click Save. The dashboard is saved and the Dashboard Definition wizard is closed.

Editing a Dashboard

1. Open Configuration > Dashboard Definition, and click Create.

2. In the table, highlight the dashboard definition you want to edit, and click the corresponding edit button.
The Dashboard Definition wizard starts.

3. Enter or change information as needed.

4. Click Save to store your changes, or Cancel to return to the Dashboard Definition page without
modifying the dashboard.

Deleting a Dashboard

Deleting a dashboard may affect the drilldown structure, breaking links to and from charts.

1. Click Configuration > Dashboard Definition from the Navigation panel.

2. In the table, locate the dashboard you want to remove and click the corresponding Delete button. You
are prompted to confirm deletion.

3. Click Yes to permanently delete the dashboard from the database, or No to return to the Dashboard
Definition page.

Exporting and Importing Enterprise View Information
Use the EV Configuration area to export or import content and data (including user-defined information).
You can also use EV utilities to import change traffic metrics and export tag metrics.

Exporting Enterprise View Information
Use the EV Configuration area to export content and data to an XML file, including:

• Survey content.
• Chart definitions.
• External metrics and their values, where external metrics are either change traffic metrics or user-

defined metrics imported into the repository with the EV import feature.

To export EV content or data, click Configuration > Export. The Export objects to XML page opens,
where you can select the type of information you want to export. When you are satisfied with your
selections, click Export. You are prompted to navigate to a download page, where you can download the
exported information.

Importing Enterprise View Information
Use the EV Configuration area to import content and data from an XML file, including:

• Previously exported EV content or data.
• Survey content and chart specifications defined in third-party tools or directly by the user.
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• External metrics and their values, where external metrics are either change traffic metrics or user-
defined metrics.

To import EV content or data, click Configuration > Import. The Import objects from XML page opens,
where you can browse for the XML file you want to import. When you are satisfied with your selection, click
Import.

Importing Change Traffic Metrics
Run the ChangeTraffic.bj script to generate change traffic metrics. Change traffic metrics compare the
source files currently in a workspace with the source files in a change unit:

• At the tag level, the number of new, modified, and deleted files in the change unit.
• At the object level, the number of new, modified, deleted, and moved lines in the modified files, and the

number of lines in the new and deleted files.

For details, see ChangeTraffic.bj in the Enterprise Analyzer documentation.

Important: An additional module required for generating the object level Change Traffic metrics is not
included in the Enterprise Analyzer installer. It is called diff and is a source comparison tool that has
been developed as an open source module using GnuWin. As such, it is free to download, but is not
something that Micro Focus can distribute.

Diff can create metrics to show differences between two source modules. These metrics are then
gathered by ChangeTraffic.bj and loaded into EA via the Enterprise View core module apm-
core.jar.

To download and install diff:

1. Go to http://www.microfocus.com/docs/links.asp?ea=gnuwin.
2. Go to the latest available version (currently it is 2.8.7.1) and select the executable to download. In

this case it is diffutils-2.8.7-1.exe.
3. Run the executable to install diff.
4. Go to its installation directory. By default it is: C:\Program Files (x86)\GnuWin32\bin.
5. Copy diff.exe into the EA bin directory. By default it is: C:\Program Files (x86)\Micro

Focus\Enterprise Analyzer\Bin.

Once diff has been placed in the EA bin directory, ChangeTraffic.bj can be run as part of Batch
Refresh Process to compare the files that are currently in a workspace against the files that are about
to be loaded into EA.

The output of ChangeTraffic.bj is an XML file that can be imported into the repository in online mode using
the Enterprise View Configuration interface, or in batch mode using the following command:

java -jar avmcore-Panther.jar "workspace" "outputfile"

where workspace is the name of the workspace and outputfile is the XML output file.

Note:

• Enterprise View must be installed before you run the import command.
• When running the java command in batch to import the Change Traffic XML file, be sure that Java

is installed. The path to java.exe should be in the Windows Path environment variable, or the
java command will need to be qualified with the full path to the JRE\bin folder. The avmcore-
Panther.jar file is located in C:\Program Files (x86)\Apache Software Foundation
\Tomcat 6.0\webapps\EV\WEB-INF\lib.

Exporting Tag Metrics
Use the command described in this section to export tag metrics for a specified period to a CSV file. The
CSV file has the format:

tag,metric,value
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For example:

Payroll,BlankLinesNum,450
Payroll,Changed Lines,9500

Two types of metrics are supported:

• External metrics, including survey-based, imported, and tag-level change-traffic metrics.
• Complexity metrics for tagged repository objects.

The input to the command is an XML file with the format:

<configuration>
    <metrics>
        <metric name="metric" aggregation="aggregation_method" />
    </metrics>
    <tags>
        <tag name="tag" />
    </tags>
    <period year="YYYY" month="MM" day="DD" calcPeriod="calc_period_method" />
    <fileformat>csv</fileformat>
    <tofilename>outputfile</tofilename>
</configuration>

<fileformat> must be CSV. <tofilename> is the path of the output CSV file. Tag attributes are
described in the table below.

Attribute Description

metric name Name of the metric.

Note: Use the internal name for a complexity
metric. You can find the internal name in
<Enterprise Analyzer Home>\Model
\Repository\Repstry.xml.

metric aggregation Aggregation method for the metric: SUM, AVG, MIN,
MAX, or COUNT.

tag name Name of the tag.

period year Year of the period that tag metrics are to be exported for.

period month Month of the period that tag metrics are to be exported
for.

period day Day of the period that tag metrics are to be exported for.

period calcPeriod Method for the calculation period:

• 0 means export the metric values for the current date.
The specified date is ignored.

• 1 means export the metric values for the specified
month.

• 2 means export the weekly metric values for change
traffic metrics only. The specified date is ignored. The
weekly value is calculated from the current date.

For example:

<configuration>
    <metrics>
        <metric name="BlankLinesNum" aggregation="SUM" />        
        <metric name="Changed Lines" aggregation="SUM" />
    </metrics>
    <tags>
        <tag name="Payroll" /> 
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        <tag name="Sales" />
    </tags>
    <period year="2010" month="4" day="16" calcPeriod="1" />
    <fileformat>csv</fileformat>
    <tofilename>C:\April2010Metrics.csv</tofilename>
</configuration>

To run the export, execute the following command from the folder C:\Program Files\Apache Software
Foundation\Tomcat 6.0\webapps\EV\WEB-INF\lib:

java -cp avmcore-Bobcat.jar 
com.microfocus.webclient.avmcore.export.TagExporter 
"workspace" "inputfile"

where workspace is the name of the workspace and inputfile is the XML input file.

Viewing Enterprise View Reports
The Enterprise View log lists every attempt to log in to Enterprise View. View the report for the log as
described below.

Note: Only users with appropriate access privileges can view reports.

1. Click Configuration > Reports. You are prompted to select a report in the Report drop-down list.

2. Choose Access Log.

3. To filter the report by: 

User name Select the type of comparison you want to perform in
the drop-down list next to the Username field, then
enter the text for the comparison in the adjacent text
field.

IP address Select the type of comparison you want to perform in
the drop-down list next to the IP field, then enter the text
for the comparison in the adjacent text field.

Message ("Login success"/"Failed login") Select the type of comparison you want to perform in
the drop-down list next to the Message field, then enter
the text for the comparison in the adjacent text field.

4. In the Results as drop-down list, choose HTML to save the report as HTML, or CSV to save the report
as CSV.

5. Click Submit. The report is displayed in the specified format.

Managing Metrics Histories
Enterprise Analyzer keeps a history of every change in the value of:

• The complexity metrics for an object.
• The external metrics for an object, where external metrics are either change traffic metrics or user-

defined metrics imported into the repository with the EV import feature.

Note: See "Exporting and Importing Enterprise View Information" for background on external metrics.

Particularly if you use external metrics extensively, you need to manage these histories to prevent their
accumulation from degrading Enterprise Analyzer performance. Use the EA Administration tool to:

• Select the complexity metrics you want to keep histories for.
• Purge metric histories selectively.
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• Delete all metrics histories.

Selecting the Complexity Metrics You Want to Keep
Histories For
Use the EA Administration tool to select the complexity metrics you want to keep histories for.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Tools > Metrics History > Attributes. The Open existing workspace dialog opens.

3. In the Open existing workspace dialog, select the workspace for which you want to specify metrics
histories and click OK. The Select Metrics Attributes dialog opens.

4. The left-hand pane of the Select Metrics Attributes dialog lists the available complexity metrics. The
right-hand pane lists the complexity metrics that are candidates for metrics histories.

•
In the left-hand pane, select each metric you want to make a candidate and click the  button.

Click the  button to make all the available metrics candidates.
•

In the right-hand pane, select a metric and click the  button to remove a metric from the list of

candidates. Click the  button to remove all metrics from the list of candidates.
• Click Restore to restore the window to its initial state.

5. In the right-hand pane, place a check mark next to each candidate you want to keep a history for.
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6. When you are satisfied with your choices, click OK.

Purging Selected Metrics Histories
Use the EA Administration tool to purge metric histories selectively.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer > Enterprise
AnalyzerAdministration. The Administration window opens.

2. Choose Tools > Metrics History > Manage Metrics History. The Open existing workspace dialog
opens.

3. In the Open existing workspace dialog, select the workspace for which you want to purge metrics
histories and click OK. The Manage Metrics History dialog opens.

4. In the Manage Metrics History dialog, select:

• Purge by Date to purge records for complexity metrics and external metrics (change traffic and
user-defined metrics) with a date earlier than the specified date. The current value of the metric is
preserved even if it has a date earlier than the specified date. Specify the date in the Timestamp
combo box.

• Complexity Metrics Only to purge only records for complexity metrics by date. Records for external
metrics are preserved.
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• Purge by Attributes to purge records for all complexity metrics except the ones you select. Click
Browse to select the metrics you want to preserve. Follow the instructions in "Selecting the
Complexity Metrics You Want to Keep Histories For" to select the metrics you want to preserve.
Metrics are purged regardless of their date. The current value of the metric is preserved.

Note: Click Refresh to update the dialog with the latest repository information.

5. When you are satisfied with your choices, click Purge. You are prompted to confirm that you want to
purge the selected records. Click OK.

Deleting Metrics Histories
Use the EA Administration tool to delete all metric histories from a workspace.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise
AnalyzerAdministration. The Administration window opens.

2. Choose Tools > Metrics History > Delete Metrics History. The Open existing workspace dialog
opens.

3. In the Open existing workspace dialog, select the workspace for which you want to delete all metrics
histories and click OK. You are prompted to confirm that you want to delete all metrics histories. Click
OK.
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Troubleshooting and FAQs
This section includes a list of frequently asked questions and troubleshooting tips.

See the following topics for assistance.

Why do I get an HTTP status 404 error when accessing
http://server name:port/ev?

The URL for accessing Enterprise View is case-sensitive. Capitalize “EV" in this string.

Why do I get a "workspace not found" error when I
configure EV?

When you configure EV, you identify the location of the workspace (.rwp) file you want to access in the
Enterprise View Setup page. Security settings in the Web browser may result in your receiving
"<workspace>.rwp not found" error messages when you attempt to specify the location of the .rwp file.

Internet Explorer 8

IE 8 displays the message "<workspace>.rwp not found" when the option Include local directory path
when uploading files to a server is disabled. Enable the option for each required zone in Tools >
Internet Options > Security > <zone> > Custom level.

Firefox 3 or Higher

Firefox 3 or higher displays the message "<workspace>.rwp not found" when you attempt to specify the
location of the .rwp file. If you are using Apache Tomcat as the application server for EV, work around this
problem by editing the file <drive>:\Program Files\Apache Software Foundation\Tomcat\webapps\EV\WEB-
INF\data\Configuration.xml. In the <APMRwp> tag, enter the full path of the .rwp file, as in the following
example:

<APMRwp>C:\Workspace\Provider.rwp</APMRwp>

Note: Do not point to the workspace file in the browser again after making this change to
Configuration.xml. You can log in to EV immediately.

Why do I get an "Error connecting to workspace"
message?

If you are using Apache Tomcat as the application server for EV, the Tomcat logon property must be set to
an account that has read/write access to the folder containing the.rwp file for the workspace you want to
access in EV.

Note: If you have configured EA on the Web server as an EA client, this folder is the folder containing
the .rwp file on the EA server, not the local folder containing the link file for the workspace.

Note: The account set for the Apache Tomcat service logon needs to have access to the database in
cases of SQL Server workspaces where the SQL Server uses Windows authentication.
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Why are the APM dashboards not displaying?

Symptom

None of the charts on the APM Dashboard page will load. Instead a pop-up window appears displaying an
error message that instructs you to get the latest Flash Player.

Solution

Adobe Flash Player 8 or above is required to view the charts in your browser. Clicking Ok will redirect your
browser to the Adobe website where you can download and install the latest Flash Player.

Why can I not create or edit dashboards and surveys?

Answer

Your assigned role doesn’t permit access to administration tasks.

Users without appropriate access privileges have the equivalent of “view only” access to dashboards and
surveys. They can browse dashboards (via the APM Dashboards area), and view and respond to surveys
(via the Surveys area). However, they cannot add or edit dashboards and surveys, nor can they change
the properties of charts and survey questions.

Management of global settings such as user accounts, workspace access, roles and tags is done through
the Configuration area. In addition, configuration of dashboards, surveys, and their respective
components (charts and questions) can only be performed if you have sufficient access privileges.

Why does my chart not display any data?

Symptom

A dashboard contains an empty chart with the message “no data to display.”

Possible Cause

No survey results and/or metrics are available for the chart.

This can occur if, during drilldown, you pass a tag to a chart for which no surveys have been completed.
This means no survey results (and thus no data) are stored under that tag.

This message would also be displayed if the chart was designed to show metrics but there are no objects
available with the specified metrics. If the chart is filtered for a tag by design or through drilldown, the tag
may not be applied to any objects that have those metrics.

Why do I see the "workspace not available" message on
some pages?

Answer
There is a problem accessing the selected workspace.
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Potential Cause
The workspace does not exist in the location you specified.

Solution

Verify the location of the workspace, delete and re-add it using the correct path.

Potential Cause

The user logged in on the Enterprise View server is the user under which the Tomcat service runs. This
user may not have access to the workspace folder.

Solution

Log in and run the Tomcat service under a user account with access permissions for the workspace folder.

Tip: To avoid having to repeat these steps for each folder containing a workspace, put all workspaces
in the same folder. When specifying sharing and security permissions, make sure to includethe
subfolder with the name of the workspace as well as the .rwp file.

Why can I not view Analysis pages or Business Rule
source code?

Answer

The relevant files are not located on the Enterprise View server, and the user under which the Tomcat
service is running does not have access to the computer where these files are stored.

Solution

Log in and run the Tomcat service under a user account with access permissions for the computer(s)
where the files are stored, or grant access permissions for the relevant computer(s) to the current user
logged in to the Tomcat service.
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Post-Installation Administrative Tasks
If you are experiencing problems working in EV, it may be because your EV administrator failed to perform
the post-installation administrative tasks described in this section.

Configuring Tomcat Logon Properties
If you are using Apache Tomcat as the application server for EV, the Tomcat logon property must be set to
an account that has read/write access to the folder containing the.rwp file for the workspace you want to
access in EV.

Note: If you have configured EA on the Web server as an EA client, this folder is the folder containing
the .rwp file on the EA server, not the local folder containing the link file for the workspace.

Note: The account set for the Apache Tomcat service logon needs to have access to the database in
cases of SQL Server workspaces where the SQL Server uses Windows authentication.

1. Click Start > Settings > Control Panel > Administrative Tools > Services (or its equivalent on your
system). The Services window opens.

2. In the Services window, select the Apache Tomcat service and click Action > Properties. The
Properties window for the Apache Tomcat service opens. Click the Log On tab.

3. On the Log On tab, select This account. In the adjacent text field, enter the Windows user ID of an
account with read/write access to the folder containing the .rwp file for the workspace. In the
Password field, enter the password for the account. In the Confirm password field, re-enter the
password. Click OK to save your changes and exit the Properties window.

4. You are prompted to restart the service. Click Action > Restart. The Apache Tomcat service is
restarted.

Configuring the Application Server for Survey
Assignment Email Notifications

EV notifies users via email when a survey has been assigned to them. If you are using Apache Tomcat as
the application server for EV, you need to set email notification properties in the file <drive>:\Program
Files\Apache Software Foundation\Tomcat\webapps\EV\WEB-INF\conf
\system.properties. The table below describes the properties.

Note: Restart the Apache Tomcat service after setting these properties. For instructions on how to
restart the service, see "Configuring Tomcat Logon Properties".

Property Description Example

mail.protocol Email protocol. smtp

mail.host Email host. emailhost.microfocus.com

mail.username Email user name. myusername@microfocus.com

mail.password Email password.

mail.authentification.required Whether email authentication is
required, True or False.
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Property Description Example

default.system.email Email address that appears in the From
line of the email message.

myusername@microfocus.com

delivery.list.default.subject Subject line of the email message. A new survey is waiting for you

delivery.list.default.text Email message for survey notification
when surveys are assigned directly to
email addressees. The email message
contains a link to the survey. The
addressee need not log in to EV.

Dear [user], \n This is an auto-generated
message from your SurveyDelivery
System. \n Please follow the link below to
complete the survey\n [link]

delivery.list.default.text.reg.us
er

Email message for survey notification
when surveys are assigned to EV user
accounts. The user account must have
an email address. The addressee logs in
to EV and goes to the Survey Inbox to
respond to the survey.

Dear [user], \n This is an auto-generated
message from your SurveyDelivery
System. \n There is a new survey
[survey.label] assigned to you. Please login
and check your Survey Inbox.

Configuring EV
Before you can work in EV, you must install Enterprise Analyzer on the Web server machine. You can
configure EA as a client or server:

• If you configure EA as a server, a master user needs to create the workspace you want to access in EV
(if it has not already been created). The workspace has a .rwp extension.

• If you configure EA as a client, you need to connect to the workspace you want to access in EV. When
you connect to a workspace, you create a link file with connection information that points to the
workspace on the EA server. Like a workspace file, the link file has a .rwp extension.

In either case, you must identify the location of the .rwp file to EV, as described below.

1. In a Web browser (both Internet Explorer and Firefox are supported), go to http://<server
name>:<port>/EV, where <server name> is the name of the machine running EV and <port> is the port
number:

• For Apache Tomcat, the port number is specified at installation. The default is 8080. For example:
http://localhost:8080/EV.

• For WebSphere Application Server, the port number is the HTTP transport port for the application
server profile. For example: http://localhost:9081/EV. You can find the HTTP transport port in the file
AboutThisProfile.txt in the logs folder for the application server profile.

Note: Make sure “EV" is in upper case.

2. You are prompted to enter the setup code. The default code is “setup” (no quotes). Enter the code and
click Login.

Note: For security purposes, you can (and should) change the default setup code, as described
below.

3. The Enterprise View Setup page opens, with a message that the workspace has not been set. Click the
Code tab. Enter and confirm a new code, then click Save. A confirmation message is shown, verifying
the setup code has been updated.

4. Optionally configure EV security options. Click the Options tab:

• In the Lock User after this many attempts field, enter the number of failed login attempts users are
permitted before being locked out of their accounts. A blank, 0, or non-numeric character means that
users never are locked out. The administrator can lock or unlock a user account manually on the
Enterprise View Manage User Accounts page.
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• In the Passwords expire after this many days field, enter the number of days passwords may be
used before they expire. A blank, 0, or non-numeric character means that passwords do not expire.
Users with expired passwords are prompted to create new ones. The administrator can expire or
unexpire passwords manually on the Enterprise View Manage User Accounts page.

• Select Clear Query Repository Cache if you want to clear the cache used to store EA Query
Repository information. This information is used to populate drop-downs on the Query Repository
page. You should always clear the cache after the workspace has been modified, so that the most
recent workspace information is available in the drop-downs.

5. Click the Workspace tab, then click Browse. In the Browse dialog, specify the location of the .rwp file,
then click Save. A confirmation message displays the path to the workspace.

Note: IE 8 displays the message "<workspace>.rwp not found" when the option Include local
directory path when uploading files to a server is disabled. Enable the option for each required
zone in Tools > Internet Options > Security > <zone> > Custom level.

Firefox 3 or higher displays the message "<workspace>.rwp not found" when you attempt to
specify the location of the .rwp file. If you are using Apache Tomcat as the application server for
EV, work around this problem by editing the file <drive>:Program Files\Apache Software
Foundation\Tomcat 6.0\webapps\EV\WEB-INF\data\Configuration.xml. In the <APMRwp> tag,
enter the full path of the .rwp file, as in the following example:

<APMRwp>C:\Workspace\Provider.rwp</APMRwp>

Do not point to the workspace file in the browser again after making this change to
Configuration.xml. You can log in to EV immediately.

6. The Enterprise View Login page opens. Enter the EV user name and password. The default user name
is “administrator” (no quotes). The default password is “admin” (no quotes). The fields are case-
sensitive. Click Login. The Enterprise View window opens.
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