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About This Guide

Best Practice Deployments

To create a production-viable, best practice Filr deployment, complete the sections below in the
order presented.

+ Chapter 1, “Overview,” on page 9

+ Chapter 2, “Planning Is Critical,” on page 11

+ Chapter 3, “Filr System Requirements,” on page 13

+ Chapter 4, “Setting Up Shared Storage,” on page 21

¢ Chapter 5, “Downloading and Preparing the Filr Software,” on page 25

+ Chapter 6, “Deploying the Virtual Machines,” on page 29

+ Chapter 7, “Starting and Configuring the Filr Appliances,” on page 41

+ Chapter 8, “Creating an Expandable Filr Deployment,” on page 47

+ Chapter 9, “Content Editor,” on page 67

+ Chapter 10, “Upgrading from Filr 4.3.1.2 to Filr 5.0,” on page 103

+ Chapter 12, “Setting Up Filr Services,” on page 135

+ Chapter 13, “Setting Up Sharing,” on page 139

Test and Evaluation Deployments
To create an evaluation or test deployment, see the following sections.

+ Appendix B, “All-in-One (Small) Deployment—Creating,” on page 161

and

+ Appendix C, “Non-Expandable Deployment—Creating,” on page 163
Upgrade Instructions
To upgrade existing deployments, see

+ Chapter I, “Upgrading Filr,” on page 101

+ “Upgrading an All-in-One (Small) Deployment” on page 120
Audience

This guide is intended for Filr Administrators.

About This Guide
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Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the comment on this topic link at the bottom of each page of
the online documentation.

Documentation Updates

For the most recent version of this guide, visit the Filr Documentation web site.

About This Guide


http://www.microfocus.com/documentation/filr/filr-23.4/

Overview

What Is OpenText Filr?

OpenText Filr is an enterprise file sharing tool that leverages your current file server and security
infrastructure to provide multi-device access to organizational and personal files.

eDirectory
Users
Comments CES
| 2
-l. [ ]
Active } -
Directory My Files m/
Users
Windows
| MNet Folders
U o
Other O (=_F
Internal Search SharePoint
Users e
E-‘-__E}
' Sharing {=}
Extemnal Filr Data Disk
Users Synchronization
— e T

For more detail about this illustration and for more illustrations and explanations, see the OpenText
Filr 23.4: Understanding How Filr Works.

What Is “Filr Clustering”?

“Filr clustering” is a term that is sometimes used in the Filr product and means that multiple Filr
appliances access a shared storage location, which contains deployment-level configuration settings
and data. “Filr clustering” provides a measure of

+ Fault tolerance

Overview
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https://www.microfocus.com/documentation/filr/filr-23.4/pdfdoc/filr-overvw/filr-overvw.pdf#bookinfo

And
+ High availability

“Filr clustering” is not related to Novell Cluster Services.

This guide refers to “Filr-clustered” deployments as “Expandable” deployments.

10 Overview



2 Planning Is Critical

Creating a successful Filr deployment requires that you

1. Involve pertinent stakeholders.
2. Conduct a thorough needs assessment.

3. Plan your deployment based on the needs assessment.

Planning Is Critical 11
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3 Filr System Requirements

The following sections outline platform, version, and other requirements for your expandable Filr

deployment.

*

*

*

*

“Administrative Workstations and Browsers” on page 13
“Appliance Disk Space” on page 13

“Appliance Memory and CPU” on page 14

“Appliance Shared Storage (/vashare Mount Point) Platforms” on page 13
“Desktop Platforms (for the Desktop Application)” on page 15
“Desktop Web Application Access” on page 15

“File Servers (Backend Storage)” on page 16

“Filr Software” on page 17

“IP Addresses” on page 17

“LDAP Directory Services (Users and Groups)” on page 18
“Mobile Device Platforms” on page 18

“SQL Database Server” on page 19

“Secure Access” on page 19

“Virtualization Hypervisor Platform” on page 20

Administrative Workstations and Browsers

Table 3-1 Administrative Workstations and Browsers

Platform Browser Requirement
Windows, Mac, or Linux Microsoft Edge Latest version
Google Chrome Latest version
Safari Latest version

Appliance Disk Space

Planning for disk space varies widely according to organization needs.

For an overview of Filr storage, see “Appliance Storage lllustrated” in the OpenText Filr 23.4:
Understanding How Filr Works.

Appliance Shared Storage (/vashare Mount Point) Platforms

+ Storage Planning Summary

Filr System Requirements
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The Filr appliances in an Expandable deployment access a commonly-shared CIFS or NFS storage disk
that you will identify and create in Chapter 4, “Setting Up Shared Storage,” on page 21.

Table 3-2 Shared Storage Platforms (/vashare Mount Point)

Protocol Requirement

CIFS + A Windows-based CIFS Share
¢ Any OES based CIFS share (OES 23.4 or later)

NFS Exported mount point on one of the following:
¢ SLES 15SP4

NFS on Windows is not supported.

Appliance Memory and CPU

Table 3-3 Memory and CPU

Appliance Recommended

Filr ¢ 20 GB RAM
+ 12 GBJava Heap
¢ 4CPUs

Filrsearch Less than 1,000 Users
¢+ 8 GBRAM

+ 2 GB Memcached
* 4 GBJava Heap
¢ 4 CPUs

More than 1,000 Users

*

16 GB RAM

3 GB Memcached
+ 8 GBJava Heap

* 4CPUs

*

PostgreSQL Less than 1,000 Users

¢+ 8GBRAM
¢ 2CPUs

More than 1,000 Users

¢ 12 GBRAM
¢ 2CPUs

*

Content Editor 16 GB RAM

¢ 4 CPUs

14 Filr System Requirements



NOTE: Do not overcommit more memory for the processes than mentioned in the above table,
beware that operating system needs considerable amount to free memory to operate.

Desktop Platforms (for the Desktop Application)
For more information about the Filr desktop application, see the following guides:

+ Linux: Filr Desktop Application for Linux Guide
* Mac: Filr Desktop Application for Mac
+ Windows: Filr Desktop Application for Windows Guide

Table 3-4 Desktop Platforms (Desktop Application)

Platform Versions

Windows IMPORTANT: Always make sure that the latest patches and support packs are installed.
+ Windows 11
+ Windows 10

Mac IMPORTANT: Always make sure that the latest patches and support packs are installed.

* Intel - macOS 15 and macOS 14
¢ ARMG64 - macOS 15 and macOS 14

Linux Platform ¢ Ubuntu 16.04.4 LTS (Xenial Xerus)

NOTE: Supports Unity graphical desktop environment
¢ SLED 12 SP4

NOTE: Filr supports only the default GNOME graphical desktop environment that is
shipped with SLED.

Desktop Web Application Access
Three components apply:

+ A Browser
+ Java

+ An Office Application

Filr System Requirements
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Table 3-5 Browsers for Web Application Access

Platform Requirement
Linux Mozilla Firefox
Windows + Microsoft Edge
+ Mozilla
* Firefox

+ Google Chrome (latest versions)

Mac * Safari
* Mozilla
* Firefox

+ Google Chrome

Table 3-6 Java for Web Application Functionality

Version Functionality

Java v1l ¢ Editing files with Edit-in-Place
+ Uploading folders to Filr

If the browser does not support HTML 5, uploading both files
and folders requires this version of Java to be installed.

Table 3-7 Office Application for Edit-in-Place Functionality

NOTE: OpenOffice and LibreOffice are used synonymously throughout the Filr documentation.

Linux + OpenOffice.org (latest version)

*

LibreOffice (latest version)

Windows + LibreOffice (latest version)
+ OpenOffice (latest version)
+ MS Office 2016, 2019, and 2022
+ MS Office 365

Mac + LibreOffice (latest version)
+ OpenOffice (latest version)
+ MS Office 2011 for MAC
* MS Office 2013 for MAC
¢ MS Office 365 for MAC

File Servers (Backend Storage)

NOTE: Your organization’s file servers provide the backend storage for Net Folders.

If you use Filr only for user personal storage (My Files), then file servers aren’t required.

Filr System Requirements



Table 3-8 File Servers

Platform Supported Versions

Windows .

(Standalone and ¢

Clustered environment) .

Windows Server 2022 (CIFS)
Windows Server 2019 (CIFS)
Windows Server 2016 (CIFS)

Windows native DFS-N and DFS-R with replication are supported

OES IMPORTANT: You must apply the latest Scheduled Maintenance Update, otherwise
the NCP server can fail.

(Standalone and
Clustered environment) .

*
*

*

OES 23.4 (NCP and CIFS)
OES 23.4 NSS AD (CIFS)
OES 24.2 (NCP and CIFS)
OES 24.2 NSS AD (CIFS)

Other In addition to storage that is directly attached to the file servers listed in Net
Folders can provide access to files that are being stored on any of the following
storage platforms:

*

*

*

NetApp NAS device
EMC

Other Microsoft Active Directory joined NAS devices that support the CIFS
protocol.

Storage Area Network (SAN)

SharePoint .

2019

Filr Software

To download and prepare the Filr software, See Chapter 5, “Downloading and Preparing the Filr

Software,” on page 25.

IP Addresses

Each appliance requires the following.

Table 3-9 |IP Addresses

Component

Requirement

IP Address

+ A static address that is associated with a DNS host name.

Example: 192.168.1.61

Network Mask

+ The appropriate network mask for the IP address.

Example: 255.255.255.0

Gateway IP Address

¢ The gateway for the IP address subnet.

Example: 192.168.1.254

Filr System Requirements
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Component Requirement

DNS Host Name * The DNS name associated with the IP address.

Example: filr-1.myorg.local

DNS IP Address ¢ Up to three IP addresses of DNS servers for the IP address
subnet.

Example: 192.168.1.1

NTP IP Address or DNS Name + Up to three IP addresses or DNS names of reliable NTP servers
used to coordinate time on your organization’s network—
especially your LDAP directory servers.

Example: time.myorg.local

When using VMware, it is recommended that you set up NTP in
accordance with the VMware best practices guidelines.

LDAP Directory Services (Users and Groups)

Table 3-10 LDAP Directory Services

Directory Service Platform Version

eDirectory + NetlQ eDirectory 9.2.8.x
+ NettlQ eDirectory 8.8.x.x
For more information, see the NetlQ eDirectory 8.8 Documentation website.
+ NetlQ eDirectory version 8.8.x.x on standalone Windows.
IMPORTANT: eDirectory running on Windows servers with file shares is not
supported.
Active Directory + Windows Server 2022 Active Directory with the latest Service Pack
+ Windows Server 2019 Active Directory with the latest Service Pack

+ Windows Server 2016 Active Directory with the latest Service Pack

Mobile Device Platforms

IMPORTANT: Accessing Filr through a web browser on a mobile device is not supported. Instead,
download the Filr mobile app that is compatible with your mobile device.

For more information about the Filr mobile app, see the OpenText Filr 23.4 Mobile App Quick Start
Help.

Filr System Requirements
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Table 3-11 Mobile Devices

Platform

Supported Versions

iOS Phones and Tablets

+ i0S17.xandi0OS 16.x

The native app is available as a free download in the
Apple App Store.

Android Phones and Tablets

* Android 8 to 14

The native app is available as a free download in the
Google Play App Store.

SQL Database Server

Table 3-12 SQL Database Server

Database Type Supported Versions
PostgreSQL ¢ 156
(Standalone and ¢ 143

Clustered environment)

MySQL .

8.0.34

Microsoft SQL .

SQL Server 2022
SQL Server 2019
SQL Server 2017
SQL Server 2016 SP1

MariaDB .

10.11
11.1.3

Secure Access

Table 3-13 Secure Access

Component

Supported Versions

NetlQ Access Manager

NetlQ Advance Authentication

5.0and 4.5

6.4.2 and 6.4.1.1. Only the Enterprise Editions are
supported.

Filr System Requirements
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Virtualization Hypervisor Platform

Table 3-14 Virtualization Hypervisor Platform

Hypervisor Type Supported Versions

VMware + One of the following VMware host servers for hosting the appliance VMs.
+ ESXi8.0.1
* ESXi 7.0
* ESXi6.7
For the most up-to-date compatibility matrix of supported VMware host servers, see
the VMware Compatibility Guide provided by VMware.

+ VMware vMotion is supported when running Filr on VMware ESXi

Hyper-V ¢ The following platforms
* Windows Server 2022
* Windows Server 2019
¢ Windows Server 2016

+ Hyper-V Manager to deploy, set up, and configure the appliances.

Xen IMPORTANT: Apply all Xen and kernel patches before installing.

+ The server with the Xen packages installed and the Xen bootloader running by
default.

+ SLES155SP4

+ Virtual Machine Manager to deploy, set up, and configure the appliances.

Citrix Xen + Citrix XenServer 8.2
+ Citrix XenServer 7.6

+ Citrix XenCenter to deploy, set up, and configure the appliances.

20 Filr System Requirements


http://www.vmware.com/resources/compatibility/search.php?deviceCategory=software&testConfig=16

Setting Up Shared Storage

Figure 4-1 is the first in a series of illustrations that visually track deployment order.

Figure 4-1 Export an NFS Directory or Create a CIFS share for the /vashare mount point

Set Up NFS or CIFS Shared Storage

(NFS v3 Server CIFS Server\
=em  O' omam (.
) w—— - .
o .
Exported Directory
for /vashare on all
Filr appliances

u
—~B-B

download.novell.cor

SQL Server

Filr Search 1

Filr Search 2

Complete the instructions in the section below:
+ “Exporting an NFS Directory for the /vashare Mount Point” on page 21
Or

¢ “Creating a CIFS Share for the /vashare Mount Point” on page 22

Exporting an NFS Directory for the /vashare Mount Point

IMPORTANT: Filr does not support remote NFS from a Novell Storage Services (NSS) volume.

If you plan to use a CIFS share for Filr shared storage (/vashare), skip to “Creating a CIFS Share for the
/vashare Mount Point” on page 22. Otherwise, export an NFS directory on a Linux server by doing
the following:

Setting Up Shared Storage 21
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Table 4-1 Task 1: Exporting an NFS Directory for /vashare

Page, Dialog, or Option Do This

1 - Verify that the server has adequate disk space.

1.

Make sure that the Linux server that you are targeting has the available disk
space you have identified.

If necessary, add disk space to the Linux server.

On the Linux server, launch YaST2.

YaST Control Center 1.

In the Network Services section, click NFS Server.

The NFS Server Configuration dialog box displays.

NFS Server Configuration 1.

Make sure that the NFS Server is set to Start, that Open Port in Firewall is
selected (running firewall required for option), and that Enable NFSv4 is not
selected - i.e. NFS v4 is disabled.

2. Click Next.
Directories to Export 1. Click Add Directory.
YaST2 1. Click Browse and choose the directory or share path that has the required
disk space.
You can add a directory name, such as / shar ed to the path if desired.
IMPORTANT: The directory path must not be located in the /var directory
structure on the NFS server, as explained in “NFS Mount Point Must Not Point
to /var on Target Server” on page 171.
2. Click OK.

As your first Filr appliance is deployed, a directory named fi | r will be
created within the directory path you have specified.

3. If you added to the directory path, click Yes to confirm directory creation.

Leave the asterisk (*) in the Host Wild Card field.

5. Click the Options field to edit it and change the following options:

¢ 1o torw(read-only to read-write)
¢ root_squashtono_root _squash.
Click OK.

Directories to Export 1.

Click Finish.

Skip to Chapter 5, “Downloading and Preparing the Filr Software,” on
page 25.

Creating a CIFS Share for the /vashare Mount Point

Table 4-2 Task 1: Creating a CIFS Share for /vashare

Page, Dialog, or Option Do This

1 - Verify that the Windows server has adequate disk space.

Setting Up Shared Storage



Page, Dialog, or Option Do This

1. Make sure that the Windows server that you are targeting has the available
disk space you have identified.

Beginning with Filr 4.0, CIFS share is configured with SMB2/SMB3 protocol.
Versions earlier than SMB2/SMB3 are not supported.

2. Open Windows Explorer

Windows Explorer 1. In Windows Explorer, navigate to the folder that will be the shared storage
location (/vashare) for Filr.

2. Right-click the folder, then click Properties.

folder Properties 1. Click the Sharing tab.
2. Click Share.
Filr Sharing 1. Add a user (new or existing) to the list and assign the Read/Write permission
to the user.

IMPORTANT: You will need the username and password when you select the
CIFS share while deploying the Filr appliances.

2. Click Share > Done > Close.

Directories to Export 1. Continue with Chapter 5, “Downloading and Preparing the Filr Software,” on
page 25.

Windows Share as /Vashare
By default, encryption is disabled. To enable the encryption, perform the following steps:

For the steps to enable the encryption on the Windows Share, see https://learn.microsoft.com/en-
us/windows-server/storage/file-server/smb-security

Perform the following steps to enable encryption on the Filr server:
Open/etc/fstab
Change from

//server/path /vashare cifs credential s=/etc/opt/novell/base/
.snbcredential s, vers=3. 0, rw, nouni X, i ochar set =ut f 8, ui d=30, gi d=478, fi | e_node
=0777, di r _nmode=0777 0 O

To

/I server/path /vashare cifs credential s=/etc/opt/novell/base/
.snbcredential s, vers=3. 0, seal , rw, nouni x, i ochar set =ut f 8, ui d=30, gi d=478,file
_nmode=0777,dir _nmode=0777 0 0

OESCIFS Share as /Vashare

By default, encryption is disabled. To enable the encryption, perform the following steps:
On the OES server level, run the command

#novcifs --encrypt - dat a=yes
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Perform the following steps to enable encryption on the Filr server:
Openthe/etc/fstab

Change from

//server/path /vashare cifs credential s=/etc/opt/novell/base/
.snbcredential s, vers=3. 0, rw, nouni X, i ochar set =ut f 8, ui d=30, gi d=478, fi | e_node
=0777, di r _node=0777 0 O

To

/I server/path /vashare cifs credential s=/etc/opt/novell/base/
.snmbcredential s, vers=3. 0, seal , rw, nouni x, i ochar set =ut f 8, ui d=30, gi d=478, file
_node=0777, di r _mode=0777 0 O
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Downloading and Preparing the Filr
Software

After planning your deployment and making sure you have the necessary system requirements in
place, you are ready to download and prepare the Filr software that applies to your virtualization
platform.

Figure 5-1 Download the Filr Software for your VM platform

Download Filr Software

NFS v3 Server CIFS Server

Filr Search 1

v
Filr Search 2

Filr 1
]
Filr 2

Filr 3

+ “YMWare” on page 25
+ “Hyper-V” on page 26
+ “Xen” on page 26

+ “Citrix Xen” on page 27

VMWare

1 Download the Filr software shown below to the location where you plan to host your VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.
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Appliance Type Filename

Filr Filr.x86_64-version.ova
Search Fi |l rsearch. x86_64-version. ova
PostgreSQL Post greSQ.- ver si on. ova

2 Continue with “Deploying a VMware VM” on page 29.

Hyper-V

1 Log in to the Hyper-V host server either locally or from a remote workstation using Remote

Desktop.

Download the Filr software shown below to the location where you plan to host your VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.

Appliance Type Filename

Filr Filr.x86_64-version. vhdx

Search Fi |l rsearch. x86_64-versi on. vhdx
PostgreSQL Post gr eSQL- ver si on. vhdx

Move the Fi | r. x86_64- ver si on. vhdx archive file to the first Filr appliance-type folder and
then copy the archive file to the remaining Filr appliance type folders.

Move the Fi | r sear ch. x86_64- ver si on. vhdx archive file to the first Filrsearch appliance-
type folder and then copy the archive file to the second Filrsearch folder.

5 Continue with “Deploying a Hyper-V VM” on page 31.

Xen

1 Login to the Xen VM host server either locally or from a remote workstation.

If you are connecting from a remote Linux workstation, use the following command:
ssh - X root @ost i p_address

The -X in the command in required for the GUI installation program upon which the steps in this
section are based.

Download the Filr software shown below to the Xen VM host server in the location where you
plan to host your VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.
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Appliance Type Filename

Filr Filr.x86_64-version. gcow2
Search Fi | rsearch. x86_64-ver si on. gcow2
PostgreSQL Post gr eSQL- ver si on. gcow2

3 Create two hard disks - In the Appl i anceType- ver si on directory, execute the following
commands:

gemu-ing create -f raw storagel. gcow2 20G
gemu-ing create -f raw storage2.gcow2 20G
Two hard disks with names storagel and storage?2 are created with 20 GB space.

4 Copy and rename the Appl i anceType directories until you have one directory for each
appliance that you have planned to deploy.

Consider including information in the name that easily identifies the appliance, such as the IP
address. For example:

1. Renamethe Fi |l r-versi on directoryto Fil r-30-192. 168. 1. 61.

2. CopytheFilr-30-192. 168. 1. 61 directory and rename it to Fi | r - 30-
192. 168. 1. 62, and so on until you have the number of Filr appliances you have planned
for.

3. In asimilar manner, copy and rename the Fi | r sear ch- ver si on directory until you have
two Filrsearch appliances.

4. If you need a PostgreSQL appliance, follow the same methodology.

IMPORTANT: Do not change the names of the . gcow?2 or. xenconf i g files within the
directories that you have copied and renamed.

5 Continue with “Deploying a Xen VM” on page 34.

Citrix Xen

1 On a workstation with Citrix XenCenter installed, download the Filr software shown below.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.

Appliance Type Filename

Filr Filr.x86_64-version. xva

Search Fi |l rsearch. x86_64-versi on. xva
PostgreSQL Post greSQ_- ver si on. xva

2 Continue with “Deploying a Citrix Xen VM” on page 37.
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Deploying the Virtual Machines

After downloading and preparing the Filr software as instructed in Chapter 5, “Downloading and
Preparing the Filr Software,” on page 25, complete the instructions in the section for your
virtualization platform.

Figure 6-1 Deploy All VMs

Deploy All the VMs

NFS v3 Server CIFS Server

&/ /|
download.novell.com l

SQL éerver
]
Filr Search 1
J
Filr Search 2
Filr 1
3
Filr 2
Filr 3

+ “Deploying a VMware VM” on page 29
+ “Deploying a Hyper-V VM” on page 31
+ “Deploying a Xen VM” on page 34

+ “Deploying a Citrix Xen VM” on page 37

Deploying a VMware VM

Complete the steps in Table 6-1 for each appliance that you have planned:

Deploying the Virtual Machines 29



30

Table 6-1 Deploying a VMware VM

Page, Dialog, or Option

Do This

1 - Identifying the appliance.

1. Choose an appliance to deploy.
IMPORTANT: Your Filr deployment must be set up in the order specified in
Chapter 8, “Creating an Expandable Filr Deployment,” on page 47.

2. Itis recommended to deploy the PostgreSQL appliance behind the firewall.

3. The Search appliance runs Memcached service to enable clustering. To
secure Memcached, it is strongly recommended to deploy the Search
appliance behind the firewall. Port 11211 is used by the Memcached service.

For more information on securing Memcached, see Securing Memcached in
the OpenText Filr 23.4: Administrative Ul Reference.

2 - Launching the Web browser, naming the VM, and choosing the datastore.

Web Browser

1. On a Web browser, enter the URL for the VMware server and login with the
root credentials.

2. Right-click on the Virtual Machines and click Create/register VIVI.

Select creation type

Select Deploy a virtual machine from an OVF or OVA file, then click Next.

Select OVF and VMDK
files

Specify the name for the virtual machine. For example, Demo-VM. Upload the ovf
and vmdk files of Filr, and click Next.

Select Storage

Select a storage repository where the disk images for the imported VMs will be
placed. Review the datastore details, and select an appropriate disk format from
the available options.

Retain all the other default settings, and click Next.

Deployment options

Do not select Power on automatically (so that the VM can be powered on after
adding the disks), and click Next.

Ready to complete

Review the screen and click Finish to successfully deploy the Filr Appliance.

The boot disk is created and the appliance is deployed.

3 - Editing the VM settings.

Right-click the VM you just deployed and select Edit Settings.

The Virtual Machine Properties dialog displays.

Virtual Machine
Properties

Filr VMware VMs ship with Memory and CPU settings that are appliance-type
appropriate in most circumstances.

You can adjust them at this point if desired, or you can adjust them later if required
for performance tuning purposes.

If you increase or decrease server memory for a Filr or Filrsearch appliance, you
should also modify the Java heap size, as described in “Changing JVM
Configuration Settings” in the OpenText Filr 23.4: Administrative Ul Reference.

4 - Adding and configuring disk 2 (/vastorage) and disk 3 (/var)
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Page, Dialog, or Option Do This

Virtual Hardware 1. Click Add hard disk > New standard hard disk. This adds second hard disk.
2. Click Add hard disk > New standard hard disk. This adds the third hard disk.
Click Save to successfully add the hard disks.

Repeat the steps in this table until all of your planned appliances have been
deployed, then continue with Chapter 7, “Starting and Configuring the Filr
Appliances,” on page 41.

Deploying a Hyper-V VM
Complete the steps in Table 6-2 for each appliance:

Table 6-2 Deploying a Hyper-V VM

Page, Dialog, or Option Do This

1 - Identifying the appliance.

1. Choose an appliance to deploy.

IMPORTANT: Your Filr deployment must be set up in the order
specified in Chapter 8, “Creating an Expandable Filr
Deployment,” on page 47.

2. ltisrecommended to deploy the PostgreSQL appliance behind
the firewall.

3. The Search appliance runs Memcached service to enable
clustering. To secure Memcached, it is strongly recommended
to deploy the Search appliance behind the firewall. Port 11211
is used by the Memcached service.

For more information on securing Memcached, see Securing
Memcached in the OpenText Filr 23.4: Administrative Ul
Reference.

2 - Open Hyper-V Manager.

Hyper-V Host Server 1. Open the Hyper-V Manager.

3 - Create a new VM.

Hyper-V Manager 1. Inthe left pane, right-click the server where you have planned
to create the new virtual machine, then click New > Virtual
Machine.

The New Virtual Machine Wizard displays.
2. Click Next.

Specify Name and Location 1. Specify the appliance name and select the folder that you
created in “VMWare” on page 25.

2. Click Next.
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Page, Dialog, or Option

Do This

Specify Generation

1.

2.

Select Generation 1 or Generation 2. Only Generation 2
supports Hyper-V Windows Server 2022 or later.

NOTE: If error message is displayed, disable the Secure Boot
option in Settings and start the boot process.

Click Next.

4 - Specify memory

Assign Memory

1.

2.

In the Startup RAM field, specify the amount of memory (in
MB) that you have planned for this VM.

Click Next.

5 - Assign network adapter

Configure Networking

1.

2.

On the Configure Networking page, select the networking card
for this VM.

Click Next.

6 - Identify the system disk

Connect Virtual Hard Disk

1.
2.

Select Use an existing virtual hard disk.

Browse to and select the . vhd file in the folder you created
for this appliance.

3. Click Open.

Click Next.

Summary

Click Finish.

The VM is created and appears in the list of Virtual Machines.

7 - Specify processors

Hyper-V Manager

In Hyper-V Manager, right-click the VM that you just created.
Click Settings.

Processor

3.

Click Processor.

In the Number of virtual processors field, specify the number
of processors.

Click Next.

8 - Add hard disk 2 (/vastorage).

Settings for VM on Host Server

Under Hardware, select IDE Controller 1
Click Hard Drive.
Click Add.

A Hard Drive entry is added below the controller.

Hard Drive 1. Under Media, select Virtual hard disk.
2. Click New.
New Virtual Hard Disk Wizard 1. Click Next.

Deploying the Virtual Machines



Page, Dialog, or Option

Do This

Choose Disk Format

. Select VHD.
. Click Next.

Choose Disk Type

. On the Choose Disk Type page, select Fixed size
. Click Next.

Specify Name and Location

. Specify the following:

+ Name: A descriptive name for the virtual disk. For
example, Fi I r-1-Di sk- 2.

+ Location: Specify the location where you want the virtual
disk to be located.

. Click Next.

Configure Disk

. Select Create a new blank virtual hard disk.
. Size: Specify the amount for disk 2 on this appliance.

. Click Next.

Summary

. Review the summary information.

. Click Finish

9 - Add hard disk 3 (/var).

Hyper-V Manager

. In Hyper-V Manager, right-click the VM that you just created.
. Click Settings.

Settings for VM on Host Server

. Under Hardware, select SCSI Controller.

NOTE: Ensure that the SCSI controller number is unique for
every hard disk.

. Click HardDrive.
. Click Add.

A Hard Drive entry is added below the controller.

Hard Drive

. Under Media, select Virtual hard disk.
. Click New.

New Virtual Hard Disk Wizard

. Click Next.

Choose Disk Format

. Select VHD.
. Click Next.

Choose Disk Type

. On the Choose Disk Type page, select Fixed size
. Click Next.

Specify Name and Location

. Specify the following:

+ Name: A descriptive name for the virtual disk. For
example, Fi | r-1- Di sk- 3.

¢ Location: Specify the location where you want the virtual
disk to be located.

. Click Next.

Deploying the Virtual Machines

33



34

Page, Dialog, or Option

Do This

Configure Disk

Select Create a new blank virtual hard disk.
Size: Specify the amount for disk 3 on this appliance.
Click Next.

Summary

1.
2.

Review the summary information.

Click Finish > OK

10 - (Optional) Add a Network Adapter

You can add a network adapter if your Filr deployment accesses a
separate network for one or more of the following reasons:

*

*

*

Appliance administration.
NFS mount or CIFS access to the /vashare mount point.
Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with
Filr.

Hyper-V Manager 1. In Hyper-V Manager, right-click the virtual machine for which
you want to create an additional NIC, then click Settings.
Settings for VM on Host Server 1. Under Hardware, select Add Hardware.
Add Hardware 1. Click Network Adapter.
2. Click Add.
A Network Adapter entry is added to the hardware list.
Network Adapter 1. Under Virtual Switch, select the secondary network
associated with the Filr installation.
2. Specify any other required settings for the new network
adapter.
3. Click OK.
Hyper-V Manager 1. Repeat the steps in this table until all of your planned

appliances have been deployed, then continue with Chapter 7,
“Starting and Configuring the Filr Appliances,” on page 41.

Deploying a Xen VM

Complete the steps in Table 6-3 for each appliance that you planned:
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Table 6-3 Deploying a Xen VM

Page, Dialog, or Option

Do This

1 - Before you deploy the first Xen VM.

1.

If you have not already done so, before you begin this process,
you must set up shared storage for your Filr appliances by
either:

+ Exporting an NFS directory
or
¢ Creating a CIFS share

Complete the instructions in Section 4, “Setting Up Shared
Storage,” on page 21.

2 - Identifying the appliance.

1.

Choose an appliance.

IMPORTANT: Your Filr deployment must be set up in the order
specified in Chapter 8, “Creating an Expandable Filr
Deployment,” on page 47.

It is recommended to deploy the PostgreSQL appliance behind
the firewall.

The Search appliance runs Memcached service to enable
clustering. To secure Memcached, it is strongly recommended
to deploy the Search appliance behind the firewall. Port 11211
is used by the Memcached service.

For more information on securing Memcached, see Securing
Memcached in the OpenText Filr 23.4: Administrative Ul
Reference.

3 - Launch the installer.

Terminal prompt on Xen VM Host
Server

1.

Run the following command to launch the GUI configuration
menu:

vi rt - manager

NOTE: Thevm i nstal | command is deprecated from SLES
12 releases.

Create a new virtual machine

Click File > New Virtual Machine.

The Create a new virtual machine wizard is displayed.
Select Import existing disk image.

Click Forward.

Storage path and Operating System

Browse and select the existing disk image.
Select SUSE Linux Enterprise Server 12 SP4.

Click Forward.
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Page, Dialog, or Option

Do This

Choose Memory and CPU settings

1.

3.

Set the amount of memory (in MB) to match that of the VM
you are upgrading.

Specify the CPUs to match the number of the VM you are
upgrading.

Click Forward.

4 - Name the VM.

Name of Virtual Machine

1.
2.
3.

Specify the name of the appliance.
Select Customize configuration before install.

Click Finish.

5 - Configure Disk 2 (/vastorage)

Hardware 1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.
3. Navigate to the contents of the folder for the appliance you
are creating.
4. Select the . qcow?2 file (Step 3 on page 27) that you had
created.
5. Click Open > Finish.
6 - Configure Disk 3 (/var)
1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.
3. Navigate to the contents of the folder for the appliance you
are creating.
4. Select the . qcow? file (Step 3 on page 27) that you had
created.
5. Click Open > Finish.
7 - (Optional) Add a Network Adapter
You can add a network adapter if your Filr deployment accesses a
separate network for one or more of the following reasons:
¢ Appliance administration.
* NFS mount or CIFS access to the /vashare mount point.
+ Security of Memcached.
IMPORTANT: Bonding or teaming NICs is not supported with
Filr.
Summary 1. Click Network Adapters.
Network Adapters 1. Click New.
Virtual Network Adapter 1. Specify the settings for the adapter.
2. Click Apply.
Network Adapters 1. Click Apply.
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Page, Dialog, or Option

Do This

Summary

1. Click OK.

The virtual machine is created, the appliance starts, and the
configuration process begins.

2. Goto “4 - Accept the license and specify the keyboard layout.”
on page 42, then return to Table 6-3 on page 35 to deploy your
next appliance.

Deploying a Citrix Xen VM

Complete the steps in Table 6-4 for each appliance:

Table 6-4 Deploying a Citrix Xen VM

Page, Dialog, or Option Do This

1 - Identify the appliance to deploy.

1.

Choose an appliance to deploy.

IMPORTANT: Your Filr deployment must be set up in the order specified in
Chapter 8, “Creating an Expandable Filr Deployment,” on page 47.

It is recommended to deploy the PostgreSQL appliance behind the firewall.

The Search appliance runs Memcached service to enable clustering. To
secure Memcached, it is strongly recommended to deploy the Search
appliance behind the firewall. Port 11211 is used by the Memcached service.

For more information on securing Memcached, see Securing Memcached in
the OpenText Filr 23.4: Administrative Ul Reference.

2 - Launch XenCenter.

Management 1.

Workstation

Start XenCenter.

XenCenter 1.
2.

Connect to the Citrix XenServer where you have planned to deploy Filr.

Right-click the server and select Import.

3 - Import the system disk

Locate the File you want 1.

Browse to and select the . xva file on your management workstation for the

to import appliance type that you are deploying.
2. Click Open.
3. Click Next.

Select the location 1. Select the XenServer.

where the imported VM 2
will be placed

. Click Next.

Select target storage 1.

Select the storage repository for the VM.
Click Import.
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Page, Dialog, or Option Do This

4 - Select the network adapter

Select network to 1. Select the virtual network adapter.
connect VM 2. Click Next.

Review the import 1. Deselect Start VM(s) after import.
settings 2. Click Finish.

IMPORTANT: Depending on network latency and other factors, it can take a
while to import the system disk.

5 - Specify Memory

1.

2.
3.

If you need to adjust the memory, select the newly created VM in the left
pane.

Click the Memory tab.
Click Edit, change the setting, and click OK.

6 - Specify Processors

1.

2.
3.

If you need to adjust the CPUs, right-click the newly created VM in the left
pane.

Select Properties.

Click CPU, change the setting, and click OK.

7 - Add Disk 2 (/vastorage)

1. With the newly created VM selected in the left pane, click the Storage tab.
Virtual Disks 1. Click Add....
Add Virtual Disk 1. Type a disk name that reflects the appliance name and that this is disk 2. For

2.
3.

example, Filr-1-disk-2.
Specify the Size.
Click Add.

8 - Add Disk 3 (/var)

Virtual Disks 1.

Click Add....

Add Virtual Disk 1.

2.
3.

Type a disk name that reflects the appliance name and that this is disk 3. For
example, Filr-1-disk-3.

Specify the Size.
Click Add.
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Page, Dialog, or Option

Do This

9 - (Optional) Add a Network Adapter

You can add a network adapter if your Filr deployment accesses a separate
network for one or more of the following reasons:

*

*

*

Appliance administration.
NFS mount or CIFS access to the /vashare mount point.
Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with Filr.

With the newly created VM selected in the left pane, click the Networking
tab.

Select the secondary network associated with the Filr installation..

XenCenter

Repeat the steps in this table until all of your planned appliances have been
deployed, then continue with Chapter 7, “Starting and Configuring the Filr
Appliances,” on page 41.
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Starting and Configuring the Filr
Appliances

Access Manager (NAM) and Filr Integration: You can configure NetlQ Access Manager (NAM) to act
as Proxy service for a Filr site. To integrate Filr with NAM, you must configure the NetlQ Access
Manager Identity Server, the Access Gateway, and configure protected resources for a Filr server. For
more information, see Appendix A, “Access Manager (NAM) and Filr Integration,” on page 151.

After the VMs are deployed with the necessary disks added and other settings adjusted according to
your plans, it is time to start and configure the appliance software on each appliance. When this step
is completed, all of the appliances will be running and ready to be deployed as an integrated Filr
infrastructure.

Figure 7-1 Starting and Configuring the Appliances
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Table 7-1 Starting and Configuring the Appliances

Page, Dialog, or Option Do This

NOTE: For Xen, after you have completed the instructions in “Deploying a Xen
VM” on page 34, skip to “4 - Accept the license and specify the keyboard layout.”
in this table.

1 - Before you deploy the first VM.

1. If you have not already done so, before you begin this process, you must set
up shared storage for your Filr appliances by either:

¢ Exporting an NFS directory
or
¢ Creating a CIFS share

Complete the instructions in Section 4, “Setting Up Shared Storage,” on
page 21 before continuing.

2 - Select an appliance.

1. Choose one of the appliances that you deployed in Chapter 6, “Deploying the
Virtual Machines,” on page 29.

IMPORTANT: You must set up your Filr deployment in the order specified in
Chapter 8, “Creating an Expandable Filr Deployment,” on page 47.

3 - Start the appliance.

1. After you have downloaded the Filr software and configured your appliances,
you must start and configure each appliance in turn.

+ VMware: In VmWare, power on the first appliance, then click the
Console tab.

¢ Hyper-V: In Hyper-V Manager, right-click the VM and select Start.

+ Citrix Xen: In XenCenter, right-click the appliance and select Start.

4 - Accept the license and specify the keyboard layout.

1. After the appliance boots, the License Agreement screen displays.

License Agreement 1. Select your preferred keyboard layout in the Keyboard Language drop-down.

2. (Optional) use the License Language drop-down to change the license
language.

3. (Optional) use the Keyboard Language drop-down to change the keyboard
layout.

4. Accept the license agreement.
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Page, Dialog, or Option

Do This

Passwords and Time
Zone

1. On the configuration page, specify the following information:

IMPORTANT: Keep a confidential record of the passwords you set for the
root and vaadmin users below.

Root password and confirmation: The root password provides root access to
the appliance terminal prompt. Do not access appliances as the root user
unless specifically requested by Filr support personnel.

Vaadmin password and confirmation: The preferred user for accessing the
appliance as requested by Filr support personnel.

Consider using a different password for each appliance for enhanced security.

NTP Server: The IP address or DNS name of the reliable external Network
Time Protocol (NTP) server for your network.

Example: time.example.com.

For the best results, set up NTP in accordance with the VMware best
practices guidelines (http://kb.vmware.com/selfservice/microsites/
search.do?language=en_US&cmd=displayKC&externalld=1006427).

Region: Your local region.

Time Zone: The time zone of all file servers that Filr will provide access to.

. Click Next.

Network Settings

. Specify the following:

Hostname: The fully qualified DNS host name associated with the appliance’s
static IP address.

Example: myFilr.mynetwork.example.com.
IP Address: The static IP address for the appliance.
Example: 172.17.2.3.

Network Mask: The network mask associated with the appliance’s IP
address.

Example: 255.255.255.0.

Gateway: The IP address of the gateway on the subnet where your Filr virtual
appliance is located.

Example: 172.17.2.254.

IMPORTANT: Filr appliances do not tolerate latency and should be installed
in the same subnet or a near-subnet.

DNS Servers: The IP address of a primary DNS server for your network.
Example: 172.17.1.1.

Domain Search: The domain that is associated with the Filr host name.

2. Click Next.
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Page, Dialog, or Option Do This

Additional LAN Card 1. (Conditional) If you configured multiple network adapters for this appliance,
Configuration select from the following options, then click Next:

+ Do Not Configure: Select this option to configure this network at a later
time as described in “Changing Network Settings” in the OpenText Filr
23.4: Administrative Ul Reference.

+ DHCP Dynamic Address: Select this option to have an IP address
assigned dynamically on the secondary network.

+ Statically Assigned IP Address: Select this option to assign a static IP
address on the secondary network. Then specify the IP address,
network mask, and host name.

Data Store Location 1. Hard Disk 2 is automatically detected and the disk designation is displayed in
the hard drive drop-down.

Accept the defaults for the other options on this page by clicking Next.

WARNING: If you have not already created additional disks 2 and 3 for each
of your VMs, power off the virtual machine and make sure you have the
required disk space in place for your deployment before proceeding.
Otherwise, there is a substantial risk that your deployment will not meet
your organization’s needs.

Data Log Location 1. Hard Disk 3 is automatically detected and the disk designation is displayed in
the hard drive drop-down.

Accept the defaults for the other options on this page by clicking Next.

Shared Storage NFS Referring to the work you did in “Exporting an NFS Directory for the /vashare
Location Mount Point” on page 21, do the following:

1. Forthe NFS Server Hostname field, click Browse and select the NFS server
that you identified.

2. For the Remote Directory field, click Browse and select the directory that
you exported.

3. Click Configure.

4. Go to “Configuring Password, Time, and Network Settings” on page 45.

Shared Storage CIFS Referring to the work you did in “Creating a CIFS Share for the /vashare Mount
Location Point” on page 22, do the following:

1. Type the UNC path to the share that you created.

2. Type the user name of the CIFS user that you identified or created.
3. Type the password of the CIFS user.

4. Click Configure.
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Page, Dialog, or Option Do This

Configuring Password, 1. The settings you have specified are configured, storage is verified, and the
Time, and Network appliance starts.
Settings

Continue as indicated for your deployment type:

Expandable Deployment: Repeat the above steps starting with “2 - Select an
appliance.” on page 42 until all of your appliances are started, configured,
and running. Then go to Chapter 8, “Creating an Expandable Filr
Deployment,” on page 47.

All-in-one (Small) Deployment: Return to Appendix B, “All-in-One (Small)
Deployment—Creating,” on page 161.

Non-expandable Deployment: Repeat the above steps starting with “2 -
Select an appliance.” on page 42 until all of your appliances are started,
configured, and running. Then return to Appendix C, “Non-Expandable
Deployment—Creating,” on page 163.
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Creating an Expandable Filr Deployment

Figure 8-1 illustrates the general order for deploying Filr components. Letters reference brief
component/process descriptions in the table that follows.

The first process (shared storage) was completed in Chapter 4, “Setting Up Shared Storage,” on
page 21 and illustrated in Figure 4-1 on page 21.

The illustrations that follow are to help you track deployment progress.
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Figure 8-1 Creating an Expandable Deployment

4 N\
Compoment Overview

and
General Deployment Order

NFS v3 Server CIFS Server
- or -
.. el | — =
- =1
0 - W= =y
Exported Directory
for /vashare on all
Filr appliances
_ 3
F
AN N
— ﬂip Or rgz
e < N
download.novell.com
—
F
4
0 P, = Or -
saL Dat b PostgreSQL
h atabase Appliance
—
QO
4
s |
0 < Filr Search 1
Q
v
s
Filr Search 2
—
i N
[} iy
"i‘ ‘L' Dedicated to indexing and
" Net Folder Synchronization
= =
Filr 1 Filr 3
G < 1nr 1nr G
) TR
' L iy
-3 l_: l_: .
_ Filr 2 Filr 4 Filr 5
N\ y,
Letter  Details
(A Exported NFS Directory or CIFS Share: All of the Filr appliances in an expandable deployment

share this directory, which stores

+ Mutually accessed configuration files
* Personal storage
+ Temporary files used by upload and conversion processes
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Letter Details

Q Filr Software: You download Filr software that you then deploy as a boot/system disk on your VM
host server.

(C) SQL Database: Each Filr appliance in an expandable deployment accesses the same SQL database.
If available, an SQL server should be used, but if that is not an option, the PostgreSQL appliance can
be deployed in its place.

Filrsearch Appliances: OpenText best practices require that each Filr cluster be configured with
two Filrsearch appliances.

Filr Appliances: By definition, a Filr cluster must contain at least two Filr appliances. OpenText
recommends three Filr appliances with the third appliance dedicated to Net Folder synchronization
and maintaining the search index.

(F ) Additional Filr Appliances: More Filr appliances can be included as the service load increases.

To create an expandable Filr deployment, complete the following sections in the order presented.

+ “Setting Up the SQL Database” on page 49

+ “Setting Up Two Filr Search Appliances” on page 53

+ “Setting Up the Filr Appliances” on page 54

+ “Completing the Expandable Filr Deployment” on page 60

+ “Dedicating a Filr Appliance to Indexing and Net Folder Synchronization” on page 63

+ “Using the Dedicated Filr Appliance to Complete the Indexing Setup” on page 64

Setting Up the SQL Database

Figure 8-3 illustrates that an SQL database is the second component deployed (after shared storage)

when creating an expandable Filr deployment.

Creating an Expandable Filr Deployment

49



50

Figure 8-2 Set Up an SQL Database
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IMPORTANT: OpenText recommends using an existing SQL database if one is available.

Prepare your in-house SQL server by completing the steps in one of the following sections:

+ “Configuring a PostgreSQL Appliance” on page 50
¢ “Configuring a MySQL or MariaDB Server” on page 51
+ “Configuring a Microsoft SQL Server” on page 52

Configuring a PostgreSQL Appliance

+ “Deploying a PostgreSQL Appliance” on page 50
+ “Creating User Roles for Accessing PostgreSQL Appliance” on page 51

+ “Creating Database for Connecting to Filr” on page 51

Deploying a PostgreSQL Appliance

1 Deploy the PostgreSQL Appliance similar to the Filr Appliance. The binary is available on the
sld.microfocus.com location.

2 Specify <post gresql appl i ance_I P or host nane>: 9443 to access the PostgreSQL
Appliance as the vaadmin user.
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3 Under PostgreSQL Appliance Tools, click Configure PostgreSQL.
4 Specify a password for the “post gr es” user, then click OK.

Creating User Roles for Accessing PostgreSQL Appliance

This user is used when connecting Filr to PostgreSQL in 9443 console.

1 Under PostgreSQL Appliance Tools, click phpPgAdmin.

2 Click PostgreSQL, then specify the Username as “post gr es” and password that you specified in
Step 4 on page 51.

3 Click Roles > Create role.

4 Specify all the required details to create a user. Ensure to select the options: Create DB? and Can
login? and click Create.

Creating Database for Connecting to Filr

This database is used to connect to Filr.

1 Click Databases > Create database.
2 The Name should be same as the user you created in Step 4 on page 51.
3 In the Template field, select template0, then continue with defaults and click Create.

4 (Optional) Create one more database, if you want to connect to Filr with a database with a
different name than the user.

Configuring a MySQL or MariaDB Server

This section describes configuring MySQL or MariaDB server by using the Filr configuration wizard. It
is recommended not to manually create the Filr database on your MySQL or MariaDB server.

The MySQL database mentioned in this section is an existing database and not a Filr default
database. From Filr 4, the default database is PostgreSQL.

Table 8-1 Configuring MySQL or MariaDB for Filr

File Do This

1 - Edit the configuration file.

Creating an Expandable Filr Deployment 51



52

File Do This

MySQL or MariaDB 1. Edit the file as follows:
server >/ et ¢/ my. cnf )
file [client]

defaul t-character-set = utf8

[ nysql d]

character-set-server = utf8
max_connecti ons = 900
transaction-isolati on = READ- COW TTED
expi re_|l ogs_days = 7

The expi re_| ogs_days setting is optional, but is recommended because
it cleans up mysql - bi n-* files.
Unless this is done regularly, the files will consume significant disk space in
the vast or age directory.

2. Uncomment the InnoDB tables section.

3. Increase the buffer pool size to approximately 60 percent of the amount of
RAM that has been allocated to the dedicated server.

For example, a dedicated server with 4 GB of RAM should have a buffer pool
size of 2560 MB, as follows:

i nnodb_buf f er _pool _size = 2560M

4. Identify or create a user account with sufficient rights to create and manage
the Filr database.

Continue with “Setting Up Two Filr Search Appliances” on page 53.

Configuring a Microsoft SQL Server

IMPORTANT: Do not create the Filr database on your MS SQL server manually.

Let the Filr configuration wizard create the database to ensure the correct configuration.

Table 8-2 Configuring Microsoft SQL Server for Filr

File Do This

1 - Configure the server.

Server management 1. Enable remote access to the Microsoft SQL database server.

console 2. Open port 1433 on the Windows firewall where the database server is

running.

3. Identify or create a user account that is configured with SQL Server
Authentication and has sufficient rights to create and manage the Filr
database.

IMPORTANT: Filr supports only SQL Server Authentication. Windows
Authentication and Windows Domain User Authentication to Microsoft SQL
are not supported.
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File Do This

Server management 1. Run the following queries against the database:

console
ALTER DATABASE dat abase- nane SET READ _COWM TTED_ SNAPSHOT

ON
ALTER DATABASE dat abase- nane COLLATE
Latinl General Cl_AS KS W5

2. Continue with “Setting Up Two Filr Search Appliances” on page 53.

Setting Up Two Filr Search Appliances

Filr best practices require that every expandable deployment have two Filrsearch appliances. There
are no advantages to having more than two.

Best practices allow for operating Filr with one search appliance, but only under special
circumstances, such as when reindexing is required. One appliance continues to service user
requests while the other is focused on rebuilding the search index.

Figure 8-3 shows that two Filr Search appliances are the third and fourth components deployed in an
expandable deployment.

Figure 8-3 Set up Two Filr Search Appliances
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Table 8-3 Setting Up the Filrsearch Appliances

Page, Dialog, or Option

Do This

1.

Open a management browser on your administrative workstation and access
the Port 9443 Administration Utility on the first Filrsearch appliance using
the following URL:

https://filrsearch_I P_Address: 9443

Where IP_Address is the IP address of the first Filrsearch appliance.

Filr Search Appliance
Sign In

Log in as the vaadmi n user with the password that you set for the appliance
in “Vaadmin password and confirmation:” on page 43.

Filr Search Tools

.+
Click the Configuration button o to launch the Filr Search Configuration
Wizard.

Filr Search Configuration
Wizard

=

Click Next.

Type and confirm a password for the Lucene Service User (use the same
password for both appliances).

Make a note of the password for later.
Click Finish.

Search Settings

. Scroll down and click Submit > OK.

Repeat the steps in this table for the second Filrsearch appliance, then close
the browser.

Continue with “Setting Up the Filr Appliances” on page 54

Setting Up the Filr Appliances

Figure 8-4 illustrates that the Filr appliances are deployed after all other components are in place.
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Figure 8-4 The Filr Appliances Are Set Up Last
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Table 8-4 Logging in and Starting the Configuration Wizard

Page, Dialog, or Option Do This

1. Open a management browser on your administrative workstation and access
the Port 9443 Administration Utility on the first Filr appliance using the
following URL:

https://filr_I P_Address: 9443

Where IP_Address is the IP address of the first Filr appliance.

Filr Appliance Sign In 1. Login asthe vaadni n user with the password that you set for the appliance
in “Vaadmin password and confirmation:” on page 43.

Filr Appliance Tools o
1. Click the Configuration icon # | to launch the Filr Configuration Wizard.

Filr Configuration Wizard 1. Large Deployment is automatically selected.

Click Next.

Creating an Expandable Filr Deployment
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Figure 8-5 Each Filr Appliance Needs the Database Connection Information
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Table 8-5 Configuring each Filr to connect to the SQL Database

Page, Dialog, or Option Do This

Database 1. Specify the following configuration options for the database:

Database Type: Select the type of database that you prepared in “Setting Up
the SQL Database” on page 49.

Host Name: The host name or IP address of the database server.

Port: The wizard selects the standard port for the database type. If your
server communicates using a non-standard port, adjust the number
accordingly

Database Name: The name of the database you want the wizard to create
(first appliance) and then connect to (subsequent appliances).

User Name: The administrative user name you identified in “Setting Up the
SQL Database” on page 49.

Password: The administrative user’s password.

2. Click Next.
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Figure 8-6 Initially, Each Filr Appliance Is Configured to Work with One Filr Search Appliance
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Table 8-6 Specify the First Search Appliance, Locale, and Admin user

Page, Dialog, or Option

Do This

Search Appliance

1.

Specify the first Filrsearch appliance’s DNS name and Lucene password, then
click Finish.

IMPORTANT: If you specify the IP address, it must be resolvable to the DNS
hostname of the search appliance.

Click Next.

Default Locale

Select a Default Locale.

If desired, specify a name other than adm n for appliance administration on
port 8443.

. Click Finish.

IMPORTANT: Wait for the appliance to start before closing the tab or
navigating away from the page.

When the “Congratulations!” message displays, return to Table 8-4 and
deploy the next Filr appliance.

. After all of the Filr appliances are deployed, continue with “Completing the

Expandable Filr Deployment.”

Creating an Expandable Filr Deployment
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Completing the Expandable Filr Deployment

Figure 8-7 When One Filr Appliance Is Configured for “Filr Clustering,” All of Them Are

Enabling Filr-based Clustering
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Table 8-7 Enabling Filr-based Clustering

Page, Dialog, or Option Do This
Configuration Summary 1. Inthe Configuration panel, click Clustering.
Clustering 1. Select Enable Clustered Environment.

2. The JVM Route field is used only if you are setting up Apache load balancing,
and is used to uniquely identify this appliance. In many cases, the hostname
(automatically supplied) will suffice, but you can customize it if needed.

3. Inthe Server Address field, make sure that both Filrsearch appliances in your
deployment are listed. Separate the appliances with a space. Use either IP
addresses or fully-qualified hostnames to identify the appliances.

4. Click OK.

5. Click Reconfigure Filr Server.

The Filr appliance is reconfigured and restarted.

Subsequently, the configuration is shared by each Filr appliance through the
/ vashar e mount point.
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Figure 8-8 The Filr Appliances Are Individually Configured to Use Both Filrsearch Appliances
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Table 8-8 Configuring High-availability Searching

Page, Dialog, or Option

Do This

Configuration Summary

1. Inthe Configuration panel, click Search Appliance.

Search Appliance

1. Click the Configuration Type drop-down list and select High Availability.
2. Type the Lucene service password that you set in Table 8-3 on page 54.

3. Notice that the Filrsearch appliance you configured for this Filr appliance is
listed under Name.

Click Add.

New Search Node

1. Inthe Name: field, type an arbitrary name for the second appliance.

2. Inthe Host Name: field, type the DNS host name of the other Filrsearch
appliance.

3. Click OK.

Search Appliance

1. Click OK.

62 Creating an Expandable Filr Deployment



Page, Dialog, or Option Do This

Configuration 1. Click Reconfigure Filr Server.

The appliance is reconfigured and restarted.

However, in contrast with the process in Table 8-7, the Search Appliance
configuration is not propagated to the other Filr appliances.

2. In the upper-right corner, click Log out.

1. Log in to the next Filr appliance and repeat the steps in this table.

2. When all of the Filr appliances have been configured for high-availability
searching, continue with Dedicating a Filr Appliance to Indexing and Net
Folder Synchronization.

Dedicating a Filr Appliance to Indexing and Net Folder
Synchronization

As a best practice, OpenText recommends dedicating one Filr appliance to Indexing and Net Folder
Synchronization, which are very resource-intensive tasks.

Do the following:

+ Allow Net Folder Synchronization on only the dedicated appliance: Disable Net Folder
Synchronization on all other Filr appliances as follows:

1.
2. Click Net Folders.
3.
4

. Repeat on all other Filr appliances except the one you are dedicating to Net Folder

Access the Port 9443 administration console.

De-select Allow Synchronization.

Synchronization.

Now when a Full synchronization occurs (either as a result of a scheduled or manual
synchronization), the Filr appliance that you set aside is the one that handles the load.

NOTE: Just-in-time synchronization (JITS) is unaffected and takes place on whichever Filr
appliance receives the user request that triggers JITS.

+ Use Load Balancing to isolate the dedicated appliance from user requests: When you set up
load balancing, don’t include the dedicated Filr appliance in the round-robin rotation.

+ Rebuild the search index using the dedicated appliance: Follow the steps in the next section.

Thereafter, the dedicated appliance will handle all of the re-indexing workload.
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Using the Dedicated Filr Appliance to Complete the
Indexing Setup

Table 8-9 Index with the Dedicated Appliance

Page, Dialog, or Option Do This

1. Open a management browser on your administrative workstation and access
the Port 8443 Administration Utility on the Dedicated Filr Appliance using the
following URL:

https://dedicated filr_|P_Address: 8443

Where IP_Address is the IP address of the dedicated Filr appliance.

Filr Sign In Dialog 1. Login as user adm n with password adni n, or with the alternate
administrator name/password if you specified one for this appliance in Table
8-6 on page 59.

2. When prompted, change the user password.

Product Improvement 1. Click OK.
(first login only)

Filr Main Window (Web 1. Click the Admin user name in the upper-right corner.

access) 2. Select Administration Console.

Administration Console 1. Click Index in the left frame.
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Page, Dialog, or Option

Do This

Search Index

IMPORTANT: If you have users across multiple zones, ensure to perform
reindexing on every zone.

1. Take the first search index node out of service to rebuild it while the other is
still running. Set this node as “Write Only”.
For information about how to take a node out of service, see Maintaining
Your High Availability Lucene Index in the OpenText Filr 23.4: Maintenance
Best Practices Guide.
2. Select Re-Index Everything in the Search Index section of the Administration
Console.
3. After the first search index node is rebuilt, put it back into service. Set the
node as “Read and Write”.
For information about how to take a node out of service, see Maintaining
Your High Availability Lucene Index in the OpenText Filr 23.4: Maintenance
Best Practices Guide.
4. Repeat Step 1 to Step 3 for any additional search index node.
To view when indexing is complete, keep the Search Index dialog box open to
see the status. Alternatively, a message is displayed in either of the
appserver.log files stating that reindexing is complete.
5. To ensure that the rebuild was successful, verify that the following messages
appear in the appserver.log file:
Conpl eted i ndexing of tree with xxx binders. Time taken
for indexing is xxx.xxx msAdmi nistrative reindexing
conpl eted on binders [1]
For information about how to access the appserver.log file, see Accessing Filr
System Log Files in the OpenText Filr 23.4: Administrative Ul Reference.
Indexing has finished! 1. Click Close.
Administration Console 1. Click Nodes in the left frame.
Search Nodes 1. Change the User Mode Access option for the second Filrsearch appliance to
Read and Write.
2. Click Apply > Close.

The dedicated Filr appliance will now handle all of the re-indexing workload.
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Content Editor

The Content Editor (CE) Appliance enables collaborative editing for Filr users. The functionalities are:

*

*

Available with Filr Advanced Edition.
Available with the Filr Web Ul, desktop clients and mobile.
Multiple files (around 100 files) can be concurrently edited by multiple users.

Supports collaborative edits for all major file types such as Microsoft and LibreOffice.
documents, spreadsheet, and and similar formats.

Files are edited online and no native application is required to edit the files. There is no need to

move or download the files.
Policies to block copy, print, and download of the content.

Available for all files under My Files, Shared With Me, Shared By Me, and Net Folder areas.

A separate appliance is required as collaborative editing is a resource intensive task.

*

*

*

*

“Content Editor Requirements” on page 67

“Downloading and Installing Content Editor” on page 69

“Starting and Configuring the Content Editor Appliance” on page 77
“Configuring Content Editor Options in Filr Appliance” on page 80

“Content Editor With NetlQ Access Manager For Online Edit Feature” on page 81
“Load Balancing” on page 87

“Upgrading from Content Editor 1.2.3 to 2.0” on page 89

Content Editor Requirements

*

*

*

“System Requirements” on page 67
“Other Requirements” on page 68

“Virtualization Hypervisor Platform Support” on page 68

System Requirements

+ CPU: 4

*

*

RAM: 16 GB

IP address details for the appliance:
¢ Static IP address
+ Network mask

+ Gateway IP address

Content Editor
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+ Host name associated with the IP address

+ |P address of a DNS server

*

NTP server - IP address or host name

+ Primary Hard Disk: 20 GB

*

*

Hard Disk 1: 20 GB (minimum)
Hard Disk 2: 20 GB (minimum)

Other Requirements

+ Avalid CA certificate is required on the Content Editor Appliance and Filr Appliance for this
feature to work with all the Filr clients.

Virtualization Hypervisor Platform Support

Table 9-1 Virtualization Hypervisor Platform

Hypervisor Type Supported Versions

VMware

*

*

One of the following VMware host servers for hosting the appliance VMs.

* ESXi7.0

+ ESXi 6.7 with the latest update
For the most up-to-date compatibility matrix of supported VMware host servers, see
the VMware Compatibility Guide (http://www.vmware.com/resources/

compatibility/search.php?deviceCategory=software&testConfig=16) provided by
VMware.

VMware vMotion is supported when running Content Editor on VMware ESXi

Hyper-V

*

*

The following platforms
* Windows Server 2016
+ Windows Server 2012 R2

Hyper-V Manager to deploy, set up, and configure the appliances.

Xen

IMPORTANT: Apply all Xen and kernel patches before installing.

*

The server with the Xen packages installed and the Xen bootloader running by
default.

+ SLES155P4

Virtual Machine Manager to deploy, set up, and configure the appliances.

Citrix Xen

Citrix XenServer 7.6
Citrix XenServer 7.0

Citrix XenCenter to deploy, set up, and configure the appliances.
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Downloading and Installing Content Editor

+ “YMWare” on page 69
+ “Hyper-V” on page 70

+ “Xen” on page 73

+ “Citrix Xen” on page 75

VMWare

After making sure you have the necessary system requirements in place, you are ready to download
and prepare the CE software that applies to your virtualization platform.

Web Browser

Select creation type

Select OVF and VMDK files

Select Storage

Deployment options

Ready to complete

Virtual Machine Properties

1 - Downloading Content Editor Software

1. Download the Content Editor software
(Cont ent Edi t or. x86_64. 2022- 09- 13. 53. ova.zip) from the
Micro Focus Customer Center or from the trial download page. The key
and zip files will be available under the Filr 23.4 Advanced Edition.

2. Extract the . ova. zi p file on your management workstation.
2 - Launching the Web browser, naming the VM, and choosing the datastore.

1. On a Web browser, enter the URL for the VMware server and login with
the root credentials.

2. Right-click on the Virtual Machines and click Create/register VIV,
Select Deploy a virtual machine from an OVF or OVA file, then click Next.

Specify the name for the virtual machine. For example, Demo-VM. Upload the
ovf and vmdk files of Content Editor, and click Next.

Select a storage repository where the disk images for the imported VMs will be
placed. Review the datastore details, and select an appropriate disk format
from the available options.

Retain all the other default settings, and click Next.

Do not select Power on automatically (so that the VM can be powered on after
adding the disks), and click Next.

Review the screen and click Finish to successfully deploy the Content Editor
Appliance.

The boot disk is created and the appliance is deployed.

3 - Editing the VM settings.

Right-click the VM you just deployed and select Edit Settings.
The Virtual Machine Properties dialog displays.

Content Editor VMware VMs ship with Memory and CPU settings that are
appliance-type appropriate in most circumstances.

You can adjust them at this point if desired, or you can adjust them later if
required for performance tuning purposes.
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4 - Adding and configuring disk 2 (/vastorage) and disk 3 (/var)

Virtual Hardware 1. Click Add hard disk > New standard hard disk. This adds second hard disk.

2. Click Add hard disk > New standard hard disk. This adds the third hard
disk.

Click Save to successfully add the hard disks.

On successful deploying the appliance, continue with “Starting and Configuring
the Content Editor Appliance” on page 77.

Hyper-V

After making sure you have the necessary system requirements in place, you are ready to download
and prepare the CE software that applies to your virtualization platform.

Page, Dialog, or Option Do This

1 - Downloading Content Editor Software.

Hyper-V Host Server 1. Download the Content Editor software
(Content Edi t or. x86_64- 1. 0. 0. 40. vhdx. zi p) from
the Micro Focus Customer Center or from the trial download
page. The key and zip files will be available under the Filr 23.4
Advanced Edition.

2. Extract*. vhdx. zi p file on your management workstation.
2 - Create a new VM.
Hyper-V Manager 1. Log in to the Hyper-V host server either locally or from a
remote workstation using Remote Desktop.

2. Inthe left pane, right-click the server where you have planned
to create the new virtual machine, then click New > Virtual
Machine.

The New Virtual Machine Wizard displays.

3. Click Next.

Specify Name and Location 1. Specify the appliance name.
2. Click Next.

Specify Generation 1. Ensure that Generation 1 is selected.
2. Click Next.

3 - Specify memory

Assign Memory 1. Inthe Startup RAM field, specify the amount of memory (in
MB) that you have planned for this VM.

2. Click Next.
5 - Assign network adapter

Configure Networking 1. Onthe Configure Networking page, select the networking card
for this VM.

2. Click Next.
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Page, Dialog, or Option

Do This

Connect Virtual Hard Disk

Summary

Hyper-V Manager

Processor

Settings for VM on Host Server

Hard Drive

New Virtual Hard Disk Wizard

Choose Disk Format

Choose Disk Type

Specify Name and Location

Configure Disk

6 - Identify the system disk

1.
2.

Select Use an existing virtual hard disk.

Browse to and select the Cont ent Edi t or . x86_64-
1. 0. 0. *. vhdx file of this appliance.

Click Open.
Click Next.

Click Finish.

The VM is created and appears in the list of Virtual Machines.

7 - Specify processors

3.

In Hyper-V Manager, right-click the VM that you just created.
Click Settings.

Click Processor.

In the Number of virtual processors field, specify the number
of processors.

Click Next.

8 - Add hard disk 2 (/vastorage).

Under Hardware, select IDE Controller *.
Click Hard Drive.
Click Add.

A Hard Drive entry is added below the controller.

Under Media, select Virtual hard disk.
Click New.

Click Next.

Select VHDX.
Click Next.

On the Choose Disk Type page, select Fixed size.
Click Next.

. Specify the following:

* Name: A descriptive name for the virtual disk. For
example, CE- Di sk- 2.

¢ Location: Specify the location where you want the virtual
disk to be located.

. Click Next.

Select Create a new blank virtual hard disk.
Size: Specify the size for Disk 2 on this appliance.
Click Next.
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Page, Dialog, or Option

Do This

Summary

Hyper-V Manager

Settings for VM on Host Server

Hard Drive

New Virtual Hard Disk Wizard

Choose Disk Format

Choose Disk Type

Specify Name and Location

Configure Disk

Summary

1.
2.

Review the summary information.
Click Finish

9 - Add hard disk 3 (/var).

1.
2.

1.

In Hyper-V Manager, right-click the VM that you just created.
Click Settings.

Under Hardware, select IDE Controller * or SCSI Controller.
NOTE: Ensure that the SCSI controller number is unique for
every hard disk.

Click HardDrive.

Click Add.

A Hard Drive entry is added below the controller.

Under Media, select Virtual hard disk.
Click New.

Click Next.

Select VHDX.
Click Next.

On the Choose Disk Type page, select Fixed size
Click Next.

Specify the following:

+ Name: A descriptive name for the virtual disk. For
example, CE- Di sk- 3.

¢ Location: Specify the location where you want the virtual
disk to be located.

Click Next.

Select Create a new blank virtual hard disk.
Size: Specify the amount for disk 3 on this appliance.

Click Next.

Review the summary information.

Click Finish > OK
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Page, Dialog, or Option

Do This

Hyper-V Manager

Settings for VM on Host Server

Add Hardware

Network Adapter

10 - (Optional) Add a Network Adapter

You can add a network adapter if your Content Editor deployment
accesses a separate network for one or more of the following
reasons:

*

*

3.

Appliance administration.

NFS mount or CIFS access to the /vashare mount point.
Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with
Content Editor.

In Hyper-V Manager, right-click the virtual machine for which
you want to create an additional NIC, then click Settings.

. Under Hardware, select Add Hardware.

Click Network Adapter.
Click Add.
A Network Adapter entry is added to the hardware list.

Under Virtual Switch, select the secondary network
associated with the Content Editor installation.

. Specify any other required settings for the new network

adapter.
Click OK.

On successful deploying the appliance, continue with “Starting and
Configuring the Content Editor Appliance” on page 77.

Xen

After making sure you have the necessary system requirements in place, you are ready to download
and prepare the CE software that applies to your virtualization platform.

Page, Dialog, or Option

Do This

1 - Downloading the Content Editor Software

1.

Download the Content Editor software

(Cont ent Edi t or . x86_64- 1. 0. 0. 40. xen. zi p) from
the Micro Focus Customer Center or from the trial download
page. The key and zip files will be available under the Filr 23.4
Advanced Edition.

Extract. xen. zi p file in the directory where you downloaded
it.

3 - Launch the installer.
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Page, Dialog, or Option

Do This

Terminal prompt on Xen VM Host
Server

Create a new virtual machine

Storage path and Operating System

Choose Memory and CPU settings

Name of Virtual Machine

Hardware

1.

3.

Run the following command to launch the GUI configuration
menu:

Vi rt - manager

NOTE: Thevm i nstal | command is deprecated from SLES
12 releases.

Click File > New Virtual Machine.

The Create a new virtual machine wizard is displayed.
Select Import existing disk image.

Click Forward.

Browse and select the existing disk image.
Select SUSE Linux Enterprise Server 12 SP4.

Click Forward.

Set the amount of memory (in MB) to match that of the VM
you are upgrading.

. Specify the CPUs to match the number of the VM you are

upgrading.

Click Forward.

4 - Name the VM.

1.
2.
3.

Specify the name of the appliance.
Select Customize configuration before install.

Click Finish.

5 - Configure Disk 2 (/vastorage)

1.
2.
3.

Click Add Hardware at the bottom left of the screen.
Select the option Select or create custom storage.

Navigate to the contents of the folder for the appliance you
are creating.

Select the . gcow? file.

5. Click Open > Finish.

6 - Configure Disk 3 (/var)

Click Add Hardware at the bottom left of the screen.
Select the option Select or create custom storage.

Navigate to the contents of the folder for the appliance you
are creating.

Select the . qcow? file.

5. Click Open > Finish.
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Page, Dialog, or Option

Do This

Summary
Network Adapters

Virtual Network Adapter

Network Adapters

Summary

7 - (Optional) Add a Network Adapter

You can add a network adapter if your Content Editor deployment
accesses a separate network for one or more of the following
reasons:

*
*

*

2.

1.

Appliance administration.
NFS mount or CIFS access to the /vashare mount point.
Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with
Content Editor.

Click Network Adapters.
Click New.

Specify the settings for the adapter.
Click Apply.

Click Apply.

On successful deploying the appliance, continue with “Starting and
Configuring the Content Editor Appliance” on page 77.

Citrix Xen

After making sure you have the necessary system requirements in place, you are ready to download

and prepare the CE software that applies to your virtualization platform.

Page, Dialog, or Option

Do This

Management
Workstation

XenCenter

1 - Identify the appliance to deploy.

1. On a workstation with Citrix XenCenter installed, download the Content
Editor software ( Cont ent Edi t or . x86_64- 0. 0. 40. xva. zi p) from the
Micro Focus Customer Center. The key and zip files will be available under
the Filr 23.4 Advanced Edition.

2. Extract. xva. zi p file in the directory where you downloaded it.

2 - Launch XenCenter.

1. Start XenCenter.

1. Connect to the Citrix XenServer where you have planned to deploy Content

Editor.

2. Right-click the server and select Import.

3 - Import the system disk
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Page, Dialog, or Option Do This

Locate the File you want 1.

to import
2.
3.
Select the location 1.
where the imported VM 2
will be placed '
Select target storage 1.
2.

Browse to and select the . Xva file on your management workstation for the
appliance type that you are deploying.

Click Open.
Click Next.

Select the XenServer.

Click Next.

Select the storage repository for the VM.
Click Import.

4 - Select the network adapter

Select network to 1.
connect VM 2
Review the import 1.
settings 2

Select the virtual network adapter.

. Click Next.

Deselect Start VM(s) after import.

. Click Finish.

IMPORTANT: Depending on network latency and other factors, it can take a
while to import the system disk.

5 - Specify Memory

1.

2.
3.

If you need to adjust the memory, select the newly created VM in the left
pane.

Click the Memory tab.
Click Edit, change the setting, and click OK.

6 - Specify Processors

1.

2.
3.

If you need to adjust the CPUs, right-click the newly created VM in the left
pane.

Select Properties.

Click CPU, change the setting, and click OK.

7 - Add Disk 2 (/vastorage)

1.
Virtual Disks 1.
Add Virtual Disk 1.
2.
3.

With the newly created VM selected in the left pane, click the Storage tab.
Click Add....

Type a disk name that reflects the appliance name and that this is disk 2. For
example, CE-1-disk-2.

Specify the Size.

Click Add.

8 - Add Disk 3 (/var)

Virtual Disks 1.

Click Add....
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Page, Dialog, or Option Do This

Add Virtual Disk 1. Type a disk name that reflects the appliance name and that this is disk 3. For
example, CE-1-disk-3.

2. Specify the Size.
3. Click Add.

9 - (Optional) Add a Network Adapter

You can add a network adapter if your Content Editor deployment accesses a
separate network for one or more of the following reasons:

+ Appliance administration.

+ NFS mount or CIFS access to the /vashare mount point.

+ Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with Content Editor.

1. With the newly created VM selected in the left pane, click the Networking
tab.

2. Select the secondary network associated with the Content Editor installation.

XenCenter On successful deploying the appliance, continue with “Starting and Configuring
the Content Editor Appliance” on page 77.

Starting and Configuring the Content Editor Appliance

Table 9-2 Starting and Configuring the Appliances

Page, Dialog, or Option Do This

1 - Start the appliance.

1. After you have configured your appliance, you must start and configure each
appliance in turn.

+ VMware: In VmWare, power on the first appliance, then click the
Console tab.

¢ Hyper-V: In Hyper-V Manager, right-click the VM and select Start.

+ Citrix Xen: In XenCenter, right-click the appliance and select Start.
2 - Accept the license and specify the keyboard layout.

1. After the appliance boots, the License Agreement screen displays.

License Agreement 1. Select your preferred keyboard layout in the Keyboard Language drop-down.

2. (Optional) use the License Language drop-down to change the license
language.

3. (Optional) use the Keyboard Language drop-down to change the keyboard
layout.

4. Accept the license agreement.

3 - Setting Password and Network Details
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Page, Dialog, or Option

Do This

Passwords and Time
Zone

Network Settings

1. On the configuration page, specify the following information:

IMPORTANT: Keep a confidential record of the passwords you set for the
root and vaadmin users below.

Root password and confirmation: The root password provides root access to
the appliance terminal prompt. Do not access appliances as the root user
unless specifically requested by Filr support personnel.

Vaadmin password and confirmation: The preferred user for accessing the
appliance as requested by Filr support personnel.

Consider using a different password for each appliance for enhanced security.

NTP Server: The IP address or DNS name of the reliable external Network
Time Protocol (NTP) server for your network.

Example: time.example.com.

For the best results, set up NTP in accordance with the VMware best
practices guidelines (http://kb.vmware.com/selfservice/microsites/
search.do?language=en_US&cmd=displayKC&externalld=1006427).

Region: Your local region.

Time Zone: The time zone of all file servers that Filr will provide access to.

. Click Next.

. Specify the following:

Hostname: The fully qualified DNS host name associated with the appliance’s
static IP address.

Example: myFilr.mynetwork.example.com.
IP Address: The static IP address for the appliance.
Example: 172.17.2.3.

Network Mask: The network mask associated with the appliance’s IP
address.

Example: 255.255.255.0.

Gateway: The IP address of the gateway on the subnet where your Filr virtual
appliance is located.

Example: 172.17.2.254.

IMPORTANT: Content Editor appliance does not tolerate latency and should
be installed in the same subnet or a near-subnet.

DNS Servers: The IP address of a primary DNS server for your network.
Example: 172.17.1.1.

Domain Search: The domain that is associated with the Filr host name.

2. Click Next.

Content Editor


http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006427
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006427

Page, Dialog, or Option

Do This

Data Store Location

Data Store Location

Configuring Password,
Time, and Network
Settings

1.

Hard Disk 2 is automatically detected and the disk designation is displayed in
the hard drive drop-down.

Accept the defaults for the other options on this page by clicking Next.

WARNING: If you have not already created additional disks 2 and 3 for each
of your VMs, power off the virtual machine and make sure you have the
required disk space in place for your deployment before proceeding.
Otherwise, there is a substantial risk that your deployment will not meet
your organization’s needs.

Hard Disk 3 is automatically detected and the disk designation is displayed in
the hard drive drop-down.

Accept the defaults for the other options on this page by clicking Next.

The settings you have specified are configured, storage is verified, and the
appliance starts.

Configuring Content Editor Appliance

Specify the vaadmin or root user password to manage virtual-machine-level settings and Content

Editor service configuration.

Path: https://content_editor_appliance_ip_or_dns:9443

After installing a Content Editor appliance, configure it with the DNS hostnames of each Filr
appliance that you want to be able to connect to it.

Configuration

Path: Port 9443 Appliance Console > Content Editor Appliance Tools > Configuration icon
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Table 9-3 Allowed Hosts Dialog

Field, Option, or Button Information and/or Action

Allowed Hosts 1. To allow Filr appliances to access the appliance’s editing services, type their
DNS hostnames, one per line.

2. Click Submit.

The hosts you enter are listed in the left panel.
Submit button Click this to add the typed DNS hostnames to the list of allowed hosts.

Cancel button Click this to cancel any changes and return to the Home panel.

Configuring Content Editor Options in Filr Appliance

Path: Port 8443 Filr Administration Console > System > Content Editor
Before you configure the Content Editor options, you must do the following:

+ Deploy a Content Editor appliance.

+ Configure the Content Editor appliance with the DNS hostnames of each Filr appliance that you
want to be able to connect to it.

Table 9-4 Using the Content Editor Configuration dialog

Field, Option, or Button Information and/or Action

Enable Content Editor 1. Select this to enable collaborative editing for Filr users.

2. Specify the configuration information for the following fields.

+ Server URL + The access URL (IP address or DNS hostnames of the Content
Editor appliance.

+ Test connection + Click this to test the connection between Filr and the Content
Editor appliance.

Content Editor Policies: + Set the policies that will be applicable to the user when
performing collaborative edit.

¢ When a user is editing the file and if changes are made to the
policy, then the file has to be reloaded for the changes to take

effect.

+ Disable copy + Content from the document cannot be copied to any other
document.

+ Disable print and download + The file getting edited cannot be printed or downloaded to your

local workstation.
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Field, Option, or Button Information and/or Action

+ Disable Watermark + By default, this option is enabled.

When this option is enabled, watermark is displayed across the
document. Email id or name of the user is displayed as
watermark. The watermark is also displayed on printing the
document.

NOTE: This option is available with CE 1.0.1 version onwards.

Now the Collaborative Editing functionality is ready to use on all Filr Clients and Web Ul.

Content Editor With NetlQ Access Manager For Online Edit
Feature

+ “Configuring NetlQ Access Manager With Content Editor” on page 81
+ “Allowing Filr to Connect to Content Editor” on page 86
+ “Allowing Content Editor to Connect to the Filr” on page 87

¢ “Using the Online Edit Feature” on page 87

You can configure NetlQ Access Manager (NAM) to act as Reverse Proxy service for CE site when
using the Online-Edit option. This helps you provide the ease of single sign-on and establish a trusted
relationship with the Access Gateway. Using CE in conjunction with NetlQ Access Manager adds
enterprise-level security to your Filr system.

When a user performs Online Edit on a file, the Online Edit session (Filr) communicates to CE Via
NAM.

Configuring NetlQ Access Manager With Content Editor

1 Login to the NAM Administration Console.
2 Click Devices > Access Gateways > AG-Cluster.
2a Under Content Settings, click Advanced Options.
2b In the Advanced Options window, add NAGA obal Opt i ons noURLNor nal i ze=on.
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Dashboard Devices ~ Policies ~ Security

Servers b Configuration »#

Advanced Options: AG-Cluster

NAGGlobalOptions noURLNormalize=on

Server(s) must be updated before changes made on this panel will be used. See Configuration Panel for su

0K | Cancel |

Add this option to ensure that CE works with NAM.
2¢ Click OK.

3 Click Devices > Access Gateways > AG-Cluster > <Name of the Reverse Proxy> that you have
created.

4 Under the Proxy Service List create a new proxy service for CE. For example, CE_edit
5 Select the proxy service (CE_edit) that you created in Step 4.
5a In the Reverse Proxy Service > Proxy Service, select Advanced Options.

5al In the Advanced Options, specify Al | owEncodedSl ashes NoDecode.
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Servers b Configuration » Reverse Proxy F Proxy Service F

Advanced Options: AG-Cluster - apac - CE

AllowEncodedslashes NoDecode

Server(s) must be updated before changes made on this panel will be used. See Configuration P
0K | cancel |

This option ensures that files can be downloaded with CE.
5a2 Click OK.
5b Click Web Servers.
5b1 Enable the option Connect Using SSL.

+ Web Server Trusted Root: Select Do not verify.
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+ Connect Port: Specify the value 443.

Proxy Service Web -0 HTML Rewriting | Protected Resources | Logging |

Host Header: | Forward Received Host Name ¥ |

Web Server Host Name: |

(Alternate Haost Hame)
Error on DNS Mismatch (editham.apac.novell.com)

' Enable Force HTTP 1.0 to Origin
¥ Enable Session Stickiness
¥ Connect Using SSL

Web Server Trusted Root: | Do nat verify \a
SSL Mutual Certificate: | |
Connect Port: *
TCP Connect Options
5b2 Click OK.
5c¢ Click HTML Rewriting. The HTML rewriter profile was created for Filr, the same profile is
used for CE.
For the versions earlier than CE 23.2, use the following configuration:
HTML Rewriter Profile List
Mew... | Delete | Enable | Disable m 4 item(s)
[ | Name Enabled Search Boundary
v (4]
default o Word %
[] HTML Word =
[ | bhardening Word
] lool Character

For the CE 23.2 and later versions, use the following configuration:

HTML Rewriter Profile List
New... | Delete | Enable | Disable 4 item(s)

(] Name Enabled Search Boundary

() cool v Character %
default ¥ Word =

(] lool v Character %

(J HIML Word
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5d Click Protected Resources.
5d1 Create a new protected resource. For example, edit_public.
5d2 Enter the description.
5d3 Select Authentication Procedure as Cont racts: None.

5d4 For the versions earlier than CE 23.2, in the URL Path list, add two new paths. For
example, /loleaflet/* and /lool/*.

Authorization | ldentity Injection | Form Fill |

Protected Resource: edit_public

Description: ||

Authentication Procedure: ® Contracts: | [None] v

Mew... | Delete 3 item(s)
O URL Path

s

[ Jloleaflets®

] flools*

For the CE 23.2 and later versions, in the URL Path list, add two new paths. For
example, /browser/* and /cool/*.
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m Authorization | ldentity Injection | Form Fill '

Protected Resource: onlineEdit

Description: lUsed for Online Edit Feature with Filr

Authentication Procedure: ® Contracts: [ [None]

URL Path List

New... | Delete 3 item(s)
(] URL Path
(0, &

() /browser/*

. () /cools*
|

5d5 Click OK.
5e Click Logging.
5el Select Enable Logging.

Proxy Service . Web Servers | HTML Rewriting Pmdﬂmm

[# Enable Logging
Log Directory: | /var/log/ novell/ reverss/ apac

Logging Profile List

Hews.. | Delete | Enable
MHame Enabled Profile Type
Defaylt ¥  Common

5e2 Click OK.
6 To apply all your changes, click Devices > Access Gateways, then click Update All.

Allowing Filr to Connect to Content Editor

Perform the following steps, to add the DNS hostname of the CE appliance that was configured in
NAM.
1 Login to Filr: https://filr_appliance_ip_or_dns:8443/.
2 To access the Administration Console, click on Username > Administration Console.
3 Under System > Content Editor, specify the Server URL as the NAM hostname for CE.
This is the Published DNS name that you have configured for CE on the NAM server.
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Allowing Content Editor to Connect to the Filr

This works with the Filr 4 and later servers.

Perform the following steps, to add the DNS hostname of the Filr appliance that was configured in
NAM.

1 Login to CE: https://content_editor_appliance_ip_or_dns:9443/.
2 Inthe Allowed Hosts field, specify the NAM hostname for Filr.
This is the Published DNS name that you have configured for Filr on the NAM server.

Using the Online Edit Feature

When a user performs Online Edit on a file, the Online Edit session (Filr) communicates to CE via
NAM. The URL of the Online Edit session is shown accessing via NAM for CE.

Load Balancing

The Content Editor Appliance is configured by using HAProxy for load balancing. Load balancing
refers to efficiently distributing incoming network traffic across a group of backend servers, also
known as a server farm or server pool.

For collaborative editing to function correctly, you need to ensure that all the users editing the same
document are served by the same Content Editor Appliance. Using the WOPI protocol, the https URL
includes a unique identifier ( WOPI Sr ¢) for use with this document. Thus load balancing can be done
by using WOPI Sr ¢ — ensuring that all URLs that contain the same WOPI Sr ¢ are sent to the same
Content Editor Appliance.

The browser reaches the proxy with the HTTPS protocol. The proxy terminates the HTTPS connection
and passes traffic to backends via HTTP.

NOTE: For load balancing to work, all the nodes must run the same version of Content Editor
Appliance. You cannot upgrade the Content Editor with one node and continue with the older
version on another node.

For versions earlier than CE 23.2, in the Content Editor’s config file, in / var / opt / novel | /
contenteditor/| ool wsd/ | ool wsd. xnl , orin the command line which startsl ool wsd daemon,
disable SSL and enable SSL termination.

For versions CE 23.2 and later, in the Content Editor’s config file, in/ et ¢/ cool wsd/ cool wsd. xmi ,
or in the command line which starts cool wsd daemon, disable SSL and enable SSL termination.

The SSL termination option in the config file enables integration of Content Editor with SSL
termination proxies, which handle incoming SSL connections, decrypt the SSL and pass on the
unencrypted request to the server. In this setup only the proxy server has to have proper SSL
settings, the Content Editor server is hidden behind it, and Content Editor communicates
unencrypted with the proxy.
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Load Balancing for versions earlier than CE 23.2

frontend I ool wsd
bi nd *:443 ssl crt /path/to/your/certificate_and_key.pem
node http
defaul t _backend | ool wsd

backend | ool wsd
timeout tunnel 3600s
node http
bal ance url _param WOPI Src check_post
hash-type consi stent
server |oolwsd01 127.0.0. 1:9993
server |oolwsd02 127.0.0.1:9994

Sample configuration for Load Balancing with HAProxy
Add the following blocks to hapr oxy. cf g:

Frontend | ool wsd

bind *:443 ssl crt /Path to your certificate_and key. pem
http-request set-header X-HAProxy-I| ool wsd % url _paran{WOPI Src) ]
nmode http

def aul t _backend | ool wsd

backend | ool wsd

ti meout tunnel 3600s

nmode http

bal ance hdr ( X- HAPr oxy- | ool wsd)
server |ool1l <CE Server 1 |P>:9980
server | ool 2 <CE Server 2 |P>:9980
server | ool 3 <CE Server 3 |P>:9980
server | ool N <CE Server N | P>:9980

Here CE server 1, 2 and 3 are different CE nodes.

Load Balancing for CE 23.2 and above versions

frontend cool wsd

bind *:443 ssl crt /path/to/your/certificate_and _key. pem
node http

def aul t _backend cool wsd

backend cool wsd

ti meout tunnel 3600s

node http

bal ance url _param WOPI Src check_post
hash-type consi stent

server cool wsd01 127.0.0. 1: 9993
server cool wsd02 127.0.0. 1: 9994

Start Docker containers as described above, with-p 127. 0. 0. 1: 9993: 9980 and - p
127.0. 0. 1: 9994: 9980.
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Sample configuration for Load Balancing with HAProxy
Add the following blocks to hapr oxy. cf g:

Frontend | ool wsd

bind *:443 ssl crt /Path to your certificate_and key. pem
bal ance bal ance url _param WOPI Src check_post
nmode http

def aul t _backend cool wsd

backend cool wsd

timeout tunnel 3600s

nmode http

bal ance hdr ( X- HAPr oxy- | ool wsd)

server cooll <CE Server 1 |P>:9980

server cool 2 <CE Server 2 |P>:9980

server cool 3 <CE Server 3 |P>:9980

server cool N <CE Server N |P>:9980

Here CE server 1, 2 and 3 are different CE nodes.

NOTE: If users are not able to perform an Online Edit when Filr is configured with AAF and CE is
configured with Ha-Proxy Load Balancer, then add enabl e. cont ent . edi t or. check=f al se to/
opt/ novel I /filr/apache-tontat/webapps/ssf/WEB-1NF/ cl asses/ confi g/ ssf -
ext.properties and restart the Filr service.

Upgrading from Content Editor 1.2.3 to 2.0

Review the following sections before you upgrade your Content Editor Appliance 1.2.3 setup to
Content Editor 2.0:

+ “Support Matrix” on page 89

+ “Upgrading Content Editor Appliance” on page 90

+ “Understanding the Appliance Upgrade Process” on page 91

+ “Downloading and Preparing Software for the Upgrades” on page 92

+ “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 94

+ “Upgrading the VMs” on page 94

Support Matrix

Make sure that all the CE appliances are running version 1.2.3 with the latest patches applied.
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Upgrading Content Editor Appliance

Before upgrading Content Editor Appliance, you must ensure certain requirements are met. See
“Before You Upgrade!” on page 103 and then complete the instructions in the following sections in
order:

Before You Upgrade

Failure to comply with the following critical points could result in a non-functional CE system.

Critical Point

Details

*

Review the Release
Notes and Limitations

*

Check the Release Notes for any upgrade issues and “Upgrade” on
page 172 before you start the upgrade process.

Ensure that the VM
host has enough
unformatted disk
space.

The VM host server must have enough unallocated disk space to contain
the following disks for each appliance. This is only temporary because
after the upgrade completes, old appliances can be deleted and their disk
space reclaimed.

+ System Disk (/): This is created automatically as you deploy the
downloaded software.

Size is 50 GB per appliance.
+ Disk 2 (/vastorage): You make a copy of each old appliance’s Disk.
Size needed equals the total size of all disks to be copied.

+ Each Disk 3 (/var): You create this disk for each appliance in
conjunction with the upgrade process.

Size recommendation for Filr is 4 GB plus 3 times the RAM allocation
for each appliance being upgraded.

NOTE: The existing / vashar e mount point is used by the upgraded Filr
appliances. No new disk space is required for upgrading.

Make sure that existing
appliances are running
version 1.2.3 with the
latest patches.

Make sure that all appliances are running version 1.2.3 with the latest
patches applied.

The earlier version of CE must be upgraded to CE 1.2.3 for upgrading to
CE 2.0.

Remove all VMware
Snapshots

Before copying Disk 2, make sure to remove all VMware snapshots so
that the / vast or age disk has the correct disk file and latest
configuration settings.

Make sure that
upgraded appliances
meet the system
requirements.

See “System Requirements” on page 67.

Do not attempt
unsupported path
migrations.

No Cross-platform: You cannot upgrade from one virtualization platform
to another. You can only upgrade VMware to VMware, and so forth.

No Mixed Versions: All of the CE appliances in an expandable
deployment must be upgraded to the same version.
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Critical Point Details

¢ Plan when to upgrade. =@ Schedule the upgrade for a block of time that is least disruptive from

a production standpoint.

2. Notify Filr users about the upgrade.

After ensuring that you have met the prerequisites and cautions above, complete the instructions in

the following sections in order.

Understanding the Appliance Upgrade Process

The process of upgrading OpenText appliances is illustrated in Figure 10-1 on page 106.

Figure 9-1 Overview of the Appliance Upgrade Process

Upgrading an Appliance

a D.umluad a new version of the Filr, A ﬁ Orﬁ
Filrsearch, Postgre S0, .
Content Editor appliances download.novell.com

for your virtualization platform.

you are upgrading.

® Copy Disk 2 of the existing This creates a new VM with a
appliance being upgraded.

@ Deploy the appropriate file to the new
appliance location for each appliance

system disk () (Disk 1)
Mote: For Cifrix Xen, you “export® f New A,ﬂ.:lf.'_ance 1 "
rather than copying. Location |

o & 1—» & @
y

vastorage

5 Ivastorage MNew [ MNew fvar
Disk 2 h
- (Disk2) .  (Disk 1) (Disk 3)
Existing Appliance 1
0 Start and configure the newly deployed VM with: @ n
- Disks: (new fvar disk, existing /vashare digk) —
- The comect RAM, . Existing fvashare
- A second network adapter if needed, — NFS or CIF3
and 20 on. {Filr onky)

1 MNew Appliance 1

G The appliance system prompts you to confirm that you are upgrading.
After you supply a couple of passwords, the system runs through the
configuration screens automatically and the new appliance is an “upgraded™
version of the old appliance.

Important: The order in which you start the appliances during an upgrade is critical.
You must start the two search appliances and then the Filr appliances.

NOTE: +If you are using PostgreSQL DB shipped with Filr, then the order in which you start the

appliances during an upgrade has to be
1. PostgreSQL

2. Lucene (Search Appliances)
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3. Content Editor
4. Filr Appliance

+ If you are using an external database, the order in which you start the appliances during an
upgrade is critical. You must start the two search appliances and then the Filr appliances

Downloading and Preparing Software for the Upgrades

Download and prepare the software for your virtualization platform as described in the following
sections:

VMWare

1 Download the CE software shown below to your management workstation.

IMPORTANT: Registration with OpenText is required to receive an email with a software-
download link.

Appliance Type Filename

Content Editor Cont ent Edi t or. x86_64. 2022- 09-
13.53.0va. zi p

2 Extract each . ova. zi p file on your management workstation until an Appl i anceType-
ver si on folder appears.

3 Launch the vSphere Client and navigate to the datastore where you plan to host the upgraded
VMs.

4 Create a folder for each appliance that you plan to upgrade.

Name each folder with a name that is easily associated with (but not the same as) the VM name
of the associated appliance being upgraded.

5 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Hyper-V
1 Log in to the Hyper-V host server either locally or from a remote workstation using Remote
Desktop.

2 Download the CE software shown below to the location where you plan to host your upgraded
VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a software-
download link.

Appliance Type Filename

Content Editor Cont ent Edi t or. x86_64. 2022- 09-
13. 53. vhdx. zip

92 Content Editor


https://www.microfocus.com/products/filr/trial-download
https://www.microfocus.com/products/filr/trial-download

3 Extract each . vhdx. zi p file in the directory where you downloaded it until an
Appl i anceType- versi on. vhdx archive fil e appears.

4 Create a new directory for each virtual machine you are upgrading.

As a best practice, name these directories with names that are easily associated with, but not
the same as the VM name of each appliance being upgraded.

5 Move the ce- ver si on. vhdx archive file to the first CE appliance-type folder and then copy
the file to the remaining CE appliance type folders.

6 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Xen

1 Log in to the Xen VM host server either locally or from a remote workstation.
If you are connecting from a remote Linux workstation, use the following command:
ssh - X root @ost i p_address

The -X in the command in required for the GUI installation program upon which the steps in this
section are based.

2 Download the CE software shown below to the Xen VM host server in the location where you
plan to host your upgraded VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.

Appliance Type Filename

Content Editor Cont ent Edi t or. x86_64. 2022- 09-
13.53. qcow. zi p

3 Copy and rename the Appl i anceType- ver si on directories until you have one directory for
each appliance that you are upgrading.

IMPORTANT: Only change the directory names.

Do not change the names of the . gcow2 or. xenconfi g files within the directories that you
have copied and renamed.

For example:
1. Rename the CE- ver si on directory to CE- 1- 30- 192. 168. 1. 61.

2. Copy the CE- 1- 30- 192. 168. 1. 61 directory and rename it to CE- 1- 30-
192. 168. 1. 62, and so on until you have a directory for each appliance you are upgrading.

4 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Citrix Xen

1 On a workstation with Citrix XenCenter installed, download the CE software shown below.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.
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Appliance Type Filename

Content Editor Cont ent Edi t or. x86_64. 2022- 09-
13.53. xva. zi p

2 Extract each . xva file on your management workstation until an Appl i anceType- ver si on
folder appears.

3 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Copying Each Appliance’s /vastorage Disk (Disk 2)

IMPORTANT: *VMware requires shutting down an appliance before copying a disk.
This doesn’t mean that the entire service must be down while disk copying takes place.

If you have a Filr-clustered deployment, you can minimize service interruption by shutting down
one Filr or Filrsearch appliance, copying the disk, restarting the appliance and continuing with
the next appliance.

+ On Citrix Xen you “export” rather than copying Disk 2.

Copying each appliance’s disk is at the heart of the upgrade process because it uses the
corresponding “old” appliance’s configuration settings on Disk 2 to create an upgraded version of the
appliance with minimal input on your part.

Disk copying can take a while, depending on disk size and the VM host environment.

Therefore, we recommend keeping service downtime to a minimum by making the copies while the
Filr system is still running.

1 Using the tools provided by your hypervisor, copy the /vastorage (second disk) to its associated
folder or directory that you created for your upgraded appliances in “Downloading and
Preparing Software for the Upgrades” on page 92.

Upgrading the VMs

+ “Shutting Down the Appliances” on page 94

+ “Upgrading VMware VMs” on page 95

+ “Upgrading Hyper-V VMs” on page 96

¢ “Upgrading and Deploying Xen VMs” on page 98

Shutting Down the Appliances

1 Shut down all of your existing appliances in the shut down order that you identified earlier:
2 Continue with the instructions for your VM platform:
+ VMware

+ Hypter-V
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+ Xen

+ Citrix Xen

Upgrading VMware VMs

Complete the steps in Table 10-1 for each appliance that you are upgrading

Table 9-5 Upgrading a VMware VM

Page, Dialog, or Option

Do This

1 - Launching the vSphere Client.

1.

On your management workstation, start the vSphere Client.

vSphere Client

2 - Deploying the OVA Template and naming the VM.

1.

Click File > Deploy OVA Template.

Deploy OVA Template

1.

Click Browse.

Open

For the appliance type you are deploying, navigate to the contents of the
folder that you downloaded and extracted in “Downloading and Preparing
Software for the Upgrades” on page 92.

Select and open the.ova file.

Deploy OVA Template

=

o vk W N

Name the appliance with the same name of the folder that you created for
this upgraded appliance in Step 4 on page 107.

Click Next.

Choose the datastore and folder were you copied the appliance’s Disk 2.
Click Next to accept the default for the disk format.

Do not select Power on after deployment.

Click Finish.

The boot disk is created and the appliance is deployed as specified to this
point.

3 - Editing the VM settings.

vSphere Client

1.

In the vSphere Client, right-click the VM you just deployed and select Edit
Settings.

The Virtual Machine Properties dialog displays.

Virtual Machine
Properties

1.

Set the Memory and CPU settings to match the appliance you are replacing,
or increase them as planned.

4 - Configuring Disk 2 (/vastorage)

Virtual Machine
Properties

1.

Click Add.
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Page, Dialog, or Option Do This

Add Hardware 1.
2.

3.

Select Hard Disk, click Next and select Use an existing Virtual disk.

Click Next > Browse, then navigate to and select the copy of Disk 2 that you
made for this appliance.

Click Next > Next > Finish.

5 - Adding and Configuring Disk 3 (/var)

Virtual Machine 1. Click Add.
Properties
Add Hardware 1. Select Hard Disk.
2. Click Next > Next.
3. Adjust the Disk Size to the same size as disk 3 (/var) on the appliance you are
replacing.
4. Under Disk Provisioning, select either:
+ Thick Provision Eager Zeroed
or
¢ Support clustering features such as Fault Tolerance
Depending on the VMware version that you are running.
5. Under Location, select Specify a datastore or Datastore cluster
6. Click Browse.
7. Select the datastore and folder for this appliance.
8. Click OK.
9. Click Next.
10. Under the Virtual Device Node section, select SCSI.
11. Click Next.
12. Click Finish.
Virtual Machine 1. Click Add.
Properties
Add Hardware 1. Select Ethernet Adapter.
2. Click Next.
3. Under Network Connection, select the secondary network associated with
the CE installation.
4. Click Next > Finish > OK.
vSphere Client 1. Repeat the steps in this table from 2 - Deploying OVA Template until all of
your planned appliances have been deployed, then continue with “Deploying
the Upgraded (Replacement) VMs” on page 118.
Upgrading Hyper-V VMs

Complete the steps in Table 10-2 for each appliance that you are upgrading.
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Table 9-6 Upgrading a Hyper-V VM

Page, Dialog, or Option

Do This

1 - Open Hyper-V Manager.

Hyper-V Host Server

1. Open the Hyper-V Manager.

2 - Create a new VM.

Hyper-V Manager

1. Inthe left pane, right-click the server where you have planned
to create the new virtual machine, then click New > Virtual
Machine.

The New Virtual Machine Wizard displays.

2. Click Next.

Specify Name and Location

1. Name the appliance with the name of the directory that you
created for it in Step 4 on page 107.

2. Click Next.

Specify Generation

1. Make sure that Generation 1 is selected.

2. Click Next.

3 - Specify memory

Assign Memory

1. Inthe Startup RAM field, specify the same amount of memory
(in MB) of the appliance that you are replacing, or increase the
memory as planned.

2. Click Next.

4 - Assign network adapter

Configure Networking

1. Onthe Configure Networking page, select the networking card
for this VM.

2. Click Next.

6 - Identify the system disk

Connect Virtual Hard Disk

1. Select Use an existing virtual hard disk.

2. Browse to and select the . vhd that you created for this
appliance.

3. Click Open.
4. Click Next.

Summary

1. Click Finish.

The VM is created and appears in the list of Virtual Machines.

7 - Specify processors

Hyper-V Manager

1. In Hyper-V Manager, right-click the VM that you just created.
2. Click Settings.
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Page, Dialog, or Option Do This

Processor 1. Click Processor.

2. In the Number of virtual processors field, specify the number
of processors for this VM.

3. Click Next.

8 - Use existing copy of hard Disk 2 (/vastorage).

Settings for VM on Host Server 1. Add the copy you made of Disk 2 to this VM.

2. When you have added the disk, review the VM summary
information and click Finish.

9 - Add hard Disk 3 (/var).

Hyper-V Manager 1. In Hyper-V Manager, right-click the VM that you just created.
2. Click Settings.

3. Create a new blank virtual disk the same size as disk 3 on the
appliance you are upgrading.

Summary 1. Review the summary information.

2. Click Finish > OK

Hyper-V Manager 11 - Repeat until all VMs have upgraded copies

1. Repeat the steps in this table until all of your planned
appliances have been deployed, then continue with
“Deploying the Upgraded (Replacement) VMs” on page 118.

Upgrading and Deploying Xen VMs

IMPORTANT: Unlike the other virtualization platforms, which you power on and deploy separately
from the upgrade process, upgraded Xen VMs power on automatically when the upgrade process
completes. You must then deploy the appliance before continuing with the next one.

Therefore, it is critical that you make sure to follow the deployment order that you identified earlier.

Complete the steps in Table 10-3 for each appliance that you are upgrading and deploying.

Table 9-7 Upgrading and Deploying a Xen VM

Page, Dialog, or Option Do This

1 - Launch the installer.

Terminal prompt on Xen VM Host 1. Run the following command to launch the GUI configuration
Server menu:

Vi rt - manager

NOTE: Thevm i nstal | command is deprecated from SLES
12 releases.
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Page, Dialog, or Option

Do This

Create a new virtual machine

1.

Click File > New Virtual Machine.

The Create a new virtual machine wizard is displayed.
Select Import existing disk image.

Click Forward.

Storage path and Operating System

Browse and select the existing disk image.
Select SUSE Linux Enterprise Server 12 SP4.

Click Forward.

Choose Memory and CPU settings

3.

Set the amount of memory (in MB) to match that of the VM
you are upgrading.

. Specify the CPUs to match the number of the VM you are

upgrading.

Click Forward.

2 - Name the VM.

Name of Virtual Machine

1.
2.
3.

Specify the name of the appliance.
Select Customize configuration before install.

Click Finish.

3 - Configure Disk 2 (/vastorage)

Hardware 1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.
3. Add the copy you made of Disk 2 to this VM. Select the
. gcow? file.
4. Click Open > Finish.
4 - Add and Configure a new Disk 3 (/var)
1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.
3. Navigate to the contents of the folder for the appliance you
are creating.
4. Select the . qcow? file.
5. Click Open > Finish.
Summary 1. Click Network Adapters.
Network Adapters 1. Click New.
Virtual Network Adapter 1. Specify the settings for the adapter.
2. Click Apply.
Network Adapters 1. Click Apply.
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Page, Dialog, or Option Do This

Summary 1. Click OK.

The virtual machine is created, the appliance starts, and the
configuration process begins.

Console 6 - Deploy the Appliance :

1. Access the appliance’s console.

2. When prompted, enter the root and vaadmin passwords for
the appliance being replaced.

The upgrade process proceeds automatically.

3. When the appliance displays the final screen in the console
window, open your management browser and log in to the
appliance on port 9443 as the vaadmin user.

Port 9443 Admin Console 1. Depending on the appliance type you are upgrading, check the
following:

a. Click the CE configuration icon.

b. Ensure that all of the settings are in place as expected
(for example, - previously configured hostnames should
be present).

For more information see “Configuring Content Editor Options in
Filr Appliance” on page 80

7 - Upgrade the Next Appliance:

1. Return to the top of the table and repeat the process for the
next appliance in your list.
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Upgrading Filr

You can upgrade your Filr setup from Filr 4.3.1.2 to Filr 5.0.
The following chapter is covered in this section.

¢ Chapter 10, “Upgrading from Filr 4.3.1.2 to Filr 5.0,” on page 103
+ Chapter 11, “Updating Filr through Online Update Channel,” on page 133
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10 Upgrading from Filr 4.3.1.2 to Filr 5.0

Review the following sections before you upgrade your Filr 4.3.1.2 setup to Filr 5.0:

+ “Support Matrix” on page 103

+ “Upgrading a Large Filr Deployment” on page 103

+ “Upgrading an All-in-One (Small) Deployment” on page 120

Support Matrix

You must update to the latest 4.3.x patch version before upgrading to 5.0.

Source Version Status
Server 4.3.x with latest patch Supported

4.3 or earlier versions Not Supported. Upgrade to 4.3.x
Client 4.3.x Supported

4.3 or earlier versions Not Supported. Upgrade to 4.3.x

Upgrading a Large Filr Deployment

Before upgrading a Filr deployment, you must ensure certain requirements are met. See “Before You
Upgrade!” on page 103 and then complete the instructions in the following sections in order:

*

*

*

*

*

*

“Understanding the Appliance Upgrade Process” on page 106
“Downloading and Preparing Software for the Upgrades” on page 106
“Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109
“Upgrading the VMs” on page 109

“Deploying the Upgraded (Replacement) VMs” on page 118
“Performing Post-Upgrade Tasks” on page 119

Before You Upgrade!

Failure to comply with the following critical points could result in a non-functional Filr system.

Critical Point Details
+ Review the Release * Check the Release Notes for any upgrade issues and “Upgrade” on
Notes and Limitations page 172 before you start the upgrade process.

Upgrading from Filr 4.3.1.2 to Filr 5.0
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Critical Point Details

¢ Planthe upgrade order + You must upgrade the appliances in order of dependency upon each
and follow it. other.

1. Shut Down Order: Prepare a list of your appliances that defines the
correct shut down order:

+ Filr: All Filr appliances must be shut down first.
+ Filrsearch: Next, you shut down the Filrsearch appliances.

2. PostgreSQL: If you are using PostgreSQL appliance (shipped with
Filr), then ensure it is running.

3. Deployment Order: Prepare a second list of that defines the correct
upgrade and deployment order:

+ Filrsearch: You must upgrade and deploy the Filrsearch
appliances before the Filr appliances.

+ Filr: When the upgraded Filrsearch appliances are up and
running, upgrade and deploy the first Filr appliance. Then
upgrade and deploy the additional Filr appliances.

4. If there are things you need to remember about individual
appliances, include those reminders in the appropriate list.

5. Use the shut down list as you complete the steps in “Upgrading the
VMs.”

6. Use the upgrade list as you complete the steps in “Deploying the
Upgraded (Replacement) VMs.”

¢ Ensure that the VM + The VM host server must have enough unallocated disk space to contain
host has enough the following disks for each appliance. This is only temporary because
unformatted disk after the upgrade completes, old appliances can be deleted and their disk
space. space reclaimed.

+ System Disk (/): This is created automatically as you deploy the
downloaded software.

Size is 50 GB per appliance.
+ Disk 2 (/vastorage): You make a copy of each old appliance’s Disk.
Size needed equals the total size of all disks to be copied.

+ Each Disk 3 (/var): You create this disk for each appliance in
conjunction with the upgrade process.

Size recommendation for Filr is 4 GB plus 3 times the RAM allocation
for each appliance being upgraded.

NOTE: The existing / vashar e mount point is used by the upgraded Filr
appliances. No new disk space is required for upgrading.

Upgrading from Filr 4.3.1.2 to Filr 5.0



Critical Point

Details

*

Make sure that existing
appliances are running
version 4.3.1.2 with the
latest patches.

Make sure that all appliances are running version 4.3.1.2 with the latest
patches applied.

See Managing Field Test Patches in the Filr 5.0 Administrative Ul
Reference.

The earlier version of Filr must be upgraded to Filr 4.3.1.2 for upgrading
to Filr 5.0.

If the existing appliances are running version is 4.3.1.1, then before
upgrade, you will be prompted to enter the CIFS vashare details.

Remove all VMware
Snapshots

Before copying Disk 2, make sure to remove all VMware snapshots so
that the / vast or age disk has the correct disk file and latest
configuration settings.

+ Make sure that See Chapter 3, “Filr System Requirements,” on page 13.
upgraded appliances
meet the system
requirements.

+ Do not attempt No Cross-platform: You cannot upgrade from one virtualization platform
unsupported path to another. You can only upgrade VMware to VMware, and so forth.
migrations. No Mixed Versions: All of the Filr and Filrsearch appliances in an

expandable deployment must be upgraded to the same version.
No Cross-Deployment-Types: You can only upgrade small to small, non-
expandable to non-expandable, or expandable to expandable.
If you have a small or non-expandable deployment, and you need an
expandable deployment, you must either install a new system or contact
OpenText Consulting to assist you with the migration.

+ Appliances with two You should manually add the additional network card on successfully

network adapters.

upgrading the appliance.

*

Plan when to upgrade.

Filr services must be offline during the upgrade.

1. Schedule the upgrade for a block of time that is least disruptive from
a production standpoint.

2. Notify Filr users about the upgrade.

After ensuring that you have met the prerequisites and cautions above, complete the instructions in

the following sections in order.

*

*

“Understanding the Appliance Upgrade Process” on page 106

“Downloading and Preparing Software for the Upgrades” on page 106

“Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109

“Upgrading the VMs” on page 109

“Deploying the Upgraded (Replacement) VMs” on page 118

“Performing Post-Upgrade Tasks” on page 119
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Understanding the Appliance Upgrade Process

The process of upgrading OpenText appliances is illustrated in Figure 10-1 on page 106.

Figure 10-1 Overview of the Appliance Upgrade Process

-

Upgrading an Appliance
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xisting /vashare

- The correct RAM,
- A second network adapter if needed, 4 NFS or CIFS
(Filr only)

and so on. | New Appliénce 1

G The appliance system prompts you to confirm that you are upgrading.
After you supply a couple of passwords, the system runs through the
configuration screens automatically and the new appliance is an “upgraded”
version of the old appliance.

Important: The order in which you start the appliances during an upgrade is critical.
You must start the two search appliances and then the Filr appliances.

NOTE: *If you are using PostgreSQL DB shipped with Filr, then the order in which you start the
appliances during an upgrade has to be

1. PostgreSQL
2. Lucene (Search Appliances)
3. Filr Appliances

+ If you are using an external database, the order in which you start the appliances during an
upgrade is critical. You must start the two search appliances and then the Filr appliances.

Downloading and Preparing Software for the Upgrades

Download and prepare the software for your virtualization platform as described in the following

sections:
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VMWare

1 Download the Filr software shown below to your management workstation.

IMPORTANT: Registration with OpenText is required to receive an email with a software-
download link.

Appliance Type Filename

Filr Filr.x86_64-version.ova.zip

Search Fi |l rsearch. x86_64-version.ova. zi p
PostgreSQL Post greSQ.- ver si on. ova. zi p

2 Extract each . ova. zi p file on your management workstation until an Appl i anceType-
ver si on folder appears.

3 Launch the vSphere Client and navigate to the datastore where you plan to host the upgraded
VMs.

4 Create a folder for each appliance that you plan to upgrade.

Name each folder with a name that is easily associated with (but not the same as) the VM name
of the associated appliance being upgraded.

5 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Hyper-V
1 Log in to the Hyper-V host server either locally or from a remote workstation using Remote
Desktop.

2 Download the Filr software shown below to the location where you plan to host your upgraded
VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a software-
download link.

Appliance Type Filename

Filr Filr.x86_64-version.vhdx. zi p

Search Fil rsearch. x86_64-versi on. vhdx. zi p
PostgreSQL Post gr eSQ.- ver si on. vhdx. zi p

3 Extract each . vhdx. zi p file in the directory where you downloaded it until an
Appl i anceType-versi on. vhdx archive fil e appears.

4 Create a new directory for each virtual machine you are upgrading.

As a best practice, name these directories with names that are easily associated with, but not
the same as the VM name of each appliance being upgraded.

5 Movethefilr-version. vhdx archive file to the first Filr appliance-type folder and then
copy the file to the remaining Filr appliance type folders.
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6 Movethefil rsearch-version. vhdx archive file to the first Filrsearch appliance-type folder
and then copy the file to the second Filrsearch folder.

7 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Xen

1 Login to the Xen VM host server either locally or from a remote workstation.
If you are connecting from a remote Linux workstation, use the following command:
ssh - X root @ost _i p_address

The -X in the command in required for the GUI installation program upon which the steps in this
section are based.

2 Download the Filr software shown below to the Xen VM host server in the location where you
plan to host your upgraded VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.

NOTE: Begining with Filr 5.0, any .tar.gz files will not be shipped. Instead, the images will be

provided.

Appliance Type Filename

Filr Filr.x86_64-version. xen. gcow2

Search Fi | rsearch. x86_64-versi on. xen. qcow2
PostgreSQL Post gr eSQL- ver si on. xen. gcow2

3 Copy and rename the Appl i anceType- ver si on directories until you have one directory for
each appliance that you are upgrading.

IMPORTANT: Only change the directory names.

Do not change the names of the . qcow2 or. xenconf i g files within the directories that you
have copied and renamed.

For example:
1. RenametheFi |l r-versiondirectorytofilr-1-30-192.168. 1. 61.

2. Copythefilr-1-30-192.168. 1. 61 directory and renameittofilr-1-30-
192. 168. 1. 62, and so on until you have a directory for each appliance you are upgrading.

3. Inasimilar manner, copy and rename the Fi | r sear ch- ver si on directory until you have
two Filrsearch appliances.

4 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Citrix Xen

1 On a workstation with Citrix XenCenter installed, download the Filr software shown below.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.
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Appliance Type Filename

Filr Filr.x86_64-version. xva. xva
Search Fi |l rsearch. x86_64-versi on. xva. xva
PostgreSQL Post gr eSQ.- ver si on. xva. xva

2 Extract each . xva file on your management workstation until an Appl i anceType- ver si on
folder appears.

3 Continue with “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109.

Copying Each Appliance’s /vastorage Disk (Disk 2)

IMPORTANT: *VMware requires shutting down an appliance before copying a disk.
This doesn’t mean that the entire service must be down while disk copying takes place.

If you have a Filr-clustered deployment, you can minimize service interruption by shutting down
one Filr or Filrsearch appliance, copying the disk, restarting the appliance and continuing with
the next appliance.

+ On Citrix Xen you “export” rather than copying Disk 2.

Copying each appliance’s disk is at the heart of the upgrade process because it uses the
corresponding “old” appliance’s configuration settings on Disk 2 to create an upgraded version of the
appliance with minimal input on your part.

Disk copying can take a while, depending on disk size and the VM host environment.

Therefore, we recommend keeping service downtime to a minimum by making the copies while the
Filr system is still running.

1 Using the tools provided by your hypervisor, copy the /vastorage (second disk) to its associated
folder or directory that you created for your upgraded appliances in “Downloading and
Preparing Software for the Upgrades” on page 92.

Upgrading the VMs

+ “Shutting Down the Appliances” on page 110

+ “Upgrading VMware VMs” on page 110

+ “Upgrading Hyper-V VMs” on page 112

+ “Upgrading and Deploying Xen VMs” on page 114
+ “Upgrading Citrix Xen VMs” on page 117
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Shutting Down the Appliances

1 Shut down all of your existing appliances in the shut down order that you identified earlier:

2 Continue with the instructions for your VM platform:

* VMware
+ Hypter-V
+ Xen

* Citrix Xen

Upgrading VMware VMs

Complete the steps in Table 10-1 for each appliance that you are upgrading

Table 10-1 Upgrading a VMware VM

Page, Dialog, or Option

Do This

1 - Launching the vSphere Client.

1.

On your management workstation, start the vSphere Client.

vSphere Client

2 - Deploying the OVA Template and naming the VM.

1.

Click File > Deploy OVA Template.

Deploy OVA Template

1.

Click Browse.

Open 1. For the appliance type you are deploying, navigate to the contents of the
folder that you downloaded and extracted in “Downloading and Preparing
Software for the Upgrades” on page 92.
2. Select and open the.ova file.
Deploy OVA Template 1. Name the appliance with the same name of the folder that you created for

o Uk W N

this upgraded appliance in Step 4 on page 107.

Click Next.

Choose the datastore and folder were you copied the appliance’s Disk 2.
Click Next to accept the default for the disk format.

Do not select Power on after deployment.

Click Finish.

The boot disk is created and the appliance is deployed as specified to this
point.

3 - Editing the VM settings.

vSphere Client

1.

In the vSphere Client, right-click the VM you just deployed and select Edit
Settings.

The Virtual Machine Properties dialog displays.

Virtual Machine
Properties

1.

Set the Memory and CPU settings to match the appliance you are replacing,
or increase them as planned.
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Page, Dialog, or Option Do This

4 - Configuring Disk 2 (/vastorage)

Virtual Machine 1. Click Add.
Properties
Add Hardware 1. Select Hard Disk, click Next and select Use an existing Virtual disk.

2. Click Next > Browse, then navigate to and select the copy of Disk 2 that you
made for this appliance.

3. Click Next > Next > Finish.

5 - Adding and Configuring Disk 3 (/var)

Virtual Machine 1. Click Add.
Properties
Add Hardware 1. Select Hard Disk.

2. Click Next > Next.

3. Adjust the Disk Size to the same size as disk 3 (/var) on the appliance you are
replacing.

4. Under Disk Provisioning, select either:

¢ Thick Provision Eager Zeroed

or

* Support clustering features such as Fault Tolerance
Depending on the VMware version that you are running.
Under Location, select Specify a datastore or Datastore cluster
Click Browse.
Select the datastore and folder for this appliance.
Click OK.
Click Next.

W ® N o U

10. Under the Virtual Device Node section, select SCSI.
11. Click Next.
12. Click Finish.

13. If you need to add network adapters, continue with 6 - (Optional) Adding a
Network Adapter.

Otherwise, click OK, return to “2 - Deploying the OVA Template and naming
the VM.” on page 110, and deploy the next appliance that you have planned
for

When all of your planned appliances have been deployed, continue with
“Deploying the Upgraded (Replacement) VMs” on page 118.
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Page, Dialog, or Option Do This

6 - (Optional) Adding a Network Adapter

You can add a network adapter if your Filr deployment accesses a separate
network for one or more of the following reasons:

*

*

*

Appliance administration.
NFS mount or CIFS access to the /vashare mount point.
Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with Filr.

Virtual Machine 1. Click Add.
Properties
Add Hardware 1. Select Ethernet Adapter.
2. Click Next.
3. Under Network Connection, select the secondary network associated with

the Filr installation.

Click Next > Finish > OK.

vSphere Client

Repeat the steps in this table from 2 - Deploying OVA Template until all of
your planned appliances have been deployed, then continue with “Deploying
the Upgraded (Replacement) VMs” on page 118.

Upgrading Hyper-V VMs

Complete the steps in Table 10-2 for each appliance that you are upgrading.

Table 10-2 Upgrading a Hyper-V VM

Page, Dialog, or Option

Do This

1 - Open Hyper-V Manager.

Hyper-V Host Server

1. Open the Hyper-V Manager.

2 - Create a new VM.

Hyper-V Manager

1. Inthe left pane, right-click the server where you have planned
to create the new virtual machine, then click New > Virtual
Machine.

The New Virtual Machine Wizard displays.

2. Click Next.

Specify Name and Location

1. Name the appliance with the name of the directory that you
created for it in Step 4 on page 107.

2. Click Next.

Specify Generation

1. Make sure that Generation 1 is selected.

2. Click Next.
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Page, Dialog, or Option Do This

3 - Specify memory

Assign Memory 1. Inthe Startup RAM field, specify the same amount of memory
(in MB) of the appliance that you are replacing, or increase the
memory as planned.

2. Click Next.

4 - Assign network adapter

Configure Networking 1. Onthe Configure Networking page, select the networking card
for this VM.

2. Click Next.

6 - Identify the system disk

Connect Virtual Hard Disk 1. Select Use an existing virtual hard disk.

2. Browse to and select the . vhd that you created for this
appliance.

3. Click Open.
4. Click Next.

Summary 1. Click Finish.

The VM is created and appears in the list of Virtual Machines.

7 - Specify processors

Hyper-V Manager 1. In Hyper-V Manager, right-click the VM that you just created.
2. Click Settings.

Processor 1. Click Processor.

2. In the Number of virtual processors field, specify the number
of processors for this VM.

3. Click Next.

8 - Use existing copy of hard Disk 2 (/vastorage).

Settings for VM on Host Server 1. Add the copy you made of Disk 2 to this VM.

2. When you have added the disk, review the VM summary
information and click Finish.

9 - Add hard Disk 3 (/var).

Hyper-V Manager 1. In Hyper-V Manager, right-click the VM that you just created.
2. Click Settings.

3. Create a new blank virtual disk the same size as disk 3 on the
appliance you are upgrading.

Summary 1. Review the summary information.

2. Click Finish > OK

Upgrading from Filr 4.3.1.2 to Filr 5.0 113



Page, Dialog, or Option Do This

10 - (Optional) Add a Network Adapter

1. If the appliance you are upgrading has a secondary network
adapter, add that now.

Hyper-V Manager 11 - Repeat until all VMs have upgraded copies

1. Repeat the steps in this table until all of your planned
appliances have been deployed, then continue with
“Deploying the Upgraded (Replacement) VMs” on page 118.

Upgrading and Deploying Xen VMs

IMPORTANT: Unlike the other virtualization platforms, which you power on and deploy separately
from the upgrade process, upgraded Xen VMs power on automatically when the upgrade process
completes. You must then deploy the appliance before continuing with the next one.

Therefore, it is critical that you make sure to follow the deployment order that you identified earlier.

Complete the steps in Table 10-3 for each appliance that you are upgrading and deploying.

Table 10-3 Upgrading and Deploying a Xen VM

Page, Dialog, or Option Do This

1 - Launch the installer.

Terminal prompt on Xen VM Host 1. Run the following command to launch the GUI configuration
Server menu:

Vi rt - manager

NOTE: Thevm i nstal | command is deprecated from SLES
12 releases.

Create a new virtual machine 1. Click File > New Virtual Machine.

The Create a new virtual machine wizard is displayed.
2. Select Import existing disk image.

3. Click Forward.

Storage path and Operating System 1. Browse and select the existing disk image.
2. Select SUSE Linux Enterprise Server 12 SP4.
3. Click Forward.

Choose Memory and CPU settings 1. Set the amount of memory (in MB) to match that of the VM
you are upgrading.

2. Specify the CPUs to match the number of the VM you are
upgrading.

3. Click Forward.
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2 - Name the VM.

Name of Virtual Machine 1. Specify the name of the appliance.
2. Select Customize configuration before install.

3. Click Finish.

3 - Configure Disk 2 (/vastorage)

Hardware 1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.

3. Add the copy you made of Disk 2 to this VM. Select the
. gqcow? file.

4. Click Open > Finish.

4 - Add and Configure a new Disk 3 (/var)

1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.

3. Navigate to the contents of the folder for the appliance you
are creating.

4. Select the . qcow? file.
5. Click Open > Finish.

5 - (Optional) Add a Network Adapter

You can add a network adapter if your Filr deployment accesses a
separate network for one or more of the following reasons:

+ Appliance administration.

* NFS mount or CIFS access to the /vashare mount point.

* Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with

Filr.
Summary 1. Click Network Adapters.
Network Adapters 1. Click New.
Virtual Network Adapter 1. Specify the settings for the adapter.
2. Click Apply.
Network Adapters 1. Click Apply.
Summary 1. Click OK.

The virtual machine is created, the appliance starts, and the
configuration process begins.
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Page, Dialog, or Option

Do This

Console

6 - Deploy the Appliance

1. Access the appliance’s console.

2. When prompted, enter the root and vaadmin passwords for
the appliance being replaced.

The upgrade process proceeds automatically.

3. When the appliance displays the final screen in the console
window, open your management browser and log in to the
appliance on port 9443 as the vaadmin user.

Port 9443 Admin Console

1. Depending on the appliance type you are upgrading, check the

following:
* Filrsearch:
1. Click the Filrsearch configuration icon.
2. Ensure that all of the settings are in place as
expected.
3. If the configuration wizard displays, there was a
problem with the configuration.
4. Resolve the configuration issues, then click Finish to
reconfigure the system.
* Filr:
1. Click the Filr configuration icon.
2. Ensure that all of the settings are in place as
expected.
3. If the configuration wizard displays, there was a
problem with the configuration.
4. Resolve the configuration issues, then click Finish to

reconfigure the system.
Common configuration issues include:

+ [f your system is not using DNS, the most likely
problem is unresolvable DNS names and
missing /etc/hosts entries.

+ |If the appliance doesn’t have access to the
database, ensure that all of the settings are as
expected.

7 - Upgrade the Next Appliance

1. Return to the top of the table and repeat the process for the
next appliance in your list.

When all of your appliances are running, continue with
“Performing Post-Upgrade Tasks.”
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Upgrading Citrix Xen VMs

Table 10-4 Upgrading a Citrix Xen VM

Page, Dialog, or Option Do This

1 - Launch XenCenter.

Management 1. Start XenCenter.

Workstation

XenCenter 1. Connect to the Citrix XenServer where you are deploy the upgraded
appliances.

2. Right-click the server and select Import.

2 - Import the system disk

Locate the File you want 1. Browse to and select the . xva file on your management workstation for the

to import appliance that you are upgrading.
2. Click Open.
3. Click Next.

Select the location 1. Select the XenServer.

where the imported VM 2. Click Next.

will be placed

Select target storage 1. Select the storage repository for the VM.
2. Click Import.

3 - Select the network adapter

Select network to 1. Select the virtual network adapter.
connect VM 2. Click Next.

Review the import 1. Deselect Start VM(s) after import.
settings 2. Click Finish.

IMPORTANT: Depending on network latency and other factors, it can take a
while to import the system disk.

4 - Specify Memory

1. If you need to adjust the memory to the amount of memory, select the newly
created VM in the left pane.

2. Click the Memory tab.
3. Click Edit, change the setting, and click OK.

5 - Specify Processors

1. If you need to adjust the CPUs, right-click the newly created VM in the left
pane.

2. Select Properties.

3. Click CPU, change the setting, and click OK.

6 - Link to Disk 2 (/vastorage)
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1. With the newly created VM selected in the left pane, add the copy of Disk 2
for this appliance.

8 - Add Disk 3 (/var)

Virtual Disks 1. Click Add....

Add Virtual Disk 1. Type a disk name that reflects the appliance name and that this is disk 3. For
example, Filr-1-disk-3.

2. Change the Size field value to match that of the appliance you are replacing.

3. Click Add.

9 - (Optional) Add a Network Adapter

You can add a network adapter if your Filr deployment accesses a separate
network for one or more of the following reasons:

+ Appliance administration.

+ NFS mount or CIFS access to the /vashare mount point.

+ Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with Filr.

1. With the newly created VM selected in the left pane, click the Networking
tab.

2. Select the secondary network associated with the Filr installation..

XenCenter 1. Repeat the steps in this table until all of your planned appliances have been
upgraded, then continue with “Deploying the Upgraded (Replacement) VMs
on page 118.

”

Deploying the Upgraded (Replacement) VMs

IMPORTANT: *Make sure that you deploy (Start and configure) your appliances one at a time.
Attempting to start and configure multiple upgraded appliances at the same time causes timing,
synchronization, and other problems.

+ Also make sure that you deploy the appliances in the deployment order that you identified
earlier:

1. Filrsearch
2. Filr

1 Power on the first (or next) appliance in your deployment order list.

2 Access the appliance’s console.

3 When prompted, enter the root and vaadmin passwords for the appliance being replaced.
The upgrade process proceeds automatically.

4 When the appliance displays the final screen in the console window, open your management
browser and log in to the appliance on port 9443 as the vaadmin user.
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5 Depending on the appliance type you are upgrading, check the following:

Filrsearch Filr

1. Click the Filrsearch configuration icon. 1. Click the Filr configuration icon.

2. Ensure that all of the settings are in place as 2. Ensure that all of the settings are in place as
expected. expected.

3. Ifthe configuration wizard displays, there was 3. If the configuration wizard displays, there was
a problem with the configuration. a problem with the configuration.
Resolve the configuration issues, then click Resolve the configuration issues, then click
Finish to reconfigure the system. Finish to reconfigure the system.

Common configuration issues include:

+ If your system is not using DNS, the most
likely problem is unresolvable DNS names and
missing / et ¢/ host s entries.

+ |f the appliance doesn’t have access to the
database, ensure that all of the settings are as
expected.

6 When the appliance is running, deploy the next appliance.

7 When all of your appliances are running, continue with “Performing Post-Upgrade Tasks.”

Performing Post-Upgrade Tasks

After upgrading to a new version of Filr, you should perform the following tasks to ensure a fully
functional Filr system:

+ “Install Your New Filr License” on page 119

+ “Java Heap” on page 119

Install Your New Filr License

The newly upgraded Filr appliances have a 60-day evaluation license installed. The evaluation license
is expired in most cases since it considers the day of deployment as the day when it was installed
with the earlier version.

To prevent a service interruption, you must install your new license by following the instructions in
“Installing/Updating the Filr License” in the OpenText Filr 23.4: Administrative Ul Reference.

Java Heap

For optimal performance of Filr appliance, the minimum Java heap space should be 12 GB. After
upgrading the appliance, the Java heap space is overwritten with the value that was set for the
earlier Filr appliance. If new value is less, then ensure to update it to 12 GB or greater.
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Upgrading an All-in-One (Small) Deployment

Before upgrading a Filr deployment, you must ensure certain requirements are met. See “Before You
Upgrade!” on page 120 and then complete the instructions in the following sections in order:

*

*

*

*

*

*

“Small Filr Upgrade Process Overview” on page 121
“Downloading and Preparing Software” on page 121

“Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 122
“Upgrading the VMs” on page 123

“Deploying the Upgraded Filr VM” on page 131

“Performing Filr Post-Upgrade Tasks” on page 132

Before You Upgrade!

Failure to comply with the following critical points could result in a non-functional Filr system.

*

*

Review the Release Notes: Check “Upgrade Filr” before you start the upgrade process.
Ensure that the VM host has enough unformatted disk space:

+ System Disk (/): A 50 GB disk is created automatically.

+ Disk 2 (/vastorage): You make a copy of the appliance’s Disk 2.

+ Each Disk 3 (/var): You create this disk. The recommended size is 4 GB plus 3 times the
appliance’s RAM allocation.

Check the version: Make sure that the existing appliance is running version 4.3.x with the latest
patches applied.

Remove VMware Snapshots: Before copying Disk 2, make sure to remove all VMware
snapshots so that the / vast or age disk has the correct disk file and latest configuration
settings.

Filr Database User Name Changed: If the earlier Filr database was configured with an user
name other than ‘fi | r’, the upgrade fails. Ensure to reconfigure the earlier Filr appliance with
Filr database user name as ‘fi | r’ before performing upgrade.

If the appliance has two network adapters: You should manually add them after upgrading the
appliance.

After ensuring that you have met the prerequisites and cautions above, complete the instructions in
the following sections in order.

*

*

*

*

“Small Filr Upgrade Process Overview” on page 121
“Downloading and Preparing Software” on page 121

“Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 122
“Upgrading the VMs” on page 123

“Deploying the Upgraded Filr VM” on page 131

“Performing Filr Post-Upgrade Tasks” on page 132
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Small Filr Upgrade Process Overview

If you have upgraded a small Filr deployment before, the following reminder might be all you need.

Figure 10-2 Overview of the Small Filr Appliance Upgrade Process

Upgrading a Small Filr Deployment

a Download a new version of the Filr appliance [ ﬁ Glr
for your virtualization platform. -y
download .novell.com

B Deploy the downloaded file fo the new
Filr appliance focation.
This creates a new VM with a
aystem dizk (/) (Disk 1)

B - - . New Filr Appliance’
9 Copy Disk 2 of the existing Filr appliance ’ | ocation i.

to the new location. '
Mote: For Citrix Xen, you “export” 3 é @
rather than copying. /ﬁ
- fvastorage Mew / Mew fvar
@ @ (Disk 2) (Dizk 1) (Disk 3)
' Ivastorage
{Disk 2)
- o
Existing Filr Appliance '

g

@ Start and configure the newly deployed appliance. ) _
- Addlcreate a new fvar disk. R ERlEes
- Set the comect RAM.

- Add a second network adapter if needed.

eThe appliance system prompts you to confirm that you are upgrading.
After you supply a couple of passwords, the system runs through the configuration screens automatically,
and the new appliance is an “upgraded” version of the old appliance.

Downloading and Preparing Software

Download and prepare the software for your virtualization platform as described in the following
sections:

VMWare

1 Download the Filr appliance software to your management workstation.

IMPORTANT: Registration with OpenText is required to receive an email with a software-
download link.

2 Extract the . ova. zi p file on your management workstation until a Fi | r - ver si on folder
appears.
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3 Launch VMware and navigate to the datastore where you plan to host the upgraded VM.

4 Create a folder for the new appliance with a name that is easily associated with (but not the
same as) the VM name of the appliance being upgraded.

Hyper-V
1 Log in to the Hyper-V host server either locally or from a remote workstation using Remote
Desktop.

2 Download the Filr appliance software to the location where you plan to host your upgraded
VMs.

IMPORTANT: Registration with OpenText is required to receive an email with a software-
download link.

3 Extract the . vhdx. zi p file in the directory where you downloaded it untilan Fi | r -
versi on.vhdx archive fil e appears.

4 Create a directory for the new appliance with a name that is easily associated with, but not the
same as the VM name of the appliance being upgraded.

5 Move the Fi | r-ver si on. vhdx archive file to the folder you just created.

Xen

1 Login to the Xen VM host server either locally or from a remote workstation.
If you are connecting from a remote Linux workstation, use the following command:
ssh - X root @ost i p_address

The -X in the command in required for the GUI installation program upon which the steps in this
section are based.

2 Download the Filr appliance software to the Xen VM host server in the location where you plan
to host your upgraded VM.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.

Citrix Xen

1 On a workstation with Citrix XenCenter installed, download the Filr appliance software.

IMPORTANT: Registration with OpenText is required to receive an email with a download link.

2 Extract. xvz file on your management workstation until a Fi | r - ver si on folder appears.

Copying Each Appliance’s /vastorage Disk (Disk 2)

IMPORTANT: *VMware requires shutting down an appliance before copying a disk.
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This means that Filr services will be down while disk copying takes place.

+ On Citrix Xen you “export” rather than copying Disk 2.

1 Using the tools provided by your hypervisor, copy the /vastorage (second disk) to its associated

folder or directory that you created for your upgraded appliances in “Downloading and

Preparing Software” on page 121.

Upgrading the VMs

+ “Shutting Down the Appliance” on page 123

+ “Upgrading a Filr VMware VM” on page 123

+ “Upgrading a Filr Hyper-V VM” on page 126

+ “Upgrading and Deploying a Filr Xen VM” on page 127
+ “Upgrading Citrix Xen VMs” on page 129

Shutting Down the Appliance

1 Shut down the Filr appliance using the Port 9443 Appliance Console.

2 Continue with the instructions for your VM platform:
¢ Upgrading a Filr VMware VM
+ Upgrading a Filr Hyper-V VM
¢ Upgrading and Deploying a Filr Xen VM
+ Upgrading Citrix Xen VMs

Upgrading a Filr VMware VM

Complete the steps in Table 10-5.

Table 10-5 Upgrading the Filr VMware VM

Page, Dialog, or Option Do This

1 - Launching the Web browser.

1. On a Web browser, enter the URL for the VMware server and login with the

root credentials.
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Page, Dialog, or Option Do This

2 - Deploying the OVA Template and naming the VM.

1. Right-click on the Virtual Machines and click Create/register V.
2. Select Deploy a virtual machine from an OVA file, then click Next.

3. Name the appliance with the same name of the folder that you created for
this upgraded appliance in Step 4 on page 122.

4. Upload the ova and vmdk files that you downloaded and extracted in Step 4
on page 122.

Click Next.

Choose the datastore and folder were you copied the appliance’s Disk 2.
Click Next to accept the default for the disk format.

Do not select Power on after deployment.

Click Finish.

L 0 N o WU

The boot disk is created and the appliance is deployed as specified to this
point.

3 - Editing the VM settings.

vSphere Client 1. Inthe vSphere Client, right-click the VM and select Edit Settings.

The Virtual Machine Properties dialog displays.

Virtual Machine 1. Setthe Memory and CPU settings to match the appliance you are replacing,
Properties or increase them as planned.

4 - Configuring Disk 2 (/vastorage)

Virtual Machine 1. Click Add.
Properties
Add Hardware 1. Select Hard Disk, click Next and select Use an existing Virtual disk.

2. Click Next > Browse, then navigate to and select the copy of disk 2 that you
made for this appliance.

3. Click Next > Next > Finish.

5 - Adding and Configuring Disk 3 (/var)

Virtual Machine 1. Click Add.
Properties
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Page, Dialog, or Option Do This

Add Hardware 1. Select Hard Disk.
2. Click Next > Next.

3. Adjust the Disk Size to the same size as disk 3 (/var) on the appliance you are
replacing.

4. Under Disk Provisioning, select either:

¢ Thick Provision Eager Zeroed

or

+ Support clustering features such as Fault Tolerance
Depending on the VMware version that you are running.
Under Location, select Specify a datastore or Datastore cluster
Click Browse.
Select the datastore and folder for this appliance.
Click OK.
Click Next.

W ® N o U

10. Under the Virtual Device Node section, select SCSI.

NOTE: Ensure that the SCSI controller number is same as what you had used
during installing Filr.

11. Click Next.
12. Click Finish.

13. If you need to add network adapters, continue with 6 - (Optional) Adding a
Network Adapter.

Otherwise, click OK and skip to continue with “Deploying the Upgraded Filr
VM” on page 131.

6 - (Optional) Adding a Network Adapter

You can add a network adapter if your Filr deployment accesses a separate
network for one or more of the following reasons:

+ Appliance administration.

+ Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with Filr.

Virtual Machine 1. Click Add.

Properties

Add Hardware 1. Select Ethernet Adapter.
2. Click Next.

3. Under Network Connection, select the secondary network associated with
the Filr installation.

4. Click Next > Finish > OK.

vSphere Client 1. Continue with “Deploying the Upgraded Filr VM” on page 131.
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Upgrading a Filr Hyper-V VM

Complete the steps in Table 10-6.

Table 10-6 Upgrading a Filr Hyper-V VM

Page, Dialog, or Option Do This

1 - Open Hyper-V Manager.

Hyper-V Host Server 1. Open the Hyper-V Manager.

2 - Create a new VM.

Hyper-V Manager 1. Inthe left pane, right-click the server where you have planned
to create the new virtual machine, then click New > Virtual
Machine.

The New Virtual Machine Wizard displays.

2. Click Next.
Specify Name and Location 1. Name the appliance with the name of the directory that you
created for it in Step 4 on page 122.
2. Click Next.
Specify Generation 1. Make sure that Generation 1 is selected.
2. Click Next.

3 - Specify memory

Assign Memory 1. Inthe Startup RAM field, specify the same amount of memory
(in MB) of the appliance that you are replacing, or increase the
memory as planned.

2. Click Next.

4 - Assign network adapter

Configure Networking 1. Onthe Configure Networking page, select the networking card
for this VM.

2. Click Next.

6 - Identify the system disk

Connect Virtual Hard Disk 1. Select Use an existing virtual hard disk.

2. Browse to and select the . vhd file in the folder you created
for this appliance.

3. Click Open.
4. Click Next.

Summary 1. Click Finish.

The VM is created and appears in the list of Virtual Machines.

7 - Specify processors
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Page, Dialog, or Option

Do This

Hyper-V Manager

1. In Hyper-V Manager, right-click the VM that you just created.
2. Click Settings.

Processor

1. Click Processor.

2. In the Number of virtual processors field, specify the number
of processors for the VM.

3. Click Next.

8 - Use existing copy of hard Disk 2 (/vastorage).

Settings for VM on Host Server

1. Add the copy you made of disk 2 to this VM.

2. When you have added the disk, review the VM summary
information and click Finish.

9 - Add hard Disk 3 (/var).

Hyper-V Manager

1. In Hyper-V Manager, right-click the VM that you just created.
2. Click Settings.

3. Create a new blank virtual disk the same size as disk 3 on the
appliance you are upgrading.

Summary

1. Review the summary information.

2. Click Finish > OK

10 - (Optional) Add a Network Adapter

1. If the appliance you are upgrading has a secondary network
adapter, add that now.

Hyper-V Manager

11 - Deploy the upgraded appliance

1. Continue with “Deploying the Upgraded Filr VM” on page 131.

Upgrading and Deploying a Filr Xen VM

Complete the steps in Table 10-7.

Table 10-7 Upgrading and Deploying a Filr Xen VM

Page, Dialog, or Option

Do This

1 - Launch the installer.

Terminal prompt on Xen VM Host
Server

1. Run the following command to launch the GUI configuration
menu:

Vi rt - manager

NOTE: Thevm i nstal | command is deprecated from SLES
12 releases.
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Page, Dialog, or Option

Do This

Create a new virtual machine

1. Click File > New Virtual Machine.

The Create a new virtual machine wizard is displayed.
2. Select Import existing disk image.

3. Click Forward.

Storage path and Operating System

1. Browse and select the existing disk image.
2. Select SUSE Linux Enterprise Server 12 SP4.
3. Click Forward.

Choose Memory and CPU settings

1. Set the amount of memory (in MB) to match that of the VM
you are upgrading.

2. Specify the CPUs to match the number of the VM you are
upgrading.

3. Click Forward.

2 - Name the VM.

Name of Virtual Machine

1. Specify the name of the appliance.
2. Select Customize configuration before install.

3. Click Finish.

3 - Configure Disk 2 (/vastorage)

Hardware

1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.

3. Navigate to the contents of the folder for the appliance you
are creating.

4. Select the . qcow? file.
5. Click Open > Finish.

4- Configure Disk 3 (/var)

1. Click Add Hardware at the bottom left of the screen.
2. Select the option Select or create custom storage.

3. Navigate to the contents of the folder for the appliance you
are creating.

4. Select the . qcow? file.
5. Click Open > Finish.

5 - (Optional) Add a Network Adapter

You can add a network adapter if your Filr deployment accesses a
separate network for one or more of the following reasons:

+ Appliance administration.

+ Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with
Filr.
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Page, Dialog, or Option

Do This

Summary

. Click Network Adapters.

Network Adapters

. Click New.

Virtual Network Adapter

. Specify the settings for the adapter.

. Click Apply.
Network Adapters . Click Apply.
Summary . Click OK.
The virtual machine is created, the appliance starts, and the
configuration process begins.
Console 6 - Deploy the Appliance

. Access the appliance’s console.

. When prompted, enter the root and vaadmin passwords for

the appliance.

The upgrade process proceeds automatically.

. When the appliance displays the final screen in the console

window, open your management browser and log in to the
appliance on port 9443 as the vaadmin user.

Port 9443 Admin Console

. Check the following:

* Filr:
¢ Click the Filr configuration icon.

+ Ensure that all of the settings are in place as
expected.

+ If the configuration wizard displays, there was a
problem with the configuration.

+ Resolve the configuration issues, then click Finish to

reconfigure the system.

Common configuration issues include:

+ If your system is not using DNS, the most likely

problem is unresolvable DNS names and
missing /etc/hosts entries.

+ If the appliance doesn’t have access to the

database, ensure that all of the settings are as

expected.

Post-Upgrade Tasks.”

2. When the appliance is running, continue with “Performing Filr

Upgrading Citrix Xen VMs

Complete the steps in Table 10-8.
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Table 10-8 Upgrading a Citrix Xen VM

Page, Dialog, or Option Do This

1 - Launch XenCenter.

Management 1. Start XenCenter.

Workstation

XenCenter 1. Connect to the Citrix XenServer where you planned to deploy Filr.
2. Right-click the server and select Import.

2 - Import the system disk

Locate the File you want 1.

Browse to and select the . xva file on your management workstation.

to import 2. Click Open.
3. Click Next.
Select the location 1. Select the XenServer.

where the imported VM 2
will be placed

. Click Next.

Select target storage 1.

Select the storage repository for the VM that you used in Step 2 on page 122.
Click Import.

3 - Select the network adapter

Select network to 1. Select the virtual network adapter.
connect VM 2. Click Next.

Review the import 1. Deselect Start VM(s) after import.
settings 2. Click Finish.

IMPORTANT: Depending on network latency and other factors, it can take a
while to import the system disk.

4 - Specify Memory

1.

2.
3.

If you need to adjust the memory to the amount of memory, select the newly
created VM in the left pane.

Click the Memory tab.
Click Edit, change the setting, and click OK.

5 - Specify Processors

1.

2.
3.

If you need to adjust the CPUs, right-click the newly created VM in the left
pane.

Select Properties.

Click CPU, change the setting, and click OK.

6 - Link to Disk 2 (/vastorage)

1. With the newly created VM selected in the left pane, add the copy of disk 2

for this appliance.

8 - Add Disk 3 (/var)
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Virtual Disks 1. Click Add....

Add Virtual Disk 1. Type a disk name that reflects the appliance name and that this is disk 3. For
example, Filr-1-disk-3.

2. Change the Size field value to match that of the appliance you are replacing.

3. Click Add.

9 - (Optional) Add a Network Adapter

You can add a network adapter if your Filr deployment accesses a separate
network for one or more of the following reasons:

+ Appliance administration.

+ Security of Memcached.

IMPORTANT: Bonding or teaming NICs is not supported with Filr.

1. With the newly created VM selected in the left pane, click the Networking
tab.

2. Select the secondary network associated with the Filr installation..

XenCenter 1. Continue with “Deploying the Upgraded Filr VM” on page 131.

Deploying the Upgraded Filr VM

1 Power on the appliance.

2 Access the appliance’s console.

3 When prompted, enter the root and vaadmin passwords for the appliance.
The upgrade process proceeds automatically.

4 When the appliance displays the final screen in the console window, open your management
browser and log in to the appliance on port 9443 as the vaadmin user.

5 Check the following:

+ PosgtgreSQL :
+ Click the phpPgAdmin icon.
+ Verify that the database is populated as expected.

+ Filr:
+ Click the Filr configuration icon.
+ Ensure that all of the settings are in place as expected.
+ If the configuration wizard displays, there was a problem with the configuration.

+ Resolve the configuration issues, then click Finish to reconfigure the system.
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Common configuration issues include:

+ If your system is not using DNS, the most likely problem is unresolvable DNS
names and missing /etc/hosts entries.

+ If the appliance doesn’t have access to the database, ensure that all of the
settings are as expected.

6 When the appliance is running, continue with “Performing Post-Upgrade Tasks.”

Performing Filr Post-Upgrade Tasks

After upgrading to a new version of Filr, you should perform the following tasks to ensure a fully
functional Filr system:

+ “Install Your New Filr License” on page 132

+ “Java Heap” on page 132

Install Your New Filr License

Upgraded Filr appliances have a 60-day evaluation license installed. The evaluation license is expired
in most of the cases because it considers the day of deployment as the day when it was installed
with the earlier version.

To prevent a service interruption, you must install your new license by following the instructions in
“Installing/Updating the Filr License” in the OpenText Filr 23.4: Administrative Ul Reference.

Java Heap

For optimal performance of Filr appliance, the minimum Java heap space should be 12 GB. After
upgrading the appliance, the Java heap space is overwritten with the value that was set for the
earlier Filr appliance. If new value is less, then ensure to update it to 12 GB or greater.
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Updating Filr through Online Update
Channel

Filr 23.4 is available as an online update to Filr 5.0, PostgreSQL 2.0, and Filr Search 5.0 appliances or
later. Note the following:

+ No Separate Hypervisor-specific Downloads: The virtual machine configurations are not
impacted.

For information about using the Online Update feature, see “Using the Online Update dialog” in the
OpenText Filr 23.4: Administrative Ul Reference.

IMPORTANT: ¢Ensure that the required server certificates are valid and not expired. If the
certificates are expired, update them accordingly.

+ We recommend that you schedule Online updates only for updating non-interactive patches on
Filr Appliance.

+ If you change the IP address of the proxy server that is configured on the Filr Appliances, then
you must update the proxy server configuration on the Filr Appliances before registering and
applying the online updates:

1. On the Filr Appliance, use the Yast Proxy Management tool to reconfigure the proxy server.
2. Launch a new terminal.
3. Run the following command to restart the datamodel services:
rcvabase-dat anodel restart
4. Run the following command to restart the jetty services:

rcvabase-jetty restart

Review the following sections:

+ “Updating an All-in-One (Small) Deployment” on page 133
+ “Updating a Large Filr Deployment” on page 134

Updating an All-in-One (Small) Deployment

1 Ensure that the version of the Filr appliance is 5.0 or later.

2 Login to the Filr Appliance Configuration Console (htt ps: //appl i ance_i p_or _dns: 9443)
as vaadmin.

3 Click Online Update.

4 In the Patches drop-down option, select Needed Patches and ensure that the latest patch
update is listed.

5 Click Update Now.
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6 Click OK.

A progress bar displays the status of the update. After the update completes, select the Installed
Patches option in the drop-down and verify that the latest patch is listed there.

Updating a Large Filr Deployment

+ “Recommended Before Updating to Filr 23.4” on page 134

Recommended Before Updating to Filr 23.4

+ Stop the Filr service
+ Update the Filr Search appliances with latest patches
+ Update the PostgreSQL appliance with latest patches

Perform the following steps on every Filr appliance in the cluster:

1 Ensure that the version of the Filr appliance is 5.0 or later.

2 Login to the Filr Appliance Configuration Console (htt ps: //appl i ance_i p_or _dns: 9443)
as vaadmin.

3 Click Online Update.

4 In the Patches drop-down option, select Needed Patches and ensure that the Enable update to
Filr 23.4 is listed.

5 Click Update Now.
6 Click OK.

A progress bar displays the status of the update. After the update completes, select the Installed
Patches option in the drop-down and verify that the latest patch is listed there.
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Setting Up Filr Services

Complete the following steps to prepare your Filr site and make it available to users.
1 Using the Port 9443 > License dialog, install the same valid license on each Filr appliance in your
system.
2 Change any Filr infrastructure configuration settings that require restarting Filr.

This prevents interrupting Filr services after users begin accessing Filr services.

Notifications 1. (Optional) Using the Port 9443 > Configuration >
Outbound E-mail dialog, configure your system for
integration with an external email system.

2. Usingthe Port 8443 > System > E-Mail dialog, review the
default notification settings and make any required
configuration changes.

Networking Support 1. Review the settings in the Port 9443 > Firewall dialog
and make sure that the port and firewall settings on
your network are configured to support Filr services.

2. If you are enabling port redirection so that users don’t
need to include :8443 in Filr requests, configure that
now.

Path: Port 9443 Appliance Console > Configuration >
Network

3. If you are using NetlQ Access Manager.

Path: Port 9443 Appliance Console > Configuration >
Reverse Proxy

3 Add users and groups to your Filr site and set up the LDAP synchronization processes.
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Users and Groups (LDAP and Non) 1. Configure your Filr system to connect to an existing
LDAP source, such as eDirectory or Active Directory, to
control user access to the system.

Path: Port 8443 Filr Admin Console > System > LDAP

2. Manually create any non-LDAP users and groups that
need access to Filr services.

For more information, see “Filr Admin Created Users
and Groups:” in OpenText Filr 23.4: Understanding How
Filr Works and “the New User button” in the OpenText
Filr 23.4: Administrative Ul Reference.

LDAP Synchronization 1. Configure the Filr system to synchronize with your LDAP
servers.

For assistance, see “LDAP Servers and Synchronization”
in the OpenText Filr 23.4: Administrative Ul Reference.

4 If you want users to be able to share through Filr, you must enable sharing for the Filr system.

System-Level Sharing Settings 1. Configure the system-level share settings.

For more information about allowing users to share
documents within Filr, see “Managing Sharing, License
Terms, and Comments” in the OpenText Filr 23.4:
Administrative Ul Reference.

5 if you want users to be able to upload personal files and folders directly to the Filr site, you must
enable personal storage.

Personal Storage 1. Configure Personal Storage.

For more information about allowing users to share
documents within Filr, see “Enabling Personal Storage
for Users and Groups” in the OpenText Filr 23.4:
Administrative Ul Reference.

For more information about personal storage, as well as how personal storage relates to users’
Home folders, see “Enabling Personal Storage for Users and Groups” in the OpenText Filr 23.4:
Administrative Ul Reference.

6 Configure Home Net Folder servers.

Net Folder Servers 1. Configure Home Net Folder servers.

For more information, see “Creating and Managing Net
Folder Servers” in the OpenText Filr 23.4: Administrative
Ul Reference.
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If the search context of your LDAP synchronization contains an OES or Windows server that has
a Home folder attribute associated with at least one user, a Net Folder Server is ready to be
configured immediately after running the LDAP synchronization process. You need to consider
the amount of data in users’ Home folder directories when performing an LDAP
synchronization.

The following points are critical to successful Home NF Server creation and the synchronization
of access privileges.

+ Import Both Groups and Users: If you import only LDAP users and not the groups they
belong to, then file system group permissions won't map to Filr group permissions when
Net Folders are created.

+ Register User Profiles Automatically (default): If you deselect this option, then users
won't be created until after they log in. This causes the following issues:

+ You must wait until users log in to their home folders before you can configure the
proxy users and passwords for any HOME Net Folder Servers.

+ Net Folder access permissions that key off user-based file system permissions will not
be set or updated during Net Folder Synchronizations.

+ Register Group Profiles Automatically (default): If you deselect this option, groups will not
be created and Net Folder access permissions that key off group-based file system
permissions will not be set or updated during Net Folder Synchronizations.

7 Configure Net Folder Servers.

Net Folder Servers 1. Configure the other Net Folder servers.

Home Folder Net Folder Servers For more information, see “Creating and Managing Net
Folder Servers” in the OpenText Filr 23.4: Administrative

Net Folder Server Synchronization Ul Reference.

8 Configure Net Folders.

Net Folders 1. Configure the Net Folders settings.

Net Folder Sharing Settings For more information, see “Managing Net Folders” in
the OpenText Filr 23.4: Administrative Ul Reference.
Net Folder Global Settings

Net Folder Synchronization

Net Folders in Filr provide access to files on your corporate OES, Windows, file servers by
synchronizing file metadata. In essence, a Net Folder is simply a pointer or a reference to a
specific folder on a specific file server.

Filr can be configured to index the content of Net Folders to make the content searchable.

For more information about Net Folders, see “Managing Net Folders” the OpenText Filr 23.4:
Administrative Ul Reference.

9 Enable additional Filr Users for Administrative Access.
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Administrative Access 1. Configure users for administrative access to Filr.

For more information, see “Assigning and Managing
Port 8443 Direct Administrators” in the OpenText Filr
23.4: Administrative Ul Reference.

(Optional) Allow access to the Filr site through NetlQ Access Manager.

For more information about using NetlQ Access Manager with Filr, see Chapter A, “Access
Manager (NAM) and Filr Integration,” on page 151.

IMPORTANT: When you use NetlQ Access Manager with Filr, external users cannot access your
Filr site. This means that the following features are not functional:

+ Users are not able to share with external users.
+ Users cannot make items accessible to the public.

This means that public users cannot access the Filr site as the Guest user. For more
information about the Guest user, see “Guest Users:” in OpenText Filr 23.4: Understanding
How Filr Works.

For more information about external users in Filr, see “External, Self-Provisioned Users:” in
OpenText Filr 23.4: Understanding How Filr Works.

Configure mobile device access to the Filr site, as described in “Mobile Device Access—Default
Settings” in the OpenText Filr 23.4: Administrative Ul Reference.

Configure the Filr desktop application to access files from the Filr site.

For more information about configuring the Filr desktop application.

IMPORTANT: For optimal performance of the Filr system when using the Filr desktop
application, consider the following:

+ Users should not configure the Filr desktop application to synchronize more than 1,000
total files, or to synchronize individual files that are larger than 1 GB to their workstations.
For information about how users can configure the Filr desktop application to synchronize
files to their workstations, see the OpenText Filr 23.2 Desktop Application Guide for
Windows and the OpenText Filr 23.2 Desktop Application Guide for Mac.

Configure Filr to support WebDAV on a Windows 7 environment, as described in “WebDAV
Support” in the OpenText Filr 23.4: Maintenance Best Practices Guide.

If your Filr site needs to support multiple languages, configure the site as described in “Ul
Language” in the OpenText Filr 23.4: Administrative Ul Reference.

After you have completed all of the topics in this list that are relevant to your Filr environment,
you can invite users to use the Filr site.
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Setting Up Sharing

Before users can share, they must have sharing enabled for them at the Filr system level, either
individually or as a member of a group.

After that, sharing of My Files is enabled by default, but sharing in Net Folders requires additional
steps.

Use the following sections as a guide through the process of setting up sharing.

+ “Enabling Users to Share” on page 139

+ “Do Not Enable Sharing for All Internal Users and All External Users” on page 145
+ “System-Level Sharing Must Be Configured First” on page 145

+ “My Files Sharing Is Automatic” on page 146

+ “Net Folder Sharing Must Be Explicitly Allowed At Two Levels” on page 146

Enabling Users to Share

+ “Best Practices for Setting Up Sharing” on page 139

+ “General Order for Setting Up Sharing” on page 140

+ “Enabling Sharing for Specific Net Folders” on page 144

+ “Restricting Sharing Files by Group of Users” on page 144

Best Practices for Setting Up Sharing

+ Enable Sharing for the Filr System: You must enable the sharing feature before any sharing can
take place on the Filr system.

As a best practice, enable sharing in an unrestricted way for those users and groups that will be
allowed to share.

+ If Needed, Restrict My Files Sharing: Enabling sharing automatically lets all users share files in
their My Files area, including in their Home folder and in personal storage.

You can restrict My Files sharing on a per-user basis if desired.

+ Carefully Restrict Net Folder Sharing: Net Folder sharing must be explicitly allowed for each
Net Folder.

IMPORTANT: Make sure that only those who need to share a Net Folder’s contents are granted
sharing rights on that Net Folder.

For example, Group A is granted rights to share files in Net Folder A. User A (a member of Group
A) then shares a file with User B (a member of Group B). Because the file contains sensitive
information, User A doesn’t grant User B permission to reshare the file.
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As long as User B doesn’t have rights to share files in Net Folder A, there is no problem.

However, if Group B also has permission to share Net Folder A’s files, then User B can reshare
the file even though User A assumed otherwise.

General Order for Setting Up Sharing

When you set up sharing for your Filr site, complete the necessary steps in the following order:

1 Set up sharing for the entire Filr site (as described in “Enabling Sharing in Filr” on page 140).

2 Configure sharing for individual users (as described in “Restricting Personal Storage Sharing” on
page 143).
After you have enabled sharing for the entire Filr system, you can fine-tune share rights
throughout the site on the user level.

For example, if you want only a few groups of users to be allowed to share with external users,
you first need to enable sharing to external users at the site level. After you have enabled it at
the site level, you can then remove this ability from the users who you do not want to have this
ability.

3 Set up sharing for specific Net Folders (as described in “Enabling Sharing for Specific Net
Folders” on page 144).

Users who are given share rights on a specific Net Folder are able to share files within that Net
Folder that they have rights to at least view on the file system.

Enabling Sharing in Filr

After you set up sharing for the entire Filr site, all users by default are granted rights to share files in
the My Files area (this includes files in the Home folder and files in personal storage), with the site-
wide access rights that you specify. If you want only certain users to be allowed to share files from
their My Files area, you must enable sharing for the entire site as described in this section. Then you
must restrict sharing privileges at the user level, as described in “Restricting Personal Storage
Sharing” on page 143.
1 Login to the Filr site as the Filr administrator.
1a Launch a web browser.
1b Specify one of the following URLs, depending on whether you are using a secure SSL
connection:

http://Filr_hostname: 8080
https://Filr_hostnane: 8443

Replace Fi | r _host name with the hostname or fully qualified domain name of the Filr
server that you have set up in DNS.

Depending on how you have configured your Filr system, you might not be required to
enter the port number in the URL. If you are using NetlQ Access Manager, the Filr login
screen is not used.

2 Click the admin link in the upper-right corner of the page, then click the Administration Console
icon %,

3 Under System, click Share Settings.
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The Share Settings page is displayed.

Rights Whitalist / Blacklist

| Allow all users to share with groups that have baen imparted from LOAP
selech a user or group o add 1o the list and then grant share rights

User or Group

Mo one has been selected

4 Select Allow all users to share with groups that have been imported from LDAP to enable users to
share with LDAP groups.

If you select this option, groups that were imported from the LDAP directory are displayed in
the Share with field when users are sharing an item. All users in the LDAP group then have
access to the item that was shared.

Enabling Users and Groups for Net Folder Sharing

1 To enable sharing for all internal users on the Filr site, go to the User or Group field, begin typing
Al Internal Users, then selectit when it appears in the drop-down list.

or

To enable sharing on a per-user or per-group basis, go to the Select user/group field, begin
typing the name of the user or group for whom you want to grant share rights, then select the
name when it appears in the drop-down list.

The Edit Share Rights dialog box is displayed. Select from the following options:

Re-share items: When users share a file or folder, they can give the users they are sharing with
the ability to re-share the file or folder. The user receiving the share can share the file only if
that user has been given administrative rights to share the file or folder.

IMPORTANT: When selecting this option, be aware that if one user's access rights to an item
are removed, it does not remove the access rights of the user with whom the item was re-
shared.

For example, suppose User A shares an item with User B and grants re-share rights. User B then
shares the item with User C. If User A revokes User B's access rights to the item, User C
continues to have access to the shared item.

Share with Internal users: Allows users to share items with internal users.

Share with “All Internal Users” group: Allows users to perform a mass share to all internal
users by sharing withthe Al | I nternal Users group.

Share with External users: Allows users to share items with users external to the organization.

Users external to the organization receive an email notification with a link to the shared item,
and they can then log in to the Filr site.
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Share with Public: Allows users to make items publicly available. This means that anyone with
the correct URL to the shared item can access the shared item without logging in to the Filr site.

In addition to selecting this option, you also need to enable Guest access to the Filr site if you
want to allow users to share items with the public. For information about how to enable Guest
access to the Filr site, see

Share using File Link: Allows users to share a link to a file in Filr. Any user with the link can then
access the file. However, the file is not displayed in the Public area, so users must have direct
access to the link in order to access the file.

NOTE: If you select this option, users can share a link of the Filr file even with email addresses
that are listed in the Blacklist field.

(Optional) Click the Whitelist / Blacklist tab to configure which email addresses and domains
users can share with when sharing externally.

Share Settings

Rights Whitelist / Blacklist

Specity emaill addresses and domains that may (whitelist) or
may not (blacklist) be shared with as external shares

Mode

* Mo restrictions - Lists are ignored
Whitelist - Emall addresses and domains that may be shared with
Blacklist - Email addresses and domains that may not be shared with

Email addresses

Domains

Delete shares that don't meet the criteria

The following options are available when configuring a whitelist or blacklist for sharing:

No restrictions: Select this option to disregard any email addresses or domains that might
already exist in the Email addresses and Domains fields. Selecting this option means that users
can share with any email address.

Whitelist: Select this option to allow sharing only with email addresses and domains that have
been specified in the Email addresses and Domains fields.

Email addresses: Click Add, specify the email address that you want to add to the whitelist or
blacklist, then click OK.

Blacklist: Select this option to disallow sharing with any email addresses and domains that
have been specified in the Email addresses and Domains fields.

Repeat this process to add multiple email address.
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NOTE: If a user has Share using File Link rights, the user can share links of Filr files even with the
blacklisted email addresses.

Domains: Click Add, specify the domain that you want to add to the whitelist or blacklist (for
example, yahoo. com, then click OK.

Repeat this process to add multiple domains.

Delete shares that don’t meet the criteria: Select this option to delete all existing shares in the
Filr system that do not match the criteria you set.

For example, if you selected Blacklist and then specified yahoo.com in the Domains field,
selecting this option would delete all Filr shares made to Yahoo email addresses.

3 Click OK.

Restricting Personal Storage Sharing

After you have enabled sharing of files for the entire Filr system (as described in “Enabling Sharing in
Filr” on page 140), you can restrict shared-access right granting on an individual-user basis.

You cannot grant individual users more rights than are currently defined for the site-wide setting.
To restrict share rights for specific users:

1 Log in to the Filr site as the Filr administrator.
1a Launch a web browser.
1b Specify one of the following URLs, depending on whether you are using a secure SSL
connection:

http://Filr_host name: 8080
https://Filr_hostnane: 8443

Replace Fi | r _host nane with the hostname or fully qualified domain name of the Filr
server that you have set up in DNS.

Depending on how you have configured your Filr system, you might not be required to
enter the port number in the URL. If you are using NetlQ Access Manager, the Filr login
screen is not used.

2 Click the admin link in the upper-right corner of the page, then click the Administration Console
icon '+,
3 Under Management, click Users.

4 Select the users whose sharing rights you want to manage, then click More > Workspace Share
Rights.
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k|
Set User Workspace Sharing Rights (1 users)

Allow Sharing with Allow Clear
Internal Users .
External Users .
Public .
Filr Link .

Allow Clear

Allow Re-Sharing of
granted rights

L]

5 Select the radio button in the Clear column next to the sharing right that you want to remove
from the user or group, then click OK.

or

If you have already removed a share right and you want to add it again, select the radio button
in the Allow column next to the sharing right that you want to add to the user or group, then
click OK.

Enabling Sharing for Specific Net Folders

1 Ensure that you have configured sharing as described in “Enabling Sharing in Filr” on page 140.

2 Configure sharing for the Net Folder as described in ).

Restricting Sharing Files by Group of Users

You can restrict a group of users from sharing files to others.

1 Stop the Filr service.
rcfilr stop

2 Add the following two lines to the / opt / novel | / fil r/ apache-t ontat/ webapps/ ssf/
VEB- | NF/ cl asses/ confi g/ ssf-ext. properti es file:

Syntax:
+ enabl e. sharing. excepti on=true
+ enabl e. sharing. exception. |ist=<G oupNane>

GroupName is the name of the group that you do not want to have the ability to share the
files.
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3 Start the Filr service.

rcfilr start

Do Not Enable Sharing for All Internal Users and All
External Users

Prior to the release of Filr 2.0, the documentation stated that enabling sharing for Al | | nt er nal
Users and Al | External Users was an acceptable method of enabling sharing on the system.

Unfortunately, this shortcut results in significant system overhead and often leads to serious
performance degradation.

We strongly recommend that you enabling sharing only for specific users and/or groups, as outlined
in the sections that follow.

System-Level Sharing Must Be Configured First

The first step in allowing Filr sharing to take place is to list the users and groups who are allowed to
share in the Share Settings dialog. When you add the user or group, you also specify the upper limits
of possible sharing rights for them. You can further restrict the rights, but you can’t expand them
beyond this limit.

Figure 13-1 Setting Up System-Level Sharing Rights

1. Click Share Settings.

Share Settings Q

1 Whitelist / Blacklis

| Allow all users to share with groups that have been imported from LDAP

Select a user or group to add to the list and then grant share rights

2.Begin typing, then select | g4 Growa
a user or group.

User or Group

No one has been selected 3. Select the higheSt
level of rights that the
user or group will need in
Filr, then click OK.

Grant Share Rights
Recipients will be granted share rights to:
Re-share items

Share with Internal users

Share with External users
Share with the Public
Share using File Link
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My Files Sharing Is Automatic

After sharing is enabled at the system level for users individually or as members of groups, then if
those users have personal storage enabled, they can share their files and folders within the
limitations set for the system.

Administrators can disable sharing of files and folders in My Files on an individual user basis.

Figure 13-2 My Files Share Settings

Share Settings 7]

Rights ~ Whitelist / Blacklist

[7] Allow all users to share with groups that have been imported from LDAP

Select a user or group to add to the list and then grant share rights

User or Group: |
Hame Rights
e $»  All Internal Users  Internal / External / Share with all Internal users / Share File Link
A ) }I.
LYY
I
Re-Sharing Internal
Users
System-level share settings ——~/ determine My Files settings. > @ 1 {
User Red
@ )
Guest File External
Users Link Users

Net Folder Sharing Must Be Explicitly Allowed At Two
Levels

Before the users or groups listed in the Share Settings dialog can share files and folders in their
assigned Net Folders, they must have sharing enabled on those Net Folders.

When enabling Net Folder access for a user or group, a Filr administrator can only assign up to the
maximum sharing rights that are set at the system level.

In Figure 13-3, user red can only be assigned sharing rights that are allowed at the system level.
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Figure 13-3 An Example of Net Folder Sharing

Share Settings

Rights | Whitelist/ Blacklist ~ Extemal Users Licensing Terms

¥l Allow all users to share with groups that have been imported from LDAP

Select a user or group to add to the list and then grant share rights.

User or Group: \

Hame Rights Type

redapple  Intemal / External / Share File Link =  User @

.

’System—level share settings

\to a Net Folder user.,

limit the sharing rights ! .
that can be granted

IManage Net Folders

£ Net Folder: training-ces 7] I

g Confiy Grant Rights
@ Defing Grant recipient rights for this Net Folder.

** Note ** You must set the appropriate rights in the Share Settings
Userg dialog in order for the recipient to perform share eperations

= Hame Allaw access to the Net Folder Granted

] redaj | Recipient can share files in this Net Folder with:

@ Elrﬂema\ users Granted

= E External users Granted
[ Public Not available

[} Share using File Link Available, but not granted
) Allow the recipient to grant files re-share privilege — Not available
Recipient can share folders in this Net Folder with:

Elmema\ users Granted
) Extemnal users Available, but not granted
O Public Not available
[ Allow the recipient to grant folders re-share privilege —Not available
Guest Users File Link Re-Sharing Internal
(Public) Users

Files & Folders [ | (Ml

I

User redapple

Files Only [l | @]

External
Users
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I Appendixes

The following:

*

Appendix A, “Access Manager (NAM) and Filr Integration,” on page 151
Appendix B, “All-in-One (Small) Deployment—Creating,” on page 161
Appendix C, “Non-Expandable Deployment—Creating,” on page 163
Appendix D, “SCSI Controller Type—Changing on VMware,” on page 165
Appendix E, “Troubleshooting Filr,” on page 167

Appendix F, “Filr Limitations,” on page 171
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Access Manager (NAM) and Filr
Integration

You can configure NetlQ Access Manager (NAM) to act as Proxy service for a Filr site. This helps you
provide the ease of single sign-on and establish a trusted relationship with the Access Gateway.
Using Filr in conjunction with NetlQ Access Manager adds enterprise-level security to your Filr
system.

NOTE: Guest users cannot access Filr through NAM.

Review the following sections:

+ “Overview” on page 151

+ “Configuring Filr Ports” on page 152

+ “Downloading and Installing the Filr Authentication Plugin” on page 152
¢ “Configuring the NAM Identity Server” on page 152

+ “Configuring a Reverse-Proxy Single Sign-On Service for Filr” on page 154

Also, for information on configuring NAM with Content Editor, see the “Content Editor With NetlQ
Access Manager For Online Edit Feature” on page 81

Overview

To integrate Filr with NAM, you must configure the NetlQ Access Manager Identity Server, the Access
Gateway, and configure protected resources for a Filr server.

The integration of Filr with NAM allows both LDAP and non-LDAP (local and external) users to log in
to Filr through Web client, Desktop and Mobile clients through NAM.

To integrate Filr with NAM for non-LDAP users, you must create new classes, methods, and contracts
in NAM. For LDAP users, you can either use the predefined NAM classes, methods, and contracts, or
create new ones. If you have both LDAP and non-LDAP users, then you can create a new class,
method, and contract to support the authentication for both LDAP and non-LDAP users.

Filr introduces a new authentication plugin to enable both LDAP and non-LDAP (local and external)
users to log in to Filr through NAM. To download and install the authentication plugin, see
“Downloading and Installing the Filr Authentication Plugin” on page 152.

For information about NetlQ Access Manager, see the Access Manager Documentation website.
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Configuring Filr Ports

Use the following port configuration when NetlQ Access Manager is fronting your Filr system:

¢ HTTP Port: 80
¢ Secure HTTP Port: 443
You must configure the port on the Reverse Proxy and Network page of the Port 9443 Appliance

Console. For more information, see “Reverse Proxy Configuration Settings” and “Network
Configuration” in the OpenText Filr 23.4: Administrative Ul Reference.

Downloading and Installing the Filr Authentication Plugin

To enable Filr users to access the Filr services through NetlQ Access Manager (NAM), Filr provides an
authentication plugin that you must download and install on the NAM server that you want to use as
a proxy server.

To download and install the plugin:
1 Open a browser on your administrative workstation and access the Port 9443 Appliance
Console on the first Filr appliance using the following URL:
https://Filr_|I P_Address: 9443
Where Filr_IP_Address is the IP address of the Filr appliance.

2 Click the Configuration [#] and then click Reverse Proxy.

3 In the NetlQ Access Manager Integration section, click Filr Plugin for NAM to download the
Fi I rAut hd ass. | ar file.

4 Copythe Fil r Aut hd ass. j ar file to the following locations on the NAM server:
¢ Linux:/opt/ novel I/ nids/lib/webapp/ VEB-1 NF/lib

+ Windows: C.\ Program Fil es (x86)\ Novel |\ Tontat\ webapps\ ni dp\ VEB-
I NF\ cl asses

5 Run the following commands to restart the Identity Server and the Access Gateway:
+ Identity Server: /etc/init.d/ novell-idp restart
+ Access Gateway:/etc/init.d/ novell-mag restart

Configuring the NAM Identity Server

+ “Configuring the Identity User Store” on page 153

¢ “Creating the Authentication Class” on page 153

¢ “Creating the Authentication Method” on page 153
¢ “Creating the Authentication Contract” on page 154
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Configuring the Identity User Store

Configure an identity user store to which the Filr users should authenticate. See “Configuring
Identity User Stores” in the NetlQ Access Manager Administration Guide.

Creating the Authentication Class

Authentication classes let you define ways of obtaining end-user credentials.
Perform the following steps to create a class:

1 Login to the NAM Administration Console.
2 Click Devices > Identity Server > Servers > Edit > Local > Classes.
3 Click New to launch the Create Authentication Class wizard, then fill in the following fields:
+ Display name: Specify a name for the class.
+ Java class: Select Other.
+ Java class path: Specify com novel | . nam aut henti cati on. Fi | r Aut hd ass.
4 Click Next and then click New to add the following properties for the class:
+ Property Name: Specify Fi | r WsURL.

+ Property Value: Specify the HTTP or HTTPS URL of the Filr server in the format:
http(s)://1P_Address_of Filr_Server: port_nunber.

5 Continue with Creating the Authentication Method.

Creating the Authentication Method

Authentication methods let you associate authentication classes with user stores.

1 Log in to the NAM Administration Console.

2 click Devices > Identity Server > Servers > Edit > Local > Methods.

3 Click New to launch the Create Authentication Method wizard, then fill in the following fields:
+ Display name: Specify a name for the method.
+ Class: Specify the name of the class that you created in Creating the Authentication Class.
+ Identifies User: Ensure that this option is selected.

+ User stores: Add user stores to search. You can select from the list of all the user stores
you have set up. If you have several user stores, the system searches through them based
on the order specified here. If a user store is not moved to the User stores list, users in that
user store cannot use this method for authentication.

4 Continue with Creating the Authentication Contract.
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Creating the Authentication Contract

Authentication contracts define how authentication occurs. Perform the following steps to create a
new contract with the authentication method you created in Creating the Authentication Method.
1 Log in to the NAM Administration Console.
2 click Devices > Identity Server > Servers > Edit > Local > Contracts.
3 Click New to launch the Create Authentication Method Wizard, then fill in the following fields:
+ Display name: Specify a name for the contract.

+ Methods: Add the authentication methods that you created before from the list of the
available methods.

4 To save the configuration changes, click Devices > Identity Servers, then click Update All.

5 Continue with “Configuring a Reverse-Proxy Single Sign-On Service for Filr” on page 154.

Configuring a Reverse-Proxy Single Sign-On Service for Filr

The Access Gateway can be configured as a reverse proxy server that provides single sign-on to Filr
and restricts access to the Filr server by securely providing credential information for authenticated
users.

To configure a reverse-proxy single sign-on service for Filr, complete the following tasks:

+ “Creating a New Reverse Proxy” on page 154

+ “Configuring the Proxy Service” on page 154

+ “Creating Policies” on page 155

+ “Configuring Protected Resources” on page 156

+ “Configuring a Rewriter Profile” on page 158

Creating a New Reverse Proxy

You must ensure that the Reverse Proxy that you use for integrating NAM with Filr listens on the
default HTTP (port 80) and HTTPS (port 443) ports.

Before you can configure the proxy service, you need to create a new reverse proxy. See “Configuring
a Reverse Proxy” in the NetlQ Access Manager Administration Guide.

Configuring the Proxy Service

1 Inthe NAM Administration Console, click Devices > Access Gateways > Edit, then click the name
of the reverse proxy that you created in “Creating a New Reverse Proxy” on page 154.

2 In the Reverse Proxy List, click New and then fill in the following fields:
Proxy Service Name: Specify a display name for the proxy service.

Published DNS Name: Specify the publicly-available DNS name for accessing your Filr site. This
DNS name must resolve to the IP address you set up as the listening address. For example,
filr.doc. provo. m crof ocus. com
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Web Server IP Address: Specify the IP address of the Filr server.
Host Header: Select Forward Received Host Name.

Web Server Host Name: Because of your selection in the Host Header field, this option is
dimmed.

Click OK.

Click the newly added proxy service, then select the Web Servers tab.
Change the Connect Port to the default HTTP or HTTPS Filr web service port.
Click OK.

N o 1 ~AW

Continue with “Creating Policies” on page 155.

Creating Policies

You need to create two policies: LDAP Identity Injection and X-Forwarded-Proto:

+ “Creating the LDAP Identity Injection Policy” on page 155
+ “Creating the X-Forwarded-Proto HTTP Header Policy” on page 156

Creating the LDAP Identity Injection Policy

1 In the NAM Administration Console, click Policies > Policies.
2 Select the policy container, then click New.

3 Specify | dap_aut h as the name for the policy, select Access Gateway: Identity Injection for the
type, then click OK.

4 (Optional) Specify a description for the injection policy. This is useful if you plan to create
multiple policies to be used by multiple resources.

5 In the Actions section, click New, then select Inject into Authentication Header.
6 Fill in the following fields:

User Name: If users are provisioned with cn or ui d attributes, select Credential Profile, then
select LDAP Credentials:LDAP User Name. In the Refresh Data Every drop-down, select Session.

Password: Select Credential Profile, then select LDAP Credentials:LDAP Password.
7 Leave the default value for the Multi-Value Separator, which is comma.
8 Click OK.
9 To save the policy, click OK, then click Apply Changes.

For more information on creating such a policy, see “Configuring an Authentication Header
Policy” in the NetlQ Access Manager Administration Guide.
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Creating the X-Forwarded-Proto HTTP Header Policy

If your network provides HTTPS (secure) connections between browsers and NAM but HTTP
(insecure) connections between NAM and Filr, we strongly recommend creating an X-Forwarded-
Proto HTTP Header Policy as a best practice.

1 In the NAM Administration Console, click Policies > Policies.

2 Select the policy container, then click New.

3 Specify x- f or war d as the name for the policy, select Access Gateway: Identity Injection for the
type, then click OK.

4 (Optional) Specify a description for the injection policy. This is useful if you plan to create
multiple policies to be used by multiple resources.

5 In the Actions section, click New, then select Inject into Custom Header.
6 Fill in the following fields:
Custom Header Name: Specify X- For war ded- Pr ot 0 as the name.
Value: Select String Constant in the drop-down, then specify ht t ps.
7 Leave the other settings at the defaults.
8 Click OK.
9 To save the policy, click OK, then click Apply Changes.

For more information on creating such a policy, see “Configuring an Authentication Header
Policy” in the NetlQ Access Manager Administration Guide.

Configuring Protected Resources

You must create two protected resources: a protected resource for HTML content and a public
protected resource for web services.

1 Create a protected resource for HTML content:
1a In the Protected Resource List, click New. Specify a name, then click OK.

1b (Optional) Specify a description for the protected resource. You can use it to briefly
describe the purpose for protecting this resource.

1c In the Authentication Procedure, select Contracts and specify the value that uses the
FilrAuth method.

1d In the URL Path List, add the following paths for HTML content:

[filr

[filrl
[filr/authenticatedAttachnent/*
[filr/legacy/share-report/*
[filr/legacy/viewdetails
[filr/login

[filr/user/*

/rest/auth/login
[filr/permalink/*
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Servers P Configuration b Reverse Proxy B Protected Resources b

Overview: AG-Cluster - TEST-INTEGRATION - TEST - HTML

mmﬁz&ﬁm | Identity Injection | Form Fill |

Protected Resource: HTML
Description: !l [
Authentication Procedure: ® Cantracts: | Any Contract v [2 OAuth Token

Access Gateway

URL Path List Browser Web Server

New... | Delete 8 itemis) bz =
ot [ A3
URL Path K =X,
L il =% I
e il
{itrs —

Hile/ authenticatedal et/
| Lfilr/legacy/share-report/*
AHilr/ legacy/view-details
Hilr/lpgin
| Hilr/users*

[rest/auth/login

[ilr/permalink/*

Server(s) must be updated before changes made on this panel will be used. See Configuration Panel for summary of changes.

le Click OK.
2 Create a public protected resource for Web Services:

2a
2b

2c
2d
2e

In the Protected Resource List, click New. Specify publ i ¢ for the name, then click OK.

(Optional) Specify a description for the protected resource. You can use it to briefly
describe the purpose for protecting this resource.

In the Authentication Procedure, select Contracts and specify the value as None.
Click OK.
In the URL Path List, add the following paths for public content:

/
/*
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Servers P  Configuration # Reverse Proxy #  Protected Resources B

Overview: AG-Cluster - filr4311 - FILR43111 - public-html

MAmhmn | Identity Injection | Form Fill

Protected Resource: public-html
Description: I )
Authentication Procedure: @ Contracts: [Mane] v |l O OAuth Token

Access Gateway

URL Path List Web Server
Mew... | Delste 2 Itemis) r—
[] URL Path E’ ’D. .

[0 —
| B il - ——— |

L

Server(s) must be updated before changes made on this panel will be used. See Configuration Panel for summary of changes.

2f Click OK.
3 Assign the X-Forwarded-Proto Header policy to both protected resources that you created:

3a Click Access Gateways > Edit > [Name of Reverse Proxy] > [Name of Proxy Service] >
Protected Resources.

3b For each Filr protected resource, click the Identity Injection link, select the x-forwarded
policy that you created, click Enable, then click OK.

3¢ Click OK.
4 Assign the Identity Injection policy to the HTML protected resource that you created.

4a Click Access Gateways > Edit > [Name of Reverse Proxy] > [Name of Proxy Service] >
Protected Resources.

4b For each Filr protected resource, click the Identity Injection link, select the Idap_auth policy
that you created, click Enable, then click OK.

4c¢ Click OK.

5 Inthe Protected Resource List, ensure that the protected resources that you created are
enabled.

6 To apply your changes, click Devices > Access Gateways, then click Update All.

Configuring a Rewriter Profile
1 Click Devices > Access Gateways > Edit > [Name of Reverse Proxy] > [Name of Proxy Service] >
HTML Rewriting.
2 In HTML Rewriter Profile List, click New.
3 Specify a name for the profile, select Word as the search boundary, then click OK.

4 Inthe And Document Content-Type Header Is section, click New, then specify the following type:
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application/rss+xni

In the Variable or Attribute Name to Search for Is section, click New, then specify the following as
the variable to search for:

val ue

Click OK.

7 Inthe Protected Resource List, ensure that the protected resources you created are enabled.

To apply your changes, click Devices > Access Gateways, then click Update All.
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All-in-One (Small) Deployment—
Creating

To create an all-in-one deployment, you install one Filr appliance. By default Filr also includes the
PostgreSQL database and Filrsearch functions.

Ensuring All-in-One Suitability

With few exceptions, small deployments are only suitable for proof-of-concept deployments, which,
by definition, do not require extensive planning.

The OpenText best practice recommendation is always an expandable deployment, which is the
focus of this guide.

All-in-One System Requirements

Most of the requirements in Chapter 3, “Filr System Requirements,” on page 13 apply to small
deployments.

However, minimum RAM and CPU recommendations are increased to handle the database and
search functions running in addition to Filr.

+ 20 GB of RAM
+ 4 CPUs

60% of the RAM should be dedicated to the Java heap.

For information about adjusting the Java heap settings, see “Changing JVM Configuration Settings”
in the OpenText Filr 23.4: Administrative Ul Reference.

All-in-One Deployment

To deploy an all-in-one Filr appliance, complete the instructions in the following sections:

Table B-1

Section Additional Information

Chapter 5, “Downloading and Preparing the Filr You only need to download the Filr software for your
Software,” on page 25 virtualization platform.

Chapter 6, “Deploying the Virtual Machines,” on Follow the instructions in the section for your

page 29 virtualization platform.

Chapter 7, “Starting and Configuring the Filr Follow the instructions in the referenced section,
Appliances,” on page 41 then continue with
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Setting Up an All-in-One (small) Filr Appliance

Table B-2 Logging in and Setting Up a Small Filr Appliance

Page, Dialog, or Option

Do This

Filr Appliance Sign In

Filr Appliance Tools

Filr Configuration Wizard
Database

Default Locale

1. Open a management browser on your administrative workstation and access

the Port 9443 Administration Utility on the Filr appliance using the following
URL:

https://filr_| P_Address: 9443

Where IP_Address is the IP address of the Filr appliance.

. Login as the vaadni n user with the password that you set for the appliance

in “Vaadmin password and confirmation:” on page 43.

-]
. Click the Configuration icon # | to launch the Filr Configuration Wizard.

. Click Next.
. Type and confirm a password for the filr user in the PostgreSQL database.

. Select your Locale from the dropdown list.

. Change the Administrator User ID if you want to.

The User ID that you enter is also the password for the initial login for the
Port 8443 administration console.

3. Click Finish.

. Do not close or exit the browser page until the warning message disappears.
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Non-Expandable Deployment—
Creating

The steps required to create a non-expandable Filr deployment are almost identical to those for an
expandable deployment.

Do the following:

1. Begin with Chapter 2, “Planning Is Critical,” on page 11 and complete all of the instructions that
apply to your virtualization platform and plans.

2. Skip Chapter 4, “Setting Up Shared Storage,” on page 21.

3. Follow the instructions in the remaining sections as they apply.
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SCSI Controller Type—Changing on
VMware

To change the SCSI controller type on a VMware-based appliance to VMware Paravirtual:

1. Finish the installation and power on the Filr system.

2. Ensure that the Filr system is running. (Log in as the Filr administrator, create a user, and log in
as that user.)

3. Shut down each appliance in the Filr system. (For information about how to safely shut down an
appliance, see “Shutting Down and Restarting the Appliance” in the OpenText Filr 23.4:
Administrative Ul Reference.)

4. In VMware, change the controller to VMware Paravirtual.

5. Power on each appliance in the Filr system.
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E Troubleshooting Filr

+ “Installation Issues” on page 167

+ “Upgrade Issues” on page 167

Installation Issues

Unable to Access a Newly Installed Appliance

If you are unable to access a newly installed appliance and you need to change appliance settings,
such as the IP address, use the VACONFIG utility from the Filr command prompt.

For more information, see “Using VACONFIG to Modify Network Information” in the OpenText Filr

23.4: Maintenance Best Practices Guide.

Upgrade Issues

The Upgrade Dialog Box Is Not Displayed during an Upgrade

The following dialog box should be displayed when powering on the new appliance.

Updating Movell FilrAppliance from version XXX X to version X X XX

1oot Password: Confirm root Passsord:

L ]|

vaadmin Password: Caonfirm vaadmin Password:

LCancel | [ (513 ]

vasT

If it is not displayed, the data storage location was not successfully copied or attached to the new Filr
system. Begin the upgrade process again and ensure that you have configured the new Filr system to

point to the data storage location of the source Filr system.
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Rolling Back to the Previous Version after an Unsuccessful
Upgrade

You can roll the Filr system back to the previous version if the upgrade is unsuccessful.

+ “Rolling Back a Small or Non-Clustered Filr System” on page 168
+ “Rolling Back a Clustered Filr System” on page 168

Rolling Back a Small or Non-Clustered Filr System

You should have created a copy of the data storage location (/vastorage) to be used in the new Filr
system (as described in “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109).

If you experience complications when upgrading the Filr system, your existing Filr system is still
intact and you are able to power it on at any time.

Rolling Back a Clustered Filr System

A clustered Filr system (multiple Filr appliances) consists of not only a data storage location (/
vast or age), but also shared storage (/ vashar e).

+ “Rolling Back the Data Storage Location (/vastorage)” on page 168
+ “Rolling Back the Shared Storage Location (/vashare)” on page 168

Rolling Back the Data Storage Location (/vastorage)

You should have created a copy of the data storage location (/ vast or age) to be used in the new Filr
system (as described in “Copying Each Appliance’s /vastorage Disk (Disk 2)” on page 109).

If you experience complications when upgrading the Filr system, the data storage location of your
existing Filr system is still intact.

Rolling Back the Shared Storage Location (/vashare)

After an unsuccessful upgrade, you can roll back the shared storage location (/ vashar e) to the
previous version by reconfiguring clustering on the Filr server:
1 On the Filr appliance that you are rolling back to, log in as the Filr administrator.
https://ip_address: 9443
Replace ip_address with the IP address of your Filr appliance.

2 Sign in to the Filr appliance using the vaadm n user and the password that you set during
installation.

The Filr Appliance landing page is displayed.

e
3 Click the Filr Server ConfigurationE icon.

4 Click Clustering.
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5 In the Server Address field, add the port number to the server address of each search index
appliance.

For example, change 172. 17. 2. 2to 172.17. 2. 2: 11211
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F Filr Limitations

+ “Installation” on page 171

¢ “Upgrade” on page 172

+ “Appliance” on page 172

+ “Configuration” on page 172

+ “Net Folder” on page 175

+ “Filr Appliance” on page 176

+ “Database Appliance” on page 183
+ “Desktop Application” on page 184
+ “Mobile Apps” on page 184

+ “Web Application” on page 187

+ “Windows Subsystem For Linux and Filr Client” on page 188

Installation

+ “Importing of .ovf and .vmdk Files Fails with VMware vSphere 6.7 Update 2” on page 171
+ “NFS Mount Point Must Not Point to /var on Target Server” on page 171

Importing of .ovf and .vmdk Files Fails with VMware vSphere 6.7
Update 2

Import of . ovf and . vndk files fails when using VMware vSphere 6.7 Update 2. This issue is planned
to be fixed by VMware in their upcoming updates. A workaround is available to resolve this issue in
the TID 7023863 https://support.microfocus.com/kb/doc.php?id=7023863.

NFS Mount Point Must Not Point to /var on Target Server

Large installations require shared NFS or CIFS storage for the / vast or age mount point on the Filr
server.

If you are using NFS, you must not target the / var mount point or a child directory within it. Doing
so will cause / vast or age to fail to mount when the Filr appliance reboots. (See TID 7017379.)
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Upgrade

+ “Rolling Upgrades Are Not Supported in a Clustered Environment” on page 172

Rolling Upgrades Are Not Supported in a Clustered Environment

Rolling upgrades (upgrading one Filr or search index server while another continues to serve clients)
are not supported when upgrading Filr in a clustered environment.

You must shut down all Filr and search index appliances before you begin the upgrade process. Then
restart the appliances after the upgrade is complete.

This issue does not affect small or non-clustered large installations.

For information about how to upgrade Filr, see “Upgrading a Large Filr Deployment” in the OpenText
Filr 23.4: Installation, Deployment, and Upgrade Guide.

Appliance

+ “VYMware Snapshots and Appliance Backup” on page 172

VMware Snapshots and Appliance Backup

Do not use VMware snapshots as a backup method for Filr. Doing so inhibits your ability to upgrade
Filr in the future.

If you do use snapshots, you must remove them before upgrading to a new version of Filr.

For more detailed information about how to back up various Filr components, see “Backing Up Filr
Data” in the OpenText Filr 23.4: Maintenance Best Practices Guide.

Configuration

+ “User Name Character Restrictions for LDAP Synchronization and Login” on page 173

+ “User Names That Are Synchronized from LDAP Are Not Case Sensitive for Filr Login” on
page 173

+ “Disabling Web Access Does Not Block Guest Access” on page 173
+ “Unable to Upload Site Branding Image to Filr” on page 173
+ “Distributed File System (DFS) Issues” on page 173

+ “Access Manager Issues” on page 174
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User Name Character Restrictions for LDAP Synchronization and
Login

LDAP user names must contain only valid alphanumeric characters 0 - 9 and upper-case and lower-
case letters (A-Z). User names that contain ASCII characters and special characters (for example, / \ *
?"<>:|)cannot be used as Filr user names. If your LDAP directory includes user names with these
characters, they synchronize to Filr, but the associated users cannot log in.

These characters cannot be used in a Filr user name because a Filr user name becomes the user’s
workspace title, and the workspace title becomes an element of the hierarchical path that leads to
the workspace. These characters are not legal characters in Linux and Windows pathnames.

User Names That Are Synchronized from LDAP Are Not Case
Sensitive for Filr Login

User names that are synchronized from an LDAP directory are not case sensitive when users log in to
the Filr system.

Local user accounts (user accounts that are created in Filr and not synchronized from an LDAP
directory) are case sensitive. Login credentials for local user accounts are stored in the MySQL
database.

Disabling Web Access Does Not Block Guest Access

If both Allow Guest Access and Disable Web Access are selected on the Web Application page of the
Administration Console, then Enter as Guest is displayed on the initial Web Access Login dialog and
Guest users can see publicly available files and folders.

If you choose to disable the web access, you should ensure that the guest access is not enabled.

Unable to Upload Site Branding Image to Filr

If a user with administrator privileges chooses to upload image that has to be used in the site
branding to Filr, the image fails to upload.

To upload site branding image to Filr, you must login as the built-in Filr administrator (admin).

Distributed File System (DFS) Issues

+ “Access Based Enumeration Is Not Supported When Using DFS Namespace” on page 173
+ “NSS AD DFS Junction Visibility Requires Net Folder Rights Cache Refreshing” on page 174
¢ “Unable to Access Data on a DFS Junction In an OES Server Cluster Environment” on page 174

Access Based Enumeration Is Not Supported When Using DFS Namespace

Filr doesn’t support Microsoft’s Access Based Enumeration (ABE) when the backend Windows server
uses the Distributed File System (DFS) namespace.
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NSS AD DFS Junction Visibility Requires Net Folder Rights Cache
Refreshing

If you have a remote DFS junction on an OES 2015 server that is running NSS for AD, you must ensure
that the Refresh Cached Rights interval under Net Folder Settings in the Filr administration console is
not set to 0 minutes (meaning that it’s disabled). Otherwise, Filr users will not be able to access files

and folders under the DFS target through Filr and the owner of all the files and folders under the
target will be displayed as Fi | e Sync Agent in Filr.

Unable to Access Data on a DFS Junction In an OES Server Cluster
Environment

When the Filr server encounters issue accessing data on a DFS junction in an OES cluster
environment, the following error displays:

Convert Xpl at Err TOFAMIErr xpl at status: 0xc7e90503

To fix this problem, ensure that the VLDB service is up and running. For more information about the
VLDB service, see OES Documentation.

Access Manager Issues

+ “Unable to Log Into Filr as a Guest User When Filr is Fronted by Access Manager” on page 174

+ “Unable to Edit a File Using the Edit-in-Place Functionality When Filr is Fronted by Access
Manager” on page 174

+ “Logout Does Not Happen When Filr Is Accessed Directly and Is Fronted by Access Manager” on
page 175

+ “External User confirmation Link Displays the Filr login page Even When Filr Is Fronted by Access
Manager” on page 175

+ “Cannot Use Multiple Identity Injection Policies Simultaneously” on page 175

Unable to Log Into Filr as a Guest User When Filr is Fronted by Access
Manager

Currently, you cannot use a guest user account to log into Filr that is fronted by Access Manager.

Unable to Edit a File Using the Edit-in-Place Functionality When Filr is
Fronted by Access Manager

If you attempt to edit a file using the edit-in-place functionality when Filr is fronted by Access
Manager, the file fails to open.

To workaround this issue, do the following:

1 Login to the Access Manager server.

2 Navigate to Devices > Access Gateways > [Name of the Access Gateway Server] > Edit > Advanced
Options.
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3 Set the advanced option NAGA obal Opti ons Al | omvBWebDavM ni Redi r to on.

4 To apply your changes, click Devices > Access Gateways, then click Update All.

Logout Does Not Happen When Filr Is Accessed Directly and Is Fronted by
Access Manager
When Filr is fronted by NetlQ Access Manager, only the Filr administrator is able to access Filr

directly. When Filr is accessed directly in this configuration, simultaneous logout for the Filr system is
not successful.

After the Filr administrator logs in directly to Filr (and Filr is configured with Access Manager), all
browser sessions should be immediately closed to ensure logout.

External User confirmation Link Displays the Filr login page Even When
Filr Is Fronted by Access Manager

After using the registration link for self-provisioning your user account on the Filr server that is
fronted by Access Manager, clicking the same confirmation link again directs you the Filr login page
instead of NAM login page.

Cannot Use Multiple Identity Injection Policies Simultaneously

When NetlQ Access Manager is configured to front Filr, you cannot use multiple identity injection
policies simultaneously.

Net Folder

+ “Active Directory Cross Forest Trust Relationship Is Not Supported” on page 175
+ “Moving or Renaming a File from the File Server Removes Shares” on page 176
+ “Folder Path in Filr Cannot Exceed 48 Levels” on page 176

+ “Modifying the Target Location in a Junction Created On the OES Server Does Not Reflect in the
Filr Net Folder Pointing to the Junction” on page 176

Active Directory Cross Forest Trust Relationship Is Not Supported

Cross Forest Trust relationships in Active Directory are not supported in Filr.

Moving or Renaming a File from the File Server Removes Shares

If a user moves or renames a file directly from the file server (instead of using a Filr client to do the
move or rename), any shares that are associated with that file in Filr are removed. This means that
users who gained access to a file via a share in Filr no longer have access to the file if the file was
moved or renamed from the file server. Additionally, the file is not displayed in users’ Shared by Me
and Shared with Me views.

If this situation occurs, files must be re-shared in Filr.

Filr Limitations 175



176

Folder Path in Filr Cannot Exceed 48 Levels

When folders on the file system are synchronized to a Net Folder, the folder path in Filr cannot
exceed 48 levels deep (nested sub-folders). The file synchronization code will reject any sub-folder
whose depth will cause the corresponding Filr folder path to exceed the sub-folder limit of 48.

When the Filr system encounters the limit of 48 folder levels, the sync code returns the following
message and the folder is not created:

The fol der xxx has reached the allowed path maxi numdepth. Its sub-fol ders
will not be added in the system

Modifying the Target Location in a Junction Created On the OES
Server Does Not Reflect in the Filr Net Folder Pointing to the
Junction

Create a junction on the OES Server and then create a net folder in Filr pointing to this junction. On
changing the target location in this junction, the net folder still continues to point to the older target
location in the junction. Consequently, the contents of the net folder continues to be the files and
folders in the older target location.

To view the contents of the new target location in the net folder, run the following command to
restart famtd.

rcnovel |l -fantd restart

Filr Appliance

+ “Reporting Issues” on page 177

+ “My Files Storage Directory Is Displayed in Search” on page 177

+ “Sharing Issues” on page 177

+ “Editing an .rtf File Results in an Editing Conflict Error” on page 178
+ “LDAP Synchronization Issues” on page 178

+ “Email Issues” on page 180

+ “Cannot Upload Documents Created with Apple iWork (Pages, Keynote, etc.) or .app Documents
to the Filr Web Client” on page 180

+ “Unable to Upload Microsoft OneNote Files to Filr” on page 180

¢ “Cannot Extract ZIP File after Downloading on Mac” on page 180

+ “Issues When Downloading Multiple Files with Safari on Mac” on page 181
+ “File Name Should Not Be More Than about 200 Characters” on page 181

+ “WebDAV Issues” on page 181

+ “Cannot Log in to Web Client with Long User ID or Password” on page 182
+ “Display Issues Due to Third-Party Software” on page 182

+ “Cannot View ODP and ODG Files That Contain Charts, Graphs, and Tables When Viewing in
HTML Format” on page 182
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¢ “User Home Directories Are Not Synchronized until Trustee Cache Information is Updated” on
page 183

+ “Filr Does Not Support Aliases That Have Been Configured in the LDAP Directory” on page 183
+ “Cannot Use Text Editors Such as Notepad or Wordpad as a Document Editor” on page 183

+ “Must Restart All Appliances after a Network Failure with Microsoft SQL” on page 183

Reporting Issues

+ “License Report Issues” on page 177

License Report Issues

The License Report currently counts Administrator, Guest, and three internal users

(_emai | Posti ngAgent, _j obProcessi ngAgent, and _synchroni zati onAgent ) as local
users. The Administrator counts as an active user, but the other four local users do not count against
your Filr license usage.

For information about how to generate a license report, see “License Report” in the OpenText Filr
23.4: Administrative Ul Reference.

My Files Storage Directory Is Displayed in Search

When Personal Storage is disabled and Home folders have not been configured, users can find a
directory called My Files Storage when clicking in the global Search field and pressing the Spacebar.
This is normally a hidden directory, but can it be displayed under these special circumstances.

When you click My Files Storage, it can take you to either your My Files area or to the profile of
another user (depending on where you are when you do the search).

Sharing Issues

+ “External User Share Invitation Link and Confirmation Link Are Valid Only Once” on page 178

+ “Files Shared with Users In Share Point Does Not Appear in Shared with Me or Shared by Me
Areas in Filr” on page 178

External User Share Invitation Link and Confirmation Link Are Valid Only
Once

When a file is shared with an external user, the user receives an invitation email with a link to
register self and then a confirmation email with a link to sign in and access the shared items. The
user cannot use these links to access the file post they have registered and confirmed the
registration. To access the file again, they must log in to the site where the file is shared with them.
For this, the external users must note the hostname of the site from which they accessed the file for
the first time by clicking the Sign in and access shared items link in the confirmation email.
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Files Shared with Users In Share Point Does Not Appear in Shared with
Me or Shared by Me Areas in Filr

When users share files on Share Point servers, the files do not appear in the Shared by Me or Shared
with Me folders. However, the users with whom the files were shared can see the shared files if they
are in Net Folders and if the users have access to the Net Folders.

Editing an .rtf File Results in an Editing Conflict Error

After editing an . rt f file from Filr in a text editor (such as Microsoft Word), saving the file results in
a message indicating that the file has been changed by another author. In this case, select the option
to combine your changes with the other author’s changes, then click OK.

Changes that you make to the file are saved to Filr as expected.

LDAP Synchronization Issues

+ “Issues with Initial Synchronization of Filr Users” on page 178

+ “Sub-Groups Are Not Included in Group Membership during the Initial Synchronization” on
page 179

+ “Issues with Renaming and Moving Users in Your LDAP Directory” on page 179

+ “Users Cannot Log in to the Filr Mobile App or Desktop Application with New Name or Password
after Changed in LDAP” on page 179

+ “Duplicate User ID Import Attempts Are Logged but Not Reported” on page 179

Issues with Initial Synchronization of Filr Users

The LDAP value of the attribute you specify for the LDAP configuration setting LDAP attribute for the
Filr account name must be unique throughout your LDAP directory. For example, if you specify cn, all
users in the LDAP directory might not have a unique value.

To resolve this issue, use an attribute whose value is always unique across all containers, such as
emai | Addr ess.

Sub-Groups Are Not Included in Group Membership during the Initial
Synchronization

When synchronizing groups that contain sub-groups to Filr from an LDAP directory, the sub-groups
are not included in their parent group’s membership during the initial synchronization.

Perform an additional LDAP synchronization to ensure that group membership contains all expected
sub-groups.
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Issues with Renaming and Moving Users in Your LDAP Directory

In order to rename or move users in your LDAP directory, ensure that you have specified a value for
the setting LDAP attribute that uniquely identifies a user or group, as described in “LDAP Servers and
Synchronization” in the OpenText Filr 23.4: Administrative Ul Reference. If a value is not specified for
this setting, renaming or moving users in your LDAP directory might result in new users being
created in Filr or in the existing user account being deleted.

Users Cannot Log in to the Filr Mobile App or Desktop Application with
New Name or Password after Changed in LDAP

After a user is renamed in the LDAP directory or after a user’s password is changed in the LDAP
directory, the user must use the old user name or password when logging in to the Filr mobile app or
the Filr desktop application until one of the following occurs:

+ An LDAP synchronization is run

+ The user logs in to the web client using the new user name or password

A user can use the old or new user name or password when logging in to Filr from the web client.

Duplicate User ID Import Attempts Are Logged but Not Reported

If you attempt to import an LDAP user that has the same User ID as a previously imported user, the
import fails and is logged, but the failure is not reported in the administrative GUI. The import error
islogged in/ opt/ novel | / filr/apache-tontat/| ogs/ appserver.| og.

Subsequently, only the first user imported is able to log in. Other users with the same User ID are not
able to log in, but they are given no indication as to why the login request failed. Failed login
attempts are logged in/ opt/ novel I /filr/apache-tontat/| ogs/ appserver. | og.

Email Issues

+ “Test Connection Fails without User Name and Password Even When Authentication Is Not
Required” on page 180

Test Connection Fails without User Name and Password Even When
Authentication Is Not Required

When configuring Filr to use an external outbound mail system (such as Novell GroupWise), the Test
Connection button fails when no user name and password is specified, even when the
Authentication required option is not selected.

For information about how to configure Filr to use an external outbound mail system, see
“Configuring an Email Service for Filr to Use” in the OpenText Filr 23.4: Administrative Ul Reference.
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Cannot Upload Documents Created with Apple iWork (Pages,
Keynote, etc.) or .app Documents to the Filr Web Client

When uploading a document that was created with one of the following types of files, you get an
error indicating that the file or folder cannot be uploaded when attempting to upload to the Filr web
client:

+ iWork document (such as a Pages, Keynote, or Numbers document)

+ Mac application file (a document with the . app extension)

The Filr web client is not able to upload these types of documents because the document
architecture for these documents more closely resembles a folder, and you cannot upload folders
using the Filr web client.

You can upload these types of documents to Filr by using the Filr desktop application or the Filr
mobile app.

For information about how to upload documents using the desktop application or mobile app, see
the Filr Desktop Application for Windows Guide (https://www.novell.com/documentation/filr-3/filr-
desktop/data/bookinfo.html), the Filr Desktop Application for Mac Guide, and the Filr Mobile App
Quick Start (https://www.novell.com/documentation/filr-3/filr-qs-mobile/data/filr-gs-mobile.html).

Unable to Upload Microsoft OneNote Files to Filr

If a user chooses to upload . one file, the file fails to upload even if the Filr administrator has
whitelisted the . one file.

Cannot Extract ZIP File after Downloading on Mac

After downloading a single file or multiple files as a . zi p file.), the file can be extracted only when
using third-party tools such as iZip Unarchiver.

This issue is due to the fact that OS X does not currently handle ZIP64, the technology that is used to
create the . zi p file.

Issues When Downloading Multiple Files with Safari on Mac

If you are experiencing issues when downloading multiple files when using Safari on Mac, ensure
that the option Open “safe” files after downloading is not selected.

1 Click Safari > Preferences.

2 Onthe General tab, ensure that Open “safe” files after downloading is not selected.

File Name Should Not Be More Than about 200 Characters

The exact maximum file name length depends on the configuration of the Filr server, but generally it
is about 200 characters. If file names are too long, files cannot be added to Filr.
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WebDAV Issues

+ “Cannot Edit a File through WebDAV (Edit-in-Place) When the User Password Contains a Space”
on page 181

+ “Cannot Rename a File When Editing through WebDAV (Edit-in-Place)” on page 181
+ “WebDAV Limitations on Mac” on page 181

Cannot Edit a File through WebDAV (Edit-in-Place) When the User
Password Contains a Space

If you try to edit a file through WebDAV, when your user password contains a space, the
authentication fails.

To edit files through WebDAV, ensure that your user password does not contain a space.

Cannot Rename a File When Editing through WebDAV (Edit-in-Place)

When using Edit-in-Place functionality to edit a file, you cannot click Save As and rename the file.
Doing so results in an upload error, and changes to the file are not synchronized to Filr.

WebDAV Limitations on Mac

When you use WebDAV functionality in a Mac environment, you encounter the following limitations:

+ Limitations When Editing Files on Mac through WebDAV Edit-in-Place functionality is not
supported on a Mac when you use Microsoft Office as your document editor. To use Edit-in-
Place functionality on a Mac, you must use OpenOffice or LibreOffice as your document editor.

+ Cannot Edit a File through WebDAV (Edit-in-Place) When Using LibreOffice on a Mac If you
are accessing Filr from a Mac and using LibreOffice as your document editor, you cannot edit
files through WebDAV using Edit-in-Place functionality.

If you are using Apache to front the Filr system, users are able to edit files through WebDAV
when accessing Filr from a Mac and using LibreOffice as the document editor.

+ Using WebDAV to Access the Filr folder (via Mac Finder) Is Read Only When using WebDAV to
access the Filr desktop application Filr folder via Mac Finder, access is Read Only.

+ Cannot Edit a File through WebDAV (Edit-in-Place) When Using Safari 7.x with OS X 10.9.x

When accessing Filr with Safari 7.x and OS X 10.9.x, using Edit-in-Place functionality to edit a
file, results in an error and you are not able to edit the file.

To configure Safari 7.x and OS X 10.9.x to support the Filr Edit-in-Place feature and to support
adding files to folders when using a browser that does not support HTML 5:

1. With Filr open, in Safari, click Menu > Preferences.
2. Click the Security tab, then click Manage Website Settings.

3. Select Java, then click the drop-down arrow next to the Filr URL and select Run in Unsafe
Mode.

4. Click Done.
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Cannot Log in to Web Client with Long User ID or Password

Users cannot log in to the Filr web client if the user ID exceeds 128 characters or the password
exceeds 64 characters.

Display Issues Due to Third-Party Software

+ “Filr Is Not Displayed Correctly When the Ask Toolbar Is Installed on Chrome” on page 182

Filr Is Not Displayed Correctly When the Ask Toolbar Is Installed on
Chrome

When the Ask toolbar is installed on a Chrome browser, it inhibits users from being able to view all of
the Filr masthead. The Ask toolbar is not a Chrome-sanctioned toolbar and should not be installed
on a Chrome browser.

Cannot View ODP and ODG Files That Contain Charts, Graphs,
and Tables When Viewing in HTML Format

ODP and ODGfiles that contain charts, graphs, or tables are not displayed when viewing files by using
the HTML view, as described in the following situations:

+ When viewing the file in a browser

+ When viewing a file from the Filr mobile app and clicking Generate Online Preview

User Home Directories Are Not Synchronized until Trustee Cache
Information is Updated

When you add a user to your LDAP directory, the user’s Home directory in Filr is not displayed
immediately after running the LDAP synchronization.

You must wait for the trustee cache information to be refreshed on the file system before Home
directory information is displayed in Filr. (The default rights cache refresh interval is every 5 minutes.
You can modify this interval as described in “Just-in-Time Synchronization” in the OpenText Filr 23.4:
Administrative Ul Reference.)

Filr Does Not Support Aliases That Have Been Configured in the
LDAP Directory

If your users have aliases associated with their user account in the LDAP directory, the alias is not
synchronized to Filr during the LDAP synchronization. This means that users are not able to log in to
Filr with their alias.
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Cannot Use Text Editors Such as Notepad or Wordpad as a
Document Editor

Filr allows you to change the default application that is used for editing files. However, you cannot
use text editors such as Notepad or Wordpad as the default document editor for editing files
because these applications do not support WebDAV.

Must Restart All Appliances after a Network Failure with
Microsoft SQL

If your Filr deployment includes a Microsoft SQL database, and if your network fails, you must restart
all of the appliances in your Filr deployment to restore Filr services.

Database Appliance

+ “Filr Installation Program Cannot Create the Filr Database in Microsoft SQL When the Database
Name Begins with a Number” on page 183

Filr Installation Program Cannot Create the Filr Database in
Microsoft SQL When the Database Name Begins with a Number

In the configuration wizard when configuring a large deployment, the database name that you
specify in the Database Name field cannot begin with a number when using a Microsoft SQL
database. If the name does begin with a number, the configuration wizard does not allow the
database to be created. For example, 1Fi | r is not accepted, but Fi | r 1 is.

Desktop Application

For a list of issues related to the Filr desktop application (for Windows, Mac, and Linux clients), see
the Filr Desktop Application ReleaseNotes.

Mobile Apps

For information about how to install and run the Filr mobile app, see the Filr Mobile App Quick Start.
Following are known issues in the Filr mobile app:

+ “iOS Devices” on page 184
+ “Windows Device” on page 186

+ “All Mobile Devices” on page 186
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iOS Devices

+ “Files App” on page 184
¢ “Unable to Preview Some Files on an iOS Device” on page 184

+ “Activity View Display on a iOS 11 Device Does Not Honor the AppConnect Apps or Whitelist
Settings” on page 185

+ “Filr Menu Options Not Listed After Logging In To Filr on an iOS Device That Has Mobilelron
Configured” on page 185

+ “i0S App Extensions Are Restricted When Applications Are Whitelisted” on page 185

Files App

+ An error may occur while performing the Filr file operations by using Files App. To resolve the
issue, try again.
+ The download C@ icon continues to remain even after downloading the file to your iOS device.

+ On installing Filr, unable to login through file provider extension. To resolve this issue, in the
Files app edit section, toggle the switch off and then on for the Filr app.

Unable to Preview Some Files on an iOS Device

On an iOS device, you cannot preview some files such as . odt, . odp, and. dwg if the Filr server uses
a self-signed certificate.

Ensure that the Filr server uses a valid SSL certificate that is signed by a well-known certificate
authority (CA).

Activity View Display on a iOS 11 Device Does Not Honor the AppConnect
Apps or Whitelist Settings

The Activity View Display that displays on an iOS 11 device with Mobilelron configured when you tap

the Actions icon does not honor the Mobileiron AppConnect apps or Whitelist settings and lists
all applications and extensions. Even if you tap an application or extension that is not listed in
AppConnect apps or Whitelist.settings, files get shared to such blocked applications and extensions.

However, the Filr Open In & option below the Activity View Display honors the Mobileiron
AppConnect apps or Whitelist settings.
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Filr Menu Options Not Listed After Logging In To Filr on an iOS Device
That Has Mobilelron Configured

When you log into Filr from an iOS device with Mobilelron configured, the Filr menu options are not

displayed on tapping the Actions icon if the Mobileiron Allow open in setting is set to either
AppConnect apps or Whitelist.

To workaround this issue, you must create or modify the AppConnect app configuration and add the
following key-value pair to the app-specific configuration section:

¢ Key: M _AC DI SABLE _OPEN | N_ENFORCEMENT
+ Value: YES

iOS App Extensions Are Restricted When Applications Are Whitelisted

The iOS App Extensions and sharing through AirDrop is restricted when the applications are added to
whitelist.

For example, when Google drive is added to whitelist (com.google.Drive), then sharing of files
through the extensions such as AirDrop, Drive, Save to Files, and so on is restricted. The files can only
be shared through applications such as Import with Drive or Copy to Drive.

Windows Device

Windows Phone Users See an Authentication Error When Filr Has a Self-
Signed Certificate

If Filr is configured with a self-signed certificate, Windows Phone users see an authentication error
when attempting to access Filr by using the Windows Filr mobile app.

You can resolve this issue in either of the following ways:

+ (Recommended) Configure Filr to use an official certificate in the OpenText Filr 23.4:
Maintenance Best Practices Guide.

+ Send a copy of the self-signed certificate via email to each Windows Phone in your system.
Users must then open the email and click the certificate attachment. After users click the
attachment, the self-signed certificate is installed on the phone. When the certificate is
installed, users are able to log in to the Filr app without seeing the authentication error.

All Mobile Devices

+ “Files in Downloads Area Are Not Synchronized with Just-in-Time Synchronization” on page 186

+ “Files from the Home Folder in the Downloads Area Are Removed after Personal Storage Is
Enabled” on page 186

+ “Files from Net Folders Are Removed from the Downloads Area after Being Renamed or Moved”
on page 187

+ “Email Addresses in Share Dialog Cannot Contain Extended Characters” on page 187
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Files in Downloads Area Are Not Synchronized with Just-in-Time
Synchronization

Accessing a file from the Downloads area from the mobile app does not trigger Just-in-Time
synchronization.

If you have configured only Just-in-Time synchronization (scheduled synchronization is not enabled),
files that are located in a Net Folder that have been added to the Downloads area on the mobile app
are not automatically updated with changes made from the file system. The file is updated in the
Downloads area only after a user uses one of the Filr clients to browse to the Net Folder that
contains the file.

Files from the Home Folder in the Downloads Area Are Removed after
Personal Storage Is Enabled

If users have added files from their Home folder to the Downloads area on the mobile app, and then
the Filr administrator enables personal storage (as described in “Enabling Personal Storage for Users

and Groups” in the in the OpenText Filr 23.4: Administrative Ul Reference), files from the Home
folder are removed from the Downloads area on the mobile app.

Files from Net Folders Are Removed from the Downloads Area after
Being Renamed or Moved
If users have added files from a Net Folder to the Downloads area on the mobile app, and then the

file is renamed or moved on the OES or Windows file system, the file is removed from the
Downloads area on the mobile app.

Email Addresses in Share Dialog Cannot Contain Extended Characters

When specifying an email address in the Share dialog, if the email address contains extended
characters (such as an apostrophe), an error message is displayed indicating that the item cannot be
shared with the specified user.

Web Application

+ “The .bmp Images Appear Blank in the Internet Explorer” on page 187
+ “Password-Protected Files Cannot Be Viewed” on page 187

+ “Enabling a User Account Fails For a Restored User Profile If the User’s My Files Storage Folder is
Not Restored from the Trash” on page 187

The .bmp Images Appear Blank in the Internet Explorer

If you upload a .bmp image for custom branding for the Filr Web Ul, then the branded image
appears as blank on launching the GUI in Internet Explorer. The branded image is available in all the
other browsers.
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Password-Protected Files Cannot Be Viewed

Files that have been password-protected in the application where they were created cannot be
viewed in Filr.

Enabling a User Account Fails For a Restored User Profile If the
User’s My Files Storage Folder is Not Restored from the Trash

If you choose to enable a user account whose user profile is restored from the trash but the My
Fi | es St orage folder of the user is still trashed, the following error displays:

User coul d not be enabled because the 'My Files Storage' folder is in the
trash.

Before enabling the user account, you must ensure that the user account is completely restored
from the trash. To restore the user account completely from trash, you must restore both the user
profile and the My Fi |l es St or age for the user from the trash.

Windows Subsystem For Linux and Filr Client

Filr client is currently not supported with the Windows Subsystem for Linux (WSL) feature. Uninstall
the Filr client before enabling your Windows machine for Linux. Failing to do so might cause your
system to crash.
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