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About This Book and the Library

The Reference provides information about the REST API interfaces available for PlateSpin 
Transformation Manager.

The guide introduces the following minimal information you need to begin working with the APIs:

 Access information for restapi, swaggerui, and swagger.io web interfaces
 Login requirements (PTM username and password)
 Permissions (restricted and enforced as it is in the Web Interface based on roles)
 Links to Swagger UI and Swagger IO vendor documentation
 Usage options (API, URL, and command line)

Refer to the following sections for details:

 Chapter 1, “Overview of the REST APIs,” on page 7
 Chapter 2, “Components,” on page 19
 Chapter 3, “States and Sub-States,” on page 21
 Chapter 4, “Types,” on page 25

Intended Audience
This document is intended for users who want to use the PlateSpin Transformation Manager REST 
API to add, modify, or remove objects and data in the PTM Database, or to perform transactions 
through a custom client.

Additional Documentation
For the most recent version of this guide and other PlateSpin Transformation Manager 
documentation resources, visit the PlateSpin Transformation Manager 2019.2 Documentation 
website (https://www.microfocus.com/documentation/platespin/platespin-transformation-
manager-2019-2/).

Contact Information
For specific product issues, contact Micro Focus Support at https://support.microfocus.com/
contact/.

Additional technical information or advice is available from several sources:

 Product information and resources: https://www.microfocus.com/products/platespin/
transformation-manager/

 Micro Focus Customer Center: https://www.microfocus.com/customercenter/
 Product Knowledge Base and Videos: https://www.microfocus.com/support-and-services/
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 Micro Focus Communities: https://www.microfocus.com/communities/
 PlateSpin Idea Exchange: https://community.softwaregrp.com/t5/PlateSpin-Idea-Exchange/

idb-p/PlateSpin_Ideas/
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1 1Overview of the REST APIs

PlateSpin Transformation Manager acts as a central repository for a project’s transformation plans 
and workloads data. Its REST (Representational State Transfer) interface provides programmatic 
access to read project data and to write transformation data.

 “REST API Query Methods” on page 7
 “Accessing the REST API Documentation” on page 7
 “Navigating the API Documentation” on page 8
 “HTTP Status Codes” on page 15
 “Generating a REST Client for the APIs” on page 16

REST API Query Methods
You can use the following query methods:

 HTTP request URL
 Curl command line requests
 API calls

The REST service returns the query response in JSON format.

Accessing the REST API Documentation
The PlateSpin Transformation Manager REST API is available to anyone with a user account in 
PlateSpin Transformation Manager. For full privileges, the user should be a member of the 
Administrators group. Use the Web Interface to create a user account for your software developer. 
See PTM 2019.2 Administrator Guide.

NOTE: Permissions to view results of a trial command is restricted and enforced as it is in the Web 
Interface based on roles for the user account of the logged-in user.

1 Launch a supported web browser, then go to either of the following URLs:

https://<platespin_server_ip_address_or_dns_name>:8183/restapi

https://<platespin_server_ip_address_or_dns_name>:8183/swaggerui
These web locations are also available using HTTP and port 8182, if you have enabled the HTTP 
protocol for your PTM Appliance.
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2 When you are prompted for login credentials, enter your PlateSpin Transformation Manager 
user name and password.
For information about creating user accounts in PlateSpin Transformation Manager, see 
“Creating a User” in the PTM 2019.2 Administrator Guide.

Navigating the API Documentation
The PlateSpin Transformation Manager REST API interactive console uses the open source Swagger 
UI tool to provide documentation about its APIs. You can learn about the APIs and interact with the 
REST service to try them.

 “Viewing API Categories” on page 8
 “Viewing Operations” on page 9
 “Trying Queries” on page 14

Viewing API Categories
The REST APIs are grouped according to product components in the following categories: 
 applications
 batches
 cloudlocations
 clusterhosts
 clusters
 connectors
 credentials
 dependencies
 environments
 migrationservers
 networks
 operatingsystems
 organizations
 platforms
 preimages
 processes
 projects
 repositories
 resourcegroups
 resourcelimits
 subnets
 system
 transformations
8 Overview of the REST APIs
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 types
 waves

Viewing Operations
In the interactive API console, select one of the following options to expand a category and view the 
operations available:

 Show/Hide: Expands the API category to show a list of member operations, or collapses the API 
category.

 List Operations: Expands the API category to show a list of member operations.
 Expand Operations: Expands the API category and each of the member operations.
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The list view shows the operation type (Get, Post, Put, Delete), the command, and a brief 
definition for each operation.
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Expand an operation to view the following information about the operation:

 Query method (GET, POST, PUT)
 Model schema
 Query parameters (as appropriate)
 Request definition and limitations
 Response format
 Response language support (JSON)
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Most operations will have parameters that refine the query. An expanded operation view includes a 
list of parameters, the default values for them, and a brief description of the parameter. The 
following example shows the parameters for a /project query.
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Trying Queries
You can try an API to generate the proper command. Specify values for any required parameters, 
then click Try it out.

The following example shows the /types operation that does not have parameters.
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Click Try it out! to generate the corresponding query as a Curl command and an HTTP request URL It 
also includes the command response body, code, and headers.

HTTP Status Codes
PlateSpin Transformation Manager uses standard HTTP Status Codes to indicate the status of the 
executed operations. The available status codes are described by RFC 7231 (http://tools.ietf.org/
html/rfc7231#section-6) and in the IANA HTTP Status Code Registry (http://www.iana.org/
assignments/http-status-codes/http-status-codes.xhtml).
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Generating a REST Client for the APIs
PlateSpin Transformation Manager is compliant with the OpenAPI Specification (http://swagger.io/
specification/), formerly known as the Swagger RESTful API Documentation Specification. You can 
use the open source Swagger Editor (http://editor.swagger.io) to generate a REST client in your 
language of choice.

 “PTM Client Used by PlateSpin Migrate Connector” on page 16
 “Generating a Custom PTM Client from the PTM REST API” on page 16

PTM Client Used by PlateSpin Migrate Connector
The PTM Client used by PlateSpin Migrate Connector is available in the ptmclient.zip file on the 
PlateSpin Transformation Manager Appliance in the <connector-path>\resources\ folder.

Generating a Custom PTM Client from the PTM REST API
The PTM REST API leverages the Swagger framework to present descriptions for its REST APIs. 
Swagger is built around the OpenAPI Specification (OAS). You can use Swagger tools to generate a 
client to “talk” to PTM. That is, your client sends a request to PTM and PTM responds with the 
requested information. Swagger supports a variety of programming languages.

The PTM RESTAPI interface is available on your PTM server at the following URL:

http://<your-ptmserver-ip-address-or-fqdn>:8082/restapi
For example: http://10.10.10.10:8082/restapi

The basic workflow for generating a PTM client:

1 In a web browser, go to
http://<your-ptmserver-ip-address-or-fqdn>:8082/restapi/swagger.json

2 Click Raw Data to expand the code.
16 Overview of the REST APIs
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3 Click Copy to save the information to your computer clipboard.
4 In a web browser, go to the Swagger Editor website at http://editor.swagger.io.
5 In the Swagger Editor toolbar, select File > Clear editor.
6 Right-click in the editing panel on the left, then click Paste to insert the information you copied.
7 Click OK to agree to convert the code from JSON to YAML.

The PlateSpin Transformation Manager REST API with REST commands and syntax display in the 
right panel.
Overview of the REST APIs 17

http://editor.swagger.io


This is the same type of information displayed when you visit the REST API location on your 
PlateSpin Transformation Manager server at http://<your-ptmserver-ip-address-or-
fqdn>:8082/restapi.

8 In the Swagger Editor toolbar, select Generate Client > Python to download a client written in 
Python.
Our example code is written in Python. Swagger Editor supports over 50 other languages that 
you can use for the client interface you develop.

9 In the pop-up dialog, select Save File then click OK to save the a ZIP file that contains the 
generated Python client (python-client-generated.zip).
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2 2Components

The developer documentation presented in the /restapi location provides information about how to 
use the various product components. Refer to the product documentation for information about the 
concepts each represents.

Table 2-1   Conceptual Descriptions for Product Components

Component For a conceptual description, see the following:

applications “About Applications” in the PTM User Guide.

batches “About Batches” in the PTM User Guide.

cloudlocations “About Azure Cloud Locations” in the PTM User Guide.

clusterhosts “About VMware Cluster Hosts” in the PTM User Guide.

clusters “About VMware Clusters” in the PTM User Guide.

connectors “PlateSpin Migrate Connector” in the PTM Installation Guide.

credentials “About Waves” in the PTM User Guide.

credentials “About Credentials Resources” in the PTM User Guide.

dependencies Not available in the current release.

encryptionkeys “About AWS Encryption Keys” in the PTM User Guide.

environments “About Environment Resources” in the PTM User Guide.

iamroles “About AWS IAM Roles” in the PTM User Guide.

keypairs “About AWS Key Pairs” in the PTM User Guide.

migrationservers “About Migration Server Resources” in the PTM User Guide.

networks “About Network Resources” in the PTM User Guide.

operatingsystems “About Operating System Types” in the PTM Installation Guide.

organizations “About Organizations” in the PTM Installation Guide.

placementgroups “About AWS Placement Groups” in the PTM User Guide.

platforms “About Platforms” in the PTM User Guide.

preimages Not available in the UI.

processes Not available in the UI.

projects “About Projects” in the PTM User Guide.

repositories “About Datastore Resources” in the PTM User Guide.

resourcegroups “About Resource Group Resources” in the PTM User Guide.
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resourcelimits Not available in the UI.

securitygroups “About AWS Security Groups” in the PTM User Guide.

subnets “About Subnet Resources” in the PTM User Guide.

system Not available in the UI.

transformations “About the Workload Dialog” in the PTM User Guide.

types Chapter 4, “Types,” on page 25

waves “About Waves” in the PTM User Guide.

Component For a conceptual description, see the following:
20 Components

https://www.microfocus.com/documentation/platespin/platespin-transformation-manager-2019-2/pdfdoc/ptm_user/ptm_user.pdf#manntwksubnetunderstand
https://www.microfocus.com/documentation/platespin/platespin-transformation-manager-2019-2/pdfdoc/ptm_user/ptm_user.pdf#waveabout


3 3States and Sub-States

The Transformation Update API accepts sub-states from the PlateSpin Migrate Server, as shown in 
Table 3-1. The reported sub-state appears in the Status column of the Workloads list. A Warning 
condition overrides the display of the sub-state.

Table 3-1   Sub-states Reported through the Transformation Update API from the PlateSpin Migrate Server

Transformation Sub-State Description

MIGRATE_SERVER_NOT_CONFIGURED The PlateSpin Migrate Server is not yet available on 
the replication network.

NOT_CONFIGURED The PlateSpin Migrate Server does not know about 
the workload.

DISCOVERING_WL The PlateSpin Migrate Server has been told to go 
discover one of our workloads (2 to 15 minutes).

WL_DISCOVERED The PlateSpin Migrate Server has finished the 
workload discovery process.

DISCOVER_TARGET_HOST The PlateSpin Migrate Server does not yet have the 
information for the target host. Discovery is in 
progress.

DISCOVER_WAIT The target host is a physical machine. The user needs 
to insert the LRD CD and register the host with the 
PlateSpin Migrate Server.

TARGET_HOST_DISCOVERED The PlateSpin Migrate Server has the necessary 
information for the target host.

MIGRATE_SERVER_INSUFFICIENT_LICENSES The PlateSpin Migrate Server has no license available 
to configure this workload.

WL_NOT_CONFIGURED The PlateSpin Migrate Server has discovered the 
workload, but the destination workload details have 
not yet been defined.

CONFIGURE_FAILED Failure occurred while configuring the workload in 
the PlateSpin Migrate Server.

PREPARE_FAILED Failure occurred while preparing the migration 
environment to begin replicating the workload.

READY_TO_REPLICATE All discovery work for the workload is complete. The 
PlateSpin Migrate Server is waiting to perform the 
first full replication.

INITIAL_REPLICATION The PlateSpin Migrate Server is performing the first, 
full replication of the workload. This might take many 
hours to complete.
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INCREMENTAL_REPLICATION The PlateSpin Migrate Server is performing a smaller, 
incremental replication of the workload. Incremental 
replications can occur only after a successful full 
replication.

Incremental replications are fast for Block and Block 
with Driver disk copy methods. Incremental 
replications for the File disk copy method might take 
as long as a full replication.

INCREMENTAL_REPLICATION_WAIT The PlateSpin Migrate Server cannot perform 
incremental replications while the workload is in the 
Pre-Cutover Testing state.

CUTOVER_IN_PROGRESS The cutover process has started. The process can take 
between 5 minutes and several hours.

CUTOVER_FAILED The cutover process failed. This is a severe error.

Transformation Sub-State Description
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Figure 3-1   Migration States that Trigger Warnings in PTM
States and Sub-States 23



24 States and Sub-States



4 4Types

These APIs present information about the supported types for a variety of components.

Table 4-1   

Type Menu Location in the Web Interface or Bulk Import Spreadsheet

Architectures Configuration > Operating Systems > Create > Architecture

Configuration > Operating Systems > [Select OS] > Edit > 
Architecture

Disk Copy Methods Planning > Workloads > Bulk Edit > Disk Copy Method

Planning > Workloads > [Select workload] > Edit > Transformation 
Plan > Edit > Disk Copy Method

Healths Planning > Workloads > Advanced Search > Health

Migration Server Type Resources > Migration Servers > Create

Resources > Migration Servers > Edit

OS Family Configuration > Operating Systems > Create

Configuration > Operating Systems > Edit

Transformation Method Planning > Workloads > Bulk Edit > Transform Method

Planning > Workloads > Edit > Transformation Plan > Edit > 
Transformation Method

Transformation Phase Planning > Workloads > Bulk Status Change > Next Phase

Planning > Workloads > [Select workload] > Edit > [Next Phase 
buttons]

Transformation SubPhase Planning > Workloads > [Select workload] > Advanced Search > Sub 
Status

User Roles Users > Create or Edit > Membership and Access

Volume Type Planning > Workloads > [Select workload] > Edit > Storage > Edit > 
Volumes > [Select volume] > Volume Type
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