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Introduction
This Help provides all the information you need to install and uninstall Silk Test. It describes hardware and
software requirements and details the various setup options.

System Requirements and Prerequisites
The following section identifies the system requirements for installing and running Silk Test.

Hardware Requirements
Micro Focus recommends the following hardware:

System Area Requirement

Processor Intel or AMD dual-core processor running at 2 GHz.

RAM 1 GB free memory.

Hard disk space 2 GB of free disk space.

Note: The recommended hardware reflects the minimum requirements for Silk Test. Depending on
the requirements of the application under test or the requirements of your test environment, you might
require additional hardware.

When testing on an iOS device, Micro Focus recommends using a device with 1 GB RAM or more.

To test a web application on Apple Safari or a mobile application on iOS, a Mac with the following hardware
is required:

System Area Requirement

Operating system OS X El Capitan 10.11.3 or later.

Hard disk space 1 GB of free disk space.

Software Requirements
To install and execute Silk Test, the following software needs to be installed:

• Microsoft .NET Framework 4.6 (Full setup)
• Windows Update 3118401 for Universal C RunTime in Windows

Tested Software
This section lists the software with which Silk Test 19.0 has been tested.

Operating Systems

Silk Test 19.0 has been tested with the following operating systems:

• Microsoft Windows Server 2008 R2
• Microsoft Windows 7 SP1
• Microsoft Windows 8 (No Windows Store apps)
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• Microsoft Windows 8.1 (No Windows Store apps)
• Microsoft Windows Server 2012
• Microsoft Windows Server 2012 R2
• Microsoft Windows 10 (No Universal Windows Platform apps)
• Microsoft Windows Server 2016

Web Applications

For the Open Agent, Silk Test 19.0 has been tested with the following browsers and web technologies:

Technology Type Tested Version

Mozilla Firefox** 41, 42, 43, 44, 45 (ESR*), 46, 47.0.1, 47.0.2, 52 (ESR*)***, 53*** , 54***,
55***, 56***, 57***, 58***, 59***, 60***

Note: For compatibility reasons, Silk Test 19.0 does not support
Mozilla Firefox 48, 49, 50, and 51.

Google Chrome** 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67

Chrome for Android

Original Stock Android Browser
(AOSP)

Apple Safari on iOS 9, 10.1, 11

Apple Safari on Mac 9, 10.1, 11

Mac OS (Used for testing Apple
Safari or iOS)

10.11.3, 10.12, 10.13

Internet Explorer 8, 9, 10, 11

Microsoft Edge Windows 10 Anniversary Update (38.14393), Windows 10 Creators Update
(40.15063), Windows 10 Fall Creators Update (41.16299), Windows 10 April
2018 Update ( 42.17134)

Android 4.4, 5.x, 6.x, 7.x, 8.x

iOS 9.3, 10.x, 11.x

Xcode Xcode 8.3.x, Xcode 9.x

Silverlight 3 (Silverlight Runtime 4), 4 (Silverlight Runtime 4 and Silverlight Runtime 5)

Note: Microsoft has committed to support Silverlight 5.0 until 2021,
but has made no concrete announcement about the future roadmap of
Silverlight. Whilst we endeavour to maintain the highest levels of
support for our customers, we are occasionally limited in the support
we can obtain from Microsoft on this platform.

Apache Flex (Only for Internet
Explorer)

Silk Test 19.0 has been tested with Apache Flex version 3.5 to Apache Flex
version 4.14.1, and with Adobe AIR 2.0 or later (built with Apache Flex 4.x)

Silk Test supports Adobe Flash Player 10 or later.

Java Applets (Only for Internet
Explorer)

Silk Test supports Applets for web applications running in Internet Explorer.

HTML5

Oracle Forms 10g and 11g for Internet Explorer.

* Extended Support Release.

6 | Introduction



** This list includes the browser versions that have been tested with Silk Test 19.0 until the release date of
Silk Test 19.0. Nevertheless, Silk Test 19.0 should be able to support the newest versions of these
browsers, as soon as they are available.

*** In comparison to the previous versions of Mozilla Firefox, testing on Mozilla Firefox 52 and later
versions includes some additional limitations. For detailed information on the limitations, refer to the
documentation of your Silk Test client.

Native Mobile Applications

For the Open Agent, Silk Test 19.0 has been tested with the following mobile operating systems:

Technology Type Tested Version

Mac OS (Used for testing Apple
Safari or iOS)

10.11.3, 10.12

Android 4.4, 5.x, 6.x, 7.x, 8.x

iOS 9.3, 10.x, 11.x

Desktop Applications

For the Open Agent, Silk Test 19.0 has been tested with desktop applications that are developed in one of
the following technologies:

Technology Type Tested Version

Java AWT/Swing (including Java
Foundation Classes)

Java 6, Java 7, Java 8, Java 9, Java 10

Java SWT Java 6, Java 7, Java 8, Java 9, Java 10

Silk Test 19.0 has been tested with Java SWT version 3.2 or later.

Silk Test supports standalone and Rich Client Platform (RCP) applications.

SAP* SAPGUI client 7.10, SAPGUI client 7.20, SAPGUI client 7.30, SAPGUI client 7.40,
SAPGUI client 7.50

Rumba 8.1, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3, 9.4, 9.5

MFC 14.11

Visual COBOL

Win 32 any

WinForms .NET 3.0, 3.5, 3.5 SP1, 4.0, 4.5, 4.6

WPF .NET 3.5 SP1, 4.0, 4.5, 4.6

* To avoid issues when testing SAP applications, Micro Focus recommends installing the latest patch set.

Silk Test Workbench

Silk Test 19.0 has been tested with the following databases for Silk Test Workbench asset storage:

• Microsoft SQL Server 2008 (SP2) + Express
• Microsoft SQL Server 2012
• Microsoft SQL Server 2012 SP1
• Microsoft SQL Server 2014
• Microsoft SQL Server 2016
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• Microsoft SQL Server 2017
• Oracle 11.1.

Note: The Oracle 11 ODBC driver needs to be at least at patch level 4 (11.2.0.4.0). Oracle patch
13390677 includes the correct driver. You can download the patch from Here.

• Oracle 11.2

Note: The Oracle 11 ODBC driver needs to be at least at patch level 4 (11.2.0.4.0). Oracle patch
13390677 includes the correct driver. You can download the patch from Here.

• Oracle 12.1. Silk Test Workbench supports Oracle 12.1 databases with the AL32UTF8 character
encoding.

• Microsoft Access 2000 (as a single-user database)

Note: Micro Focus recommends using Microsoft SQL Server.

Silk4J

You can integrate Silk4J in Eclipse 3.7.2 or later, both 32 and 64 bit. Version 4.7.3a is shipped with Silk
Test.

To work with Silk4J 19.0 or later, Java 8 or later is required to be installed on the system where Silk4J is
installed.

Silk4NET

You can integrate Silk4NET into the following editions of Microsoft Visual Studio:

Version Editions

Visual Studio 2012 • Professional

• Ultimate

Visual Studio 2013 • Community

• Professional

• Premium

• Ultimate

Visual Studio 2015 • Community

• Professional

• Enterprise

Visual Studio 2017 • Community

• Professional

• Enterprise

Silk Test Classic

Silk Test Classic's Data Driven Workflow has been tested with:

• Text files and comma separated value files (*.txt and *.csv files)
• MS Excel
• MS Access
• MS SQL Server
• Oracle (partial support)
• SyBase SQL Anywhere
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Silk Test Classic accesses the preceding databases using ODBC and therefore has been tested with the
versions of those databases that have a working ODBC driver.

The Silk Test Classic Select Data Source dialog box allows you to choose either the Silk DDA Excel or the
Segue DDA Excel data source. For new data driven test cases, choose the Silk DDA Excel data source.
Choose the Segue DDA Excel data source for backward compatibility. This allows existing .g.t files that
reference Segue DDA Excel to continue to work.

Important: Whilst we endeavour to keep pace with new releases and runtime versions of supported
software and technology, the information given in this document is limited to what was known and
could be tested at the point in time when this version of Silk Test was released. If you have questions
about newer releases and versions of supported software or generally about software not mentioned
here, please don't hesitate to contact Micro Focus for guidance.

Administrator Privileges
You must have local administrator privileges to install Silk Test. Once Silk Test is properly installed, you
must also have administrator privileges in order to perform the following tasks:

• Run Silk Test Classic.
• Configure a database for Silk Test Workbench.

Items Included with Silk Test
When you install Silk Test, the following items are available:

• Silk Test Start Screen, which has direct links to all clients.
• Silk Test Workbench
• Silk Test Classic
• Silk Test Agents
• Silk4NET
• Silk4J
• Product documentation

Access the documentation from within each product from the Help menu.
• Release Notes

For information about new features, supported platforms, and tested versions, refer to the Release
Notes.

• Tutorials

Access the tutorials from (in Microsoft Windows 7) Start > Programs > Silk > Silk Test >
Documentation > Tutorials or Help > Tutorials.

You must have Adobe Acrobat Reader™ to view PDF documents.
• You can access the following sample applications online:

Adobe Flex sample
applications

http://demo.borland.com/flex/SilkTest19.0/index.html

Insurance Company web
application

You can access the web application at http://demo.borland.com/
InsuranceWebExtJS/.

Green Mountain Outpost
(GMO) web application

Use the GMO application with the tutorials for Silk Test Classic. You
can access the web application at http://demo.borland.com/gmopost.
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Green Mountain Outpost
(GMO) AJAX store
implementation

An AJAX-based version of the GMO sample application, enabling
you to test AJAX synchronization and other aspects of modern web
applications. You can access the web application at http://
demo.borland.com/gmoajax.
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Licensing Information
Unless you are using a trial version, Silk Test requires a license.

Note: A Silk Test license is bound to a specific version of Silk Test. For example, Silk Test 19.0
requires a Silk Test 19.0 license.

The licensing model is based on the client that you are using and the applications that you want to be able
to test. The available licensing modes support the following application types:

Licensing Mode Application Type

Mobile Native • Mobile web applications.

• Android
• iOS

• Native mobile applications.

• Android
• iOS

Full • Web applications, including the following:

• Apache Flex
• Java-Applets

• Mobile web applications.

• Android
• iOS

• Apache Flex
• Java AWT/Swing, including Oracle Forms
• Java SWT and Eclipse RCP
• .NET, including Windows Forms and Windows

Presentation Foundation (WPF)
• Rumba
• Windows API-Based

Note: To upgrade your license to a Full license,
visit http://www.microfocus.com.

Premium All application types that are supported with a Full
license, plus SAP applications.

Note: To upgrade your license to a Premium
license, visit http://www.microfocus.com.

Mobile Native Add-On In addition to the technologies supported with a Full or
Premium license, the mobile native add-on license offers
support for testing native mobile applications on Android
and iOS.
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Silk Test Licensing
This section describes how to obtain a license policy for Silk Test and how to install Silk Meter. You must
have administrator privileges to install Silk Meter.

Note: Silk Test requires Silk Meter version 2008 or later as well as a Silk Test license policy.

Install Silk Meter once per license server. If you have multiple license servers, you need multiple license
policy files, each one tied to a particular license server. A single Silk Meter license server can administer
license policies for multiple products.

If you have received a Silk Test license policy, install the license policy on your license server. If you have
not received a license policy, generate a license policy.

Generating a Silk Test License Policy
You need a license policy to run Silk Test. You can use our online license generator to generate a license
policy. The online license generator requires an SSL-capable browser, such as Firefox or Internet Explorer.
You will receive an email with instructions on how to generate your license policy. If you did not receive
these instructions, contact customer care at http://support.microfocus.com.

Finding the Host ID
To obtain a license policy file, you need to know the host ID of the machine on which you want to install the
licenses. For floating licenses this is a license server with Silk Meter installed. For node-locked licenses this
is typically the controller machine.

1. On the machine, open a command prompt and enter the command ipconfig/all. The network
adapters and additional information is listed.

2. Note the host ID, which is the MAC Address or Physical Address of your LAN card, for example
00-BF-00-1C-D3-3D.

Tip: Depending on your system setup, including virtual machines and VPN connections, your
computer might have several network adapters with different MAC addresses. Be sure to note the
host ID of your physical LAN card.

Silk Meter Installation
If you already have a Silk Test license policy file, you can install it when you install Silk Meter. If you do not
have a valid Silk Test license, access the online License Generator to generate a license policy file.

To install and run Silk Meter on your license server, no license policy file is required. However, you must
import a license policy file before you can run Silk Test. You can import a license policy file using the Silk
Meter Policy Administrator.

If you have multiple license servers, you need multiple license policy files, each one tied to a particular
license server. A single Silk Meter license server can administer license policy files for multiple products.

Silk Meter License Server Requirements

Before installing Silk Meter, refer to the Release Notes to ensure that the license server meets the
requirements.
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Uninstalling a Previous Version of Silk Meter
If a previous version of Silk Meter is installed on your license server, you must uninstall it before the latest
version of Silk Meter can be installed.

1. Choose Start > Programs > Silk > Silk Meter > Uninstall .

2. Click Yes to uninstall Silk Meter. The Remove Settings dialog box opens.

3. Click No to keep your Silk Meter settings.

Attention: You must click No to preserve license policies that currently exist on your Silk Meter
license server.

4. Reboot your computer.

Silk Meter is now uninstalled, and you can install the latest version of Silk Meter.

Installing Silk Meter on Your License Server
Before installing Silk Meter, verify the following information:

• Your user account possesses administrator privileges.
• An instance of Silk Meter is not installed on your license server.

1. Visit the product updates site and search for Silk Meter.

2. Download and save the latest Silk Meter Installation Files.

3. Navigate to the location where you saved the .exe file and double-click it. For a standard installation,
follow the Silk Meter installation wizard by using the default options.

Important: If setup prompts you to restart the computer, make sure to do so.

Modifying Your License Server Configuration
Use the Select Silk Meter License Server utility to modify or repair your license server configuration. This
utility is installed with your Silk Test installation.

1. Choose Start > Programs > Silk > Silk Test > Administration Tools > Change your License Server
Configuration . The Select Silk Meter License Server utility opens.

2. In the Application list box, select the product for which you want to configure the license server.

3. Click the Using local or remote server option button to configure a Silk Meter license server.

4. In the License Server Host field, type the computer name of the Silk Meter license server.

Unless your network administrator has defined a different port, do not change the Port Number.

5. Click Apply to activate the license server configuration.

6. Click Test Connection to verify that a Silk Meter server is accessible on the specified host and port. If
the connection is successful, the Status field displays a SUCCESS message.

Note: In some cases, specifying the simple name of the license server in the License server host
field, such as licenseserver, might not work. A message box stating Connection to Silk
Meter license server failed opens. To resolve this issue, specify the hostname by using a
fully qualified name, such as licenseserver.mycompany.com.

7. Click Close to complete the license server configuration.
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Installing Silk Test
This section explains the setup options that are available when installing Silk Test.

Installation Prerequisites
Before installing Silk Test, perform the following tasks:

• Ensure that your user account possesses local administrator privileges.
• Ensure that Windows Defender is disabled during the Silk Test installation process. If Windows

Defender is enabled on your system during the installation, you might not be able to start the Open
Agent after the installation is complete. Windows Defender might prevent the Silk Test setup from
performing some required actions.

• Ensure that the file msvcp60.dll is installed in the Windows System32 directory (windows
\system32 or winnt\system32).

This file is installed automatically as part of the standard Windows installation. If msvcp60.dll is not in
your System32 directory, use Windows Explorer to search for the file, then copy it to the System32
directory. If you cannot find this file on your system, search for the file on your installation CD, or
upgrade to the latest service pack.

• Note: To use .NET Framework with a server system, for example Windows Server 2008, enable
the .NET Framework in Server Manager. If you do not enable the .NET Framework, a dialog box
opens, which states that you must use the Role Management Tool, and the Silk Test setup process
stops.

• Close the following applications:

• Microsoft Visual Studio
• Eclipse
• Silk Central Execution Server
• Silk Test agent

• If you are installing without an internet connection and if you get an error stating that the Visual C++
Redistributable cannot be installed, see https://support.microsoft.com/en-sg/kb/3149737 for possible
solutions.

Resetting the TEMP Environment Variable
If your Windows TEMP environment variable does not point to a valid directory, an error message is
displayed. To successfully install Silk Test, your TEMP environment variable must point to a valid directory.

1. Choose Start > Settings > Control Panel.

2. Double-click System.

3. Click the Advanced tab, and then click Environment Variables.

4. Under User Variables or System Variables, double-click the TEMP variable.

5. Enter a valid directory, and then click OK.

6. Restart the Silk Test installation by double-clicking the EXE file.
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Downloading the Silk Test Executable File
Download the Silk Test executable file if you do not have the installation CD.

1. Navigate to http://supportline.microfocus.com/.

2. Type your customer ID and password in the User Name and Password text boxes.

3. Click Submit and then navigate to Silk Test and select the version that you want to install.

4. Specify the location to which you want to save this file, and then click Save.

Alternative: Run the file from your browser by double-clicking the EXE file.

Use the executable file to install Silk Test.

Installing the Standard Suite of Silk Test Products
Before you start, download the Silk Test executable file or insert the SilkTest CD into the CD drive.

Install the standard installation of Silk Test, including Silk Test Workbench, the Silk Test Agents, Silk Test
Recorder, Silk4J, and Silk4NET. The standard installation enables you to record, script, execute, and view
the results of tests.

1. Locate and double-click the Silk Test executable file.

If you have a Silk Test CD, insert your CD. If the setup program does not start automatically, manually
start the Silk Test setup program by choosing Start > Run and entering <cddrive>:\setup.exe.

Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install Silk Test, your TEMP environment variable must point
to a valid directory.

The InstallAnywhere wizard opens.

2. If a previous version of Silk Test is installed, click Uninstall and then click Next to remove all installed
features.

You must uninstall any earlier versions before you install a new version.

3. Click Next. The License Agreement opens.

4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.

By accepting the terms of the License Agreement while installing Silk Test, you agree to allow Micro
Focus to collect information about how you use Silk Test and about the computer system on which Silk
Test is installed. Micro Focus does not collect any personally identifiable information, for example your
name or address, or any of your data files, for example scripts or passwords. You can disable this data
collection from the About dialog of your Silk Test client. For additional information, refer to the client
Help.

5. Click Next. The Choose Install Set page opens.

6. Select Standard from the list.

7. To add a shortcut icon for Silk Test to the desktop, check the Create desktop shortcut check box.

8. Click Next. The Choose Install Folder page opens.

9. To change the default installation directory, perform the following steps:

a) Click Choose. The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install Silk Test, and then click OK to return to the Choose

Install Folder page.
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Note: Silk Test must be installed on a local drive. Additionally, Micro Focus recommends installing
Silk Test to C:/Program Files, because otherwise some features of Silk Test might not work as
expected. If you specify an invalid installation destination, an error message displays.

The location displays in the text field.

10.Click Next. The Welcome to Silk4J page opens.

11.Specify whether you want to install a new Eclipse environment when you install Silk4J.

a) Click one of the following option buttons:

• Download Eclipse (200MB) and install Silk4J – To install Silk4J and an Eclipse environment,
click this option.

• Install Silk4J and use an existing Eclipse environment (version 3.7 or later) – To use an
existing Eclipse environment with Silk4J, click this option. Click Browse and navigate to the
Eclipse environment that you want to use.

• Install Silk4J manually – To install Silk4J into an Eclipse environment manually, click this option.
A folder named dropins is created in the Silk Test installation directory. Copy this folder into a
valid Eclipse directory to use Silk4J.

b) Click Next.

When installation completes, access the Eclipse environment by choosing (in Microsoft Windows 7)
Start > Programs > Silk > Silk Test > Clients > Silk4J or (in Microsoft Windows 10) Start > Silk >
Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.

12.Specify whether you want to install Silk4NET for use with an existing Visual Studio environment.

The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.

Note: Ensure that the Visual Studio components for VB .NET or C# development are available in
the Visual Studio installation with which you want to use Silk4NET.

a) Click one of the following option buttons:

• Install Silk4NET and use an existing Visual Studio 2012 or later – To use an existing Visual
Studio 2012 or later environment, click this option.

• Install Silk4NET manually – To complete the installation of Silk4NET at a later time, click this
option. If Visual Studio 2012 or later is not installed on your machine, you must choose this
option. For additional information, see Installing the Silk4NET Visual Studio Plug-in Manually.

b) Click Next.

When you start Visual Studio, a menu option appears for Silk4NET and the Silk4NET project is
available from the Installed Templates list.

13.To test Apple Safari on a Mac or mobile native applications on an iOS device, check the Download OS
X setup for Silk Test check box.

Note: When the Silk Test installation is complete, you will need to install the OS X setup on a Mac.
For additional information, see Installing the Silk Test Infoservice on a Mac.

14.Click Next. The Firewall Exceptions page opens.

15.Check the Add Windows firewall exceptions check box to create Windows firewall exceptions for all
Silk Test executable files.

Note: Checking this check box enables remote testing with Silk Test. If you leave the check box
unchecked, you will not be able to perform remote testing and you will be prompted to block or
allow the Silk Test executable files each time that you launch Silk Test.

Important: Remote testing of applications is a potential security risk. Remote testing should only
be performed in a trusted development environment, and only on a network that you control.
Perform remote testing at your own risk.

16.Click Next.

17.Review the provided information and perform one of the following steps:
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• To change any settings, click Previous to return to the appropriate page.
• If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process.

18.Optional: In the Usage Data Collection page, click one of the following:

• Click Yes, I am willing to participate to allow Micro Focus to collect usage statistics.
• Click No, I would not like to participate to prevent Micro Focus from collecting usage statistics.

19.Click Next.

20.Click one of the following option buttons:

• Evaluation Installs an evaluation version of Silk Test, which enables you to explore the full product
functionality for 45 days.

• Full version – Installs an unrestricted version of Silk Test, which requires a license.

21.The Select Silk Meter License Server dialog box opens. This utility checks your local system for the
existence of Silk Meter license server configuration files. If the files are found, the configuration and type
of license server are displayed and are used for licensing. If no configuration data is found, the Select
SilkMeter License Server dialog box is displayed with the default settings. Click one of the following
option buttons:

Using local or
remote server

In the License server host text box, enter the name of the computer on which Silk
Meter is installed. The default Port, 5461, should not be changed, unless your
network administrator has defined a different port. Click Test Connection to verify
that a Silk Meter server is accessible on the specified host and port. Testing the
connection to the license server may fail during installation as required system
libraries, which will be installed later with the software package, may not yet be
available.

Note: In some cases, specifying the simple name of the license server in the
License server host text box, such as licenseserver, might not work. A
message box stating there is no license server running on the
hostname you specified opens. To resolve this issue, specify the
hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Using a
standalone
license

Runs Silk Test standalone. Click Choose and select your license file.

Note: You can import your license file later. Click Close to skip this step. The
Silk Standalone License Installer is installed with Silk Test, under Start > All
Programs > Silk > Silk Test > Administration.

22.Click Next.

Fastpath: A working network connection is required when running Silk Test with a remote Silk
Meter license server. If you need to verify that the network is working, choose Start > Run, and
then type ping localhost or ping <license server name>, or open a command prompt
and type either of those commands.

23.Click Done.
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Installing the Complete Suite of Silk Test Products
Before you start, download the Silk Test executable file or insert the SilkTest CD into the CD drive.

Install the complete installation of Silk Test. The complete installation includes Silk Test Classic, Classic
Agent, and Silk TrueLog Explorer in addition to Silk Test Workbench, the Silk Test Open Agent, Silk Test
Recorder, Silk4J, and Silk4NET.

1. Locate and double-click the Silk Test executable file.

If you have a Silk Test CD, insert your CD. If the setup program does not start automatically, manually
start the Silk Test setup program by choosing Start > Run and entering <cddrive>:\setup.exe.

Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install Silk Test, your TEMP environment variable must point
to a valid directory.

The InstallAnywhere wizard opens.

2. If a previous version of Silk Test is installed, click Uninstall and then click Next to remove all installed
features.

You must uninstall any earlier versions before you install a new version.

3. Click Next. The License Agreement opens.

4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.

By accepting the terms of the License Agreement while installing Silk Test, you agree to allow Micro
Focus to collect information about how you use Silk Test and about the computer system on which Silk
Test is installed. Micro Focus does not collect any personally identifiable information, for example your
name or address, or any of your data files, for example scripts or passwords. You can disable this data
collection from the About dialog of your Silk Test client. For additional information, refer to the client
Help.

5. Click Next. The Choose Install Set page opens.

6. Select Complete from the list.

The complete installation enables you to record, script, execute, and view the results of tests.

Checkmarks display next to each option except Silk Test Runtime.

Note: The complete installation includes the Silk Test Windows and .NET extension kits, which are
included as part of the Silk Test Classic Agent installation.

7. To add a shortcut icon for Silk Test to the desktop, check the Create desktop shortcut check box.

8. Click Next. The Choose Install Folder page opens.

9. To change the default installation directory, perform the following steps:

a) Click Choose. The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install Silk Test, and then click OK to return to the Choose

Install Folder page.

Note: You cannot install Silk Test and Silk Test Runtime on the same machine.

Note: Silk Test must be installed on a local drive. Additionally, Micro Focus recommends installing
Silk Test to C:/Program Files, because otherwise some features of Silk Test might not work as
expected. If you specify an invalid installation destination, an error message displays.

The location displays in the text field.

10.Click Next. The Welcome to Silk4J page opens.

11.Specify whether you want to install a new Eclipse environment when you install Silk4J.
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a) Click one of the following option buttons:

• Download Eclipse (200MB) and install Silk4J – To install Silk4J and an Eclipse environment,
click this option.

• Install Silk4J and use an existing Eclipse environment (version 3.7 or later) – To use an
existing Eclipse environment with Silk4J, click this option. Click Browse and navigate to the
Eclipse environment that you want to use.

• Install Silk4J manually – To install Silk4J into an Eclipse environment manually, click this option.
A folder named dropins is created in the Silk Test installation directory. Copy this folder into a
valid Eclipse directory to use Silk4J.

b) Click Next.

When installation completes, access the Eclipse environment by choosing (in Microsoft Windows 7)
Start > Programs > Silk > Silk Test > Clients > Silk4J or (in Microsoft Windows 10) Start > Silk >
Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.

12.Specify whether you want to install Silk4NET for use with an existing Visual Studio environment.

The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.

Note: Ensure that the Visual Studio components for VB .NET or C# development are available in
the Visual Studio installation with which you want to use Silk4NET.

a) Click one of the following option buttons:

• Install Silk4NET and use an existing Visual Studio 2012 or later – To use an existing Visual
Studio 2012 or later environment, click this option.

• Install Silk4NET manually – To complete the installation of Silk4NET at a later time, click this
option. If Visual Studio 2012 or later is not installed on your machine, you must choose this
option. For additional information, see Installing the Silk4NET Visual Studio Plug-in Manually.

b) Click Next.

When you start Visual Studio, a menu option appears for Silk4NET and the Silk4NET project is
available from the Installed Templates list.

13.To test Apple Safari on a Mac or mobile native applications on an iOS device, check the Download OS
X setup for Silk Test check box.

Note: When the Silk Test installation is complete, you will need to install the OS X setup on a Mac.
For additional information, see Installing the Silk Test Infoservice on a Mac.

14.Click Next. The Firewall Exceptions page opens.

15.Check the Add Windows firewall exceptions check box to create Windows firewall exceptions for all
Silk Test executable files.

Note: Checking this check box enables remote testing with Silk Test. If you leave the check box
unchecked, you will not be able to perform remote testing and you will be prompted to block or
allow the Silk Test executable files each time that you launch Silk Test.

Important: Remote testing of applications is a potential security risk. Remote testing should only
be performed in a trusted development environment, and only on a network that you control.
Perform remote testing at your own risk.

16.Click Next.

17.Review the provided information and perform one of the following steps:

• To change any settings, click Previous to return to the appropriate page.
• If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
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\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process.

18.Optional: In the Usage Data Collection page, click one of the following:

• Click Yes, I am willing to participate to allow Micro Focus to collect usage statistics.
• Click No, I would not like to participate to prevent Micro Focus from collecting usage statistics.

19.Click Next.

20.Click one of the following option buttons:

• Evaluation Installs an evaluation version of Silk Test, which enables you to explore the full product
functionality for 45 days.

• Licensed – Installs an unrestricted version of Silk Test, which requires a license.

21.The Select Silk Meter License Server dialog box opens. This utility checks your local system for the
existence of Silk Meter license server configuration files. If the files are found, the configuration and type
of license server are displayed and are used for licensing. If no configuration data is found, the Select
SilkMeter License Server dialog box is displayed with the default settings. Click one of the following
option buttons:

Using local or
remote server

In the License server host text box, enter the name of the computer on which Silk
Meter is installed. The default Port, 5461, should not be changed, unless your
network administrator has defined a different port. Click Test Connection to verify
that a Silk Meter server is accessible on the specified host and port. Testing the
connection to the license server may fail during installation as required system
libraries, which will be installed later with the software package, may not yet be
available.

Note: In some cases, specifying the simple name of the license server in the
License server host text box, such as licenseserver, might not work. A
message box stating there is no license server running on the
hostname you specified opens. To resolve this issue, specify the
hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Using a
standalone
license

Runs Silk Test standalone. Click Choose and select your license file.

Note: You can import your license file later. Click Close to skip this step. The
Silk Standalone License Installer is installed with Silk Test, under Start > All
Programs > Silk > Silk Test > Administration.

22.Click Next.

Fastpath: A working network connection is required when running Silk Test with a remote Silk
Meter license server. If you need to verify that the network is working, choose Start > Run, and
then type ping localhost or ping <license server name>, or open a command prompt
and type either of those commands.

23.Specify whether you want to restart the system to complete the installation and then click Done.

Attention: You must restart your computer for Silk Test Classic to work properly.

Installing Silk Test Workbench
Silk Test Workbench is the quality testing environment that offers .NET scripting for power users and easy
to use visual tests to make testing more accessible to a broader audience. Silk Test Workbench is
automatically installed when you choose a complete or standard installation. If you choose a basic
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installation, you can install Silk Test Workbench without any other components. When you install Silk Test
Workbench, the Open Agent is also installed. The Open Agent is required to run Silk Test Workbench.

1. Locate and double-click the Silk Test executable file.

If you have a Silk Test CD, insert your CD. If the setup program does not start automatically, manually
start the Silk Test setup program by choosing Start > Run and entering <cddrive>:\setup.exe.

Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install Silk Test, your TEMP environment variable must point
to a valid directory.

The InstallAnywhere wizard opens.

2. If a previous version of Silk Test is installed, click Uninstall and then click Next to remove all installed
features.

You must uninstall any earlier versions before you install a new version.

3. Click Next. The License Agreement opens.

4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.

By accepting the terms of the License Agreement while installing Silk Test, you agree to allow Micro
Focus to collect information about how you use Silk Test and about the computer system on which Silk
Test is installed. Micro Focus does not collect any personally identifiable information, for example your
name or address, or any of your data files, for example scripts or passwords. You can disable this data
collection from the About dialog of your Silk Test client. For additional information, refer to the client
Help.

5. Click Next. The Choose Install Set page opens.

6. Select Basic from the list.

The basic installation installs Silk Test Workbench, Silk Test Recorder, and the Open Agent.

7. To add a shortcut icon for Silk Test to the desktop, check the Create desktop shortcut check box.

8. Click Next. The Choose Install Folder page opens.

9. To change the default installation directory, perform the following steps:

a) Click Choose. The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install Silk Test, and then click OK to return to the Choose

Install Folder page.

Note: You cannot install Silk Test and Silk Test Runtime on the same machine.

Note: Silk Test must be installed on a local drive. Additionally, Micro Focus recommends installing
Silk Test to C:/Program Files, because otherwise some features of Silk Test might not work as
expected. If you specify an invalid installation destination, an error message displays.

The location displays in the text field.

10.Click Next. The Download OS X Setup page opens.

11.To test Apple Safari on a Mac or mobile native applications on an iOS device, check the Download OS
X setup for Silk Test check box.

Note: When the Silk Test installation is complete, you will need to install the OS X setup on a Mac.
For additional information, see Installing the Silk Test Infoservice on a Mac.

12.Click Next. The Firewall Exceptions page opens.

13.Check the Add Windows firewall exceptions check box to create Windows firewall exceptions for all
Silk Test executable files.

Note: Checking this check box enables remote testing with Silk Test. If you leave the check box
unchecked, you will not be able to perform remote testing and you will be prompted to block or
allow the Silk Test executable files each time that you launch Silk Test.
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Important: Remote testing of applications is a potential security risk. Remote testing should only
be performed in a trusted development environment, and only on a network that you control.
Perform remote testing at your own risk.

14.Click Next.

15.Review the provided information and perform one of the following steps:

• To change any settings, click Previous to return to the appropriate page.
• If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process.

16.Optional: In the Usage Data Collection page, click one of the following:

• Click Yes, I am willing to participate to allow Micro Focus to collect usage statistics.
• Click No, I would not like to participate to prevent Micro Focus from collecting usage statistics.

17.Click Next.

18.Click one of the following option buttons:

• Evaluation Installs an evaluation version of Silk Test, which enables you to explore the full product
functionality for 45 days.

• Licensed – Installs an unrestricted version of Silk Test, which requires a license.

19.The Select Silk Meter License Server dialog box opens. This utility checks your local system for the
existence of Silk Meter license server configuration files. If the files are found, the configuration and type
of license server are displayed and are used for licensing. If no configuration data is found, the Select
SilkMeter License Server dialog box is displayed with the default settings. Click one of the following
option buttons:

Using local or
remote server

In the License server host text box, enter the name of the computer on which Silk
Meter is installed. The default Port, 5461, should not be changed, unless your
network administrator has defined a different port. Click Test Connection to verify
that a Silk Meter server is accessible on the specified host and port. Testing the
connection to the license server may fail during installation as required system
libraries, which will be installed later with the software package, may not yet be
available.

Note: In some cases, specifying the simple name of the license server in the
License server host text box, such as licenseserver, might not work. A
message box stating there is no license server running on the
hostname you specified opens. To resolve this issue, specify the
hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Using a
standalone
license

Runs Silk Test standalone. Click Choose and select your license file.

Note: You can import your license file later. Click Close to skip this step. The
Silk Standalone License Installer is installed with Silk Test, under Start > All
Programs > Silk > Silk Test > Administration.

20.Click Next.

Fastpath: A working network connection is required when running Silk Test with a remote Silk
Meter license server. If you need to verify that the network is working, choose Start > Run, and
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then type ping localhost or ping <license server name>, or open a command prompt
and type either of those commands.

21.Click Done.

Installing Silk4J
The Silk4J Eclipse plug-in enables you to create Java based test scripts directly in your Eclipse
environment. Silk4J is automatically installed when you choose a standard or complete installation. If you
choose a basic or custom installation, you can install Silk4J at a later time. When you install Silk4J, the
Open Agent is also installed. The Open Agent is required to run Silk4J.

Note:

To work with Silk4J 19.0 or later, Java 8 or later is required to be installed on the system where Silk4J
is installed.

1. Locate and double-click the Silk Test executable file.

If you have a Silk Test CD, insert your CD. If the setup program does not start automatically, manually
start the Silk Test setup program by choosing Start > Run and entering <cddrive>:\setup.exe.

Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install Silk Test, your TEMP environment variable must point
to a valid directory.

The InstallAnywhere wizard opens.

2. If a previous version of Silk Test is installed, click Uninstall and then click Next to remove all installed
features.

You must uninstall any earlier versions before you install a new version.

3. Click Next. The License Agreement opens.

4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.

By accepting the terms of the License Agreement while installing Silk Test, you agree to allow Micro
Focus to collect information about how you use Silk Test and about the computer system on which Silk
Test is installed. Micro Focus does not collect any personally identifiable information, for example your
name or address, or any of your data files, for example scripts or passwords. You can disable this data
collection from the About dialog of your Silk Test client. For additional information, refer to the client
Help.

5. Click Next. The Choose Install Set page opens.

6. From the drop-down list, select Custom and then check the Silk4J check box. Silk4J, Silk Test
Recorder, and the Open Agent will be installed.

7. Click Next. The Choose Install Folder page opens.

8. To change the default installation directory, perform the following steps:

a) Click Choose. The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install Silk Test, and then click OK to return to the Choose

Install Folder page.

The location displays in the text field.

9. Click Next. The Welcome to Silk4J page opens.

10.Specify whether you want to install a new Eclipse environment when you install Silk4J.

a) Click one of the following option buttons:

• Download Eclipse (200MB) and install Silk4J – To install Silk4J and an Eclipse environment,
click this option.
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• Install Silk4J and use an existing Eclipse environment (version 3.7 or later) – To use an
existing Eclipse environment with Silk4J, click this option. Click Browse and navigate to the
Eclipse environment that you want to use.

• Install Silk4J manually – To install Silk4J into an Eclipse environment manually, click this option.
A folder named dropins is created in the Silk Test installation directory. Copy this folder into a
valid Eclipse directory to use Silk4J.

b) Click Next.

When installation completes, access the Eclipse environment by choosing (in Microsoft Windows 7)
Start > Programs > Silk > Silk Test > Clients > Silk4J or (in Microsoft Windows 10) Start > Silk >
Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.

11.To test Apple Safari on a Mac or mobile native applications on an iOS device, check the Download OS
X setup for Silk Test check box.

Note: When the Silk Test installation is complete, you will need to install the OS X setup on a Mac.
For additional information, see Installing the Silk Test Infoservice on a Mac.

12.Click Next. The Firewall Exceptions page opens.

13.Check the Add Windows firewall exceptions check box to create Windows firewall exceptions for all
Silk Test executable files.

Note: Checking this check box enables remote testing with Silk Test. If you leave the check box
unchecked, you will not be able to perform remote testing and you will be prompted to block or
allow the Silk Test executable files each time that you launch Silk Test.

Important: Remote testing of applications is a potential security risk. Remote testing should only
be performed in a trusted development environment, and only on a network that you control.
Perform remote testing at your own risk.

14.Click Next.

15.Review the provided information and perform one of the following steps:

• To change any settings, click Previous to return to the appropriate page.
• If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process.

16.Optional: In the Usage Data Collection page, click one of the following:

• Click Yes, I am willing to participate to allow Micro Focus to collect usage statistics.
• Click No, I would not like to participate to prevent Micro Focus from collecting usage statistics.

17.Click Next.

18.Click one of the following option buttons:

• Evaluation Installs an evaluation version of Silk Test, which enables you to explore the full product
functionality for 45 days.

• Full version – Installs an unrestricted version of Silk Test, which requires a license.

19.The Select Silk Meter License Server dialog box opens. This utility checks your local system for the
existence of Silk Meter license server configuration files. If the files are found, the configuration and type
of license server are displayed and are used for licensing. If no configuration data is found, the Select
SilkMeter License Server dialog box is displayed with the default settings. Click one of the following
option buttons:
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Using local or
remote server

In the License server host text box, enter the name of the computer on which Silk
Meter is installed. The default Port, 5461, should not be changed, unless your
network administrator has defined a different port. Click Test Connection to verify
that a Silk Meter server is accessible on the specified host and port. Testing the
connection to the license server may fail during installation as required system
libraries, which will be installed later with the software package, may not yet be
available.

Note: In some cases, specifying the simple name of the license server in the
License server host text box, such as licenseserver, might not work. A
message box stating there is no license server running on the
hostname you specified opens. To resolve this issue, specify the
hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Using a
standalone
license

Runs Silk Test standalone. Click Choose and select your license file.

Note: You can import your license file later. Click Close to skip this step. The
Silk Standalone License Installer is installed with Silk Test, under Start > All
Programs > Silk > Silk Test > Administration.

20.Click Next.

Fastpath: A working network connection is required when running Silk Test with a remote Silk
Meter license server. If you need to verify that the network is working, choose Start > Run, and
then type ping localhost or ping <license server name>, or open a command prompt
and type either of those commands.

21.Click Done.
22.Restart Eclipse if it was running when you performed the Silk4J installation.

When installation completes, access the Eclipse environment by clicking (in Microsoft Windows 7) Start
> Programs > Silk > Silk Test > Clients > Silk4J or (in Microsoft Windows 10) Start > Silk > Silk4J.
For instructions for using the plug-in, refer to the online help within the plug-in.

Installing the Silk4J Eclipse Plug-in Manually
The Silk4J Eclipse plug-in enables you to create Java-based test scripts directly in your Eclipse
environment. You can install the Silk4J Eclipse plug-in when you install Silk Test using the Silk Test
installation wizard.

Use this procedure:

• If you upgrade your version of Eclipse after you install the Silk4J plug-in.
• If you chose the Install Silk4J manually option during installation.
• If you did not install the Silk4J Eclipse plug-in when you installed Silk Test, and you want to install it

manually.

1. If you chose the Install Silk4J Manually option during installation, locate the dropins folder in the Silk
Test installation directory.
By default the location is C:\Program Files\Silk\Silk Test\dropins.

2. Copy the Silk4J.link file and paste it into the Eclipse dropins folder.

For example, if your Eclipse environment is installed at C:\Eclipse, copy the Silk4J.link file to C:
\Eclipse\dropins.

3. Restart Eclipse if it was running when you performed the Silk4J installation.
When installation completes, access the Eclipse environment by clicking (in Microsoft Windows 7) Start
> Programs > Silk > Silk Test > Clients > Silk4J or (in Microsoft Windows 10) Start > Silk > Silk4J.
For instructions for using the plug-in, refer to the online help within the plug-in.
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Tip: If you encounter problems starting Silk4J, start Eclipse with the parameter -clean one time.

Enabling and Disabling Rumba
Rumba is the world's premier Windows desktop terminal emulation solution. Rumba provides connectivity
solutions to mainframes, mid-range, UNIX, Linux, and HP servers.

Enabling Support

Before you can record and replay Rumba scripts, you need to enable support:

1. Install Rumba desktop client software version 8.1 or later.
2. Click (in Microsoft Windows 7) Start > Programs > Silk > Silk Test > Administration > Rumba plugin

> Enable Silk Test Rumba plugin or (in Microsoft Windows 10) Start > Silk > Enable Silk Test
Rumba plugin.

Disabling Support

Click (in Microsoft Windows 7) Start > Programs > Silk > Silk Test > Administration > Rumba plugin >
Disable Silk Test Rumba plugin or (in Microsoft Windows 10) Start > Silk > Disable Silk Test Rumba
plugin.

Installing Silk4NET
The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio. Silk4NET is automatically installed when you choose a standard or complete installation. If you
choose a basic or custom installation, you can install Silk4NET at a later time. When you install Silk4NET,
the Open Agent is also installed.

1. Ensure that the Visual Studio components for VB .NET or C# development are available in the Visual
Studio installation with which you want to use Silk4NET.

2. Locate and double-click the Silk Test executable file.

If you have a Silk Test CD, insert your CD. If the setup program does not start automatically, manually
start the Silk Test setup program by choosing Start > Run and entering <cddrive>:\setup.exe.

Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install Silk Test, your TEMP environment variable must point
to a valid directory.

The InstallAnywhere wizard opens.

3. If a previous version of Silk Test is installed, click Uninstall and then click Next to remove all installed
features.

You must uninstall any earlier versions before you install a new version.

4. Click Next. The License Agreement opens.

5. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.

By accepting the terms of the License Agreement while installing Silk Test, you agree to allow Micro
Focus to collect information about how you use Silk Test and about the computer system on which Silk
Test is installed. Micro Focus does not collect any personally identifiable information, for example your
name or address, or any of your data files, for example scripts or passwords. You can disable this data
collection from the About dialog of your Silk Test client. For additional information, refer to the client
Help.
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6. Click Next. The Choose Install Set page opens.

7. From the drop-down list, select Custom and then check the Silk4NET check box. Silk4NET, Silk Test
Recorder, and the Open Agent will be installed.

8. Specify whether you want to install Silk4NET for use with an existing Visual Studio environment.

The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.

Note: Ensure that the Visual Studio components for VB .NET or C# development are available in
the Visual Studio installation with which you want to use Silk4NET.

a) Click one of the following option buttons:

• Install Silk4NET and use an existing Visual Studio 2012 or later – To use an existing Visual
Studio 2012 or later environment, click this option.

• Install Silk4NET manually – To complete the installation of Silk4NET at a later time, click this
option. If Visual Studio 2012 or later is not installed on your machine, you must choose this
option. For additional information, see Installing the Silk4NET Visual Studio Plug-in Manually.

b) Click Next.
When you start Visual Studio, a menu option appears for Silk4NET and the Silk4NET project is
available from the Installed Templates list.

9. To add a shortcut icon for Silk Test to the desktop, check the Create desktop shortcut check box.

10.Click Next. The Choose Install Folder page opens.

11.To change the default installation directory, perform the following steps:

a) Click Choose. The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install Silk Test, and then click OK to return to the Choose

Install Folder page.

The location displays in the text field.

12.Click Next.
13.To test Apple Safari on a Mac or mobile native applications on an iOS device, check the Download OS

X setup for Silk Test check box.

Note: When the Silk Test installation is complete, you will need to install the OS X setup on a Mac.
For additional information, see Installing the Silk Test Infoservice on a Mac.

14.Click Next. The Firewall Exceptions page opens.

15.Check the Add Windows firewall exceptions check box to create Windows firewall exceptions for all
Silk Test executable files.

Note: Checking this check box enables remote testing with Silk Test. If you leave the check box
unchecked, you will not be able to perform remote testing and you will be prompted to block or
allow the Silk Test executable files each time that you launch Silk Test.

Important: Remote testing of applications is a potential security risk. Remote testing should only
be performed in a trusted development environment, and only on a network that you control.
Perform remote testing at your own risk.

16.Click Next.
17.Review the provided information and perform one of the following steps:

• To change any settings, click Previous to return to the appropriate page.
• If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process.
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18.Optional: In the Usage Data Collection page, click one of the following:

• Click Yes, I am willing to participate to allow Micro Focus to collect usage statistics.
• Click No, I would not like to participate to prevent Micro Focus from collecting usage statistics.

19.Click Next.
20.Click one of the following option buttons:

• Evaluation Installs an evaluation version of Silk Test, which enables you to explore the full product
functionality for 45 days.

• Full version – Installs an unrestricted version of Silk Test, which requires a license.

21.The Select Silk Meter License Server dialog box opens. This utility checks your local system for the
existence of Silk Meter license server configuration files. If the files are found, the configuration and type
of license server are displayed and are used for licensing. If no configuration data is found, the Select
SilkMeter License Server dialog box is displayed with the default settings. Click one of the following
option buttons:

Using local or
remote server

In the License server host text box, enter the name of the computer on which Silk
Meter is installed. The default Port, 5461, should not be changed, unless your
network administrator has defined a different port. Click Test Connection to verify
that a Silk Meter server is accessible on the specified host and port. Testing the
connection to the license server may fail during installation as required system
libraries, which will be installed later with the software package, may not yet be
available.

Note: In some cases, specifying the simple name of the license server in the
License server host text box, such as licenseserver, might not work. A
message box stating there is no license server running on the
hostname you specified opens. To resolve this issue, specify the
hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Using a
standalone
license

Runs Silk Test standalone. Click Choose and select your license file.

Note: You can import your license file later. Click Close to skip this step. The
Silk Standalone License Installer is installed with Silk Test, under Start > All
Programs > Silk > Silk Test > Administration.

22.Click Next.

Fastpath: A working network connection is required when running Silk Test with a remote Silk
Meter license server. If you need to verify that the network is working, choose Start > Run, and
then type ping localhost or ping <license server name>, or open a command prompt
and type either of those commands.

23.Click Done.

24.Restart Visual Studio if it was running when you performed the Silk4NET installation.

When installation completes, a menu option appears for Silk4NET and the Silk4NET project is available
from the Installed Templates list.

Installing the Silk4NET Visual Studio Plug-in Manually
The Silk4NET Visual Studio plug-in enables you to create Visual Basic or C# test scripts directly in Visual
Studio.

You can install the Silk4NET Visual Studio plug-in when you install Silk Test using the Silk Test installation
wizard.

Use this procedure:
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• If you upgrade your version of Visual Studio after you install the Silk4NET plug-in.
• If you chose the Install Silk4NET manually option during installation.

1. Ensure that the Visual Studio components for VB .NET or C# development are available in the Visual
Studio installation with which you want to use Silk4NET.

2. Execute MicroFocus.SilkTest.Silk4NET.vsix in the folder <Silk Test installation
directory>\ng\Silk4NET.

By default the location is C:\Program Files\Silk\Silk Test\ng\Silk4NET.

Note: If the following message is displayed during the installation, you can safely ignore the
message and resume: This extension contains an invalid digital signature.

3. Depending on the version of Visual Studio, copy the following files:

• For Visual Studio 2012, copy the file <Silk Test installation directory>\ng\NTF\
SilkTest.Ntf.VisualStudio2012.DataCollector.dll to the folder \Common7\IDE
\PrivateAssemblies\DataCollectors\ in the Visual Studio installation directory. Additionally,
copy the file <Silk Test installation directory>\ng\NTF
\SilkTest.Ntf.VisualStudio2012.UnitTestingExtension.dll to the folder
\Common7\IDE\CommonExtensions\Microsoft\TestWindow\Extensions\ in the Visual
Studio installation directory.

• For Visual Studio 2013, copy the file <Silk Test installation directory>\ng\NTF\
SilkTest.Ntf.VisualStudio2013.DataCollector.dll to the folder \Common7\IDE
\PrivateAssemblies\DataCollectors\ in the Visual Studio installation directory. Additionally,
copy the file <Silk Test installation directory>\ng\NTF\
SilkTest.Ntf.VisualStudio2013.UnitTestingExtension.dll to the folder
\Common7\IDE\CommonExtensions\Microsoft\TestWindow\Extensions\ in the Visual
Studio installation directory.

• For Visual Studio 2015, copy the file <Silk Test installation directory>\ng\NTF\
SilkTest.Ntf.VisualStudio2015.DataCollector.dll to the folder \Common7\IDE
\PrivateAssemblies\DataCollectors\ in the Visual Studio installation directory. Additionally,
copy the file <Silk Test installation directory>\ng\NTF\
SilkTest.Ntf.VisualStudio2015.UnitTestingExtension.dll to the folder
\Common7\IDE\CommonExtensions\Microsoft\TestWindow\Extensions\ in the Visual
Studio installation directory.

• For Visual Studio 2017, copy the file <Silk Test installation directory>\ng\NTF\
SilkTest.Ntf.VisualStudio2017.DataCollector.dll to the folder \Common7\IDE
\PrivateAssemblies\DataCollectors\ in the Visual Studio installation directory. Then copy
the file <Silk Test installation directory>\ng\NTF\
SilkTest.Ntf.VisualStudio2017.UnitTestingExtension.dll to the folder
\Common7\IDE\CommonExtensions\Microsoft\TestWindow\Extensions\ in the Visual
Studio installation directory. Finally, copy the file <Silk Test installation directory>\ng
\Silk4NET\Silk4NET_2017.pkgdef to the folder \Common7\IDE\Extensions in the Visual
Studio installation directory.

4. In Visual Studio, verify that the menu option for Silk4NET appears and that the Silk4NET project is
available from the Installed Templates list.

Integrating Silk4NET with a Visual Studio 2017 Agent
If you want to run Silk4NET tests on a machine which has only the Visual Studio 2017 Agent installed,
perform the following actions:

1. Copy the file <Silk Test installation directory>\ng\Silk4NET
\Silk4NET_2017.pkgdef to the folder \Common7\IDE\Extensions in the Visual Studio Agent
installation directory.
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2. If the file privateregistry.bin exists in the folder %localappdata%/ Microsoft
\VisualStudio\15.0_<some ID>, delete the file.

When you execute the next test, the Visual Studio Agent is reconfigured and recognizes Silk4NET.

Installing Silk Test Classic
Before you start, download the Silk Test executable file or insert the SilkTest CD into the CD drive.

Silk Test Classic is automatically installed when you choose a complete installation. If you choose a custom
installation, you can install Silk Test Classic to use only the traditional 4Test interface and tools. When you
install Silk Test Classic, Silk Test Recorder, Silk Test Classic Agent, and the Open Agent are also installed.
Silk Test Recorder enables you to record tests rather than manually coding them. Silk Test Classic uses the
Classic Agent or the Open Agent to connect to supported technology domains. While the Open Agent is
required for the Silk Test Recorder.

Note: If User Account Control (UAC) is activated on your system, we recommend that you install Silk
Test Classic into a different location than the Program Files folder.

1. Locate and double-click the Silk Test executable file.

If you have a Silk Test CD, insert your CD. If the setup program does not start automatically, manually
start the Silk Test setup program by choosing Start > Run and entering <cddrive>:\setup.exe.

Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install Silk Test, your TEMP environment variable must point
to a valid directory.

The InstallAnywhere wizard opens.

2. If a previous version of Silk Test is installed, click Uninstall and then click Next to remove all installed
features.

You must uninstall any earlier versions before you install a new version.

3. Click Next. The License Agreement opens.

4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.

By accepting the terms of the License Agreement while installing Silk Test, you agree to allow Micro
Focus to collect information about how you use Silk Test and about the computer system on which Silk
Test is installed. Micro Focus does not collect any personally identifiable information, for example your
name or address, or any of your data files, for example scripts or passwords. You can disable this data
collection from the About dialog of your Silk Test client. For additional information, refer to the client
Help.

5. Click Next. The Choose Install Set page opens.

6. From the drop-down list, select Custom and check the check box for Silk Test Classic IDE. When you
install Silk Test Classic, Silk Test Recorder, Silk Test Classic Agent, and the Open Agent are also
installed.

7. To add a shortcut icon for Silk Test to the desktop, check the Create desktop shortcut check box.

8. Click Next. The Choose Install Folder page opens.

9. To change the default installation directory, perform the following steps:

a) Click Choose. The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install Silk Test, and then click OK to return to the Choose

Install Folder page.

Note: You cannot install Silk Test and Silk Test Runtime on the same machine.
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Note: Silk Test must be installed on a local drive. Additionally, Micro Focus recommends installing
Silk Test to C:/Program Files, because otherwise some features of Silk Test might not work as
expected. If you specify an invalid installation destination, an error message displays.

The location displays in the text field.

10.Click Next.

11.To test Apple Safari on a Mac or mobile native applications on an iOS device, check the Download OS
X setup for Silk Test check box.

Note: When the Silk Test installation is complete, you will need to install the OS X setup on a Mac.
For additional information, see Installing the Silk Test Infoservice on a Mac.

12.Click Next. The Firewall Exceptions page opens.

13.Check the Add Windows firewall exceptions check box to create Windows firewall exceptions for all
Silk Test executable files.

Note: Checking this check box enables remote testing with Silk Test. If you leave the check box
unchecked, you will not be able to perform remote testing and you will be prompted to block or
allow the Silk Test executable files each time that you launch Silk Test.

Important: Remote testing of applications is a potential security risk. Remote testing should only
be performed in a trusted development environment, and only on a network that you control.
Perform remote testing at your own risk.

14.Click Next.

15.Review the provided information and perform one of the following steps:

• To change any settings, click Previous to return to the appropriate page.
• If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process.

16.Optional: In the Usage Data Collection page, click one of the following:

• Click Yes, I am willing to participate to allow Micro Focus to collect usage statistics.
• Click No, I would not like to participate to prevent Micro Focus from collecting usage statistics.

17.Click Next.

18.Click one of the following option buttons:

• Evaluation Installs an evaluation version of Silk Test, which enables you to explore the full product
functionality for 45 days.

• Licensed – Installs an unrestricted version of Silk Test, which requires a license.

19.Click Next to continue. The Silk Test licensing dialog box opens.

This dialog box provides generic information about Silk Meter licensing. For detailed information on Silk
Meter licensing, click Open SilkMeter ReadMe. This opens the Silk Meter documentation in your
default browser.

Note: Open SilkMeter ReadMe is disabled if the document is not available in the installation
source directory. This is usually the case when installing a Silk Test Web package.

Provided that you have already installed a Silk Meter license server on your computer network, or you
know which computer on your network will become the Silk Meter license server, or you want to run Silk
Meter in standalone mode, you can open the Select Silk Meter License Server dialog box by clicking
OK.

Click Cancel to continue the installation without specifying a Silk Meter license server.
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20.Click Next.

Fastpath: A working network connection is required when running Silk Test with a remote Silk
Meter license server. If you need to verify that the network is working, choose Start > Run, and
then type ping localhost or ping <license server name>, or open a command prompt
and type either of those commands.

21.Specify whether you want to restart the system to complete the installation and then click Done.

Attention: You must restart your computer for Silk Test Classic to work properly.

Installing Silk Test Runtime or the Silk Test Agents
Before you start, download the Silk Test executable file or insert the SilkTest CD into the CD drive.

To install the Silk Test agents or the Silk Test Runtime:

1. Locate and double-click the Silk Test executable file.

If you have a Silk Test CD, insert your CD. If the setup program does not start automatically, manually
start the Silk Test setup program by choosing Start > Run and entering <cddrive>:\setup.exe.

Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install Silk Test, your TEMP environment variable must point
to a valid directory.

The InstallAnywhere wizard opens.

2. If a previous version of Silk Test is installed, click Uninstall and then click Next to remove all installed
features.

You must uninstall any earlier versions before you install a new version.

3. Click Next. The License Agreement opens.

4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.

5. Click Next. The Choose Install Set page opens.

6. From the drop-down list, select Agent/Runtime Only and check the check boxes for the components
that you want to install.

• Check the Silk Test Open Agent check box to perform distributed testing on tests in Silk4J,
Silk4NET, and most of the technology types for Silk Test Classic.

• Check the Silk Test Classic Agent check box to perform distributed testing in a traditional 4Test
environment. The Classic Agent includes the Silk Test Unix Agent.

Note: The Classic Agent is only available for Silk Test Classic. The Classic Agent installation
includes the Silk Test Windows and .NET extension kits.

• Check the Silk Test Classic Runtime check box to execute a set of tests and view the results.

Note: To execute Silk Test Workbench scripts from the command line or from Silk Central, you
cannot just install the Open Agent. You have to install the entire Silk Test Workbench.

7. Click Next. The Choose Install Folder page opens.

8. To change the default installation directory, perform the following steps:

a) Click Choose. The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install Silk Test, and then click OK to return to the Choose

Install Folder page.

Note: You cannot install Silk Test and Silk Test Runtime on the same machine.
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Note: Silk Test must be installed on a local drive. Additionally, Micro Focus recommends installing
Silk Test to C:/Program Files, because otherwise some features of Silk Test might not work as
expected. If you specify an invalid installation destination, an error message displays.

9. Click Next.

10.To test Apple Safari on a Mac or mobile native applications on an iOS device, check the Download OS
X setup for Silk Test check box.

Note: When the Silk Test installation is complete, you will need to install the OS X setup on a Mac.
For additional information, see Installing the Silk Test Infoservice on a Mac.

11.Click Next. The Firewall Exceptions page opens.

12.Check the Add Windows firewall exceptions check box to create Windows firewall exceptions for all
Silk Test executable files.

Note: Checking this check box enables remote testing with Silk Test. If you leave the check box
unchecked, you will not be able to perform remote testing and you will be prompted to block or
allow the Silk Test executable files each time that you launch Silk Test.

Important: Remote testing of applications is a potential security risk. Remote testing should only
be performed in a trusted development environment, and only on a network that you control.
Perform remote testing at your own risk.

13.Click Next.

14.Review the provided information and perform one of the following steps:

• To change any settings, click Previous to return to the appropriate page.
• If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process.

15.Optional: In the Usage Data Collection page, click one of the following:

• Click Yes, I am willing to participate to allow Micro Focus to collect usage statistics.
• Click No, I would not like to participate to prevent Micro Focus from collecting usage statistics.

16.Click Next.

17.Click one of the following option buttons:

• Evaluation Installs an evaluation version of Silk Test, which enables you to explore the full product
functionality for 45 days.

• Licensed – Installs an unrestricted version of Silk Test, which requires a license.

18.The Select Silk Meter License Server dialog box opens. This utility checks your local system for the
existence of Silk Meter license server configuration files. If the files are found, the configuration and type
of license server are displayed and are used for licensing. If no configuration data is found, the Select
SilkMeter License Server dialog box is displayed with the default settings. Click one of the following
option buttons:

Using local or
remote server

In the License server host text box, enter the name of the computer on which Silk
Meter is installed. The default Port, 5461, should not be changed, unless your
network administrator has defined a different port. Click Test Connection to verify
that a Silk Meter server is accessible on the specified host and port. Testing the
connection to the license server may fail during installation as required system
libraries, which will be installed later with the software package, may not yet be
available.
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Note: In some cases, specifying the simple name of the license server in the
License server host text box, such as licenseserver, might not work. A
message box stating there is no license server running on the
hostname you specified opens. To resolve this issue, specify the
hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Using a
standalone
license

Runs Silk Test standalone. Click Choose and select your license file.

Note: You can import your license file later. Click Close to skip this step. The
Silk Standalone License Installer is installed with Silk Test, under Start > All
Programs > Silk > Silk Test > Administration.

19.Click Next.

Fastpath: A working network connection is required when running Silk Test with a remote Silk
Meter license server. If you need to verify that the network is working, choose Start > Run, and
then type ping localhost or ping <license server name>, or open a command prompt
and type either of those commands.

20.Specify whether you want to restart the system to complete the installation and then click Done.

Attention: You must restart your computer for Silk Test Classic to work properly.

Note: If you have purchased a license for a Silk Test agent, but not for Silk Test itself, then only the
agent, the documentation, and the Silk Test Bitmap Tool are accessible after installation.

Installing the Classic Agent for Unix
After you install the Silk Test Agent software, additional steps are required if you want to use the Silk Test
Classic Agent for Unix.

1. On the computer where you installed the Silk Test Classic Agent software, locate the directory where
the Silk Test Unix Agent TAR files are.

By default, this location is c:\Program Files\Silk\Silk Test\unix_agent.

2. Copy the TAR file that is appropriate for your Unix machine.

Silk Test provides the following files:

• linux21_sp3.tar.gz – For Linux 2.1
• linux30_sp3.tar.gz – For Linux 3.0
• solaris_sp3.tar.gz – For Solaris 9 and 10

3. Extract the TAR file on your Unix machine by typing tar xzf <filename>.tar.gz.

where <filename> is the appropriate file name for your version of Unix.

4. Change to the bin directory and then run a shell or cshell script.
For instance, type:

cd bin
csh <filename>

5. Start the Agent.

Uninstalling Silk Test
When you install a new version of Silk Test, the wizard prompts you to uninstall any existing versions of Silk
Test. You can also uninstall Silk Test from the programs menu at any time.

34 | Installing Silk Test



1. Click (in Microsoft Windows 7) Start > Programs > Silk > Silk Test > Administration > Silk Test
Uninstall or (in Microsoft Windows 10) Start > Silk > Silk Test Uninstall. The InstallAnywhere wizard
opens the Uninstall Silk Test <version> page.

2. Click Uninstall.
The following items or folders are removed:

• The Access database and samples.
• The contents of [AppDATA]/Silk/Silk Test.

For example, on Windows 7 this directory is located at: C:\Users\[username]\AppData
\Roaming\Silk\Silk Test.

• The contents of [commonAppData]/Silk/Silk Test.

For example, on Windows 7 this directory is located at: C:\ProgramData\Silk Test.
• The contents of [commonAppData]/Silk/Silk Test Workbench.

For example, on Windows 7 this directory is located at: C:\ProgramData\Silk Test
Workbench.

If any files were not removed, a list of the files is provided.

3. Click Done.

Silk Test Silent Mode Installation
During a typical user-driven installation, the install process gets its information from a user responding to
dialog boxes. However, during a silent installation, the installation process gets its information from a
properties file. Silent installation is especially useful if you want to distribute software over a LAN or the
Internet by using remote installation tools. You can execute silent installs of the following types:

• Complete – Installs Silk Test Workbench, the Silk Test Agents, Silk Test Recorder, Silk4J, Silk4NET,
and Silk Test Classic.

• Standard – Installs Silk Test Workbench, the Silk Test Open Agent, Silk Test Recorder, Silk4J, and
Silk4NET.

• Basic – Installs Silk Test Workbench and the Silk Test Open Agent.
• Agent/Runtime – Installs Silk Test Runtime and the Silk Test Agents.

Creating a Silent Installation Properties File
Before you can run the installation package in silent mode, you must create a properties file that includes
the settings for the installation.

1. Open a text editor, such as Notepad.

2. Paste the following example into the text editor, name the file, and then save the file with
a .properties extension.

For example, you might call the file SilentInstall.properties.

# Silent Installation Execution Instructions:
################################
# Start the Install.exe (not Setup.exe) with the following arguments:
# -i silent -f [path to properties file][properties file]
# (You may use the direct or the relative path to the properties file)
#
# example: install.exe -i silent -f SilentInstall.properties
#
# SilkTest installation path - use "\\" to separate directories 
# (default: [System_Programs_Folder]\\Silk\\Silk Test)
################################
# USER_INSTALL_DIR_CHOSEN=C:\\Program Files\\Silk\\Silk Test
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#
# Select an install set:
# (default: complete)
################################
# basic - Basic (Workbench)
# standard - Standard (Workbench, Silk4J, Silk4NET)  
# complete - Complete
# agent_runtime - Agent/Runtime Only
# NONE - Custom mode
# SELECTED_INSTALL_SET=complete
#
# Shortcut locations: enter the location(s) for icons.
# (allowed: Desktop, QuickLaunch)
# (default: no shortcuts)
################################
# SHORTCUT_LOCATIONS=Desktop,QuickLaunch
#
# Path to the existing Eclipse directory (containing eclipse.exe) into
# which Silk4J will be integrated 
# (default: USER_INSTALL_DIR_CHOSEN)
################################
# ECLIPSE_CHOSEN_DIR=C:\\Eclipse
#
# Silk4NET installation option: if set to 1, Silk4NET will be integrated
# into an existing VS2010
# (default: 0)
################################
# USER_INPUT_SILK4NET_INTEGRATE=1
#
# Firewall exceptions:
# (default: no exceptions)
#########################
# USER_INPUT_FIREWALL=Yes
#
# Create system restore point
# (default: 1)
################################
# CREATE_SYSTEM_RESTORE=0
#
# Allow Silk Test to collect usage data
# (default: 1)
#########################################
# if set to 0, data collection will be disabled
# USER_INPUT_USAGE_DATA=1
#
# Licensing Mode (no default value)
###############################
# Use to install an evaluation license
# USER_VERSION_EVAL=1
#
# Use to install a full license
# USER_VERSION_FULL=1
# 
# Settings that specify the license server and port
# (no default values)
################################
# LICENSE_SERVER=localhost
# Port of license server
# LICENSE_PORT=5461
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Setting Up the Silent Installer
Before you can set up the properties for the silent installer, you must create a properties file that includes
the settings for the installation.

Note: To set a property value, make sure to remove the hash (#) sign from the property value string.

1. In a text editor, open the properties file that you created for the silent installation.

2. Locate the SELECTED_INSTALL_SET property and set the value to match the type of installation that
you want to complete.

Choices include:

# basic         - Basic (Workbench)
# standard      - Standard (Workbench, Silk4J, Silk4NET)
# complete      - Complete 
# agent_runtime - Agent/Runtime Only
# NONE - Custom mode

For example:

• To install the complete version of Silk Test, type:

SELECTED_INSTALL_SET=complete

• To install Silk Test Classic, type:

SELECTED_INSTALL_SET=NONE
CHOSEN_INSTALL_FEATURE_LIST=OA,CA,Partner

Note: When you use the custom mode, you can specify the components that you want to install
by setting the CHOSEN_INSTALL_FEATURE_LIST. Do not set this option if you use another
mode. The list includes the following components:

Component Value

Open Agent OA

Silk Test Workbench VT

Classic Agent CA

Silk Test Classic Partner

Silk4J Silk4J

Silk4NET Silk4NET

Silk Test Runtime RunTime

3. To include additional shortcut icons, locate the SHORTCUT_LOCATIONS property and specify one or
both of the following options:

• Desktop – Adds icons to the desktop.
• QuickLaunch – Adds icons to the Quick Launch toolbar.

For example to install both the Desktop and Quick Launch icons, type:

SHORTCUT_LOCATIONS=Desktop,QuickLaunch

4. To integrate an existing Eclipse environment with the Silk4J Java Testing Framework (JTF), locate the
ECLIPSE_CHOSEN_DIR property and specify the Eclipse directory location.
For example, you might specify:

ECLIPSE_CHOSEN_DIR=C:\\Eclipse

where C:\\Eclipse is the directory where Eclipse is installed.
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Note: Directory levels are specified with a double \\.

5. To install Silk4NET for use with an existing Visual Studio environment, locate the
USER_INPUT_SILK4NET_INTEGRATE property and specify one of the following options:

• 0 – Silk4NET is not set up for use.
• 1 – Silk4NET is set up for use.

The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.

Note: Ensure that the Visual Studio components for VB .NET or C# development are available in
the Visual Studio installation with which you want to use Silk4NET.

For example, you might specify:

USER_INPUT_SILK4NET_INTEGRATE=1

6. To specify the language for the Classic Agent browser application, locate the
USER_INPUT_BROWSER_LANGUAGE property and specify one of the following languages:

By default, English is specified.

• English

• Simplified Chinese

• French

• German

• Japanese

For example, you might specify:

USER_INPUT_BROWSER_LANGUAGE=English

7. To specify the default browser for the Classic Agent, locate the USER_INPUT_DEFAULT_BROWSER
property and specify one of the following choices:

By default, the installer uses the default system browser, if it supported by Silk Test.

• None - Choose None if you do not test with the Classic Agent or if you do not test web applications.
• Firefox

• Internet Explorer

For example, you might specify:

USER_INPUT_DEFAULT_BROWSER=Firefox

8. To specify the Internet Explorer version for the Classic Agent, locate the IE_VERSION property and
specify 6, 7, or 8.
For example, you might specify:

IE_VERSION=7

9. To specify the Mozilla Firefox version for the Classic Agent, locate the FIREFOX_DOMEX_VERSION
property and specify 1_5 or 2_0.
For example, you might specify:

FIREFOX_DOMEX_VERSION=2_0

10.Specify whether the installation includes Windows firewall exceptions for all Silk Test executable files.

By default, no firewall exceptions are set.

For example, to create Windows firewall exceptions specify:

USER_INPUT_FIREWALL=Yes

11.Specify whether you want to allow Micro Focus to collect usage data.

• To allow usage data collection, type:

USER_INPUT_USAGE_DATA=1
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• To disable usage data collection, type:

USER_INPUT_USAGE_DATA=0

12.Specify whether the installation requires an evaluation license or a full license.

• To use a 45-day trial evaluation license, type:

USER_VERSION_EVAL=1

• To use a full license, type:

USER_VERSION_FULL=1

13.To specify the license server name, locate the LICENSE_SERVER property and specify the server
name.

This value is not set by default. To use your local machine, in most cases, you type localhost.

14.To specify the license server port, locate the LICENSE_PORT section.

This value is not set by default. To use the predefined port, type 5461.

15.Save the file.

Run the silent installation command to launch the installation.

Using the Web Installer to Install in Silent Mode
Before you can run the installation package in silent mode, you must

• Create a properties file that includes the settings for the installation.
• Install Windows Installer version 4.5 on the host machine.

When you use the Installation wizard, Windows Installer version 4.5 is installed automatically. When
you use Silent mode, you must manually install this component if it is not already on the machine.

Caution: Ensure that earlier versions of Silk Test have been uninstalled before proceeding. If an
earlier version of Silk Test is located on the computer, Silk Test overwrites the existing files without
notification. Do not install multiple versions of Silk Test on the same machine.

To install Silk Test with the Web installer and without any user interaction:

1. Locate the installation package on your hard drive.

2. To execute silent installation, enter the following command from a DOS shell or batch file.

SilkTest<Version>.exe -i silent -f [path to properties file]\[properties 
file]

Where the <Version> is the Silk Test version and build number, for example
SilkTest14.0_6393.exe

Note: The properties file is a text file with the extension .properties . You can name the file
whatever you choose.

For example, if the silent installation properties file is located in the same directory as the
SilkTest<Version>.exe, you might specify:

SilkTest<Version>.exe -i silent -f SilentInstall.properties 

If the SilkTest<Version>.exe is not located in the same directory as the silent installation
properties file, specify the absolute path to the properties file location. For example:

SilkTest<Version>.exe -i silent -f C:\temp\SilentInstall.properties

Silk Meter is a licensing tool; when you run the silent installer it “skips” detecting a Silk Meter server. If you
have not already configured your license server, you may have to do so after you install Silk Test with the
silent installer.
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Using the Installation CD to Install in Silent Mode
Before you can run the installation package in silent mode, you must

• Create a properties file that includes the settings for the installation.
• Install Windows Installer version 4.5 on the host machine.

When you use the Installation wizard, Windows Installer version 4.5 is installed automatically. When
you use Silent mode, you must manually install this component if it is not already on the machine.

Caution: Ensure that earlier versions of Silk Test have been uninstalled before proceeding. If an
earlier version of Silk Test is located on the computer, Silk Test overwrites the existing files without
notification. Do not install multiple versions of Silk Test on the same machine.

To install Silk Test from the installation CD without any user interaction:

1. Copy the contents of the Silk Test installation CD to an empty directory on your hard drive.

2. To execute silent installation, enter the following command from a DOS shell or batch file.

SilkTest<Version>.exe -i silent -f [path to properties file]\[properties 
file]

Where the <Version> is the Silk Test version and build number, for example
SilkTest14.0_6393.exe

Note: The properties file is a text file with the extension .properties . You can name the file
whatever you choose.

For example, if the silent installation properties file is located in the same directory as the
SilkTest<Version>.exe, you might specify:

SilkTest<Version>.exe -i silent -f SilentInstall.properties 

If the SilkTest<Version>.exe is not located in the same directory as the silent installation
properties file, specify the absolute path to the properties file location. For example:

SilkTest<Version>.exe -i silent -f C:\temp\SilentInstall.properties

Silk Meter is a licensing tool; when you run the silent installer it “skips” detecting a Silk Meter server. If you
have not already configured your license server, you may have to do so after you install Silk Test with the
silent installer.

Verifying the Success of the Silent Installer
When you run the Silent Installer, you may not see any messages or Silk Test dialog boxes. It may be
difficult to know whether the installation was a success. You can, however, review the Silk
Test_<version>_InstallLog.log file, which contains the status of the install. By default, the Silk
Test_<version>_InstallLog.log file is generated in the Silk Test installation directory. We
recommend examining the log file before you make the Silent Installer available for others to use.

Note: If an earlier version of Silk Test, such as Silk Test 2009, is detected on the computer, Silk Test
continues the installation and does not include an entry in the log file. Do not install multiple versions
of Silk Test on the same machine.

1. Locate the Silk Test_<version>_InstallLog.log file and open it in a text editor.

2. To determine whether the Silent Installer succeeded, review the status messages for each action
performed by the setup.

The installation log records SUCCESSFUL, WARNING, or ERROR for each action the installer executes.
The installation log also includes a summary which tallies the number of successes, warnings, non-fatal
errors, or errors.
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For example, an action might look like the following:

Install File: C:\Program Files\Silk\Silk Test\ng\recorder\plugins\
            com.borland.silktest.recorder_11.1.0.4440\plugin.xml
     Status: SUCCESSFUL

The summary might look like the following:

Summary
-------

Installation: Successful.

2497 Successes
0 Warnings
0 NonFatalErrors
0 FatalErrors

Viewing Error Codes
View the installation error codes to analyze the errors that occurred during silent installation.

1. Create a batch file to start the installation and run it.
For example, you might create a file named install.bat with the following code:

@echo off
install.exe -I silent -f SilentInstall.properties
echo %errorlevel%
pause

2. Review the installation codes.

The following table lists possible return values for the Code keyname.

Table 1: Installer Exit Codes

Code Description

0 Success: The installation completed successfully without any warnings or errors.

1 The installation completed successfully, but one or more of the actions from the installation
sequence caused a warning or a non-fatal error.

-1 One or more of the actions from the installation sequence caused a fatal error.

1000 The installation was cancelled by the user.

1001 The installation includes an invalid command line option.

2000 Unhandled error.

2001 The installation failed the authorization check, may indicate an expired version.

2002 The installation failed a rules check. A rule placed on the installer itself failed.

2003 An unresolved dependency in silent mode caused the installer to exit.

2004 The installation failed because not enough disk space was detected during the execution of the
Install action.

2005 The installation failed while trying to install on a Windows 64-bit system, but installation did not
include support for Windows 64-bit systems.

2006 The installation failed because it was launched in a UI mode that is not supported by this installer.

3000 Unhandled error specific to a launcher.

3001 The installation failed due to an error specific to the lax.main.class property.

3002 The installation failed due to an error specific to the lax.main.method property.
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Code Description

3003 The installation was unable to access the method specified in the lax.main.method property.

3004 The installation failed due to an exception error caused by the lax.main.method property.

3005 The installation failed because no value was assigned to the lax.application.name
property.

3006 The installation was unable to access the value assigned to the
lax.nl.java.launcher.main.class property.

3007 The installation failed due to an error specific to the lax.nl.java.launcher.main.class
property.

3008 The installation failed due to an error specific to the
lax.nl.java.launcher.main.method property.

3009 The installation was unable to access the method specified in the
lax.nl.launcher.java.main.method property.

4000 A Java executable could not be found at the directory specified by the java.home system
property.

4001 An incorrect path to the installer jar caused the relauncher to launch incorrectly.

Uninstalling in Silent Mode
Uninstall in silent mode to uninstall Silk Test without any user interaction.

Note: You can uninstall Silk Test with silent mode regardless of how you installed the product.
However, if you install Silk Test in silent mode, the uninstall mode is executed silently also.

1. Locate the Uninstall_Silk Test <version> folder.

The Uninstall Silk Test <version>.exe is located in this folder.

2. To execute the silent mode uninstallation procedure, enter one of the following commands from a DOS
shell or batch file.

• If you installed Silk Test in silent mode, enter the following command.

<Silk Test Install Directory>\Silk\Silk Test\Uninstall_Silk Test 
2011\Uninstall Silk <version>.exe

• If you did not install Silk Test in silent mode, enter the following command.

<Silk Test Install Directory>\Silk\Silk Test\Uninstall_Silk Test <version>
\Uninstall Silk Test <version>.exe -i silent

For example, you might type the following command if you did not install Silk Test in silent mode:

C:\Program Files\Silk\Silk Test\Uninstall_Silk Test <version>\Uninstall 
Silk Test <version>.exe -i silent

Prerequisites for Testing with Apple Safari on a Mac
Before you can test with Apple Safari on a Mac, ensure that the following prerequisites are met:

• The Mac is connected as a remote location to a Windows machine, on which Silk Test is installed.
• If you are testing with Apple Safari 9, the SafariDriver, which is the WebDriver extension for Apple Safari

that inverts the traditional client/server relationship and communicates with the WebDriver client using
WebSockets, needs to be installed on the Mac. With Apple Safari 10.1, Safari features a built-in driver
implementation.

• Java JDK is installed on the Mac.
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• The information service is installed on the Mac. To get the files that are required for the information
service, use the Silk Test installer. For additional information, see Installing the Silk Test Information
Service on a Mac.

• To run tests on Apple Safari, the user that has installed the information service needs to be logged in on
the Mac.

Tip: Micro Focus recommends to set the Mac to automatically log in the correct user during
startup. For additional information, see Set your Mac to automatically log in during startup.

• To run unattended tests against Apple Safari on a Mac, adjust the following energy-related settings in
the Energy Saver pane of the System Preferences:

• Set Turn display off after to Never.
• Check the Prevent computer from sleeping automatically when the display is off check box.

Note: You can use the Silk Test Configuration Assistant to easily configure such settings. To
open the Configuration Assistant on a Mac, click on the Silk Test icon in the status menus and
select Configuration Assistant.

• To run unattended tests against Apple Safari on a Mac, disable the screen saver.

1. Navigate to System Preferences > Desktop & Screen Saver.
2. Click the Screen Saver tab.
3. Set Start screen saver to Never.

Note: You can use the Silk Test Configuration Assistant to easily configure such settings. To
open the Configuration Assistant on a Mac, click on the Silk Test icon in the status menus and
select Configuration Assistant.

• If you are testing with Apple Safari 10.1, enable the Safari developer menu. Choose Safari >
Preferences , click Advanced, and check Show develop menu in menu bar.

• If you are testing with Apple Safari 10.1, enable remote automation. In the Safari developer menu,
check Allow Remote Automation.

• When executing a test for the first time against Apple Safari 10.1, you need to provide a password.

Installing the Silk Test Information Service on a Mac
Note: To install the information service on a Mac, you require administrative privileges on the Mac.

To create and execute tests against Apple Safari on a Mac, or against mobile applications on an iOS or
Android device that is connected to a Mac, install the Silk Test information service (information service) on
the Mac, and then use the Remote Locations dialog box to connect a Windows machine, on which Silk
Test is installed, to the Mac.

To install the information service on a Mac:

1. Ensure that a Java JDK is installed on the Mac.

2. If you want to test mobile applications on an iOS device, ensure that Xcode is installed on the Mac.

3. Access the information service setup file, SilkTestInformationService<Version>-<Build
Number>.pkg.

• If you have downloaded the information service setup file while installing Silk Test, open the folder
macOS in the Silk Test installation directory, for example C:\Program Files (x86)\Silk
\SilkTest.

• If you have not downloaded the information service setup file while installing Silk Test, you can
download the setup file from Micro Focus SupportLine.

4. Copy the file SilkTestInformationService<Version>-<Build Number>.pkg to the Mac.

5. Execute SilkTestInformationService<Version>-<Build Number>.pkg to install the
information service.
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6. Follow the instructions in the installation wizard.

7. When asked for the password, provide the password of the currently signed in Mac user.

8. When Apple Safari opens and a message box asks whether to trust the SafariDriver, click Trust.

Note: You can only install the SafariDriver if you are directly logged in to the Mac, and not
connected through a remote connection.

To complete the installation, the installer logs the current Mac user out. To verify that the information
service was installed correctly, log in to the Mac and click on the Silk Test icon in the top-right corner of the
screen to see the available devices and browsers.

Tip: If the Silk Test icon does not appear, restart the Mac.

What To Do Next

Try the tutorials

If you are new to Silk Test, we recommend that you try the Silk Test tutorials, available from (in Microsoft
Windows 7) Start > Programs > Silk > Silk Test > Documentation > Tutorials.
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Upgrading Silk Test to a New Version
To upgrade Silk Test to a new version, perform the following actions:

1. File a support incident to upgrade your Silk Test licenses.

2. Use the Silk Meter Policy Administrator to import the upgraded licenses into your license server.

Note: You do not need to upgrade your license server.
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Configuring a Silk Test Workbench
Database

To store any assets and settings, Silk Test Workbench requires a database. The default Silk Test
Workbench installation, includes a Microsoft Access database designed for single user operation. For
professional enterprise operation, Silk Test Workbench supports Microsoft SQL Server and Oracle
databases. To use Microsoft SQL Server or Oracle databases with Silk Test Workbench, create and
configure the database on a central server machine and, on each client machine, create a data source
name (DSN) that targets the central database. Micro Focus recommends using Microsoft SQL Server for
long term automation projects with multiple users contributing to the same project.

For information about the supported databases, refer to the Release Notes.

Note: If a database is updated when a new version of Silk Test Workbench is installed, all Silk Test
Workbench users that use this database need to update to the new version of Silk Test Workbench.

Note: Silk Test cannot use 64-bit DSNs. You can review the default DSNs and ODBC drivers for 64-bit
machines using the WOW64 tools, which are located at C:\Windows\SysWow64.

Configuring an SQL Server Database
Important: We recommend that a database administrator or person with general knowledge of
database administration performs the database setup and configuration.

Silk Test Workbench stores and accesses test assets stored in a database configured for use with Silk Test
Workbench. This section describes how to configure the following SQL Server databases to use as a Silk
Test Workbench database.

For information about new features, supported platforms, and tested versions, refer to the Release Notes.

SQL Server Requirements

A SQL Server database configured for use with Silk Test Workbench has the following requirements:

• Each computer running Silk Test Workbench must be able to access the computer where the SQL
Server database resides and have a new data source configured.

• Silk Test Workbench must be installed on all computers accessing the database.
• The Silk Test Workbench database connection file must be configured to point to the SQL Server

database.
• The user that is used to connect to the SQL Server database must have the VIEW_SERVER_STATE

permission on the database.

Note: Silk Test cannot use 64-bit DSNs. You can review the default DSNs and ODBC drivers for 64-bit
machines using the WOW64 tools, which are located at C:\Windows\SysWow64.

For additional information about maintaining a Silk Test Workbench database, refer to the Silk Test
Workbench Help.

Creating a New SQL Server Database
This section describes how to create a SQL Server database using SQL Server Management Studio. In
addition to the following procedures, you must also populate the database with Silk Test Workbench tables
using the Silk Test Workbench Database Maintenance utility.
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1. In the Object Explorer of SQL Server Management Studio, right-click the Databases folder and choose
New Database. The New Database dialog box opens.

2. Enter a name for the database in the Database name text box.

3. Click OK.

Creating a New SQL Server Admin User
A SQL Server user with system administrator rights is required to perform subsequent setup steps.

This user requires the following permissions:

• Either sysadmin or both db_ddladmin and db_owner.
• db_datareader.
• db_datawriter.

These permissions are required because the user needs to be able to create indexes by using the 
CREATE INDEX (Transact-SQL) statement. Once the Silk Test Workbench database has been created, all
users who connect to the database only require db_datareader and db_datawriter permissions.

1. To create a new user with system administrator rights, perform the following steps:

a) In the Object Explorer of SQL Server Management Studio, navigate to the Security folder and
expand it.

b) Right-click the Logins folder and choose New Login. The Login - New dialog box opens.
c) Select the General page, and then enter a user name in the Login name text box.
d) Select SQL Server Authentication and enter a password.
e) Select the default database from the Default database list.
f) Select the Server Roles page, and then check the sysadmin check box in the Server roles list.
g) Select the User Mapping page.
h) In the Map column, check the check box for the database that the new login can access.

By default, the login name appears in the User column. Leave this value.
i) In the Database role membership for list, check the db_owner check box.
j) Click OK.

2. To create a new schema for the new user, perform the following steps:

a) In the Object Explorer, navigate to the database in which you want to create a schema.
b) Expand the database object tree to show the Schemas folder.

The Schemas folder is a child of the Security folder for the database.

For example, if you are adding a schema to the master database, expand the following folders to
show the Schemas folder: Databases > System Databases > master > Security.

c) Right-click the Schemas folder and choose New Schema.
d) In the Schema name text box, type a name for the new schema.

The new schema name must match the name of the previously created user with system admin
rights.

e) Assign the new user with system administrator rights as the owner of the schema.
f) Click OK.

3. To add the schema to the database, perform the following actions:

a) Expand the database object tree to show the Users folder.

The Users folder is a child of the Security folder for the database.

For example, if you are adding a schema to the master database, click Databases > System
Databases > master > Security > Users.

b) Double-click the admin user you have just created. The Database User dialog box appears.
c) Select the Owned Schemas page and check that the schema you have just created has been

assigned to the new database.
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Setting Up Users in SQL Server
The following procedure should be performed on the database server computer for each user who needs to
connect to the SQL server database.

1. In the Object Explorer of SQL Server Management Studio, navigate to the Security folder and expand
it. Right-click the Logins folder and choose New Login. The Login - New dialog box opens.

2. Select the General page, and then enter a name for the database in the Login name text box.

3. Select either Windows Authentication or SQL Server Authentication.

4. Select the default database from the Default database list.

5. Select the User Mapping page.

6. In the Map column, check the check box for the database that your login can access.

By default, the login name appears in the User column. Leave this value.

7. In the Default Schema column, enter the default schema.

For use with Silk Test Workbench, the default schema must match the schema of the previously created
user with system admin rights.

8. In the Database role membership for list, leave the default option public selected.

9. Check the db_datareader and db_datawriter check boxes.

10.Click OK.

Important: To use SQL Server Express with multiple users, each SQL Server Express installation
must be enabled for remote connectivity. To enable SQL Server Express for remote connectivity, refer
to the Microsoft support article How to enable remote connections on SQL Server .

Preparing the SQL Server Silk Test Workbench
Database

Note: SQL Server Authentication Mode must be set to: SQL Server and Windows (Mixed Mode) to
allow connection to the SQL Server database through the Database Maintenance utility. This setting
can be changed after any database maintenance tasks are performed.

Note: You can only perform the tasks described in this topic if the SQL Server database is empty.

You must prepare your new SQL Server database for use with Silk Test Workbench. This section describes
how to use the Database Maintenance utility to populate the database with Silk Test Workbench tables.

1. Click (in Microsoft Windows 7) Start > Programs > Silk > Silk Test > Administration > Database
Maintenance or (in Microsoft Windows 10) Start > Silk > Database Maintenance. The Database
Maintenance utility starts.

2. Click File > New Database > SQL Server. The SQL Server Data Source Connection dialog box
opens.

3. Type the name of the new SQL Server data source or click Browse and select a data source name from
the Select ODBC Data Source dialog box.

4. In the appropriate text boxes, type the name of the database owner, which is the user with the role
db_owner, and the SQL Server user ID and password, and then click Create.

Note: Only one schema can be associated with a DSN name (ODBC connection). If the chosen
DSN name is already associated with a schema, click Replace to change the association of the
DSN name from its current schema to the new schema (users will no longer be able to access Silk
Test Workbench tables in the old schema), or click Alias to create an alias for the DSN name.

You are now ready to start Silk Test Workbench and log on.

48 | Configuring a Silk Test Workbench Database



Configuring an Oracle Database
This section describes how to set up an Oracle database with Silk Test Workbench.

Note: The following instructions assume familiarity with the Oracle database management system.
We recommend that a database administrator or a person with general knowledge of database
administration performs database setup and configuration.

Each client computer requires an ODBC data source to connect to the database. As a result, connecting to
an Oracle database for Silk Test Workbench has the following requirements:

• Each computer running Silk Test Workbench must be able to access the computer where the database
resides and have a new data source configured.

• Silk Test Workbench must be installed on all computers that access the database.
• The appropriate database client connectivity software must be installed on any computer that runs Silk

Test Workbench.
• The database connection must be configured for use with Silk Test Workbench.

Selecting an Authentication Method
Silk Test Workbench supports the use of either Oracle OS authentication (Windows NT) or Oracle
database authentication. There are additional installation procedures required when using Oracle OS
authentication.

Oracle OS Authentication
This topic provides instructions for creating users and granting connection rights when using Oracle OS
authentication. Prior to performing these steps, consider the following:

• You must be a member of the ORA_DBA group and have SYSDBA privileges.
• Users must be created in such a way that Oracle knows they are authenticated via a DOMAIN

controller.
• Use SQL*Plus or SQL*Plus Worksheet to create users. If you are not familiar with SQL*Plus, consult

your Oracle documentation.
• Users must be created within a Windows NT domain and added to the ORA_DBA group. Refer to your

Microsoft Windows documentation for more information about using a Windows domain.
• When setting up users for Silk Test Workbench in Oracle, create a schema to house the actual tables in

addition to the remotely authenticated users. The schema is not domain authenticated, but is password
authenticated.

1. Start SQL*Plus or SQL*Plus Worksheet.

2. Log on as SYSTEM and connect as SYSDBA.

3. Type commands to create each user as "DOMAIN\USERNAME" IDENTIFIED EXTERNALLY, and grant
connection rights and system privileges as shown in the following example.

For each user as "DOMAIN\USERNAME". Type DOMAIN\USERNAME in uppercase and between double
quotation marks, where DOMAIN\USERNAME is each user’s domain and user name.

For example:

CREATE USER "NT-DOMAIN\JEFF" IDENTIFIED EXTERNALLY;
GRANT SELECT ANY SEQUENCE TO "NT-DOMAIN\JEFF";
GRANT UNLIMITED TABLESPACE TO "NT-DOMAIN\JEFF";
GRANT "CONNECT" TO "NT-DOMAIN\JEFF";
GRANT "RESOURCE" TO "NT-DOMAIN\JEFF";
GRANT "SELECT_CATALOG_ROLE" TO "NT-DOMAIN\JEFF";
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Important: Microsoft operating systems return the DOMAIN\USERNAME when the user is queried.
If this does not match what is defined in the database, Oracle OS authentication will fail with
ORA-1017.

4. Test that Oracle OS authentication is set up correctly by connecting to the database via SQL*Plus.

a) Type a "/" for the user name.
b) Leave the Password text box empty, and enter the host string appropriately.
c) Click OK. If you can log on, Oracle OS authentication is working properly.

Oracle Database Authentication
This topic provides instructions for creating users and granting connection rights when using Oracle
database authentication. Prior to performing these steps, consider the following:

• You must be a member of the ORA_DBA group and have SYSDBA privileges.
• Use SQL*Plus or SQL*Plus Worksheet to create users. If you are not familiar with SQL*Plus, consult

your Oracle documentation.
• When setting up users for Silk Test Workbench in Oracle, create a schema to house the actual tables in

addition to the remotely authenticated users. The schema is not domain authenticated, but is password
authenticated.

1. Start SQL*Plus or SQL*Plus Worksheet.

2. Log on as SYSTEM and connect as SYSDBA.

3. Type commands to create each user as "USERNAME" IDENTIFIED BY “ORACLEPASSWORD”, and
grant connection rights and system privileges as shown in the following example.

For each user as "USERNAME". Type USERNAME in uppercase and between double quotation marks,
where DOMAIN\USERNAME is each user’s user name.

For example:

CREATE USER "JEFF" IDENTIFIED BY “ORACLEPASSWORD”;
GRANT SELECT ANY SEQUENCE TO "JEFF";
GRANT UNLIMITED TABLESPACE TO "JEFF";
GRANT "CONNECT" TO "JEFF";
GRANT "RESOURCE" TO "JEFF";
GRANT "SELECT_CATALOG_ROLE" TO "JEFF";

Creating a New Oracle Database
Create a new Oracle database with the following character set:

• UTF8 with Oracle versions prior to Oracle 12.
• AL32UTF8 with Oracle 12 or later.

For more information, refer to the Oracle product documentation.

Setting Up Oracle OS Authentication
Note: This procedure is only necessary if you use Oracle OS authentication. If you use Oracle
database authentication, continue by setting up the Oracle client.

1. On the server where the database is located, locate the Oracle Initialization file in the directory where
Oracle was installed.

2. In the Oracle Initialization file, set values for the following parameters:

• remote_login_passwordfile = none

• remote_os_authent = true

• os_authent_prefix = ““
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Note: If any of the parameters and values do not exist, you must add them. In Oracle 11g, the
remote_os_authent and os_authent_prefix parameters are set by default.

3. Locate the SQLNET.ORA file in the directory where Oracle was installed.

The file is located in ORACLE_HOME\Network\Admin directory under the main Oracle installation
directory where ORACLE_HOME is the name assigned for the Oracle home during installation.

4. Open SQLNET.ORA and set the value of the following parameter as follows:

sqlnet.authentication_services = (NTS)
 

Note: Ensure this parameter is not commented out with a # at the beginning of the line. You may
need to add this parameter.

5. Access the Run dialog box from the Start menu.

6. In the Open text box, type regedit and then click OK. The Registry Editor dialog box opens.

7. In the path HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOMEn (where n is the number associated
with the Oracle installation), right-click HOMEn and choose New > String Value. A new string value
appears in the right pane of the registry editor.

8. Replace the default name, New Value #1 with OSAUTH_PREFIX_DOMAIN.

9. Double-click the string value you just created. The Edit String dialog box opens.

10.In the Value data text box, type TRUE and then click OK.

Setting Up the Oracle Client
On the client computer from which you will connect:

1. Locate the SQLNET.ORA file in the directory where Oracle was installed.

The file is located in ORACLE_HOME\Network\Admin directory under the main Oracle installation
directory where ORACLE_HOME is the name assigned for the Oracle home during installation.

2. Open SQLNET.ORA and set the value of the following parameter as follows:

sqlnet.authentication_services = (NTS)

Note: Ensure this parameter is not commented out with a # at the beginning of the line. You may
need to add this parameter.

3. Open the TNSNAMES.ORA file in the directory where Oracle was installed.

This file is located in ORACLE_HOME\Network\Admin directory.

4. Copy the server’s database entry to the TNSNAMES.ORA file on the client computer.
For example:

ORACLE_SID.DOMAIN.COM=
(DESCRIPTION=
(ADDRESS_LIST=
(ADDRESS=(PROTOCOL=TCP)(HOST=SERVERNAME)(PORT=1521))
)
(CONNECT_DATA=
(SERVICE_NAME=ORACLE_SID)
)
)

Preparing the Oracle Database for Client Connectivity
Note: This procedure is only necessary if you are using Oracle OS authentication and an Oracle
client to set up the Silk Test Workbench database. If you are using Oracle database authentication,
you can begin to set up users.
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1. On the computer that has User Manager for Domains, access the Windows Control Panel, and then
choose Administrative Tools > Computer Management 

The Computer Management utility opens.

2. In the tree view, click Local Users and Groups.

3. Click Groups.

If Oracle is installed, you should see a group named ORA_DBA. If not, you must add it.

Next, create server access for users.

Creating the ORA_DBA Group

1. In the tree view of the Computer Management utility, right-click Groups and choose New Group. The
New Group dialog box opens.

2. In the Group Name text box, type ORA_DBA.

3. Click Create.

4. Click Close.

Creating Server Access for Users
To create individual user accounts:

1. In the tree view of the Computer Management utility, click Local Users and Groups.

2. Click Groups.

3. In the right pane, double-click ORA_DBA. The ORA_DBA Properties dialog box opens.

4. Click Add. The Select Users, Computers, or Groups dialog box opens.

5. Click Advanced, then use the Common Queries tab to search for users, click Find Now and select
users from the list.

Alternatively, click in the Enter the object names to select text box and type the following: domain
name\user ID

Where domain name is the name of the domain where the user is located and user ID is the network
ID of the user you want to give access to.

6. Click OK to save the user information and return to the ORA_DBA Properties dialog box.

Repeat steps 4–6 to create any additional user accounts.

7. Click OK in the Users Properties dialog box to return to the Computer Management utility.

Setting Up Users for Silk Test Workbench in Oracle
This section provides instructions for creating users and granting connection rights for users. This
procedure is necessary when using either Oracle OS authentication or Oracle database authentication.
Separate instructions are provided for each type of authentication.

Oracle OS Authentication

Users must be created in such a way that Oracle knows they are authenticated via a DOMAIN controller.

Important:

When setting up users for Silk Test Workbench in Oracle, a schema must be also created to house
the actual tables in addition to the remotely authenticated users. The schema is not domain
authenticated, but is password authenticated. For more information, see Creating the Password
Authenticated Schema.
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Users must be created within a Windows NT domain. Refer to your Microsoft Windows documentation
for more information about using a Windows domain.

Users must be added to the ORA_DBA group. Use SQL*Plus or SQL*Plus Worksheet to create users.
If you are not familiar with SQL*Plus, consult your Oracle documentation.

The user performing these steps must be a member of the ORA_DBA group and have SYSDBA privileges.
To specify users that can access the Oracle database:

1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "DOMAIN\USERNAME" IDENTIFIED EXTERNALLY, and grant

connection rights for each user as "DOMAIN\USERNAME". Type DOMAIN\USERNAME in uppercase and
between double quotation marks, where DOMAIN\USERNAME is each user’s domain and user name. For
example:

SQL> create user "NT-DOMAIN\JEFF" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "NT-DOMAIN\JEFF";

Note: SELECT_ANY_SEQUENCE and SELECT_CATALOG_ROLE must also be granted to the user.
For example:

SQL> grant select any sequence to "JEFF";
SQL> grant select_catalog_role to "JEFF";

Microsoft operating systems return the DOMAIN\USERNAME when the user is queried. If this does
not match what is defined in the database, NT authentication will fail with ORA-1017.

4. Test that Windows NT authentication is set up correctly by connecting to the database via SQL*Plus.
Type a "/" for the user name. Leave the Password field blank, and enter the host string appropriately.
Click OK. If you are able to log on, Windows NT authentication is working properly.

Oracle Database Authentication

Important: When setting up users for Silk Test Workbench in Oracle, a schema must also be created
to house the actual tables in addition to the remotely authenticated users. The schema is password
authenticated. For more information, see Creating the Password Authenticated Schema.

Use SQL*Plus to create users. If you are not familiar with SQL*Plus, consult your Oracle documentation.
The user performing these steps must be a member of the ORA_DBA group and have SYSDBA privileges.

To specify users that can access the Oracle database:

1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "USERNAME" IDENTIFIED BY "ORACLEPASSWORD", and

grant connection rights for each user as "USERNAME". Type USERNAME in uppercase and between
double quotation marks, where DOMAIN\USERNAME is each user’s user name. For example:

SQL> create user "JEFF" IDENTIFIED BY "ORACLEPASSWORD";
SQL> grant connect, resource to "JEFF";

Note: SELECT_ANY_SEQUENCE, SELECT_CATALOG_ROLE, and SELECT_ANY_DICTIONARY
must also be granted to the user. For example:

SQL> grant select any sequence to "JEFF";
SQL> grant select_catalog_role to "JEFF";
SQL> grant select any dictionary to "JEFF";

Creating the Password Authenticated Schema
To set up the password authenticated schema into which the Silk Test Workbench tables are stored,
perform the following steps:
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Note: The password authenticated schema should not be more than five characters in length because
of Oracle character limitations in SQL series.

1. Start SQL*Plus or SQL*Plus Worksheet.

2. Log on as SYSTEM and connect as SYSDBA.

3. Type commands to create each user as "USERNAME" IDENTIFIED BY "ORACLEPASSWORD", and
grant connection rights for each user as "USERNAME".

Type USERNAME in uppercase and between double quotation marks, where USERNAME is each user’s
user name. For example:

SQL> create user "TOM" IDENTIFIED BY "ORACLEPASSWORD";
SQL> grant connect, resource to "TOM";

Preparing the Oracle Database
You must prepare your new Oracle database for use with Silk Test Workbench. This section describes how
to use the Database Maintenance utility to populate the database with Silk Test Workbench tables.

1. Click (in Microsoft Windows 7) Start > Programs > Silk > Silk Test > Administration > Database
Maintenance or (in Microsoft Windows 10) Start > Silk > Database Maintenance. The Database
Maintenance utility starts.

2. Click File > New Database > Oracle. The Oracle Data Source Connection dialog box opens.

3. Type the name of the new Oracle data source or click Browse and select a data source name from the
Select ODBC Data Source dialog box.

4. In the appropriate boxes, type the name of the Oracle user ID, and password, and then click Create.
The Schema box is filled in automatically with the same information as the User ID.

You are now ready to start Silk Test Workbench and log on.

Setting Up a SQL Server or Oracle Database Without a
Domain

We strongly recommend that you use authentication within a domain when setting up an Oracle or SQL
Server database with Silk Test Workbench. However, if you are not on a domain, it is still possible to set up
these databases.

This section provides specific instructions for setting up a SQL Server or Oracle database with a domain.

Creating Users Without a Domain
To set up a SQL Server or Oracle database without a domain, you must first create a user account on both
the client and server computers.

Note: This procedure only applies when using Windows NT authentication.

1. Access the Windows Control Panel, and then choose Administrative Tools > Computer
Management 

The Computer Management utility opens.

2. In the left pane, click Local Users and Groups.

3. Under Local Users and Groups, right-click the Users folder and choose New User. The New User
dialog box opens.

4. Type a valid user name in the User name text box, and the corresponding user’s full name in the Full
Name text box.
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5. Type a valid password in both the Password and Confirm password text boxes, and then click Create.

6. Repeat these steps on each client computer using the username and password.

Setting Up SQL Server Without a Domain
To set up SQL server without a domain:

1. Access the Windows Control Panel, and then choose Administrative Tools > Computer
Management 

The Computer Management utility opens.

2. In the left pane, expand Local Users and Groups, and then click Groups.

3. In the right pane, double-click Users. 

The Users Properties dialog box opens.

4. Click Add. 

The Select Users, Computers, or Groups dialog box opens.

5. Click Advanced, then use the Common Queries tab to search for users.

6. Click Find Now, and then select users from the list.

Alternatively, click in the Enter the object names to select text box and enter the [user ID] of the
user you want to give access.[user ID],:

7. Click OK to save the user information and return to the Users Properties dialog box.

8. Repeat the previous steps to create additional user accounts.

9. Click OK.

Setting Up an Oracle Database Without a Domain
To set up Oracle without a domain, follow the procedure for creating server access for individual user
accounts; however, substitute the user name you created in the procedure for creating users without a
domain.

1. In the Enter the object names to select text box, type the user name instead of [domain name]\
[user ID] or [domain name]\[group name]. 

The Computer Management utility appears.

2. Set up users.

When using SQL*Plus to create users, substitute [computer name\user name] for [domain name
\user name] as shown in the following example.

SQL> create user "FH0002RED\USER1" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "FH0002RED\USER1";

Note:

For the [computer name\user name], use uppercase and enclose in quotes.

Creating a Data Source Name
To work with a database that you have set up for Silk Test Workbench, use the ODBC utility to create a
data source name (DSN) for the Silk Test Workbench database on each machine that connects to the
database.

Note: This step does not apply to default Access databases installed by the Silk Test Workbench
installer. For these databases, a data source name is automatically created.
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Creating a Data Source Name for an Access Database
On each client computer connecting to an Access database, perform the following steps to set up a DSN:

1. Navigate (in Microsoft Windows 7) to Start > Silk > Silk Test > Administration > Data Sources
(ODBC) or (in Microsoft Windows 10) to Start > Windows Administrative Tools > ODBC Data
Sources (32-bit). The ODBC Data Source Administrator dialog box opens.

2. Click the System DSN tab, then click Add. The Create New Data Source dialog box opens. This dialog
box lists the available ODBC drivers.

3. From the list of drivers, select the Microsoft Access Driver and click Finish. The ODBC Microsoft
Access Setup dialog box opens.

4. In the Data Source Name text box, type the data source name.

Enter a logical name as this name appears as the database name in the logon dialog box.

5. In the Description text box, type a description for the data source.
For example, Connection to Silk Test Workbench database.

6. Click Select and browse for your Access database.

7. On the ODBC Microsoft Access Setup dialog box, click OK.

8. On the ODBC Administrator dialog box, click OK to complete the process.

Creating a Data Source Name for a SQL Server
Database

Note: Silk Test Workbench cannot use 64-bit DSNs. To create a DSN for a 64-bit machine, click (in
Microsoft Windows 7) Start > Silk > Silk Test > Administration > Data Sources (ODBC) or (in
Microsoft Windows 10) Start > Windows Administrative Tools > ODBC Data Sources (32-bit) and
create a 32-bit DSN. You can also use the WOW64 tools located at C:\WINDOWS
\SysWOW64\odbcad32.exe.

On each client computer connecting to a SQL server database, perform the following steps to set up a
DSN:

1. Navigate (in Microsoft Windows 7) to Start > Silk > Silk Test > Administration > Data Sources
(ODBC) or (in Microsoft Windows 10) to Start > Windows Administrative Tools > ODBC Data
Sources (32-bit). The ODBC Data Source Administrator dialog box opens.

2. Click the System DSN tab, then click Add. The Create New Data Source dialog box opens. This dialog
box lists the available ODBC drivers.

3. From the list of drivers, select the ODBC Driver 11 for SQL Server and click Finish. The Create a
New Data Source to SQL Server dialog box opens.

4. In the Name box, type the data source name.

Enter a logical name as this name appears as the database name in the logon screen.

5. In the Description text box, type a description for the data source.
For example, Connection to Silk Test Workbench database.

6. In the Server text box, enter the server name or select it from the drop-down list.

7. Click Next.
8. Perform one of the following:

• If user(s) using the DSN to access the SQL Server database are connecting with non-native
credentials, select the With Windows authentication using the network login ID option.

• If user(s) using the DSN to access the SQL Server database are connecting with native
authentication, select the With SQL Server authentication using a login ID and password
entered by the user option. Make sure the Connect to SQL Server to obtain the default settings
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for the additional configuration options check box is checked. Type the users native SQL Server
logon credentials in the Login ID and Password text boxes.

9. Click Next.

10.Check the Change the default database to check box, and then select your database name from the
list.

11.Accept all the other entries and click Next until the last panel in the wizard appears.

12.Accept the defaults and click Finish.

13.To test the connection, click Test Data Source. The SQL Server ODBC Data Source Test dialog box
opens.

14.Click OK.

The ODBC Data Source Administrator dialog box reappears. The newly created data source appears
in the System Data Sources list.

15.Click OK.

Creating a Data Source Name for an Oracle Database
Note: Silk Test Workbench cannot use 64-bit DSNs. To create a DSN for a 64-bit machine, click (in
Microsoft Windows 7) Start > Silk > Silk Test > Administration > Data Sources (ODBC) or (in
Microsoft Windows 10) Start > Windows Administrative Tools > ODBC Data Sources (32-bit) and
create a 32-bit DSN. You can also use the WOW64 tools located at C:\WINDOWS
\SysWOW64\odbcad32.exe.

On each client computer connecting to an Oracle database, perform the following steps to set up a DSN:

1. Navigate (in Microsoft Windows 7) to Start > Silk > Silk Test > Administration > Data Sources
(ODBC) or (in Microsoft Windows 10) to Start > Windows Administrative Tools > ODBC Data
Sources (32-bit). The ODBC Data Source Administrator dialog box opens.

2. Click the System DSN tab, then click Add. The Create New Data Source dialog box opens. This dialog
box lists the available ODBC drivers.

3. From the list of drivers, select the appropriate Oracle ODBC driver for the version of Oracle database
being used (not the Microsoft ODBC for Oracle driver), and then click Finish. The Oracle ODBC Driver
Configuration dialog box opens.

4. In the Oracle Data Source Name text box, type the data source name.

Enter a logical name as this name appears as the database name in the logon dialog box.

5. In the Description text box, type a description for the data source.
For example, Connection to Silk Test Workbench database.

6. In the TNS Service Name text box, select the service name for the database you want to connect to in
the format ORACLE_TNS.DOMAIN, where ORACLE_TNS is usually the Oracle SID that was assigned to
the database upon creation and DOMAIN is the domain to which you are connecting. The domain is
usually optional.

Note: To connect Silk Test Workbench, the TNS service name is mandatory.

7. If using Oracle authentication, type a valid user ID for the database being connected to in the User ID
text box. Otherwise, leave the User ID text box empty.

8. To test the connection, click Test Connection.

Note: When using Oracle database authentication, type a username, and then a password. For
Oracle OS authentication, do not specify a username.

A message box appears stating the connection was successful.

9. Click OK.
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Connecting to a Database
After installing Silk Test Workbench and configuring a database, you must create a database connection.
This connection defines the relationship between a Silk Test Workbench database and the local Silk Test
Workbench installation. This section contains topics describing how to log on and create a database
connection.

Logging On
1. Click (in Microsoft Windows 7) Start > Programs > Silk > Silk Test > Clients > Silk Test Workbench

or (in Microsoft Windows 10) Start > Silk > Silk Test Workbench. Silk Test Workbench starts and
displays the Login to SilkTest Workbench dialog box.

2. From the Authentication list box, select if you want to use the Silk Test Workbench authentication, or
the Windows authentication.

Note: You can use the Windows authentication only for users that were added to the Silk Test
Workbench users by using Tools > Administration.

3. If you are using the Silk Test Workbench authentication, type a user name in the User Name field and
a password in the Password field. If you are using the Windows authentication, you do not have to
provide a user name and password.

Note: If you are using Silk Test Workbench for the first time, an administrative user name and
password may be required. The default user name is Admin and the default password is admin.
Change this password after logging on to prevent unauthorized access. You can change your
logon password at any time.

4. Select the database to use from the Database list.

For a database to appear in the Database list, you must first configure its database connection for use.
To configure a database connection, click Configure on the Logon dialog box.

5. Click OK.

If you are the first user that is logging in to this database, Silk Test Workbench will create a default
project named Project1 in the database. All assets that you create will be stored by default into this
project. You can change the project name by clicking Edit Project.

The Start Screen opens. If you are logging in to Silk Test Workbench for the first time, Silk Test
Workbench selects Project1 or the first available non-global object as the active object.

Changing Your Logon Password
Use the following procedure to change your logon password.

1. Click Tools > Change Password. The Change Password dialog box opens. The logon name of the
current user displays in the title bar of the dialog box.

2. Change your password and then click OK. Changes take effect the next time the User ID is used to log
on.

Configuring a Database Connection
Before you can use a database with Silk Test Workbench, you must configure its database connection. The
configuration process consists of using the Configure Database Connection dialog box to perform the
following tasks:

• Specify the database connection data required to initiate the database connection.
• Verify the connection to the database.
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• Save the database connection data.

All configured database connections appear in the Database list that is located on the Silk Test Workbench
dialog box.

You can also use the Configure Database Connection dialog box to view, edit, and remove any existing
configured database connections.

Note: Before configuring a database connection for use with Silk Test Workbench, you must create
and configure a database instance and ODBC Data Source Name (DSN).

Note: Silk Test Workbench cannot use 64-bit DSNs. To create a DSN for a 64-bit machine, click (in
Microsoft Windows 7) Start > Silk > Silk Test > Administration > Data Sources (ODBC) or (in
Microsoft Windows 10) Start > Windows Administrative Tools > ODBC Data Sources (32-bit) and
create a 32-bit DSN. You can also use the WOW64 tools located at C:\WINDOWS
\SysWOW64\odbcad32.exe.

1. Click Configure on the Login to Silk Test Workbench dialog box. The Configure Database
Connection dialog box opens.

2. In the Data Source Type section, select the type of data source.

3. From the Select Data Source list, select from the list of available DSNs.

4. Check the Use as a Silk Test Workbench database check box to add the selected DSN to the list of
configured database connections that appear in the Database list on the Login to Silk Test Workbench
dialog box.

You must check this check box when configuring a database connection for the first time. For existing
configured database connections, unchecking the Use as a Silk Test Workbench database check box
and clicking Apply removes the selected DSN from the Database list on the dialog box. Silk Test
Workbench does not retain the associated database connection data.

5. In the Database Settings section, specify the appropriate information for the selected DSN. For
Access, the Database box is read-only and displays the location of the database file. This value is read
directly from the ODBC DSN. The other Database Settings text boxes are not applicable for Access
and are disabled. For Oracle, the Server text box is read-only and displays only the database name.
This value is read directly from the ODBC DSN.

6. In the Database box, type the appropriate value. For SQL Server/MSDE, the Database text box is
modifiable and allows you to type the appropriate database name.

7. In the Owner box, type the appropriate value.

8. Select a type of authentication.

Authentication options only apply to Oracle or SQL Server/MSDE databases. You can choose to use
either Windows NT authentication or authenticate using the database’s native authentication
capabilities. When selecting database authentication, you must provide the user name and password in
the appropriate text boxes.

9. Click Validate to verify that you can connect to the database using the specified database connection
data.

10.Click Apply to save the database connection data.

11.Click Close to dismiss the dialog box.
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