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Migrating from the Classic Agent to the
Open Agent

This document provides an overview of the basic concepts of the Open Agent and explains the differences
between the Classic Agent and the Open Agent. If you plan to migrate from testing using the Classic Agent
to the Open Agent, review this information to learn how to migrate your existing assets, including window
declarations and scripts.

Silk Test Agents

The Silk Test agent is the software process that translates the commands in your test scripts into GUI-
specific commands. In other words, the agent drives and monitors the application you are testing. One
agent can run locally on the host machine. In a networked environment, any number of agents can run on
remote machines.

Silk Test Classic provides two types of agents, the Open Agent and the Classic Agent. The agent that you
assign to your project or script depends on the type of application that you are testing.

The Open Agent supports dynamic object recognition to record and replay test cases that use XPath
queries to find and identify objects. With the Open Agent, one Agent can run locally on the host machine.
In a networked environment, any number of Agents can replay tests on remote machines. However, you
can record only on a local machine.

The Classic Agent uses hierarchical object recognition to record and replay test cases that use window
declarations to find and identify objects. With the Classic Agent, one Agent process can run locally on the
host machine, but in a networked environment, the host machine can connect to any number of remote
Agents simultaneously or sequentially. You can record and replay tests remotely using the Classic Agent.

When you create a new project, Silk Test Classic automatically uses the agent that supports the type of
application that you are testing. For instance, if you create an Apache Flex or Windows API-based client/
server project, Silk Test Classic uses the Open Agent. When you open a project or script that was
developed with the Classic Agent, Silk Test Classic automatically uses the Classic Agent. For information
about the supported technology domains for each agent, refer to Testing in Your Environment.

For information about new features, supported platforms, and tested versions, refer to the Release Notes.

Overview of the Locator Keyword

Traditional Silk Test Classic scripts that use the Classic Agent use hierarchical object recognition. When
you record a script that uses hierarchical object recognition, Silk Test Classic creates an include (.inc) file
that contains window declarations and tags for the GUI objects that you are testing. Essentially, the INC file
serves as a central global, repository of information about the application under test. It contains all the data
structures that support your test cases and test scripts.

When you record a test case with the Open Agent, Silk Test Classic creates locator keywords in an INC file
to create scripts that use dynamic object recognition and window declarations. The locator is the actual
name of the object, as opposed to the identifier, which is the logical name. Silk Test Classic uses the
locator to identify objects in the application when executing test cases. Test cases never use the locator to
refer to an object; they always use the identifier.

You can also manually create test cases that use dynamic object recognition without locator keywords.
Dynamic object recognition uses a Find or FindAl 1 function and an XPath query to locate the objects
that you want to test. No include file, window declaration, or tags are required.
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The advantages of using locators with an INC file include:

* You combine the advantages of INC files with the advantages of dynamic object recognition. For
example, scripts can use window names in the same manner as traditional, Silk Test Classic tag-based
scripts and leverage the power of XPath queries.

« Enhancing legacy INC files with locators facilitates a smooth transition from using hierarchical object
recognition to new scripts that use dynamic object recognition. You use dynamic object recognition but
your scripts look and feel like traditional, Silk Test Classic tag-based scripts that use hierarchical object
recognition.

* You can use AutoComplete to assist in script creation. AutoComplete requires an INC file.

Syntax

The syntax for the locator keyword is:
[gui-specifier] locator locator-string

where locator-string is an XPath string. The XPath string is the same locator string that is used for the
Find or FindAll functions.

Example

The following example shows a window declaration that uses locators:

[-1 window MainWin TestApplication
[ 1 locator "//MainWin[@caption="Test Application®]"

1
[ 1 7/ The working directory of the application when it is
invoked
[ 1 const sDir = "{SYS_GetEnv(''SEGUE_HOME'™)}"

[ 1 7/ The command line used to invoke the application
[ 1 const sCmdLine =
" fSYS GetEnv("SEGUE_HOME'™)}testapp.-exe' ™"

[1]
[-1 Menu Control

[ 1 locator *//Menu[@caption="Control~]"
[-1 Menultem CheckBox

[ 1 locator "'//Menultem[@caption="Check box"]"
[-1 Menultem ComboBox

[ 1 locator "//Menultem[@caption="Combo box"]"
[-1 Menultem ListBox

[ 1 locator //Menultem[@caption="List box™]"
[-1 Menultem PopupList

[ 1 locator "//Menultem[@caption="Popup list"]"
[-1 Menultem PushButton

[ 1 locator "//Menultem[@caption="Push button®]"
[-1 Menultem RadioButton

[ 1 locator “//Menultem[@caption="Radio button®]"
[-1 Menultem ListView

[ 1 locator "//Menultem[@caption="List view"]"
[-1 Menultem PagelList

[ 1 locator "//Menultem[@caption="Page list"]"
[-1 Menultem UpDown

[ 1 locator *“//Menultem[@caption="Up-Down=]"
[-1 Menultem TreeView

[ 1 locator "//Menultem[@caption="Tree view"]"
[-1 Menultem Textfield

[ 1 locator "//Menultem[@caption="TextFfield"]"
[-1 Menultem StaticText

[ 1 locator //Menultem[@caption="Static text"]"
[-1 Menultem TracKBar

[ 1 locator "//Menultem[@caption="Track bar=]"
[-1 Menultem ToolBar
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[ 1 locator "*//Menultem[@caption="Tool bar®]"
[-1 Menultem Scrollbar
[ 1 locator "//Menultem[@caption="Scrollbar=]"

[-1 DialogBox CheckBox

[ 1 locator "//DialogBox[@caption="Check Box"]"
[-1 CheckBox TheCheckBox

[ 1 locator "//CheckBox[@caption="The check box"]"
[-1 PushButton Exit

[ 1 locator "//PushButton[@caption="Exit"]"

For example, if the script uses a menu item like this:
TestApplication.Control .TreeView.Pick()

Then the menu item is resolved by using dynamic object recognition Find calls using
XPath locator strings.

The above statement is equivalent to:

Desktop.Find(*“//MainWin[@caption="Test Application”]
//Nenu[@caption="Control"]//Menultem[@caption="Tree
view"]”).Pick(Q)

Locator String Syntax

For convenience, you can use shortened forms for the XPath locator strings. Silk Test Classic automatically
expands the syntax to use full XPath strings when you run a script. You can omit:

* The hierarchy separator, “.//". Silk Test Classic defaults to using “//".

» The class name. Silk Test Classic defaults to the class name of the window that contains the locator.
e The surrounding square brackets of the attributes,"[ ]".

* The “@caption=""if the xPath string refers to the caption.

The following locators are equivalent:

Menu Control
//1ocator "//Menu[@caption="Control™]"
//1ocator "Menu[@caption="Control"]"
//1ocator "[@caption="Control™]"
//locator "@caption="Control™"
locator "Control™

You can use shortened forms for the XPath locator strings only when you use an INC file. For scripts that
use dynamic object recognition without an INC file, you must use full XPath strings.

Window Hierarchies

You can create window hierarchies without locator strings. In the following example, the “Menu Control”
acts only as a logical hierarchy, used to provide the INC file with more structure. “Menu Control” does not
contribute to finding the elements further down the hierarchy.
[-1 window MainWin TestApplication

[ 1 locator "//MainWin[@caption="Test Application™]"

[-1 Menu Control

[-1 Menultem TreeView
[ 1 locator *"//Menultem[@caption="Tree view"]"

In this case, the statement:
TestApplication.Control .TreeView.Pick()

is equivalent to:

Desktop.Find(*“.//MainWin[@caption="Test Application®]
//Menultem[@caption="Tree view"]”).PickQ
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Window Declarations

A window declaration in Silk Test Classic cannot be executed for both agent types, Classic Agent and Open
Agent, during the execution of a test. The window declaration will only be executed for one of the agent

types.

Expressions

You can use expressions in locators. For example, you can specify:

[-1 STRING getSWTVersion()
[ 1 return SYS_GETENV(''SWT_VERSION"™)
[-1 window Shell SwtTestApplication
[ 1 locator "SWT {getSWTVersion()} Test Application”

Comparing the Locator Keyword to the Tag Keyword
The syntax of locators is identical to the syntax of the tag keyword.

The overall rules for locators are the same as for tags. There can be only one locator per window, except
for different gui-specifiers, in this case there can be only one locator per gui-specifier.

You can use expressions in locators and tags.

The locator keyword requires a script that uses the Open Agent while the tag keyword requires a script that
uses the Classic Agent.

Hierarchical Object Recognition

When you record window declarations with the Classic Agent, Silk Test Classic records descriptions based
on hierarchical object recognition of the GUI objects in your application. Silk Test Classic stores the
declarations in an include file (*.inc). When you record or replay a test case with the Classic Agent, Silk
Test Classic references the declarations in the include file to identify the objects named in your test scripts.

The object recognition system of the Classic Agent uses a window declaration identifier as the logical
name of an object and a tag or multitag as the attribution to uniquely identify an object. To permit robust
operation across browsers, Silk Test Classic uses a complicated system of rules to construct the identifiers
and associated attributes.

The window declaration identifiers and tags or multitags are constructed hierarchically from information
such as HTML object attributes and closest static text. The class dependent caption and windowID
construction rules form the basis for the window declaration identifier, single tag, and multitag construction
rules. The Index construction rules are class independent.

Using hierarchical object recognition compared to using dynamic object recognition

Use hierarchical object recognition to test applications that require the Classic Agent. Dynamic object
recognition requires the Open Agent.

Alternatively, you can combine the advantages of INC files with the advantages of dynamic object
recognition by including locator keywords in INC files. Enhancing INC files with locators facilitates a smooth
transition from using hierarchical object recognition to new scripts that use dynamic object recognition.
With locators, you use dynamic object recognition but your scripts look and feel like traditional, Silk Test
Classic tag-based scripts that use hierarchical object recognition.

You can create tests for both dynamic and hierarchical object recognition in your test environment. You can
use both recognition methods within a single test case if necessary. Use the method best suited to meet
your test requirements.
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Open Agent Example

For example, if you record a test to open the New Window dialog box by clicking File >
New > Window in the SWT sample application, Silk Test Classic performs the following
tasks:

* Records the following test:

testcase Testl ()
recording
SwtTestApplication.WindowMenultem.Pick()

» Creates window declarations in the include file for Window menu item. For example:

window Shell SwtTestApplication
locator "/Shell[@caption="Swt Test Application™]"
Menultem WindowMenultem
locator "//Menultem[@caption="Window"]"

Classic Agent Example

For example, if you record a test to open the New Window dialog box by clicking File >
New > Window in a sample application, Silk Test Classic performs the following tasks:

« Records the following test:

testcase Testl ()
recording
SwtTestApplication.File_New.xWindow.Pick()

+ Creates window declarations in the include file for File menu, New menu item, and
xWindow menu item. For example:

Menu File
tag "File"
Menultem New
tag ""New.."
Menultem xWindow
tag "Window"

Dynamic Object Recognition

Dynamic object recognition enables you to create test cases that use XPath queries to find and identify
objects. Dynamic object recognition uses a Find or FindAll method to identify an object in a test case.
For example, the following query finds the first top-level Shell with the caption SWT Test Application:

Desktop.-find(*'/Shell[@caption="SWT Test Application®]")

To create tests that use dynamic object recognition, you must use the Open Agent.
Examples of the types of test environments where dynamic object recognition works well include:

* In any application environment where the graphical user interface is undergoing changes. For example,
to test the Check Me check box in a dialog box that belongs to a menu where the menu and the dialog
box name are changing, using dynamic object recognition enables you to test the check box without
concern for what the menu and dialog box are called. You can then verify the check box name, dialog
box nhame, and menu name to ensure that you have tested the correct component.

« In a Web application that includes dynamic tables or text. For example, to test a table that displays only
when the user points to a certain item on the web page, use dynamic object recognition to have the test
case locate the table without regard for which part of the page needs to be clicked in order for the table
to display.

< In an Eclipse environment that uses views. For example, to test an Eclipse environment that includes a
view component, use dynamic object recognition to identify the view without regard to the hierarchy of
objects that need to open prior to the view.
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Using dynamic object recognition compared to using hierarchical object recognition

The benefits of using dynamic object recognition rather than hierarchical object recognition include:

« Dynamic object recognition uses a subset of the XPath query language, which is a common XML-based
language defined by the World Wide Web Consortium, W3C. Hierarchical object recognition is based on
the concept of a complete description of the application's object hierarchy and as a result is less flexible
than dynamic object recognition.

< Dynamic object recognition requires a single object rather than an include file that contains window
declarations for the objects in the application that you are testing. Using XPath queries, a test case can
locate an object using a Find command followed by a supported XPath construct. Hierarchical object
recognition uses the include file to identify the objects within the application.

You can create tests for both dynamic and hierarchical object recognition in your test environment. You can
use both recognition methods within a single test case if necessary. Use the method best suited to meet
your test requirements.

Using dynamic object recognition and window declarations

Silk Test Classic provides an alternative to using Find or FindAll functions in scripts that use dynamic
object recognition. By default, when you record a test case with the Open Agent, Silk Test Classic uses
locator keywords in an include (.inc) file to create scripts that use dynamic object recognition and window
declarations. Using locator keywords with dynamic object recognition enables users to combine the
advantages of INC files with the advantages of dynamic object recognition. For example, scripts can use
window names in the same manner as traditional, Silk Test Classic tag-based scripts and leverage the
power of XPath queries.

Existing test cases that use dynamic object recognition without locator keywords in an INC file will continue
to be supported. You can replay these tests, but you cannot record new tests with dynamic object
recognition without locator keywords in an INC file. You must manually record test cases that use dynamic
object recognition without locator keywords. You can record the XPath query strings to include in test cases
by using the Locator Spy dialog box.

XPath Basic Concepts

Silk Test Classic supports a subset of the XPath query language. For additional information about XPath,
see http://www.w3.org/TR/xpath20/.

XPath expressions rely on the current context, the position of the object in the hierarchy on which the Find
method was invoked. All XPath expressions depend on this position, much like a file system. For example:

» "//Shell" finds all shells in any hierarchy starting from the current context.
« "Shell" finds all shells that are direct children of the current context.

Additionally, some XPath expressions are context sensitive. For example, myWindow.find(xPath) makes
myWindow the current context.

Silk Test Classic provides an alternative to using Find or FindAll functions in scripts that use XPath
queries. You can use locator keywords in an INC file to create scripts that use dynamic object recognition
and window declarations.

Supported XPath Subset

Silk Test Classic supports a subset of the XPath query language. Use a FindAll or a Find command
followed by a supported construct to create a test case.

To create tests that use dynamic object recognition, you must use the Open Agent.

The following table lists the constructs that Silk Test Classic supports.
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Supported XPath Construct

Sample

Description

Attribute

Menultem[@caption="abc™]

Finds all menu items with the given
caption attribute in their object definition
that are children of the current context.
The following attributes are supported:

e caption (without caption index)
» priorlabel (without index)
* windowid

Index

Menultem[1]

Finds the first menu item that is a child
of the current context. Indices are 1-
based in XPath.

Logical Operators: and, or, not, =, !=

Menultem[not(@caption="a*
or @windowid!="b") and
@priorlabel="p"]

TestApplication.Find(*“//
Dialog[@caption="Check
Box"1/./.7.")

Finds the context on which the Find
command was executed. For instance,
the sample could have been typed as
TestApplication.Find(*“//
Dialog[@caption="Check
Box"]1”).

Desktop.Find(*“//
PushButton[@caption="Previ
ous"1/../
PushButton[@caption="0k”]”

)

Finds the parent of an object. For
instance, the sample finds a
PushButton with the caption “Ok” that
has a sibling PushButton with the
caption “Previous.”

/Shell

Finds all shells that are direct children
of the current object.

"./Shell" is equivalent to "/Shell" and
"Shell".

/Shell/Menultem

Finds all menu items that are a child of
the current object.

1

/IShell

Finds all shells in any hierarchy relative
to the current object.

1

/IShell//Menultem

Finds all menu items that are direct or
indirect children of a Shell that is a
direct child of the current object.

)

/[IMenultem

Finds all menu items that are direct or
indirect children of the current context.

*[@caption="c']

Finds all objects with the given caption
that are a direct child of the current
context.

//Menultem/*/Shell

Finds all shells that are a grandchild of
a menu item.

The following table lists the XPath constructs that Silk Test Classic does not support.
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Unsupported XPath Construct Example

Comparing two attributes with each other. PushButton[@caption = @windowid]

An attribute name on the right side is not supported. An PushButton["abc®™ = @caption]

attribute name must be on the left side.

Combining multiple XPath expressions with ‘and' or 'or". PushButton [@caption = "abc"] or .//
Checkbox

More than one set of attribute brackets. PushButton[@caption = “abc] [@windowid =
"123"]

Use PushButton [@caption = "abc and
@windowid = "1237"] instead.

More than one set of index brackets. PushButton[1][2]

Any construct that does not explicitly specify a class orthe  //[@caption = "abc"]
class wildcard, such as including a wildcard as part of a _ .

g P Use //*[@caption = “abc"] instead.
class name.

"/[*Button[@caption="abc'T"

Recording Locators Using the Locator Spy

This functionality is supported only if you are using the Open Agent.

Use the Locator Spy to record the locator of a specific object in your application under test. You can then
copy the locator to the test case or to the Clipboard.

Configure the application to set up the technology domain and base state that your application requires.
Click File > New. The New File dialog box opens.

Select 4Test script and then click OK. A new 4Test Script window opens.

Click Record > Window Locators. The Record Locator dialog appears.

From the Application State list box, select DefaultBaseState to have the built-in recovery system
restore the default base state before the test case begins executing.

a s~ w e

< If you choose DefaultBaseState as the application state, the test case is recorded in the script file as
testcase testcase_name ().

« If you choose another application state, the test case is recorded as testcase testcase name
() appstate appstate_nhame.

6. Click Start Recording. Silk Test Classic performs the following actions:

* Closes the Record Locator dialog box.
e Starts your application, if it was not already running. If you have not configured the application yet,
the Select Application dialog box opens and you can select the application that you want to test.

* Removes the editor window from the display.
* Displays the Recording window.
» Waits for you to take further action.
7. Position the mouse over the object that you want to record. The related locator XPath query string

shows in the Selected Locator text box. The Locator Details section lists the hierarchy of objects for
the locator that displays in the text box.

Note: If you are testing on a browser, the Selected Locator field displays the locator only when
you actually capture it.

8. Perform one of the following steps:
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* Press Ctrl+Alt to capture the object. The Locator field displays the XPath query string for the object.
You can edit the locator.

* Press Ctrl+Shift to capture the object if you specified the alternative Record Break key sequence on
the General Recording Options page of the Recording Options dialog box.

Note: For SAP applications, you must set Ctrl+Shift as the shortcut key combination to use to
pause recording. To change the default setting, click Options > Recorder and then check the
OPT_ALTERNATE_RECORD_BREAK check box.
» Click Stop Recording Locator to capture the locator that is currently displayed in the Locator field.
« If you use Picking mode, click the object that you want to record and press the Record Break keys.

Note: Silk Test Classic does not verify whether the locator string is unique. Micro Focus
recommends that you ensure that the string is unique, because otherwise additional objects might
be found when you run the test. Furthermore, you might want to exclude some of the attributes
that Silk Test Classic identifies because the string will work without them.
9. Click Validate Locator to highlight the object, to which the locator in the Locator field corresponds, in
the test application.

10.To refine the locator, in the Locator Details table, click Show additional locator attributes, right-click
an object and then choose Expand subtree. The objects display and any related attributes display in
the Locator Attribute table.

11.0Optional: You can replace a recorded locator attribute with another locator attribute from the Locator
Details table.
For example, your recorded locator might look like the following:
/Window[@caption="MyApp~]//Control [@id="tablel"]

If you have a caption Fi les listed in the Locator Details table, you can manually change the locator to
the following:
/Window[@caption="MyApp~]//Control[@caption="Files"]

The new locator displays in the Selected Locator text box.
12.Copy the locator to the test case or to the Clipboard.

* Click Paste Hierarchy to Editor to paste the window declarations that are displayed in the Locator
Details into the open Silk Test Classic file.

» Click Copy Hierarchy to Clipboard to copy the window declarations that are displayed in the
Locator Details to the Clipboard.

« Click Paste Locator to Editor to paste the contents of the Locator field into the open Silk Test
Classic file.

* Click Copy Locator to Clipboard to copy the contents of the Locator field to the Clipboard.

( 3y Tip: If you have copied code to the Clipboard, you can click Edit > Paste in the Silk Test Classic
" menu to insert the code into the current window at the location of your choice, or even into a
different editing window.

13.Click Close.

Recording Window Declarations that Include Locator
Keywords

A window declaration specifies a cross-platform, logical name for a GUI object, called the identifier, and
maps the identifier to the object’s actual name, called the tag or locator. You can use locator keywords,
rather than tags, to create scripts that use dynamic object recognition and window declarations. Or, you
can include locators and tags in the same window declaration.

To record window declarations that include locator keywords, you must use the Open Agent.
To record window declarations using the Locator Spy:
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1. Configure the application to set up the technology domain and base state that your application requires.
2. Click Record > Window Locators. The Locator Spy opens.
3. Position the mouse over the object that you want to record and perform one of the following steps:

* Press Ctrl+Alt to capture the object hierarchy with the default Record Break key sequence.

* Press Ctrl+Shift to capture the object hierarchy if you specified the alternative Record Break key
sequence on the General Recording Options page of the Recording Options dialog box.

Note: For SAP applications, you must set Ctrl+Shift as the shortcut key combination. To
change the default setting, click Options > Recorder and then check the
OPT_ALTERNATE_RECORD_BREAK check box.

« If you use Picking mode, click the object that you want to record and press the Record Break keys.
4. Click Stop Recording Locator.
The Locator text box displays the XPath query string for the object on which the mouse rests. The

Locator Details section lists the hierarchy of objects for the locator that displays in the text box. The
hierarchy listed in the Locator Details section is what will be included in the INC file.

5. To refine the locator, in the Locator Details table, click Show additional locator attributes, right-click
an object and then choose Expand subtree. The objects display and any related attributes display in
the Locator Attribute table.

6. To replace the hierarchy that you recorded, select the locator that you want to use as the parent in the
Locator Details table. The new locator displays in the Locator text box.

7. Perform one of the following steps:

« To add the window declarations to the INC file for the project, position your cursor where you want to
add the window declarations in the INC file, and then click Paste Hierarchy to Editor.

* To copy the window declarations to the Clipboard, click Copy Hierarchy to Clipboard and then
paste the window declarations into a different editing window or into the current window at the
location of your choice.

8. Click Close.

Differences Between the Silk Test Agents

This section describes the key differences between the Classic Agent and the Open Agent.

Differences for Agent Options Between the Silk Test
Agents

Before you migrate existing Classic Agent scripts to the Open Agent, review the Agent Options listed below
to determine if any additional action is required to facilitate the migration.

Classic Agent Option Action for Open Agent

OPT_AGENT_CLICKS_ONLY Option not needed.

Note: Use OPT_REPLAY_MODE for switching
between high-level (API) clicks and low-level clicks.

OPT_CLOSE_MENU_NAME Not supported by Open Agent.

OPT_COMPATIBLE_TAGS Option not needed.

OPT_COMPRESS_WHITESPACE Not supported by Open Agent.
OPT_DROPDOWN_PICK_BEFORE_GET Option not needed. The Open Agent performs this action by

default during replay.
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Classic Agent Option

Action for Open Agent

OPT_EXTENSIONS

Option not needed.

OPT_GET_MULTITEXT_KEEP_EMPTY_LINES

Not supported by Open Agent.

OPT_KEYBOARD_LAYOUT

Not supported by Open Agent.

OPT_MENU_INVOKE_POPUP

No action. Pop-up menu handling using the Open Agent
does not need such an option.

OPT_MENU_PICK_BEFORE_GET

Option not needed.

OPT_NO_ICONIC_MESSAGE_BOXES

Option not needed.

OPT_PLAY_MODE

Option not needed.

OPT_RADIO_LIST

Open Agent always sees RadioL i st items as individual
objects.

OPT_REL1_CLASS_LIBRARY

Obsolete option.

OPT_REQUIRE_ACTIVE

Use the option OPT_ENSURE_ACT I VE instead.

OPT_SCROLL_INTO_VIEW

Option not needed. Open Agent only requires scrolling into
view for low-level replay. By default, high-level replay is used,
so no scrolling needs to be performed. However,
CaptureBitmap never scrolls an object into view.

OPT_SET_TARGET_MACHINE

Option not needed.

OPT_SHOW_OUT_OF_VIEW

Option not needed. Out-of-view objects are always
recognized.

OPT_TEXT_NEW_LINE

Option not needed. The Open Agent always uses Enter to
type a new line.

OPT_TRANSLATE_TABLE

Not supported by Open Agent.

OPT_TRAP_FAULTS

Fault trap is no longer active.

OPT_TRAP_FAULTS_FLAGS

Fault trap is no longer active.

OPT_TRIM_ITEM_SPACE

Option not needed. If required, use a * wildcard instead.

OPT_USE_ANSICALL

Not supported by Open Agent.

OPT_USE_SILKBEAN

SilkBean is not supported on the Open Agent.

OPT_VERIFY_APPREADY

Option not needed. The Open Agent performs this action by
default.

OPT_VERIFY_CLOSED

Option not needed. The Open Agent performs this action by
default.

OPT_VERIFY_COORD

Option not needed. The Open Agent does not typically check
for native input in order to allow clicking outside of an object.

OPT_VERIFY_CTRLTYPE

Option not needed.

OPT_VERIFY_EXPOSED

Option not needed. The Open Agent performs this action
when it sets a window to active.
OPT_ENSURE_ACTIVE_OBJECT_DEF should yield the

same result.

OPT_VERIFY_RESPONDING

Option not needed.

OPT_WINDOW_MOVE_TOLERANCE

Option not needed.
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Differences in Object Recognition Between the Silk
Test Agents

When recording and executing test cases, the Classic Agent uses the keywords tag or multitag in a window
declaration to uniquely identify an object in the test application. The tag is the actual name, as opposed to
the identifier, which is the logical name.

When using the Open Agent, you typically use dynamic object recognition with a Find or FindAll
function and an XPath query to locate objects in your test application. To make calls that use window
declarations using the Open Agent, you must use the keyword locator in your window declarations. Similar
to the tag or multitag keyword, the locator is the actual name, as opposed to the identifier, which is the
logical name. This similarity facilitates a smooth transition of legacy window declarations, which use the
Classic Agent, to dynamic object recognition, which leverages the Open Agent.

The following sections explain how to migrate the different tag types to valid locator strings.

Caption
Classic Agent tag “<caption string>"
Open Agent locator “//<class name>[@caption="<caption string>"]"

Note: For convenience, you can use shortened forms for the XPath locator strings. Silk Test Classic
automatically expands the syntax to use full XPath strings when you run a script.

You can omit:

« The hierarchy separator, “.//". Silk Test Classic defaults to “//".

e The class name. Silk Test Classic defaults to the class hame of the window that contains the locator.
e The surrounding square brackets of the attributes, “[ ]".

* The “@caption="if the XPath string refers to the caption.

Note: Classic Agent removes ellipses (...) and ampersands (&) from captions. Open Agent removes
ampersands, but not ellipses.

Example

Classic Agent:

CheckBox CaseSensitive
tag “Case sensitive”

Open Agent:

CheckBox CaseSensitive
locator “//CheckBox[@caption="Case sensitive"]”

Or, if using the shortened form:

CheckBox CaseSensitive
locator “Case sensitive”

Prior text
Classic Agent tag “"Find What:”
Open Agent locator “//<class hame>[@priorlabel="Find What:]"
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Note: Only available for Windows API-based and Java Swing applications. For other technology
domains, use the Locator Spy to find an alternative locator.

Index

Classic tag “#1”
Agent

Open Agent  Record window locators for the test application. The Classic Agent creates index values
based on the position of controls, while the Open Agent uses the controls in the order
provided by the operating system. As a result, you must record window locators to identify
the current index value for controls in the test application.

Window ID

Classic Agent tag “$1041”

Open Agent locator “//<class name>[@windowid="1041"]"
Location

Classic Agent tag “@(57,75)"
Open Agent not supported

Note: If you have location tags in your window declarations, use the Locator Spy to find an
alternative locator.

Multitag

Classic Agent multitag “Case sensitive” “$1011”"

Open Agent  locator “//CheckBox[@caption="Case sensitive’ or @windowid="1011"]" ‘parent’ statement

No changes needed. Multitag works the same way for the Open Agent.

Differences in the Classes Supported by the Silk Test
Agents

The Classic Agent and the Open Agent differ slightly in the types of classes that they support. These
differences are important if you want to manually script your test cases. Or, if you are testing a single test
environment with both the Classic Agent and the Open Agent. Otherwise, the Open Agent provides the
majority of the same record capabilities as the Classic Agent and the same replay capabilities.

Windows-based applications

Both Agents support testing Windows API-based client/server applications. The Open Agent classes,
functions, and properties differ slightly from those supported on the Classic Agent for Windows API-based
client/server applications.

Classic Agent Open Agent

AnyWin AnyWin

AgentClass (Agent) AgentClass (Agent)
CheckBox CheckBox

ChildWin <no corresponding class>
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Classic Agent

Open Agent

ClipboardClass (Clipboard)

ClipboardClass (Clipboard)

ComboBox

ComboBox

Control

Control

CursorClass (Cursor)

CursorClass (Cursor)

CustomWin

CustomWin

DefinedWin

<no corresponding class>

DesktopWin (Desktop)

DesktopWin (Desktop)

DialogBox

DialogBox

DynamicText

<no corresponding class>

Header HeaderEx
ListBox ListBox
ListView ListViewEx
MainWin MainWin
Menu Menu
Menultem Menultem

MessageBoxClass

<no corresponding class>

MoveableWin

MoveableWin

PagelList PagelList

PopupList ComboBox

PopupMenu <no corresponding class>

PopupStart <no corresponding class>

PopupSelect <no corresponding class>

PushButton PushButton

RadioButton Note: Items in Radiolists are recognized as RadioButtons on the CA. OA only
identifies all of those buttons as RadioList.

RadioList RadioList

Scale Scale

ScrollBar ScrollBar, VerticalScrollBar, HorizontalScrollBar

StaticText StaticText

StatusBar StatusBar

SysMenu <no corresponding class>

Table TableEx

TaskbarWin (Taskbar)

<no corresponding class>

TextField

TextField
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Classic Agent

Open Agent

ToolBar

ToolBar

Additionally: PushToolltem, CheckBoxToolltem

TreeView, TreeViewEXx

TreeView

UpDown

UpDownEx

The following core classes are supported on the Open Agent only:

* CheckBoxToolltem
» DropDownToolltem

« Group

e ltem

e Link

e MonthCalendar
e Pager

¢ PushToolltem

« RadioListToolltem
« ToggleButton

e Toolltem

Web-based Applications

Both Agents support testing Web-based applications. The Open Agent classes, functions, and properties
differ slightly from those supported on the Classic Agent for Windows API-based client/server applications.

Classic Agent

Open Agent

Browser

BrowserApplication

BrowserChild

BrowserWindow

HtmICheckBox

DomCheckBox

HtmIColumn

<no corresponding class>

HtmIComboBox

<no corresponding class>

HtmlForm DomForm

HtmIHeading <no corresponding class>
HtmlIHidden <no corresponding class>
Htmllmage <no corresponding class>
HtmlLink DomLink

HtmiList <no corresponding class>
HtmiListBox DomListBox

HtmIMarquee

<no corresponding class>

HtmIMeta <no corresponding class>
HtmIPopupList DomlListBox
HtmlPushButton DomButton

HtmlIRadioButton

DomRadioButton
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Classic Agent Open Agent
HtmlIRadioList <no corresponding class>
HtmlITable DomTable

HtmlIText <no corresponding class>
HtmlTextField DomTextField

XmINode <no corresponding class>
Xul* Controls <no corresponding class>

Note: The DomElement class of the Open Agent enables you to access any element on an HTML
page. If the Open Agent has no class associated with a specific class supported on the Classic Agent,
you can use the DomElement class to access the controls in the class.

Java AWT/Swing Applications

Both Agents support testing Java AWT/Swing applications. The Open Agent classes, functions, and
properties differ slightly from those supported on the Classic Agent for Windows API-based client/server

applications.
Classic Agent Open Agent
JavaApplet AppletContainer

JavaDialogBox

AWTDialog, JDialog

JavaMainWin

AWTFrame, JFrame

JavaAwtCheckBox AWTCheckBox
JavaAwtListBox AWTList
JavaAwtPopuplList AWTChoice
JavaAwtPopupMenu <no corresponding class>
JavaAwtPushButton AWTPushButton
JavaAwtRadioButton AWTRadioButton
JavaAwtRadioList <no corresponding class>

JavaAwtScrollBar

AWTScrollBar

JavaAwtStaticText AWTLabel
JavaAwtTextField AWTTextField, AWTTextArea
JavaJFCCheckBox JCheckBox

JavaJFCCheckBoxMenultem

JCheckBoxMenultem

JavaJFCChildWin

<no corresponding class>

JavaJFCComboBox

JComboBox

JavaJFClmage

<no corresponding class>

JavaJFCListBox JList
JavaJFCMenu JMenu
JavaJFCMenultem JMenultem
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Classic Agent Open Agent
JavaJFCPagelList JTabbedPane
JavaJFCPopuplList JList
JavaJFCPopupMenu JPopupMenu
JavaJFCProgressBar JProgressBar
JavaJFCPushButton JButton
JavaJFCRadioButton JRadioButton

JavaJFCRadioButtonMenultem

JRadioButtonMenultem

JavaJFCRadioList

<no corresponding class>

JavaJFCScale

JSlider

JavaJFCScrollBar

JScrollBar, JHorizontalScrollBar, JVerticalScrollBar

JavaJFCSeparator JComponent
JavaJFCStaticText JLabel

JavaJFCTable JTable
JavaJFCTextField JTextField, JTextArea
JavaJFCToggleButton JToggleButton
JavaJFCToolBar JToolBar
JavaJFCTreeView JTree
JavaJFCUpDown JSpinner

Java SWT/RCP Applications

Only the Open Agent supports testing Java SWT/RCP-based applications. For a list of the classes, see

Supported SWT Widgets for the Open Agent.

Differences in the Parameters Supported by the Silk

Test Agents

The Classic Agent and the Open Agent differ slightly in the function parameters that they support. These
differences are important if you want to manually script your test cases. Or, if you are testing a single test
environment with both the Classic Agent and the Open Agent. Otherwise, the Open Agent provides the
majority of the same record capabilities as the Classic Agent and the same replay capabilities.

For some parameters, the Open Agent uses a hard-coded default value internally. If one of these
parameters is set in a 4Test script, the Open Agent ignores the value and uses the value listed here.

Function Parameter

Classic Agent Value Open Agent Value

AnyWin::PressKeys/ nDelay
ReleaseKeys

AnyWin::PressKeys/ sKeys
ReleaseKeys
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Any number. 0

More than one key is Only one key is supported.

supported. The first key is used and
the remaining keys are
ignored. For example
MainWin.PressKeys(




Function Parameter Classic Agent Value Open Agent Value

"<Shift><Left>") will
only press the Shift key. To
press both keys, specify

MainWin.PressKeys(

"<Shift>")
MainWin.PressKeys(
"<Left >").
AnyWin::TypeKeys sEvents Keystrokes to type or The Open Agent supports
mouse buttons to press. keystrokes only.
AnyWin::GetChildren binvisible TRUE or FALSE. FALSE.
AnyWin::GetChildren bNoTopLevel TRUE or FALSE. FALSE.
TextField::GetFontName iLine The Classic Agent The Open Agent ignores
recognizes this parameter.  this parameter.
AnyWin::GetCaption bNoStaticText TRUE or FALSE. FALSE.
AnyWin::GetCaption, bRawMode TRUE or FALSE. FALSE. However, the
. . returned strings include
Control::GetPriorStatic trailing and leading spaces,

but ellipses, accelerators,
and hot keys are removed.

PageList::GetContents/ bRawMode TRUE or FALSE. FALSE. However, the
returned strings include
GetPageName trailing and leading spaces,

ellipses, and hot keys but
accelerators are removed.

AnyWin::Click/ bRawEvent The Classic Agent The Open Agent ignores

) recognizes this parameter.  this value.
DoubleClick/

MoveMouse/ MultiClick/
PressMouse/
ReleaseMouse,
PushButton::Click

Overview of the Methods Supported by the Silk Test
Agents

The winclass. inc file includes information about which methods are supported for each Silk Test
Classic Agent. The following 4Test keywords indicate Agent support:

supported_ca Supported on the Classic Agent only.

supported_oa Supported on the Open Agent only.

Standard 4Test methods, such as AnyWin::GetCaption(), can be marked with one of the preceding
keywords. A method that is marked with the supported_ca or supported_oa keyword can only be executed
successfully on the corresponding Agent. Methods that do not have a keyword applied will run on both
Agents.

To find out which methods are supported on each Agent, open the .inc file, for instance winclass. inc,
and verify whether the supported_ca or supported_oa keyword is applied to it.
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Classic Agent

Certain functions and methods run on the Classic Agent only. When these are recorded and replayed, they
default to the Classic Agent automatically. You can use these in an environment that uses the Open Agent.
Silk Test Classic automatically uses the appropriate Agent. The functions and methods include:

e C data types for use in calling functions in DLLs.
» ClipboardClass methods.

e CursorClass methods.

e Certain SYS functions.
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