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Introduction
�  Who Should Read This Guide

�  Related Publications

�  World Wide Web Information

�  Getting Help
.

Who Should Read This Guide
This guide is intended for administrators who are installing or Configur-
ing TestPartner; it does not contain reference or usage information. You 
can find that information in your product’s online help facility and 
documentation set.

Compuware assumes that you are familiar with basic Microsoft Windows 
navigation. If this is not the case, familiarize yourself with the documen-
tation for Microsoft Windows before reading this guide.

Related Publications
The TestPartner installation documentation set includes:

� The TestPartner Installation and Configuration Guide, which contains 
system requirements and instructions for installing TestPartner.

� The License Installation Guide, which contains instructions for licens-
ing your QACenter product.

All of these books are provided in PDF format only. You can access the 
online versions of these books from the installation bookshelf (as 
described below) or from Compuware’s FrontLine customer support Web 
site at http://frontline.compuware.com
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Viewing and Printing Online Books

To access these online books:

1 Insert the QACenter CD into the CD-ROM drive. If the CD browser 
does not automatically start, navigate to the CD’s root directory and 
run setup.exe.

2 Click View QACenter Documentation. The documentation book-
shelf opens in Acrobat Reader. (If necessary, Acrobat Reader can be 
installed from the QACenter CD by clicking Install 3rd Party Soft-
ware, then clicking Install Adobe Acrobat Reader.)

3 From the bookshelf, select the installation guide that you wish to 
view.

Because PDF is based on PostScript, a PostScript printer is the most 
reliable way to print online books. In most cases, you can also print .pdf 
files to PCL printers. If you cannot print the .pdf files to your printer, 
refer to Adobe’s Web site at http://www.adobe.com for troubleshooting 
information.

World Wide Web Information 
To access Compuware Corporation’s site on the World Wide Web, point 
your browser at http://www.compuware.com. The Compuware site 
provides a variety of product and support information.

FrontLine Support Web Site: You can access online customer support for 
Compuware products via the FrontLine support web site. FrontLine 
provides fast access to critical information about your QACenter product. 
You can read or download documentation, frequently asked questions, 
and product fixes, or e-mail your questions or comments. To access 
FrontLine, follow these steps:

1 Open a web browser and go to: http://frontline.compuware.com 
The Welcome to FrontLine page appears.

2 On the right side of the page, enter your login ID and password and 
click the Login button. 

Note: If you are a first-time visitor, click the Register button to receive your 
free password to access FrontLine. After you complete the registra-
tion form, your login ID and password will be e-mailed to you and 
your account will be activated.
6     TestPartner Installation and Configuration Guide
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3 From the drop-down list in the center of the page, select a product 
and click the Go button. You will see the product’s FrontLine home 
page, where you can access documentation, technical information, 
fixes, and other support items.

Getting Help
At Compuware, we strive to make our products and documentation the 
best in the industry. Feedback from our customers helps us maintain our 
quality standards. If you need support services, please obtain the follow-
ing information before calling Compuware’s 24-hour product support 
hotline:

� The name, release (version), and build number of the QACenter prod-
uct. This information is displayed when you select the About com-
mand from your product’s Help menu. The name and release are also 
on the covers of the product documentation.

� Installation information, including installed options, whether the 
product uses local or network databases, whether it is installed in the 
default directories, whether it is a standalone or network installation, 
and whether it is a client or server installation.

� Environment information, such as the operating system and release 
on which the product is installed, memory, hardware/network speci-
fications, and the names and releases of other applications that were 
running.

� The location of the problem in the QACenter product software, and 
the actions taken before the problem occurred.

� The exact product error message, if any.

� The exact application, licensing, or operating system error messages, 
if any.

� Your Compuware client, office, or site number, if available

Compuware Customer support

Compuware Corporation 
One Campus Martius 
Detroit MI 48226-5099 
1-800-538-7822
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Chapter 1

Getting Started
� Overview of QACenter

� Installation Types

� Before Installation

Overview of QACenter
QACenter is a suite of automated software quality products for enterprise 
and e-business applications. QACenter offers a comprehensive solution 
for IT organizations concerned with assuring quality and performance, 
while keeping pace with faster development cycles. QACenter includes:

Compuware Central:  An HTML-based component that provides a Web 
framework for managing and performing testing efforts from the begin-
ning to the end of a project. Compuware Central supports a complete, 
seamless testing process from requirements management to test execu-
tion to results analysis and defect tracking. Because it is Web-based, 
Compuware Central supports remote testing for those organizations 
whose testing and development teams are not in the same geographic 
location. Compuware Central’s flexibility allows small to large compa-
nies to customize it according to their needs.

QADirector:  Coordinates the entire testing process by organizing, track-
ing, and executing automated and manual tests. QADirector integrates 
with Compuware’s testing, program analysis, defect tracking, and 
requirements management tools.

QAHiperstation+: Works with mainframe QAHiperstation to test host-
based applications directly from your Windows desktop. This integrated, 
workstation-based interface tool uses 32-bit code that provides improved 
performance and better stability on 32-bit Windows platforms.
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QARun: Tests enterprise client/server applications. QARun creates and 
runs test scripts that support a wide variety of development tools and the 
diverse components of today's corporate environments. QARun couples 
advanced verification facilities with error-recovery mechanisms to 
reliably test local and remote applications. 

Reconcile: Helps create and control project requirements. It stores the 
project requirements in a relational database. You can view the require-
ments through Microsoft Word, a reporting view (grid), and the Web. 
Reconcile is fully integrated with QADirector and TrackRecord. Working 
together, these products help you manage project development from 
conception through delivery.

TestPartner: Tests Web- and Windows-based applications that use 
Microsoft technologies. You can record user sessions with the applica-
tion, add validation functions, and replay the sessions later to ensure 
that the application works as expected. TestPartner’s scripting language is 
Visual Basic for Applications (VBA); it supports testing of Java, Visual 
Basic, and Visual C++ applications; browser-based Web applications; and 
COM components including both ActiveX controls and automation 
objects.

TrackRecord: Records and reports information about products being 
developed or supported. Information on team members, testers, sched-
ules, and defect reports is recorded in an object-oriented database; it can 
be retrieved using TrackRecord's query and reporting features.

WebCheck:  Checks the quality of even the largest web sites. WebCheck 
automatically scans a web site for more than 50 potential types of 
problems and provides 19 HTML reports. WebCheck is integrated with 
QARun and QADirector and can be used as a stand-alone product.

In addition to the QACenter suite of products, the QACenter CD includes 
Adobe Acrobat Reader, Microsoft Internet Explorer, Java 2 Runtime 
Environment, and Microsoft Virtual Machine installation programs. To 
install one or more of these products from the QACenter CD, click Install 
3rd Party Software, then click on the product installation you would 
like to perform.
10     TestPartner Installation and Configuration Guide



Installation Types
Before you begin, determine the type of installation you need to perform:

Tip: An upgrade to a new 
release does not require 
you to uninstall the 
current release provided 
the current release is not 
a beta version or 
TestPartner 5.0.4 or 
earlier.

Initial Installation: An initial installation is the first-time installation of a 
product on your computer. See the installation chapter for each product 
for instructions.

Modify: A modification of the product installation occurs when you add 
or remove one or more of a product’s components, but not all of them. 
See the maintenance chapter for instructions.

Repair: A repair installation may be necessary due to a corruption of a 
program or the inadvertent deletion of the product. See the maintenance 
chapter for instructions.

Remove: A remove or uninstall removes all the components of a product. 
See the maintenance chapter for instructions.

Before Installation 
Before installing any QACenter product, you should carefully review the 
following information:

System Requirements

Review the system requirements to ensure that you meet the prerequi-
sites for the successful installation and operation of the product. System 
requirements are listed in the Release Notes as well as in this book.

Release Notes

Review the Release Notes for information about new features, technical 
notes, and known issues that may enhance or impact your product’s 
performance. Release Notes contain recent changes that may not be 
included in your QACenter product documentation. 

Release Notes can be viewed from the QACenter CD or on FrontLine, 
Compuware’s product support web site. The Release Notes on FrontLine 
are periodically updated as new information becomes available.

To access the Release 
Notes from the 

QACenter CD, follow 
these steps:

1 Insert the QACenter CD into the CD-ROM drive. If the CD browser 
does not start automatically, navigate to the CD’s root directory and 
run setup.exe.

2 Click View QACenter Release Notes. The Release Notes open in your 
default web browser.
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3 Read the Release Notes online, or print the document.

4 After reading and/or printing the Release Notes, close the document 
to return to the CD browser.

To access the Release 
Notes on FrontLine, 

follow these steps:

1 Open a web browser and go to: http://frontline.compuware.com 
The Welcome to FrontLine page appears.

2 On the right side of the page, enter your login ID and password and 
click the Login button. 

Note: If you are a first-time visitor, click the Register button to receive your 
free password to access FrontLine. After you complete the registra-
tion form, your login ID and password will be e-mailed to you and 
your account will be activated.

3 From the drop-down list in the center of the page, select a product 
and click the Go button. You will see the product’s FrontLine home 
page.

4 On the left side of the product’s homepage, select the Documenta-
tion link. You will see the product’s documentation page, which 
includes links to Release Notes and other documentation types.

5 Click the HTML or PDF icons to view documents.
12     TestPartner Installation and Configuration Guide
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Chapter 2

Installing TestPartner
� System Requirements

� Installing TestPartner

� Setting Up a SQL Server or MSDE Database with TestPartner

� Setting Up an Oracle Database with TestPartner

� Setting Up SQL Server or Oracle for TestPartner Without a 
Domain

� Creating a Data Source Name

� Migrating TestPartner Objects from a Standard Character Set 
to UTF8 (for Unicode)

� Logging On and Starting TestPartner

System Requirements
TestPartner has the following minimum system requirements:

� Microsoft Windows Server 2003 (formerly named .NET server 2003) 
including Standard Edition (32 bit) and Enterprise Edition (32 bit), 
Windows XP Professional with Service Pack 1a or Service Pack 2, or 
Windows 2000 with Service Pack 4.

� Mid-level Pentium III PC with 256 MB of RAM.

� 200 MB of available disk space.

� 800 x 600 or higher screen resolution.

� Microsoft Visual Basic for Applications (VBA) 6.4 (6.4.9969, 6.4.9971, 
or 6.4.9972), 6.3 (6.0.9108), 6.2x (6.0.8967), or 6.2 (6.0.8714). 
TestPartner installs VBA 6.2 (6.0.8714).
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� Microsoft Internet Explorer 6.0 (SP1), Microsoft Internet Explorer 5.5 
(SP2), or Microsoft Internet Explorer 5.01 (build 5.00.3700.100, 
Update Versions SP4; Q822925).

� Microsoft SQL Server v2005, v2000 SP3a, Oracle v9.2.0, v9.0.1, or 
8.1.7 database on a Microsoft platform. For SQL Server v2000 SP3a, 
MDAC 2.6 SP2 (2.62.7400.1) is required for establishing an ODBC 
connection. Microsoft MSDE 2.0 database can be used for up to 5 
users. TestPartner also supports Microsoft Access 2000 as a single-user 
database.

� Adobe Acrobat or Acrobat Reader (provided on the QACenter CD) to 
view the online books in PDF format.

� Additional resources may be required for testing tools and the appli-
cation under test.

Input Method Editor (IME) Support

TestPartner supports the following IMEs for the listed input systems.

Legend X = Supported

Japanese Input 
System:

Description Name Windows 
2000

Windows 
XP

Windows 
2003

MS-IME2000 imejp.ime X X X

MS-IME2002 imjp81.ime X X

MS-IME2003 imjp9.ime X X

Korean Input System:

Description Name Windows 
2000

Windows 
XP

Windows 
2003

MS-IME98 imekr98u.ime X

IME 2002 imekr61.ime X X

IME 2003 imekr.ime X X

Simplified Chinese 
Input System:

Description Name Windows 
2000

Windows 
XP

Windows 
2003

QuanPin winpy.ime X X X
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* Only appears with Windows XP and Windows Server 2003 with Office 
XP Multilingual Support complete install.

Traditional Chinese 
Input System:

Description Name Windows 
2000

Windows 
XP

Windows 
2003

Alphanumeric romanime.ime X X X

Unicode unicdime.ime X X X

Quick quick.ime X X X

Phonetic phon.ime X X X

New Phonetic tintlgnt.ime X X X

New ChangJie cintlgnt.ime X X X

DaYi dayi.ime X X X

ChangJie chajie.ime X X X

Big5 Code winime.ime X X X

Array winar30.ime X X X

Notes: IMEs not listed above are not supported. 
 
Text Services FrameWork (TSF) and the Rich Edit control (version 4.1 
and above) are not supported for recording. This does not affect 
playback. 
 
Office 2003 IMEs are only supported for the Japanese Input System.

MS-PinYin98 pintlgnt.ime X X

MS-PinYin 3.0 pintlgnt.ime X X

NeiMa wingb.ime X X

ZhengMa winzm.ime X X X

ShuangPin winsp.ime X X X

WuBi86 winwb86.ime X* X* X*

WuBi98 winwb98.ime X* X* X*

Enhanced Unicode surime.ime X* X*

Description Name Windows 
2000

Windows 
XP

Windows 
2003
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Installing TestPartner 
This section explains the installation process for TestPartner. Please 
review “System Requirements” on page 13 to ensure that TestPartner will 
install and operate properly on your computer.

Before proceeding with the TestPartner installation, Compuware recom-
mends that you review the TestPartner Release Notes which includes 
information about new features, technical notes, and known issues. The 
Release Notes also document recent changes that might not be included 
in TestPartner documentation. Please review this information carefully; 
the Release Notes document is updated as new product information 
becomes available. To review the Release Notes prior to installation, refer 
to the “Before Installation” section of the “Getting Started” chapter.

Required: Compuware recommends that you exit all non-essential Windows 
programs before running this setup program. Some Windows 
programs may interfere with the installation process. 
 
If TestPartner version 5.0.4 or earlier is installed on your computer, 
or if you have any beta version installed, Compuware recommends 
that you back up your data and uninstall TestPartner before install-
ing the new version. Failure to do so may cause problems.

To install TestPartner, follow these steps:

1 If you are installing TestPartner on Windows 2000 or Windows XP 
Professional, log on as a user with administrator permissions (user 
must have full administrator permissions in order to both install and 
use TestPartner).

2 Insert the Compuware CD into the CD-ROM drive. The CD browser 
should automatically appear. If it does not, open the Run option 
from the Start menu. Click the Browse button to navigate to the 
setup.exe file on the CD-ROM disk.

3 Click Install QACenter Products.

4 Click Install TestPartner. The Choose Setup Language dialog box 
appears.

5 Select the language for which you want TestPartner installed from the 
list and click Next.

An installation setup screen appears, then the Welcome dialog box 
appears.

6 Read the welcome screen and click Next. The License Agreement dia-
log box appears.
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7 Read the license agreement and click Yes to accept the terms of the 
agreement. The Customer Information dialog box appears.

8 Type your name and company in the User Name and Company 
Name fields. Click Next. The Choose Destination Location dialog 
box appears.

9 Select a location for the TestPartner installation.

� By default, TestPartner installs in the folder x:\Program 
Files\Compuware\TestPartner where x is the drive where Win-
dows resides on your computer.

� To specify a different path, click the Browse button and select an 
existing folder or type the path name in the Path field. Click OK.

10 Click Next. The Select Components dialog box appears. This dialog 
box allows you to select or clear components for installation. High-
light a component to view a brief description.

11 Select the components you want to install:

� Active Object Recognition: Lets you define support for Java con-
trols that may not be recognized by TestPartner out of the box. 
The Active Object Recognition (AOR) utility includes a collection 
of core Java classes and lets you add custom Helper classes and 
metadata based on your application and requirements. This com-
ponent is typically used by advanced Java users.

� SAP eCATT Integration: Configures TestPartner for proper inte-
gration with SAP eCATT, the online SAP testing tool for the SAP 
Web Application Server 6.20. This allows for storage/retrieval of 
TestPartner data from the eCATT repository and full integration 
for external testing from eCATT.

� Visual Studio Integration: There are two selections for Visual 
Studio Integration. Microsoft Visual Studio 2005 Team Suite must 
be installed to install these features.
� Visual Studio Team Suite Integration: This option installs 

TestPartner’s integration with Microsoft Visual Studio 2005 
Team Suite. This integration allows you to use TestPartner as 
the testing solution for Visual Studio 2005 test projects. With 
the option installed, you can create TestPartner functional 
test suites, run TestPartner scripts, analyze test runs, and 
launch TestPartner from within Visual Studio 2005. Note that 
if selecting this feature, the Testing Tools sub-component of 
the Team Developer and Tester Tools component for Visual 
Studio 2005 Team Suite must be installed to install this 
feature.
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� Visual Studio Team Test Load Agent Integration: This 
option installs TestPartner’s remote testing integration with 
Visual Studio 2005. This integration allows TestPartner scripts 
to run on remote computers through the Microsoft Visual 
Studio 2005 Team Test Load Agent. Note that the Microsoft 
Visual Studio 2005 Team Test Load Agent and the Visual 
Studio 2005 Team Test Load Controller must be installed on 
the same computer to install this feature.

Note: To start TestPartner functional testing in VisualStudio 2005 Team 
Suite, start VisualStudio 2005 Team Suite after installing TestPartner 
and click Project>Add New Test... or Test>New Test.... When the 
Add New Test dialog box appears, select the Compuware Functional 
Test template and click OK.

Make your selection(s) and click Next. The Select Program Folder 
dialog box appears.

12 Specify a location for the TestPartner program shortcuts. You may 
type a new folder name, or select one from the existing folders list. 
Click Next. The Start Copying Files dialog box appears.

13 Review the summary of the settings that you specified and click Next 
to start copying the program files. The Setup Status dialog box dis-
plays the progress of the installation. 

14 After the installation completes, the Setup Complete dialog box 
appears. Depending on the circumstances, you will see one of the fol-
lowing dialog boxes:

� Display Release Notes and/or Register for FrontLine.
� Display Release Notes: Select this check box to review the 

information in the Release Notes. This file contains 
information about new features, technical notes, and known 
issues that may enhance or impact TestPartner’s performance. 
Release Notes contain recent changes that may not be 
included in your TestPartner product documentation.

� Register for FrontLine: Select this check box to register for 
the FrontLine customer support site. The first time you access 
FrontLine, you are required to register and obtain a password. 
FrontLine provides fast access to critical information such as 
documentation, frequently asked questions, and product 
fixes.

� Restart Your Computer: You may be prompted to restart your 
computer. If you are prompted to restart your computer, you may 
choose to restart it now (recommended) or to restart it later.

15 Click Finish to complete the installation of TestPartner.
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Where To Go Next

� The evaluation license (CompuLock) supplied with your QACenter 
product allows you to install the product and run it for a specific time 
period without first installing a license. During this trial period, you 
will be informed of how much evaluation time remains. 

At any time during the evaluation period, you can obtain and install 
a permanent license. When the evaluation period expires, you must 
obtain a license and install it before you can successfully run this 
product. See the License Installation Guide for instructions on install-
ing a license. To access this online book:

a Insert the QACenter CD into the CD-ROM drive. If the CD 
browser does not automatically start, navigate to the CD’s root 
directory and run setup.exe.

b Click View QACenter Documentation.

c From the bookshelf, select the License Installation Guide.

� If Adobe Acrobat or Acrobat Reader is not installed on your com-
puter, click Install 3rd Party Software, then Install Adobe Acrobat 
Reader from QACenter’s CD browser. Adobe Acrobat or Acrobat 
Reader is required to view the online books in PDF format.

� TestPartner automatically configures an ODBC data source when 
installed using an Access Database. Before using TestPartner with 
other databases, you must create and configure an ODBC data source 
and an ODBC database. Continue to the following sections for 
instructions:

� “Setting Up a SQL Server or MSDE Database with TestPartner” on 
page 20

� “Setting Up an Oracle Database with TestPartner” on page 29

� “Setting Up SQL Server or Oracle for TestPartner Without a 
Domain” on page 42.

� After you have created and configured your database resources, you 
are ready to begin using TestPartner. Refer to TestPartner online help 
for more information about the tasks and activities associated with 
preparing for, planning, building, and running test projects.
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Setting Up a SQL Server or MSDE Database with TestPartner
TestPartner accesses scripts and other assets stored in the TestPartner 
database. This section describes how to set up a SQL Server or MSDE 
database for use with TestPartner. 

Note: Compuware recommends that a database administrator or a person 
with general knowledge of database administration performs the 
database setup and configuration.

SQL Server/MSDE Database Connection Requirements

Each client machine uses an ODBC data source to connect to the 
database. As a result, connecting to the TestPartner database has the 
following requirements:

� Each machine running TestPartner must be able to access the 
machine where the database resides.

� TestPartner must be installed on all machines accessing the database.

� The database connection must be configured for use with TestPart-
ner. See “Configuring a TestPartner Database Connection” on page 
59.

Creating a New SQL Server Database

This section describes how to create a SQL Server 2000 database using 
SQL Server Enterprise Manager and a SQL Server 2005 database using SQL 
Server Management Studio. In addition to the following procedures, you 
must also populate the database with TestPartner tables using the 
Database Maintenance utility, which is described in “Preparing the SQL 
Server TestPartner Database” on page 26. 

Create a SQL Server database on the server machine by following these 
steps (separate instructions are provided for both SQL Server 2000 and 
SQL Server 2005):
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SQL Server 2000

1 From the SQL Server Enterprise Manager, expand the navigation tree 
until the Databases folder is visible. 

2 Right-click the Databases folder and choose New Database. The 
Database Properties window appears. 

3 In the Database Properties window, enter a name for the database in 
the Name field and click OK.

SQL Server 2005

1 In the Object Explorer of SQL Server Management Studio, right-click 
the Databases folder and choose New Database. The New Database 
window appears.

2 Enter a name for the database in the Database Name field.

3 Click OK.

Creating a New SQL Server Admin User

You need to create a SQL Server user with system administrator rights to 
perform subsequent setup steps. To create a SQL Server admin user, 
follow these steps:
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SQL Server 2000

1 In SQL Server Enterprise Manager, navigate to the Security folder and 
expand it. Right-click the Logins icon and choose New Login. The 
SQL Server Login Properties dialog box appears. 

2 Select the General page. Enter a user ID in the Name field and select 
SQL Server Authentication.

3 Click the Server Roles tab. Select System Administrators.

4 Click the Database Access tab. Select your TestPartner database and 
select db_owner in the database roles list that appears below. Click 
OK.

SQL Server 2005

1 In the Object Explorer of SQL Server Management Studio, navigate to 
the Security folder and expand it. Right-click the Logins icon and 
choose New Login. The New-Login window appears.

2 Select the General page. Enter a user ID in the Login name field. 
Select SQL Server Authentication and enter a password. Select the 
default database from the Default database drop-down list.

3 Select the Server Roles page. From the Server roles list, select sysad-
min.

4 Select the User Mapping page.

5 In the Map column, select the check box for the database that your 
login can access. By default, the login name appears in the User col-
umn. Leave this value. 
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6 In the Database role membership for list, select db_owner.

7 Click Ok.

8 In the Object Explorer, right-click the Schemas folder and choose 
New Schema. Create a new schema. The new schema name must 
match the name of the previously created user with system admin 
rights.

9 Assign the system administrator as the owner of the schema.

10 Click OK. 

Setting Up Users in SQL Server

The following procedure should be performed on the database server 
machine for each user who needs to connect to the SQL Server database. 

SQL Server 2000

1 Click Start>Programs>Microsoft SQL Server>Enterprise Manager. 
The SQL Server Enterprise Manager Window appears:

2 In the left pane, navigate to the database to which you would like to 
add users. 
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3 Click Tools>Wizards... or click the Run a Wizard button on the tool-
bar. This is the button with an image of a wand. The Select Wizard 
dialog box appears:

4 Click Database and select Create Login Wizard. Click OK. The Cre-
ate Login Wizard dialog box appears.

5 Click Next.

6 Users that are set up in SQL Server can use either Windows NT or SQL 
Server Authentication. 

7 To use SQL Server Authentication, select the SQL Server login infor-
mation that was assigned to me by the system administrator (SQL 
Server Authentication) option and click Next. The Authentication 
with SQL Server panel appears.

a In the Login ID field, type the SQL Server login ID for the user 
that will be used to access the SQL Server. This ID is used to 
authenticate the user login credentials to the SQL Server data-
base.

b In the Password field, type the password for the user ID entered 
in the Login ID field. Then retype the user’s password in the Con-
firm Password field. Click Next.

c Click Next. The Grant Access to Security Roles panel appears.

d Click Next. The Grant Access to Databases panel appears.

e Click the appropriate check boxes to select the databases to 
which the user’s account is to have access. Click Next.

f Click Finish. Go to step 9.

8 To use Windows NT Authentication, select the Windows account 
information I use to logon to my computer (Windows authentica-
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tion) option and click Next. The Authentication With Windows 
panel appears.

a Type the domain name and user ID or group name for the user or 
group you would like to add

a Select the Grant access to the server option. Click Next.

b Click Next again.

c Select the check box for the database(s) to which the users will 
have access. Click Next.

d Click Finish.

9 In the left pane, navigate to the database to which you added users 
with the Create Login Wizard. Click Users.

10 In the right pane, right-click the user ID or group you added with the 
wizard in the steps above and choose Properties. The Database User 
Properties dialog box appears.

11 Select the db_datareader and db_datawriter check boxes. Click OK.

SQL Server 2005

1 In the Object Explorer of SQL Server Management Studio, navigate to 
the Security folder and expand it. Right-click the Logins icon and 
choose New Login. The New-Login window appears.

2 Select the General page. Enter a user ID in the Login name field. 
Select either Windows Authentication or SQL Server Authentica-
tion. 

3 Select the default database from the Default database drop-down 
list.

4 Select the User Mapping page.

5 In the Map column, select the check box for the database that your 
login can access. By default, the login name appears in the User col-
umn. Leave this value. 

6 In the Default Schema column, enter the default schema. For use 
with TestPartner, the default schema must match the schema of the 
previously created user with system admin rights.

7 In the Database role membership for list, leave the default option 
public checked. Select the db_datareader and db_datawriter check 
boxes.

8 Click OK.
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9 Next, you must add the newly created user to the default schema. In 
the Object Explorer of SQL Server Management Studio, navigate to 
the Schemas folder, right-click the default schema (which was previ-
ously created to match the name of user with system admin rights). 
Select Schema Properties.

10 Select the Permissions page.

11 Click the Add button and select a user.

12 Click OK.

Creating a New Data Source

You must create a new data source to SQL Server from the workstation 
that has TestPartner installed. See “Creating a Data Source Name for a 
SQL Server Database” on page 49 for detailed instructions.

Preparing the SQL Server TestPartner Database

You must prepare your new SQL Server database for use with TestPartner. 
This section describes how to use the Database Maintenance utility to 
populate the database with TestPartner tables.

Required: SQL Server Authentication Mode must be set to: SQL Server and 
Windows (Mixed Mode) to allow connection to the SQL Server 
database through the Database Maintenance utility. This setting 
can be changed after any database maintenance tasks are 
performed.

1 Start TestPartner’s Database Maintenance utility. 

2 Click File>New Database>SQL Server. The SQL Server Data Source 
Connection dialog box appears.
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3 Type the name of the new SQL Server data source or click the Browse 
button and select a data source name from the Select ODBC Data 
Source dialog box. Type the name of the database Owner, the SQL 
Server User ID, and Password. Click the Create button.

Note: A table called TP_DSNSCHEMA must exist in the dbo schema. If the 
table does not already exist in the dbo schema, a System Login 
dialog box appears, requiring the password for dbo. Type the 
password, and click OK. The table is created.

Only one schema can be associated with a DSN name (ODBC connec-
tion). If the chosen DSN name is already associated with a schema, a 
Database Maintenance dialog box appears:

4 Click the Replace button to change the association of the DSN name 
from its current schema to the new schema (users will no longer be 
able to access TestPartner tables in the old schema), or click the Alias 
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button to create an alias for the DSN name, a DSN Alias Creation dia-
log box appears:

5 Type an alias name for the DSN, this alias will be associated with the 
current schema. Click OK.

The Data Source Creation Status dialog box appears and displays the 
progress of the database creation.

Log on to TestPartner

To test your setup, start TestPartner and log on. See “Logging On and 
Starting TestPartner” on page 58 for instructions.
28     TestPartner Installation and Configuration Guide



Setting Up an Oracle Database with TestPartner
This section describes how to set up an Oracle database with TestPartner. 

Note: The following instructions assume familiarity with the Oracle 
database management system. Compuware recommends that a 
database administrator or a person with general knowledge of 
database administration performs database setup and configuration.

Oracle Database Connection Requirements

Each client machine requires a data source to connect to the database. As 
a result, connecting to an Oracle database for TestPartner has the follow-
ing requirements:

� Each machine running TestPartner must be able to access the 
machine where the database resides.

� TestPartner must be installed on all machines that access the data-
base. 

� The appropriate database client connectivity software must be 
installed on any machine that runs TestPartner.

� The database connection must be configured for use with TestPart-
ner. See “Configuring a TestPartner Database Connection” on page 
59.

Selecting an Authentication Method

TestPartner supports the use of either Oracle OS authentication 
(Windows NT) or Oracle database authentication. There are additional 
installation procedures required when using Oracle OS authentication. 
For a complete list of installation procedures required when using either 
authentication method, refer to the appropriate subsection below.

Oracle OS Authentication

1 “Creating a New Oracle Database” on page 30

2 “Setting Up Oracle OS Authentication” on page 30

3 “Setting Up the Oracle Client” on page 31

4 “Preparing the Oracle Database for Client Connectivity” on page 32

5 “Setting Up Users for TestPartner in Oracle” on page 35.

6 “Creating the Password Authenticated Schema” on page 39

7 “Creating a New Data Source” on page 39
Chapter 2� Installing TestPartner     29



8 “Creating the Oracle TestPartner Database” on page 39

Oracle Database Authentication

1 “Creating a New Oracle Database” on page 30

2 “Setting Up the Oracle Client” on page 31

3 “Setting Up Users for TestPartner in Oracle” on page 35.

4 “Creating the Password Authenticated Schema” on page 39

5 “Creating a New Data Source” on page 39

6 “Creating the Oracle TestPartner Database” on page 39

Creating a New Oracle Database

Create a new Oracle database with character set UTF8 (and National 
Character Set UTF8 for Oracle 8i). Consult your Oracle documentation if 
creating an Oracle database is unfamiliar.

Setting Up Oracle OS Authentication
Note: This procedure is only necessary if using Oracle OS authentication. If 

using Oracle database authentication, see “Setting Up the Oracle 
Client” on page 31. 

On the server where the database is located, perform the following steps:

1 Locate the Oracle Initialization file in the directory where Oracle was 
installed.

Note: In Oracle versions below 9i, this file is called INIT.ORA. However, in 
Oracle 9i and later, initialization parameters can be set differently, 
please refer to Oracle documentation for details on initialization.

2 In the Oracle Initialization file, set values for the following parame-
ters:

Note: If any of these parameters and values do not exist, add them.

remote_login_passwordfile = none

remote_os_authent = true

os_authent_prefix = ““

3 Locate the SQLNET.ORA file in the directory where Oracle was 
installed. The file should be located in ORACLE_HOME\Network\Admin 
directory under the main Oracle installation directory where 
ORACLE_HOME is the name assigned for the Oracle home during 
installation.
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4 Open SQLNET.ORA and set the value of the following parameter to 
(NTS):

Note: If this parameter does not exist, add it.

sqlnet.authentication_services = (NTS)

Required: Ensure this parameter is not commented out with a # at the begin-
ning of the line.

5 Click Start>Run. The Run dialog box appears.

6 In the Open field, type regedit. Click OK. The Registry Editor dia-
log box appears. 

7 In the path HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOMEn (where n 
is the number associated with the Oracle installation), right-click 
HOMEn and choose New>String Value. A new string value appears in 
the right pane of the registry editor.

8 Replace the default name, New Value #1, with 
OSAUTH_PREFIX_DOMAIN. 

9 Double-click the string value you just created. The Edit String dialog 
box appears:

10 In the Value data field, type TRUE. Click OK.

Setting Up the Oracle Client

On the client machine from which you will connect, follow these steps:

1 Locate the SQLNET.ORA file in the directory where Oracle was 
installed. The file should be located in ORACLE_HOME\Network\Admin 
directory under the main Oracle installation directory where 
ORACLE_HOME is the name assigned for the Oracle home during 
installation.

2 Open SQLNET.ORA and set the value of the  
sqlnet.authentication_services as follows:

Note: If this parameter does not exist, add it.

sqlnet.authentication_services = (NTS)
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Required: Ensure this parameter is not commented out with a # at the begin-
ning of the line.

3 Open the TNSNAMES.ORA file in the directory where Oracle was 
installed. This file should be located in ORACLE_HOME\Network\Admin 
directory.

4 Copy the server’s database entry to the TNSNAMES.ORA file on the cli-
ent machine. For example:

ORACLE_SID.DOMAIN.COM=
(DESCRIPTION=
(ADDRESS_LIST=
(ADDRESS=(PROTOCOL=TCP)(HOST=SERVERNAME)(PORT=1521))
)
(CONNECT_DATA=
(SERVICE_NAME=ORACLE_SID)
)
)

Preparing the Oracle Database for Client Connectivity
Note: This procedure is only necessary if you are using Oracle OS authenti-

cation. If you are using Oracle database authentication, see “Setting 
Up Users for TestPartner in Oracle” on page 35.

Use the following procedure to prepare an Oracle database for client 
connectivity.

Note: This procedure is only necessary if you are using an Oracle client to 
set up the TestPartner database.

Required: You must be a member of the ORA_DBA group and have SYSDBA 
privileges to perform these steps. 
 
You must create users within a Windows NT domain. Refer to your 
Microsoft Windows documentation for more information about 
using a Windows domain. 
 
These procedures are for the Windows 2000 operating system. To 
set up users in another operating system, consult your Windows 
documentation.

1 On the machine that has User Manager for Domains, click Start>Set-
tings>Control Panel.

2 Select Administrative Tools. 
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3 Select Computer Management. The Computer Management utility 
window appears:

4 In the tree view, click Local Users and Groups.

5 Click Groups.

If Oracle is installed, you should see a group named ORA_DBA. If not, 
add it using the following procedure:

Creating the 
ORA_DBA group:

1 In the tree view of the Computer Management utility, right click 
Groups and choose New Group. The New Group dialog box appears. 

2 In the Group Name field, type ORA_DBA. 

3 Click Create.

4 Click Close.

You are now ready to create server access for users.

Creating Server 
Access For Users 

To create individual user accounts:

1 In the tree view of the Computer Management utility, click Local 
Users and Groups.
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2 Click Groups.

3 In the right pane, double click ORA_DBA. The ORA_DBA Properties 
dialog box appears: 
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4 Click the Add button. The Select Users or Groups dialog box appears:

5 In the Name field, browse for the user’s ID, select it, and click Add. 

Or, click in the text area under the Add button and type:

domain name\user ID

Where:

domain name: The name of the domain where the user is 
located.

user ID: The network ID of the user you want to give 
access to.

6 Click OK to save the user information and return to the ORA_DBA 
Properties dialog box.

7 Repeat step 4–6 to create any additional user accounts. 

8 When you are finished, click OK in the Users Properties dialog box to 
return to the Computer Management utility.

Setting Up Users for TestPartner in Oracle
Note: This procedure is necessary when using either Oracle OS authentica-

tion or Oracle database authentication. Separate instructions are 
provided for each type of authentication. For Oracle OS authentica-
tion, see the subsection immediately after this note. For Oracle 
database authentication see the subsection, “Oracle Database 
Authentication” on page 37.
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Oracle OS Authentication

Users must be created in such a way that Oracle knows they are authenti-
cated via a DOMAIN controller. 

Required: When setting up users for TestPartner in Oracle, a schema must be 
also created to house the actual tables in addition to the remotely 
authenticated users. The schema is not domain authenticated, but 
is password authenticated. See “Creating the Password Authenti-
cated Schema” on page 39 for instructions. 
 
Users must be created within a Windows NT domain. Refer to your 
Microsoft Windows documentation for more information about 
using a Windows domain.

Use SQL*Plus to create users. If you are not familiar with SQL*Plus, 
consult your Oracle documentation.

To specify users that can access the Oracle database, follow these steps:

1 Click Start>Programs>Oracle>Database Administration>SQL Plus. 

2 Log on as SYSTEM and connect as SYSDBA.

3 Type commands to create each user as "DOMAIN\USERNAME" IDEN-
TIFIED EXTERNALLY, and grant connection rights for each user as  
"DOMAIN\USERNAME". Type DOMAIN\USERNAME in uppercase and 
between double quotation marks, where DOMAIN\USERNAME is each 
user’s domain and user name. For example:

SQL> create user "NT-DOMAIN\JEFF" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "NT-DOMAIN\JEFF";

Note: SELECT_CATALOG_ROLE must also be granted to the user. For 
example:

SQL> grant select_catalog_role to "NT-DOMAIN\JEFF";

Required: Microsoft operating systems return the DOMAIN\USERNAME when 
the user is queried. If this does not match what is defined in the 
database, NT authentication will fail with ORA-1017.

4 Grant rights to access the V_$SESSION view to individual users or to 
all users as a public group. 

Required: All TestPartner users will need rights to access the V_$SESSION 
view. To grant these rights, you must be logged on as a user with 
administrative rights, e.g., SYSDBA.
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When connecting remotely, use the server name or its alias from the 
TNSNAMES.ORA file with the password.

If typing the command to remotely grant access for individual users, 
type DOMAIN\USERNAME in uppercase and between double quotation 
marks, where DOMAIN\USERNAME is the user name within the domain 
of each user.

The following shows examples of the commands that are typed for 
remotely granting access for individual users, and remotely granting 
access for all users.

Remotely Granting 
Access for Individual 

Users

SQL>CONNECT SYSTEM/password@ORACLE_SID.DOMAIN.COM AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO “NT-DOMAIN\JEFF”;

Remotely Granting 
Access for All Users 

(PUBLIC) 

SQL>CONNECT SYSTEM/password@ORACLE_SID.DOMAIN.COM AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO PUBLIC;

Note: If you receive any errors that indicate you cannot grant these rights, 
or that the V_$SESSION table cannot be found, you are not logged 
on appropriately.

5 Test that Windows NT authentication is set up correctly by connect-
ing to the database via SQL*Plus. Type a "/" for the user name. 
Leave the Password field blank, and enter the host string appropri-
ately. Click OK. If you are able to log on, Windows NT authentication 
is working properly.

Note: In the future, you do not need to create another Oracle TestPartner 
database to add users. You do not have to perform the procedures 
“Creating a New Data Source” and “Creating the Oracle TestPartner 
Database”.

Oracle Database Authentication

Required: When setting up users for TestPartner in Oracle, a schema must be 
also created to house the actual tables in addition to the remotely 
authenticated users. The schema is password authenticated. See 
“Creating the Password Authenticated Schema” on page 39 for 
instructions.

Use SQL*Plus to create users. If you are not familiar with SQL*Plus, 
consult your Oracle documentation.

To specify users that can access the Oracle database, follow these steps:

1 Click Start>Programs>Oracle>Database Administration>SQL Plus. 

2 Log on as SYSTEM and connect as SYSDBA.
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3 Type commands to create each user as "USERNAME" IDENTIFIED BY 
“ORACLEPASSWORD”, and grant connection rights for each user as  
"USERNAME". Type USERNAME in uppercase and between double 
quotation marks, where DOMAIN\USERNAME is each user’s user name. 
For example:

SQL> create user "JEFF" IDENTIFIED BY “ORACLEPASSWORD”;
SQL> grant connect, resource to "JEFF";

Note: SELECT_CATALOG_ROLE must also be granted to the user. For 
example:

SQL> grant select_catalog_role to "JEFF";

4 Grant rights to access the V_$SESSION view to individual users or to 
all users as a public group. 

Required: All TestPartner users will need rights to access the V_$SESSION 
view. To grant these rights, you must be logged on as a user with 
administrative rights, e.g., SYSDBA.

When connecting remotely, use the server name or its alias from the 
TNSNAMES.ORA file with the password.

If typing the command to remotely grant access for individual users, 
type USERNAME in uppercase and between double quotation marks, 
where USERNAME is the user name within the domain of each user.

The following shows examples of the commands that are typed for 
remotely granting access for individual users, and remotely granting 
access for all users.

Remotely Granting 
Access for Individual 

Users

SQL>CONNECT SYSTEM/password@ORACLE_SID.DOMAIN.COM AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO “JEFF”;

Remotely Granting 
Access for All Users 

(PUBLIC) 

SQL>CONNECT SYSTEM/password@ORACLE_SID.DOMAIN.COM AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO PUBLIC;

Note: If you receive any errors that indicate you cannot grant these rights, 
or that the V_$SESSION table cannot be found, you are not logged 
on appropriately. 
 
In the future, you do not need to create another Oracle TestPartner 
database to add users. You do not have to perform the procedures 
“Creating a New Data Source” and “Creating the Oracle TestPartner 
Database”.
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Creating the Password Authenticated Schema

Perform the following steps to set up the password authenticated schema 
into which the TestPartner tables are stored. 

Note: The password authenticated schema should not be more than five 
characters in length because of Oracle character limitations in SQL 
series.

1 If SQL*Plus is not started, start it by click Start>Programs>Ora-
cle>Database Administration>SQL Plus. 

2 If you are not properly logged on, log on as SYSTEM and connect as 
SYSDBA.

3 Type commands to create each user as "USERNAME" IDENTIFIED AS 
"ORACLEPASSWORD", and grant connection rights for each user as 
"USERNAME". Type USERNAME in uppercase and between double 
quotation marks, where USERNAME is each user’s user name. For 
example:

SQL> create user "TOM" IDENTIFIED AS "ORACLEPASSWORD";
SQL> grant connect, resource to "TOM";

Creating a New Data Source

You must create a new data source to Oracle. See “Creating a Data Source 
Name for an Oracle Database” on page 52 for detailed instructions.

Creating the Oracle TestPartner Database

1 Start the Database Maintenance utility.

2 Click File>New Database>Oracle. The Oracle Data Source Connec-
tion dialog box appears.
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3 Type the name of the new Oracle data source or click the Browse but-
ton and select a data source name from the Select ODBC Data Source 
dialog box. Type a User ID, Password, and a brief description of the 
DSN (the Schema field is filled in automatically with the same infor-
mation as the User ID). Click the Create button.

Note: A table called TP_DSNSCHEMA must exist in the SYSTEM schema. If 
the table does not already exist in the SYSTEM schema, a System 
Login dialog box appears, requiring the password for SYSTEM. Type 
the password, and click OK. The table is created.

Only one schema can be associated with a particular DSN name 
(ODBC connection). If the chosen DSN name is already associated 
with a schema, a Database Maintenance dialog box appears:

Click the Replace button to change the association of the DSN name 
from its current schema to the new schema (users will no longer be 
able to access TestPartner tables in the old schema), or click the Alias 
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button to create an alias for the DSN name, a DSN Alias Creation 
dialog box appears:

Type an alias name for the DSN, this alias will be associated with the 
current schema. Click OK.

The Data Source Creation Status dialog box appears and displays the 
progress of the database creation.

Log on to TestPartner

To test your setup, start TestPartner and log on. See “Logging On and 
Starting TestPartner” on page 58 for instructions.
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Setting Up SQL Server or Oracle for TestPartner Without a 
Domain

Note: This procedure only applies when using Windows NT authentication.

Compuware strongly recommends that you use authentication within a 
domain when setting up an Oracle or SQL Server database with TestPart-
ner. However, if you are not on a domain, it is still possible to set up 
these databases.

Required: To begin, you must create a user on both the client and the server 
computers.

To create a user, follow these procedures:

1 Click Start>Settings>Control Panel.

2 Double-click Users and Passwords. The Users and Passwords dialog 
box appears:
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3 On the Users tab, click Add. The Add New User dialog box appears:

4 Type a valid user name in the User name field. Click the Next but-
ton.

5 Type a valid password in both the Password and Confirm password 
fields. Click the Next button.

6 Select the level of access for the user and click the Finish button.

7 On the Users and Passwords dialog box, click OK.

8 Repeat these steps on each client machine using the username and 
password.

Setting Up SQL Server for TestPartner without a Domain

To set up SQL Server for TestPartner without a domain, follow these steps:

1 On the server machine, click Start>Settings>Control Panel.

2 Select Administrative Tools.
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3 Select Computer Management. The Computer Management utility 
window appears:

4 In the tree view, click Local Users and Groups.

5 Click Groups.
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6 In the right pane, double click Users. The Users Properties dialog box 
appears: 

7 Click the Add button. The Select Users or Groups dialog box appears.

8 In the Name field, browse for the user’s ID, select it, and click Add. 

Or, click in the text area under the Add button and type:

[user ID],

where [user ID] is the user you want to give access to.
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9 Click OK to save the user information and return to the Users Proper-
ties dialog box.

10 Repeat step 7–9 to create any additional user accounts.

11 When you are finished, click OK in the Users Properties dialog box to 
return to the Computer Management utility.

12 Close the Computer Management utility.

Setting Up Oracle for TestPartner without a Domain

To set up Oracle for TestPartner without a domain, follow the procedures 
for “Creating Server Access For Users” on page 33 with the following 
exceptions:

Substitute the user name you created under, “Setting Up SQL Server or 
Oracle for TestPartner Without a Domain” on page 42 as shown in step 1 
below:

Figure 2-1. Select Users or Groups Dialog Box

1 Click in the text area under the Add button (Figure 2-1) and type 
[user name] instead of [domain name]\[user ID] or [domain 
name]\[group name].

In addition, when using SQL*Plus to create users see step 3 on page 36, 
substitute COMPUTERNAME\USERNAME for DOMAIN\USERNAME as shown 
below:
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2 Create the user as "[COMPUTERNAME]\USERNAME" IDENTIFIED EXTER-
NALLY, entering the COMPUTERNAME\USERNAME in uppercase and 
between "" like the following example:

SQL> create user "FH0002RED\USER1" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "FH0002RED\USER1"; 

3 Click Start>Programs>Compuware>TestPartner>Utilities>Data-
base Maintenance.

4 Grant rights to access the V_$SESSION view to individual users or to 
all users as a public group.

Open Oracle’s SQL*Plus Worksheet. Login as SYSTEM and connect as 
SYSDBA. You can grant the access rights by entering the commands 
shown below.

Required: All TestPartner users will need rights to access the V_$SESSION 
view. To grant these rights, you must be logged on as a user with 
administrative rights, e.g., SYSDBA.

Granting Access for 
Individual Users

SQL>CONNECT SYSTEM/password AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO “COMPUTER NAME\JEFF”;

Granting Access for All 
Users (PUBLIC) 

SQL>CONNECT SYSTEM/password AS SYSDBA;
SQL>GRANT SELECT ON “V_$SESSION” TO PUBLIC;

Note: If you receive any errors that indicate you cannot grant these rights, 
or that the V_$SESSION table cannot be found, you are not logged 
on appropriately.
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Creating a Data Source Name
On each computer that is connecting to the TestPartner SQL Server, 
MSDE, Access or Oracle database, you must create a data source name 
(DSN) using the ODBC utility.

The ODBC utility can be accessed from the Windows Control Panel.

Required: These procedures are for the Windows 2000 operating system. To 
set up users in another operating system, consult your Windows 
documentation.

Creating a Data Source Name for an Access Database

On each client computer connecting to an Access database, perform the 
following steps to set up a DSN:

1 Click Start>Settings>Control Panel>Administrative Tools>Data 
Sources (ODBC). The ODBC Data Source Administrator dialog box 
appears.

2 Click the System DSN tab, then click the Add button. The Create 
New Data Source dialog box appears: 

This dialog box lists the available ODBC drivers.

3 From the list of drivers, select the Microsoft Access Driver and click 
the Finish button. The ODBC Microsoft Access Setup dialog box 
appears.

4 In the Data Source Name field, type the data source name. Since this 
name appears as the database name in TestPartner’s logon screen, it is 
recommended you enter a logical name in this field.
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5 In the Description field, type a description for the data source. For 
example, Connection to TestPartner Access database.

6 Click the Select button and browse for your Access database.

7 On the ODBC Microsoft Access Setup dialog box, click OK.

8 Click OK on the ODBC Administrator dialog box.

Creating a Data Source Name for a SQL Server Database

On each client computer, perform the following steps to set up a DSN:

1 Click Start>Settings>Control Panel>Administrative Tools>Data 
Sources (ODBC). The ODBC Data Source Administrator dialog box 
appears.

2 Click the System DSN tab, then click the Add button. The Create 
New Data Source dialog box appears:

This dialog box lists the available ODBC drivers.

3 From the list of drivers, select SQL Server and click the Finish but-
ton. The Create a New Data Source to SQL Server dialog box appears.

4 In the Name field, enter the data source name. Since this name 
appears as the database name in TestPartner’s logon screen, it is rec-
ommended you enter a logical name in this field.

5 In the Description field, enter a description for the data source. For 
example, Connection to TestPartner SQL database.

6 In the Server field, enter the server name or select it from the drop-
down list. If you do not know the server name, consult your database 
administrator.
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7 Click the Next button. The Create a New Data Source to SQL Server 
dialog box appears.

8 Do one of the following:

� If user(s) using the DSN to access the SQL Server database are con-
necting with native authentication, select the With SQL Server 
authentication using a login ID and password entered by the 
user option. 

Make sure the Connect to SQL Server to obtain the default 
settings for the additional configuration options check box is 
selected.

Type the users native SQL Server logon credentials in the Login 
ID and Password fields.

or

� If user(s) using the DSN to access the SQL Server database are con-
necting with non-native credentials, select the With Windows 
NT authentication using the network login ID option.

9 Click the Client Configuration button. The Add Network Library 
Configuration dialog box appears: 

Ensure that the appropriate network library protocol is selected. If 
necessary, consult your network administrator to verify the correct 
network protocol.

10 Click OK to exit. You are returned to the Create a New Data Source to 
SQL Server dialog box.

11 Click Next.

12 Select the Change the default database to check box, then select 
your TestPartner database name from the drop-down list.
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13 Accept all the other entries and click the Next button until the last 
panel in the wizard appears.

14 Accept the defaults and click the Finish button. The ODBC Microsoft 
SQL Server Setup window appears.

Testing the Connection

Once the connection to the database is established, use the following 
procedure to test the connection:

1 In the ODBC Microsoft SQL Server Setup window, click the Test Data 
Source button. You should see the following:

2 Click OK. The ODBC Microsoft SQL Server Setup window displays.

Note: If your test results fail, you need to check your setup steps again.

3 Click OK. The ODBC Data Source Administrator window displays. 
The newly created data source appears in the System Data Sources 
list.

4 Click OK to close the ODBC utility.
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Creating a Data Source Name for an MSDE Database

Follow the same steps under “Creating a Data Source Name for a SQL 
Server Database” on page 49, with the following exceptions:

� In step 3, select (local) for the server name.

Figure 2-2. Create a New Data Source to SQL Server

� In step 6, a list of databases will be available for selection. However, 
only the default databases from the MSDE installation will appear in 
the drop-down list. If you wish to create your own database for 
MSDE, you must use a front-end interface such as Enterprise Man-
ager.

Creating a Data Source Name for an Oracle Database

On each client machine connecting to an Oracle database, perform the 
following steps to set up a DSN:

1 Click Start>Settings>Control Panel>Administrative Tools>Data 
Sources (ODBC). The ODBC Data Source Administrator dialog box 
appears.
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2 Click the System DSN tab, then click the Add button. The Create 
New Data Source dialog box appears:

3 From the list of drivers, select the Oracle in OraHome90 (not the 
Microsoft ODBC for Oracle driver) and click the Finish button. 

Note: For Oracle 8.1.7, select the Oracle ODBC Driver (not the Microsoft 
ODBC for Oracle driver) and click the Finish button. 

The Oracle ODBC Driver Configuration dialog box appears. The 
following shows this dialog box for Oracle 9.0.1.

4 In the Data Source Name field, type the data source name. Since this 
name appears as the database name in TestPartner’s logon screen, it is 
recommended you enter a logical name in this field.
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5 In the Description field, type a description for the data source. For 
example, Connection to TestPartner Oracle database.

6 In the TNS Service Name field, select the service name for the data-
base you would like to connect to in the format 
ORACLE_SID.DOMAIN, where ORACLE_SID is the Oracle SID you 
assigned to the database upon creation and domain is the domain 
that you are connecting to.

7 If you are creating a Data Source name for an Oracle 9.0.1database, 
test the connection. See “Testing the Connection” below. Otherwise, 
click OK.

Testing the Connection

Oracle 9.0.1 1 On the Oracle ODBC Driver Configuration dialog box, click the Test 
Connection button.

Note: When using Oracle database authentication, type a username, and 
then a password. For Oracle OS authentication, do not specify a 
username.

A message box appears stating the connection was successful.

2 Click OK to close the message box.

The Data Source name creation is complete.

Oracle 8.1.7 1 Click Start>Programs>Oracle>Network Administration>Oracle 
ODBC Test. The Oracle ODBC 32Bit Test - QUERY 1 dialog box 
appears.

2 Click the Connect button. The Select Data Source dialog box appears:
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3 Click the Machine Data Source tab and select the appropriate DSN 
you created in the procedure described above. 

4 Click OK. You are returned to the Oracle ODBC 32Bit Test - QUERY 1 
dialog box.

5 Click the All Tables button. If data appears in the QUERY 1 section 
of the dialog box, your setup is complete.
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Migrating TestPartner Objects from a Standard Character Set to 
UTF8 (for Unicode)

It is recommended that an Oracle DBA or someone familiar with Oracle 
export and import utilities perform the following task. For databases 
larger than 2GB, the DBA should select appropriate parameters based on 
the size of the database.

TestPartner only supports databases with a UTF8 (Unicode) character set. 
Access stores strings in TEXT and MEMO fields, which are already 
Unicode, so no schema changes are needed. SQL Server uses the NCHAR, 
NVARCHAR, and NTEXT data types to store Unicode characters, so no 
schema changes are needed. However, in Oracle 8.x, the NCHAR family 
of data types is not Unicode, which means that any Oracle database 
character set must be converted to UTF8.

Note: In Oracle 9.x, the NCHAR data type is redefined to UTF16, but 
because TestPartner must support both 8.1.7 and 9.x, the 8.1.7 
migration approach will be used in both instances, eliminating the 
need for two separate schemas.

In order to support a TestPartner database previously created in an Oracle 
instance with a standard character set, the database must be exported 
from the standard database and imported into an Oracle instance created 
with a UTF8 character set.

Caution: If the schema from which the TestPartner objects are being 
exported contains more than just TestPartner objects, it is recommended 
(required if the schema is SYSTEM) that the TestPartner objects be transferred 
to a new schema using the TestPartner Database Maintenance Utility 
05.02.00 (or older) Oracle-to-Oracle Copy Utility. The objects can be then 
exported from the new schema.

To perform the Migration:

1 Start a command prompt and change the directory to 
$ORACLE_HOME/bin. This directory should contain both exp.exe 
and imp.exe. Exp.exe will be used to perform the export, imp.exe will 
be used to perform the import.

Caution: Before exporting, be sure there is sufficient disk space. If there 
is not enough space, export will end in a write failure.

2 Type SET ORACLE_SID=MYSID into the command prompt, where 
MYSID is the SID of the Oracle instance, and press Enter.

3 Type EXP USERNAME/PASSWORD FILE=EXPORT.DMP 
LOG=EXPORT.LOG CONSISTENT=Y into the command prompt, 
56     TestPartner Installation and Configuration Guide



where USERNAME is the name of the schema to export and PASS-
WORD is the password for the schema. Press Enter to start the 
export.

Note: To perform the export without knowing the user’s password, instead 
execute it as the system user. Type EXP SYSTEM/PASSWORD 
FILE=EXPORT.DMP LOG=EXPORT.LOG CONSISTENT=Y 
OWNER=USER1 into the command prompt, where PASSWORD in the 
system user password and USER1 is the owner of the schema to 
export.

4 Create a new Oracle database with character set UTF8 (and National 
Character Set UTF8 for Oracle 8i). Consult your Oracle documenta-
tion if creating an Oracle database is unfamiliar.

5 Create a new user in the new Oracle instance and grant them CON-
NECT, RESOURCE, and SELECT_CATALOG_ROLES privileges.

6 Click Start>Programs>Compuware>TestPartner>Utilities>Data-
base Maintenance from the Windows Start menu to start the 
TestPartner Database Maintenance Utility.

7 Click Tools>Create UTF8 Migration Database, the Oracle Data 
source Connection dialog displays.

8 Browse to the new Oracle instance with the UTF8 character set for 
the Oracle Data Source Name field and fill in the User ID and Pass-
word fields with the new schema (the Description field is optional). 
Click OK (steps identical to the steps in Creating the Oracle TestPart-
ner Database may have to be followed in order to complete this step).

9 Return to the command prompt and type SET ORACLE_SID=MYSID, 
where MYSID is the SID of the UTF8 Oracle instance, and press Enter.

10 Type IMP USERNAME/PASSWORD FILE=EXPORT.DMP 
LOG=IMPORT.LOG IGNORE=Y into the command prompt, where 
USERNAME is the name of the schema to import into and PASS-
WORD is the password for the schema. Press Enter to start the 
import.

Note: To perform the import without knowing the user’s password, instead 
execute it as the system user. Type IMP SYSTEM/PASSWORD 
FILE=EXPORT.DMP LOG=IMPORT.LOG FROMUSER=USER1 
TOUSER=USER1 IGNORE=Y into the command prompt, where 
PASSWORD in the system user password and USER1 is the owner of 
the schema that was exported and FROMUSER and TOUSER are 
identical.
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Logging On and Starting TestPartner
Use the following procedure to launch TestPartner and log on to TestPart-
ner.

1 Start TestPartner by clicking the taskbar’s Start button, then choose  
Programs>Compuware>TestPartner>TestPartner. The TestPartner 
splash screen appears, followed by the TestPartner Logon dialog box.

2 Type a user name in the User Name text box and type a password in 
the Password text box.

If using TestPartner for the first time, an administrative User Name 
and password may be required. The default user name is Admin and 
the default password is admin. Change this password after logon to 
prevent unauthorized access.

3 Select the TestPartner database to work with from the Database list. 
TestPartner’s testing assets are stored in a test asset repository, or data-
base, which offers centralized control of users and system access 
rights under password control. 
 
For a database to appear in the Database list, you must first configure 
its database connection for use with TestPartner. To configure a data-
base connection, click the Configure button on the TestPartner 
Logon dialog box. See “Configuring a TestPartner Database Connec-
tion” on page 59.

Note: Clicking the Cancel button while logging on exits the TestPartner 
application. This is because TestPartner requires attaching to a 
database during startup.

4 Click OK to log on.
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The TestPartner Welcome dialog box appears. This dialog box guides 
entry into the TestPartner desktop. It appears after the first successful 
logon. 

Figure 2-3. TestPartner Welcome Dialog Box

TestPartner may be configured so that this screen does not appear 
during future access. See “Setting TestPartner Options” in TestPart-
ner’s online help.

� Display scripts using the Visual Navigator window or the VBA Code 
window, run the online tutorial, or peruse the online documentation 
from the TestPartner Welcome dialog box.

� Choose The Visual Navigator or The Code Window option to open 
TestPartner’s desktop. The Select Project dialog box appears. Because 
TestPartner automatically opens a new script each time it starts, and 
prompts to select a project. See TestPartner’s online help for informa-
tion about administering users and adding projects.

Configuring a TestPartner Database Connection

Before you can use a database with TestPartner, you must configure its 
database connection. The configuration process consists of using the 
Configure Data Source dialog box to perform the following tasks:

� Specify the database connection data required to initiate the database 
connection 
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� Verify the connection to the database

� Save the database connection data

All configured database connections appear in the Database list on the 
TestPartner Logon dialog box. 

You can also use the Configure Data Source dialog box to view, edit, and 
remove any existing configured database connections. 
 
Use the following procedure to configure a TestPartner database connec-
tion.

1 Click the Configure button on the TestPartner Logon dialog box. 
The Configure Data Source dialog box appears.

Figure 2-4. TestPartner’s Configure Data Source Dialog Box

2 In the Data Source Type text box, select the type of data source.
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3 From the Select Data Source list, select from the list of available 
DSNs.

4 Select the Use as a TestPartner database check box to add the 
selected DSN to the list of configured database connections that 
appear in the Database list on TestPartner Logon dialog box. You 
must select this check box when configuring a database connection 
for the first time.

Note: For existing configured database connections, clearing the Use as a 
TestPartner database check box and clicking the Apply button 
removes the selected DSN from the Database list on the TestPartner 
Logon dialog box. TestPartner does not retain the associated 
database connection data.

5 Under Database Settings, specify the appropriate information for the 
selected DSN. The Database/Server and Owner/Schema fields func-
tion differently depending on the selected data source type.

a For Access, the Database text box is read-only and displays the 
location of the database file. This value is read directly from the 
ODBC DSN. The other Database Settings fields are not applica-
ble for Access and are disabled. 

b For Oracle, the Server text box field is read-only and displays 
only the database name. This value is read directly from the 
ODBC DSN. In the Schema text box, type the appropriate value.

c For SQL Server, the Database text box is modifiable and allows 
you to type the appropriate database name. In the Owner text 
box, type the appropriate value.

6 The Authentication field determines the method of authentication 
being used and only applies to Oracle or SQL Server/MSDE databases. 
You can choose to either use Windows NT authentication or authen-
ticate using the database’s native authentication capabilities. When 
selecting database authentication, you must provide the user name 
and password in the appropriate fields.

7 Click Validate to verify that you can connect to the database using 
the specified database connection data.

8 Click Apply to save the database connection data.

9 Click Close.
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Chapter 3

Maintaining the Installation
� Accessing Maintenance Mode

� Modifying an Installation

� Repairing an Installation

� Removing a Product

Note: TestPartner releases before 5.1.0 do not employ these maintenance 
procedures. If you need to modify or repair a TestPartner installation 
on releases before 5.1.0, you must uninstall it, then reinstall it. See 
the “Installing TestPartner” chapter for instructions on removing 
TestPartner from your machine.

Accessing Maintenance Mode
There are two methods for accessing a QACenter product’s maintenance 
mode: from the QACenter CD or from the Windows Control Panel.

Required: Compuware recommends that you exit all non-essential Windows 
programs before running this setup program. Some Windows 
programs may interfere with the installation process.

Accessing Maintenance Mode from the Windows Control 
Panel

1 Click the Windows Start button and choose Settings>Control Panel. 
The Control Panel window appears.

2 Click the Add/Remove Programs icon. The Add/Remove Programs 
dialog box appears. Select the QACenter product to maintain and 
click Change/Remove.
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You are presented with the three maintenance mode options: modify, 
repair, and remove. For more information about these options, see the 
appropriate section in this chapter.

Accessing Maintenance Mode from the QACenter CD

1 In the CD-ROM drive, insert the QACenter CD containing the same 
version of the product that you have installed. The QACenter CD 
browser should automatically appear. If it does not, navigate to the 
root directory and run the setup.exe file.

2 Click Install QACenter Products.

3 Click Install product name (where product name is the name of 
the product that you want to maintain).

You are presented with three maintenance mode options: modify, repair, 
and remove. 

Modifying an Installation
For products with optional components, you may want to add or remove 
a component. 

Rather than uninstall and re-install the product, you can modify your 
installation.

Modifying Products With Optional Components

1 Access maintenance mode using one of the two methods described at 
the beginning of this chapter.

2 Select the Modify option. Click Next. The Select Components dialog 
box appears allowing you to add or remove components.

3 Click Next. Setup will add or remove the appropriate components.

4 After modifying, you may be prompted to restart your computer. If 
you are prompted to restart your computer, you may choose to restart 
it now (recommended) or to restart it later.

5 Click Finish to complete the maintenance.
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Repairing an Installation
There may be times when you will need to repair a damaged QACenter 
product installation. This could be due to an inadvertent deletion or 
corruption of the program. To repair your QACenter product, follow 
these steps:

1 Access maintenance mode using one of the two methods described in 
“Accessing Maintenance Mode” at the beginning of this chapter.

2 Select the Repair option. Click Next. Setup will repair the specified 
QACenter product. 

3 After repairing, you may be prompted to restart your computer. If 
you are prompted to restart your computer, you may choose to restart 
it now (recommended) or to restart it later.

4 Click Finish to complete the maintenance.

Removing a Product
If you want to remove a QACenter product from a PC, follow these steps:

1 Access maintenance mode using one of two methods described at the 
beginning of this chapter. 

2 Select the Remove option. Click Next. The Confirm File Deletion 
dialog box appears. 

3 Click OK. Setup will remove the specified QACenter product from 
your PC. If your product uses a database repository, you have the 
option to either save or delete it. Do not delete it if you need to retain 
the data in the database, as in the case of a product upgrade.

4 After uninstalling, you may be prompted to restart your computer. If 
you are prompted to restart your computer, you may choose to restart 
it now (recommended) or to restart it later.

5 Click Finish to complete the maintenance.
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