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Micro Focus Visual COBOL 2.3 Update 2 for
Visual Studio Release Notes

These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.

/ Note:

» This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link.
Web sites by their nature can change very rapidly and although we try to keep our links up-to-date,
we cannot guarantee that they will always work as expected.

» Check the Product Documentation section of the Micro Focus SupportLine Web site and the Micro
Focus Infocenter for any updates to the documentation which might have been uploaded.

Product Overview

Visual COBOL enables you to develop COBOL applications within Microsoft Visual Studio. You use the
Visual Studio integrated development environment (IDE) to edit, compile and debug COBOL applications.
The IDE provides all the functionality to manage projects and build applications.

The product is available in the following variants - Visual COBOL for Visual Studio 2012, Visual COBOL for
Visual Studio 2013 and Visual COBOL for Visual Studio 2015. The execution environment for applications
created with any of these product variants is COBOL Server.

Upgrading from earlier Micro Focus products

Application executables that were compiled using earlier Micro Focus products must be recompiled from
the sources using Visual COBOL.
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What's New

This release provides enhancements in the following areas:

* Integration with Visual Studio

« Building applications

e COBOL language enhancements
» Classic Data File Tools

« Compiler directives

» Debugging applications

« Dialog System GUI

* File handling

e Library routines

Integration with the Visual Studio IDE
Back to Top

This release provides the following enhancements in the integration of Micro Focus COBOL with the Visual
Studio IDE:

* A new menu command SQL Option for DB2 on the Tools menu enables you to access all the SQL
Option for DB2 utilities.

e Itis now possible to specify options for compiling native resource files (.rc) by accessing the file's
properties from within the IDE.

Editor improvements:

« Colorization of the code in the ToolTips for collapsed regions in the COBOL editor has been added.

¢ The Time and Date Warp options are now available on the Run-Time Configuration tab when editing
an application configuration file for native COBOL projects.

* Go To Next Method and Go To Previous Method editor context menu commands are now available
for native Object-Oriented and for managed COBOL code.

* Improvements have been made to editing performance.

Building applications
Back to Top
It is now possible to use the 64-bit version of MSBuild to build COBOL projects.

COBOL language enhancements
Back to Top

Numeric, edited and external floating point items can now specify USAGE NATIONAL when the
NATIONAL"2" Compiler directive is in effect. Signed numeric items must be specified with the SIGN IS
SEPARATE clause.

Classic Data File Tools
Back to Top

A new command line utility is available which enables you to initiate the following actions: open data files,
create or open record layout files, create or open segment layout files, and open IMS databases using a
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6 | What's New

DBD or PSB file. Note that although you can initiate these actions from the command line, you must
complete them from within the IDE.

Compiler directives
Back to Top
The following Compiler directives are new in this release:

e COMMAND-LINE-LINKAGE - enables you to call a program and pass the command line to the main
program as a parameter to be accessed via the Linkage Section. This offers equivalent functionality to
the command_line_linkage tunable, which has now been deprecated.

« EBC-COL-SEQ - controls the behavior of an EBCDIC collating sequence, specified in a
NATIVE"EBCDIC" program. EBC-COL-SEQ"1" (the default) maintains use of the long-standing fixed
(platform-independent) EBCDIC collating sequence. EBC-COL-SEQ"2" prompts use of the latest
CODESET table, which varies according to platform and user-controlled MFCODESET environment
variable setting.

* NATIONAL - enables you to specify numeric, edited and external floating point items as USAGE
NATIONAL.

Debugging applications
Back to Top

* You can configure the debug tooltip for subscripted OCCURS items to either display the elements of
arrays or to display the value of the current expression. To do this, right-click in the editor, click COBOL
Debug Tooltip Style and either enable or disable Show COBOL OCCURS or reference modification
value.

Dialog System GUI
Back to Top

Installing the version of the Compatibility AddPack for Visual COBOL provided with this release adds a new
menu item, Micro Focus Dialog System, to the Tools menu of Visual Studio for starting the Dialog
System GUI from within the IDE.

File handling
Back to Top
MFJSORT ICETOOL now supports the USING parameter in the SELECT operator.

Library routines
Back to Top
The following library routine contains new functionality:

e CBL_GET_PROGRAM_INFO - a new function (function 10) has been added for native COBOL which
returns the path and program name, or the program name only of a particular program.



Significant Changes in Behavior or Usage

This section describes significant changes in behavior or usage. These changes could potentially affect the
behavior of existing applications or impact the way the tools are used.

Where present, the numbers that follow each issue are the Support Incident Numbers followed by the
Reported Problem Incident (RPI) number (in parentheses).

* Enterprise Server

e Compiler

e MF Directory Server

* Monitoring and Management
¢ Run-Time System

Compiler
Back to the list

e The ILPINVOKE directive is now allowed only in an initial $SET. This is in line with similar directives like
ILREF and ILTARGET. Previously, the ILPINVOKE directive was allowed in other positions in the source
code, but could later result in ‘Insufficient memory' errors.

2860347 (1104422)

* Replacing a partial token no longer causes the second part of the token to appear on a new line. This
could happen if the new text was larger than the text being replaced.

2869185 (1105763)

* There is no longer a problem opening an RM/COBOL indexed file when the program has a RECORD
CONTAINS n CHARACTERS clause and there are record descriptions with lengths less than n. This
situation previously caused a 39 error on the OPEN (other than OPEN OUTPUT) because there was a
mismatch in the minimum record length.

Enterprise Server

Back to the list

« Previously, it was possible to install groups that should not have been installed. If a group name, as
defined in the Startup List, did not exist in the list of Groups then the next Group in the alphabetical
order would be loaded instead. Now, if a Group is not defined in the list of Groups, a warning that the
Group could not be loaded is issued.

2869848 (619107)

MF Directory Server
Back to the list

e The "-n" option for the mfds command now supports hostnames as the network addresses in addition to
IPv4 addresses.

2816871 (1099564)

Monitoring and Management
Back to the list

« Messages that are written to the console log by applications that perform "display upon console" now
contain a standard message ID (CASMGO00011).
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2854207 (1103659)

Run-Time System

Back to the list

« The command_line_linkage tunable has been deprecated; equivalent functionality can be achieved by
using the COMMAND-LINE-LINKAGE Compiler directive instead.

2838118 (1101539)

8 | Significant Changes in Behavior or Usage



Known Issues

Refer to the Known Issues and Restrictions topic in the Product Information section of your product Help.

In addition, note the following:

Enterprise Server

The Historical Statistics Facility may generate incorrect records for SSTM-enabled enterprise servers.
On Windows 10, if you are using Microsoft's EDGE browser to access the Enterprise Server
Administration GUI, issues with EDGE can cause the automatic refresh feature to display a dialog
asking whether you want to resubmit a form. To work around this issue, cancel the resubmit request and
then refresh the server list page or the Home page of Enterprise Server Administration. You can also
turn off the automatic refresh by setting the Auto-refresh interval setting on the Home page of
Enterprise Server Administration to O.

IDE

When you add a COPY statement in a COBOL program and then show it in Expanded Copybook View,
the line for the copybook statement is read-only. If you then perform an Undo in the COBOL program,
the COPY statement is removed while the contents of the copybook is still shown in the program.
Replace All does not work inside the Expanded Copybook View

For copybooks with file extensions that are not traditionally associated with COBOL you must first add
the file extension to the list of known copybooks extensions in Tools > Options > Text Editor > File
Extensions before you can show them in Expanded Copybook View.

Linking

Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C
object code built with that version of Visual Studio in the same executable. In this scenario, you must
use the Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro
Focus cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might
also need to specify some additional C runtime libraries - see the Microsoft documentation for more
details.

Note that when using COBOL and C object code together, Micro Focus recommends you build and
keep the COBOL and C executables separate, and use import libraries and the Micro Focus C functions
for calling COBOL (see "C functions for calling COBOL" in the product help) to resolve calls between
them.

Resource Adapters

Trying to deploy the local resource adaptor nf cobol -1 ocal t x. r ar to WebLogic may fail with a
ClassCastException. To work around this issue, you need to deploy nf cobol - xa. r ar first, then need
to undeploy this file and deploy the local one, nf cobol -1 ocal t x. r ar . If there are issues deploying
using the WebLogic GUI, you can use the command line. If there are issues with this as well, try
reducing the length of the command (for example, by moving the file to a location with a shorter path).

REST/JSON IMTK implementation and the same-origin policy (SOP)

HTTP requests sent from scripts within a web browser to REST services deployed on an enterprise
server might fail due to the same-origin policy (SOP). Some browsers might implement (or support
plugins that implement) techniques for relaxing SOP such as cross-origin resource sharing (CORS) that
enable sending cross-origin requests successfully. For REST services, Enterprise Server does not
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implement a method for relaxing SOP. This means that browsers that implement CORS (or any other
SOP relaxation technique) might still forbid requests made from scripts due to Enterprise Server not
implementing the equivalent technique on the server side.
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Resolved Issues

The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem
Incident (RPI) number (in parentheses).

e Code Analysis
e Codeset Support
« Common Communications Interface

e Compiler
» Data Tools
» Debugging

« Dialog System

» Documentation

» Editor Writing Assistance
» Enterprise Server

* File Handling

e H2cpy

- IDE

* Micro Focus Directory Server
*  MVS REXX Emulation

¢ OpenESQL

¢ Run-Time System

e SQL: COBSQL

e SQL:DB2

¢ SQL: OpenESQL

e SQL Option for DB2

¢ XML Syntax Support

Code Analysis
Back to the list

« The GO TO statements targeting non-exit paragraphs query no longer returns points inside EXEC
statements.

« The performance has been improved.

« The criterion for dead statements within a program has been modified to exclude child elements of
statements.

« Level 78 constant names used in picture definitions are now replaced with the actual values.
< Anissue with de-referencing NULL pointers during program generation has been fixed.
e Anissue with de-referencing a NULL pointer has been fixed.

Codeset Support
Back to the list

« A number of DBCS translation tables for CODESET have been added to the deployment product to fix
the 'COBRT255 CODESET cannot open double byte conversion table' error.

2858171 (1104157)

< The following changes have been made to CODESET tables: « The Japanese Katakana Extended
codeset (country code 81) now corresponds to EBCDIC code page 290 when converting between
ASCII and EBCDIC, which means lower case letters (which start at x61, and not x81) can now be
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converted. « Unused entries for the following codesets have been filled in order to allow round tripping
(ASCII>EBCDIC>ASCII conversions) of SBCS values: « Japanese Latin Extended, country code 939,
which corresponds to EBCDIC code page 1027. « Korean, country code 82, which corresponds to
EBCDIC code page 833. « Simplified Chinese, country code 86, which corresponds to EBCDIC code
page 836. « Traditional Chinese, country code 886, which corresponds to EBCDIC code page 37.

Common Communications Interface

Back to the list

The formatting of the context help pages for the Enterprise Server Administration HTML GUI has been
improved.

Compiler

Back to the list

12 | Resolved Issues

When a program uses SQL, the debugger could highlight the wrong line when entering that program.
This has been fixed.

2869190 (1105765)
On 32-bit Intel platforms you could receive an error "001-F Internal error 38" when generating for debug.

2856865 (1104040)
A COBRT114 error produced at generate time has been fixed.

2853877 (1103611)

An error in the "ACCEPT binary-floating-point-item" syntax, which occurred on Intel x86 platforms in 32-
bit generated code, has been fixed.

If more than one report shared the same FD, for example: REPORTS ARE REPORT-1 REPORT-2. then
under HOSTRW, the record length was wrong. This has been corrected.

2865849 (1105553)

Programs using B-AND, B-OR, or B-XOR now compile with the ARITHMETIC"ENTCOBOL" Compiler
directive in effect.

2864991 (1105087)

A DISPLAY statement containing a very large number of operands now compiles as expected.

2864361 (1105017)
An inline method invoke with a variable-length group item now produces correct object code.

2864131 (1105018)

Report Writer now generates the correct record length. Previously, if the BLOCK CONTAINS clause
came after the RECORD CONTAINS clause in the File Descriptor, the BLOCK would corrupt the value
from the RECORD clause, causing the record to have the wrong length when written to the file.
2863045 (1105008)

The use of 'AS' as a data-name for programs using an SQL ECM now works as expected.

2863002 (1104821)

If an INVOKE statement specifies more parameters than the method actually has, an appropriate error
message is produced. Previously, an 'internal error' error message was produced.

2860899 (1104519)

An INITIALIZE statement performed on a subscripted table containing fields that are object references
or procedure pointers now executes as expected.

2860416 (1104588)

Messages produced by the FLAGSTD directive now have the correct line and column info reported in
the IDE.



2859026 (1104318)
A COBOL program compiled with the PROFILE Compiler directive now shows information on the
number of times the program has been called, as well as loaded.

2858944 (1104278)
When REPLACE is active, a literal containing

2858804 (1104264)
A compilation where a user pre-processor is specified below CP in the pre-processor stack, and this
pre-processor passes COPY statements through unopened, now works as expected.

2858013 (1105427)
Compilation of a STRING statement, with an operand that reference modifies the result returned by a
user function, now works as expected.

2857266 (1104189)

A new directive, EBC-COL-SEQ, now controls the behavior of an EBCDIC collating sequence, specified
in a NATIVE"EBCDIC" program. EBC-COL-SEQ"1" (the default) maintains use of the long standing
fixed (platform independent) EBCDIC collating sequence. EBC-COL-SEQ"2" prompts use of the latest
CODESET table, which varies according to platform and user-controlled MFCODESET environment
variable setting.

2856776 (1104074)

SCREEN SECTIONSs with very large amounts of fields, which worked in Net Express, now work in
Visual COBOL.

2854533 (1103648)
Copybook dependency information is now shown correctly in Eclipse for programs compiled with a
preprocessor such as CP.

2854371 (1103662)
Compiler warning message "COBCH972 Linkage item (or subordinate item) is referenced but has no
addressability" is no longer produced inappropriately.

2854113 (1103542)
The use of the HOSTRW and CURRENT-DATE directives no longer causes an excessive number of
lines in a report produced from the Report Writer.

2853789 (1105472)
Subscripts specified via intrinsic function LENGTH-AN no longer receive spurious boundary violation
error messages.

2851928 (1103254)
Preprocessor created error messages containing SJIS characters are now displayed correctly, as
expected.

2646229 (1089272)

A USE FOR DEBUGGING statement that references a table item and is triggered by a condition where
the table item is referenced but not evaluated (due to short-circuit evaluation) now executes as
expected.

2433731 (1073167)

There is a new option, CP, in EXECPERIOD. It controls the processing of periods that follow EXEC
statements. In most scenarios, the default option, EXECPERIOD(SMART), enables you to compile by
applying a flexible behavior based on the program's context.

2867788 (1105608)

If a program contained 'PERFORM of section-name THRU paragraph-name', where the section-name is
known to terminate, the compiler erroneously assumed that the PERFORM THRU terminates (which is
not necessarily the case when paragraph-name is within section-name). This meant that no code was
generated for any statements following that PERFORM statement. This is now fixed.

now compiles as expected.

Resolved Issues

13



2871380 (1106107)

*  When ILSMARTLINKAGE was specified for a program compiled with the directive ODOSLIDE (which is
set automatically when a mainframe dialect is used), and when the program contained a linkage section
record with multiple OCCURS DEPENDING ON items, then illegal code was being produced with
multiple error messages. This is now fixed.

2870166 (1105899)

« Index names (that is, names defined using INDEXED BY) in the Linkage Section were being allocated
in local storage. This is correct for linkage records in methods, but for procedural programs, they need
to be allocated in working-storage for compatibility with previous behavior. This is now the case.

2870162 (1105922)

» Ifthe OUTDD or INDD directives were in effect, but the CHARSET directive was set to ASCII, then use
of a DISPLAY statement could result in a warning about a 'Reference to undeclared extern assembly'.
This has been fixed. (Note - this situation could arise by setting DIALECT to a mainframe variant such
as ENTCOBOL (which in turn sets OUTDD/INDD), and then setting CHARSET"ASCII".)

2869937 (1105859)
* Level 66 items declared as instance or static data in a class are now accessible from methods.
Previously, attempting such an access produced a compile time error.

2869374 (1105791)

« The ILMAIN directive being set no longer results in incorrect code being generated for the EXIT
PROGRAM statement.

2868383 (1105651)

« If two overloads exist for a method with identical parameters except that one has an additional optional
parameter, then an invocation of the method specifying only the fixed parameters will now choose the
overload without optional parameters. Previously the method with optional parameters was chosen.

2867722 (1105552)
« When compiling for .NET, a sequence of two or more IF NUMERIC tests joined together by the OR
operator no longer causes the Compiler to crash with an error 114.

2866846 (1105400)

* In previous versions of the product, a comparison between an arithmetic expression and a single-digit
literal or data item could produce invalid code in the case where CHARSET"EBCDIC",
HOSTNUMCOMPARE and ILVERIFY were all set. This is now fixed.

2866229 (1105284)

*  Whilst debugging, it is now possible to examine the value of an INDEXED BY item declared inside the
LINKAGE SECTION of a program.
2864353 (1105075)

* The CURSOR IS syntax in the SPECIAL-NAMES paragraph is now working correctly for managed
COBOL code.
2863432 (1104897)

* The use of an EVALUATE statement in one of the WHEN branches of an outer EVALUATE statement no
longer has the effect of switching off the HOSTNUMCOMPARE directive.

2863206 (1104921)

« A TABLE OF expression that includes a subscripted item in its list of operands no longer generates bad
code; previously, this was leading to an invalid program.

2860957 (1104571)

« A COMP-X operand used as a second (or subsequent) operand to a full-screen DISPLAY statement no
longer causes generation of bad code. A move of low-value (or other non-numeric alphanumeric literal)
to a PIC 9(4) display data item now follows RM rules when the ACU dialect is in effect.

2860907 (1104515)
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* With ILSMARTLINKAGE, the data access get method for data with multiple subscripts was being
generated incorrectly. This could mean that the value passed for subscripts other than the first was
being ignored. This is no longer the case.

2859095 (1104263)

*  When a referenced assembly was loaded, but one or more of its dependent assemblies could not be
found by the Compiler, unreported errors could occur. In particular, this could have the effect that
operator overloads (such as the equality operator for items of type string) were not found. In the case of
string comparisons, this could then result in two strings with the same contents (but different object
references) comparing unequal. Such behavior is now fixed.

2857192 (1104066)
* Anissue where Content Assist/IntelliSense did not offer all available extension methods has been
resolved.

« The LENGTH OF expression is no longer allowed on an object expression; an error (COBCH1869) is
produced if attempted. For objects of type string, collection types, or single dimensional managed
arrays, the SIZE OF expression can be used to determine the current size (i.e. the length of string or of
the managed array, or the number of elements in the collection).

Data Tools

Back to the list

» DFCONV now correctly supports a command line length of 1024 characters, as documented.
2868190 (1105640)

« The classic Data File Tools utility now shows the correct field sizes for PL/I array elements.

2858068 (1104147)
e« The DFCONV utility now converts correctly between IEEE and 370 floating points.

2857502 (1104054)

Debugging
Back to the list

« Examining an object reference with a null value in Visual Studio no longer causes a Run-Time System
error 200 when the application completes.

2863181 (1104826)
« Examining the value of a large OCCURS depending on item no longer crashes Visual Studio.

2855996 (1104988)

* When debugging Object COBOL programs, methods can now be stepped into if the Visual Studio Autos
window is enabled.

Dialog System
Back to the list

« Installing the Compatibility Addpack now adds a link for the Dialog System painter to the Tools menu in
Visual Studio.

2779520 (1094515)
* The Dialog System configuration information can now be updated using the painter.

Documentation
Back to the list

Resolved Issues
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* The documentation of the format of CCIL.INI has been corrected.

2867660 (1105532)

e The product help now clarifies that navigation bar in Visual Studio displays the lists of the objects and
procedures used in the current program as well as the Procedure Division, any sections, paragraphs,
and group level data definitions and enables you to position the cursor on any of them.

2858290 (1104219)
e The topic "Making the Most Out of The COBOL Editor" in the product help for Visual Studio now
provides a link to the information about limitations with single file support.

2858263 (1104217)
« Information on setting the mfdepinst security credentials in the .mfdeploy file in the deployment parent
directory has been added to the documentation.

2854625 (1103607)
« The product help now includes information about the ExcilRespException and InvalidDataException
classes and corresponding serialized form information.

2851195 (1103171)

« Changing the project's connection type can result in the project losing the connection to its version
control system. You can re-establish the connection with your version control system in the Share
Project dialog.

2792882 (1101965)

« The product help has been updated to remove the requirement to install the gcc libraries. These
libraries are not required to install and configure the product and then for the basic functionality. gcc is
only required if you need to use C and COBOL together and gcc will be installed together with the
required development tools.

2863618 (1104878)
» User exits MFDASIMP and MFDASEXP are now documented.

2858575 (1104507)
* Updated the information on the action of the MFJESPWR user exit program contained in the
documentation.

2856725 (1103944)
* The DATAFIELD built-in function has been removed from the documentation.

2852986 (1103391)

» Details have been added to the topics "To enable Windows Event Logging" and "To enable Performance
Counters" to state that the user must be able to write to the appropriate registry, and have appropriate
privileges, to complete these tasks.

2840002 (617369)

« ECI programs that use mfccl.jar raise an error exception, EXCIException, if exciRespl and exciResp2
are not both equal to zero. To ensure your ECI program captures all errors, you must catch this
exception in your code. Please add the following code snippet, which enables your program to compile
and execute properly: try { ... } catch(ExciException e) { String rcMsg = e.getRcMsg(); } If an error
occurs, rcMsg captures the appropriate error message.

2830787 (1100664)

« The documentation for the “MF Directory Server Security” page has been clarified, to show that the
Security Facility Configuration parameters are available on this screen only when MFDS is configured to
use an ESF (i.e. setup to use a Security Manager other than "MFDS Internal Security"), otherwise no
ESF security configuration options (including the caching options) will be seen on this MFDS Security
tab screen. These parameters are: Allow unknown resources Allow unknown users Cache limit Cache
TTL Create audit events Verify against all Security Managers

e The product Help now includes some additional details on creating advanced filters for using regular
expressions with the Compare and Synchronization Monitor.
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2645110 (1089268)

Editor Writing Assistance
Back to the list

« IntelliSense (Visual Studio) and Content Assist (Eclipse) would sometimes not offer reserved word
types where they were valid.

« IntelliSense (Visual Studio) and Content Assist (Eclipse) offered unqualified managed members where
they could not be used without qualification.

* IntelliSense (Visual Studio) and Content Assist (Eclipse) sometimes offered invalid pointer items.

« IntelliSense (Visual Studio) and Content Assist (Eclipse) incorrectly offerred level 88 itens or require
them to be qualified.

* IntelliSense (Visual Studio) and Content Assist (Eclipse) did not offer items in the PERFORM USING
statement.

« Anissue where members with reserved word names were not colorized correctly has been fixed.
IntelliSense (Visual Studio) and Content Assist (Eclipse) suggestions are now offered in member
headers for members with names that are reserved words.

* IntelliSense (Visual Studio) and Content Assist (Eclipse) did not show options after items which were
subscripted or reference modified.

* IntelliSense (Visual Studio) and Content Assist (Eclipse) did not correctly offer typedefs in LENGTH OF
phrases.

« Items from external programs were incorrectly offered in IntelliSense (Visual Studio) and Content Assist
(Eclipse).

« IntelliSense (Visual Studio) and Content Assist (Eclipse) did not offer variables with the same name as
classes, methods or properties in the same file.

« IntelliSense (Visual Studio) and Content Assist (Eclipse) did not offer suggestions after variables with
the same name as classes, methods or properties in the same file.

« IntelliSense (Visual Studio) and Content Assist (Eclipse) omitted options after the SET SIZE [OF]
statement.

« IntelliSense (Visual Studio) and Content Assist (Eclipse) did not offer items within indexers on natively
typed arrays.

< IntelliSense (Visual Studio) and Content Assist (Eclipse) did not offer or recognise PIC 1 items within
conditional expressions.

« IntelliSense (Visual Studio) showed the wrong members after a cast to SUPER.

« IntelliSense (Visual Studio) and Content Assist (Eclipse) sometimes did not list any members after
names of unqualified types.

« The Content Assist (Eclipse) and IntelliSense (Visual Studio) lists would not include any options if there
where unknown parameter types in the code.

« Some IntelliSense (Visual Studio) and Content Assist (Eclipse) proposals for items from external
programs did not have any descriptions.

« If there were multiple items with the same name declared in external programsm they were not offered
correctly by IntelliSense.

« IntelliSense now supports constructing instances of the current or parent type using either NEW SELF
or NEW SUPER.

« IntelliSense in Visual Studio would sometimes show the wrong members for unqualified type names
within partial classes.

» Content Assist (Eclipse) and IntelliSense (Visual Studio) now offer to qualify file record items by their FD
items.

* IntelliSense (Visual Studio) and Content Assist (Eclipse) would sometimes list the wrong members after
an unqualified type name.

Enterprise Server
Back to the list
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 The CASGLM.LCK and ESCLRMLs.cfg files were not generated if the system catalog was in a spacey
path.

* The security when displaying any of the Enterprise Server configuration pages in the Enterprise Server
Administration HTML GUI has been increased.

2846702 (1102642)
« The "Renew" command available from the left hand side navigation pane in the Enterprise Server
Administration HTML GUI did not work when SSL was enabled.

e A potential memory corruption when a SEP executing an EXEC CICS DELAY is killed has been fixed.
This situation only occurred when TRANCLASS was enabled.

2865931 (1105228)

« An initial 3270 terminal connection could hang if there was an attempt to send an error message to the
terminal not yet connected and an XA error occurred at the same time.

2865927 (1105226)
* IN-only messages are now supported for CICS Web Services.

2864329 (1104991)

e Anissue causing an RTS 114 error in mfjclsub when a CICS program executed a 'display’ call in an
SSTM-enabled region has been fixed.

2858651 (1104770)

e Itis now possible to programmatically change the name of a Web service displayed in the HSF records
by calling the following entry point: call 'ES_trace_application_data' using by reference ws-trace-block .
Where ws-trace-block is defined as follows: 01 ws-trace-block. 03 ws-trace-version pic x comp-X. 03 ws-
trace-data. 05 ws-trace-type pic x comp-x. 05 ws-trace-text pic x(255). - ws-trace-version and ws-trace-
type must have a value of 1. - ws-trace-text is restricted to 255 bytes in length, must be terminated by
low-values (x'00) and must not have any spaces embedded in it.

2856234 (1103860)

* When using cassout from the API and not cancelling it between calls, it was possible to overwrite the file
output from a previous invocation if the '-d' option (output to file) was not specified. The product now
initializes the required environment variables on each invocation to ensure this problem does not occur.

2852058 (1103778)
» Trying to access ESMAC in a secure region no longer results in the application crashing.

2851933 (1103724)

* On a CICS stateful request, after a run-time system failure, a transient SEP could loop, produce an RTS
114 error or an abend CDCD on shutdown during SDP2. This was caused by the ATP not being at the
expected level when running SDP2.

2851618 (1103389)

e The casutl command line utility supports a new option, /n. When used with /n, the utility starts a new
console.log and saves the contents of the current console.log to a new file,
console.nnn_switch_date_time (where nnn is a number).

2851178 (1103265)
¢ Visual COBOL and COBOL Server with SOA now include castran with the CANCEL support.

2849934 (1103037)
» Credentials are now masked out in the formatted dump.

2848888 (1102908)

» A default password for an external Security Manager connection is no longer used when you specify a
user id but not a password. This is to help avoid locking out the user id. Also, if no password has been
specified, the Enterprise Server Administration HTML GUI no longer displays a dummy value in the
password field on the Security Manager configuration page.
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2864790 (1105187)
Under heavy loads, the ESFCA0401I log messages were not appearing at the correct intervals.

2863222 (1104948)

Restricting access to the Enterprise Server External Security Facility's Admin API for the MLDAP ESM
Module now works correctly when you use resource definitions in the optional AdminAPI class.

2830660 (1100636)

With some types of tracing enabled, the MLDAP ESM Module for Enterprise Server security would
sometimes report that a group ACE matched the user's logon group when in fact it did not match. The
trace message now correctly indicates whether the ACE matched or not.

When using Enterprise Server security with LDAP, on some platforms, a resource access rule with an
empty access control list (ACL) could cause an RTS 114 or other program crash. This has now been
fixed.

File Handling

Back to the list

An internal field used to store the current file status was being overwritten by the allocation of a buffer.
Now we store it off beforehand so its value can be restored, and an accurate file status returned.

2868664 (1105707)

When certain in-flight rewritten records were rolled back at the end of a transaction, the File Handler
was setting incorrect values for the length field in some records and various warning messages were
displayed during index file validation.

2864802 (1106106)

VB files are now created with the correct Irecl, taking into account the extra space for a print character
when creating the file header.

2856899 (1104023)

FS CHECK FILE_EXIST is now being processed correctly when called with an environment variable
that contains a Fileshare server-name. Previously, the request was not being sent to the server.

2851717 (1103253)

Memory is now correctly being deallocated at end of IMS rollback recovery processing; previously, it
was not.

2840046 (1101795)
The rollback recovery process is now working as expected.

2802180 (1097066)

For corrupted files, where a corrupted offset occurs beyond the end of the file, you now receive a
validation message instead of a Run-Time System error 114.

2860981 (1104576)

When MFJSORT fails to open SYSOUT, it now gives an error message to the console, and then
abends.

2861239 (1104614)
The MFJSORT E15 user exit is now giving the correct record length.

2858360 (1104276)
A COBOL SORT called from JCL no longer causes a COBRT200 error message in managed code.

2857600 (1104073)
SORT now treats leading spaces in ZD fields as zero, which emulates mainframe behavior.

2855141 (1103700)
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The conversion of PD to ZD is now giving correct SORT results for negative numbers.
2854443 (1103597)

H2cpy

Back to the list

H2cpy now successfully parses cURL header files.
2858155 (1104162)

HCO for Microsoft SQL Server
Back to the list

The OpenESQL pre-compiler generated code has been modified to perform swap logic for COMP fields
if an SQLCODE of -305 or -811 is also returned, as data can be returned with either of those
SQLCODEs.

2871163 (1106063)
An issue with OpenESQL handling cursor names that start with "CURSOR" has been fixed.

2866507 (1105337)
An issue where HCOSS was not locating the correct stored procedure for a bound statement in multi-
step JCL jobs has been fixed.

2861657 (1104733)
When using DIALECT=MAINFRAME, if a program references a DECLARE GLOBAL TEMPORARY
TABLE before the declaration, the precompiler now produces a warning and not an error message.

2853667 (1103453)

IDE
Back to the list

Resolved Issues

In Visual Studio 2015 or later, the Properties window for assembly references might have incorrectly
displayed a value of "false" for the 'Copy Local' property.

2868449 (1105875)
Visual Studio should not support editing of data items at a group level. This is option is now disabled.

2864986 (1105083)

When debugging an application running on a remote machine with the expanded copybook debugging
enabled, the Visual Studio debugger now steps on the correct lines. In such cases, if the application
sources are not loaded in Visual Studio, the debugger will not step the copybooks inline. Instead, it will
open the copybooks in a separate tab in the editor.

2864082 (1105134)
Debug tooltips are now shown correctly in statements that contain multiple data items.

2862422 (1104764)
When building a COBOL project, outlining would be temporarily turned off for any open source files.

2860767 (1104493)

The IDE setting "Debug tooltip style for OCCURS items" in Tools > Options > Micro Focus COBOL >
Advanced has been renamed to "Show COBOL occurs or reference modification value" and is now
available under Tools > Options > Debugging->Micro Focus COBOL. While debugging, you can enable
this setting directly from the editor - either choose "COBOL debug tooltip style" from the editor context
menu or from the context menu of the debug tooltips.

2858786 (620858)



Watchpoints are now hit when debugging Mainframe Subsystem applications.

2857670 (1104106)

The environment variables specified on the Environment tab in the Application Settings dialog box when
you edit a project's Application.config file are now expanded when the application is executed from
within Visual Studio.

2853990 (619225)
The editor is now more responsive when editing large source files.

2852087 (1103629)

It is now possible to switch off the colorization of uncompiled code in the editor - click Tools > Options >
Text Editor > Micro Focus COBOL > Advanced and set "Enable inactive code colorization" to False.
Switching this setting off can help improve the editor performance.

The debugger is now positioned on the correct source line when debugging 64-bit Oracle Pro*COBOL
programs.

It is now possible to specify options for compiling native resources files (.rc) by accessing the files'
properties from within the IDE.

This release offers various improvements in the performance and stability of outlining support in the
COBOL editor.

The Call Hierarchy and Quick Browse window now display information about items with non-ASCI|
names.

IntelliSense and colorization did not work in the Visual Studio COBOL editor in sourceformat(free) when
the first word on the line started with a "d", and this was not a debug indicator.

When querying items, if you expand the tables and groups, they now show the element name rather
than a fully qualified name. This is to improve the readability.

Visual Studio could crash when attempting to use the "Debug/Attach to Process" feature and when
Visual Studio was started with non-administrator privileges.

In the Project Details Window, unchecking the Allow Columns Reorder context menu option would crash
the IDE.

Displaying the context menu for a file in the Project Details Window could sometimes cause the IDE to
crash.

Micro Focus Directory Server

Back to the list

Fixed an issue where XA open string which included the "=" character would not display correctly in the
Enterprise Server Administration HTML GUI.

2856722 (1103958)

If a user attempts to login to the MFDS process using a valid ID but an invalid password the message
"ML3073W Unknown user" is no longer logged in the MFDS journal output.

2842321 (1102116)

MVS REXX Emulation
Back to the list

This release provides a technology preview support for the DSNREXX commands for DB2 LUW.
2842140 (1102170)

OpenESQL
Back to the list

A problem with SQL(SQLCLRTRANS) that caused a COBOL 173 runtime error on stored procedures
that make COBOL calls to other modules has been fixed.

Resolved Issues
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Resolved Issues

2871330 (1106084)
A problem using SQL(CHECK) with statements that contain a FOR :hostVariable prefix has been fixed.

2868823 (1105704)
In managed code only, a problem with the OpenESQL preprocessor sometimes generating incorrect
code after a stored procedure call resulted in some data being returned incorrectly. This has been fixed.

2868405 (1105663)

Compiler errors sometimes resulted when the SQLCLR wrapper generator generated duplicate
parameter names. This has been fixed by updating the generator to check for the potential of duplicate
names and choose an alternate extension to insure unique names.

2866086 (1105262)

The OpenESQL Managed Runtime for ADO.NET now allows non-printing characters in PIC X host
variables.

2865166 (1105140)

The OpenESQL pre-compiler incorrectly generated code for programs compiled with
CHARSET(EBCDIC) and SQL(DBMAN=ADO) when SQL statements were greater than 4000
characters.

2864850 (1105064)

Previously, the SPD Generator did not handle correctly some of the parameters which resulted in
generating an incorrect COBOL code.

2864348 (1104993)

The OpenESQL component was updated to resolve an issue executing the HCOSS Assess Application
Migration tool when either no Visual Studio product was installed, or just the Visual Studio Integrated
Shell was installed.

2864021 (1104951)

The SPD generator incorrectly handled quotes around the procedure name, resulting in a compile error
of generated COBOL code. This has been corrected.

2863699 (1104906)

HCOSS was improperly handling UPDATE statements that uses row constructors based on a subquery.
This has been fixed.

2860329 (1104628)
Using SQL(DETECTDATE=SERVER) with queries containing single quote characters sometimes
resulted in an error. This has been fixed.

2857619 (1104103)

The DCLGEN function of OpenESQL Assistant now supports including comments in copybooks for the
Label extended properties on SQL Server columns.

2856215 (1104118)

The SQL(CHECKSP) Compiler directive has been added to list of directives which you can set from the
project's or a file's properties. Also, receiving an error message that the SPD file was not found no
longer causes compiling to hang.

2853668 (1103454)

A problem with the ADO.NET run-time system for OpenESQL not implementing the default threading
behavior for THREAD=SHARE has been fixed, enabling single-user applications, such as Windows
Forms or WPF applications, to use background worker threads provided that the application takes steps
to ensure that only one thread executes embedded SQL statements at a time. When using the
THREAD directive, be aware that ADO does not support THREAD=ISOLATE. For multi-user
applications, we recommend using COBOL run units instead.

2850789 (1103122)



Run-Time System
Back to the list

* A statement "MOVE <justified-alphanumeric-item> TO <numeric-item>" no longer produces a
COBRT200 error.

2869985 (1105986)

< If the Audit Manager was under heavy load by many client processes and was then re-cycled, it was
possible that the client processes would not send the correct details when attaching to the new Audit
Manager process, which would cause Audit Manager to crash. This is now fixed.

2863509 (1104863)
« Pasting of DBCS characters that have a 2nd byte of x"EQ" is now working correctly.

2861398 (1104580)

* A dynamically bound application DLL that uses Object COBOL no longer hangs intermittently when
loaded concurrently in multiple threads.

2858271 (1104328)

« An additional sub-function has been added to the CBL_GET_PROGRAM_INFO library routine. The
sub-function, number 10, returns a program's full path, or name only, depending on flag settings.

(618769)
< Detaching from animation that was started using the debug_on_error tunable could cause animation to
re-start again for the initial error - this has now been resolved.

« In managed COBOL code, setting an environment variable to spaces or low-values now unsets that
environment variable.

2864896 (1105147)

« You now receive a correct error message when the CBL_CHECK_FILE_EXIST library call is used with
DD_ environment variable expansion on a directory that already exists.

2864515 (1105023)

e Inthe .NET COBOL Run-Time system, default NLS messages are now returned for locales that do not
have the messages defined.

2863236 (1104831)

SQL: Cobsql
Back to the list

« A problem with processing an SQL statement when it was on the same line as a COBOL condition
resulted in a CSQL-F-026 error. This has been fixed.

2864989 (1105085)
* A problem with COBSQL incorrectly handling EXEC SQL INCLUDE statements has been fixed.

2821960 (1099586)
« A problem with COBSQL not recognizing or properly processing a section that comes directly after
comment lines and returning an error has been fixed.

2818934 (1099169)

* A problem with COBSQL not properly invoking cobpre64 when COBSQLTYPE is set to SYBASE has
been fixed.

2794407 (1096173)

SQL: DB2 ECM
Back to the list

Resolved Issues | 23



* A problem with the HCO import tool incorrectly handling packed decimals greater than 18 digits has
been fixed.It has been updated to now handle packed decimals up to 26 digits.

2866180 (1105278)

* The DB2 pre-compiler sometimes incorrectly restored the RETURN-CODE after a SQL statement was
executed.

2857403 (1104045)

SQL: OpenESQL
Back to the list
* The INSENSITIVE option is no longer available for the STATICREADONLY directive.

2871907 (1106251)
* A problem with error message handling in the ODBC run time for SAVEPOINT statements has been

fixed.
2870141 (1105889)
e A problem with HCOSS incorrectly renaming parenthesized expressions in select lists has been fixed.

2869320 (1105787)

e SQL(SPTHROWEXCPETION) now throws an exception only for errors that result when SQL Server
terminates the current transaction.
2868965 (1105736)

+ SQL(DETECTDATE) would sometimes incorrectly match dates and times in European and USA
formats.
2868282 (1105622)

* A problem with the OpenESQL preprocessor failing to properly check the length of an SQL statement
properly, resulting in a 153 RTS error, has been fixed.
2867772 (1105549)

* A problem with OpenESQL SQL Entry and Exit not showing in trace output has been fixed. The trace
output is now sent to Auxiliary trace during CICS transaction execution.
2867423 (1105490)

e A problem running SQL CLR stored procedures on heavily loaded servers has been fixed.

2865750 (1105229)

e A problem with OpenESQL allocating duplicate server cursor names for positioned updates in stored
procedures has been fixed.
2865750 (1105230)

e A problem with the OpenESQL Assistant generating copybooks with TINYINT columns as PIC S9(2)
COMP-5 rather than PIC S9(4) COMP-5 has been fixed.
2865378 (1105139)

* HCOSS now correctly handles hexadecimal constant strings.

2865026 (1105146)

* A problem with the OpenESQL preprocessor when compiling with the CHARSET(EBCDIC) directive
sometimes generating COBCH0002/COBCHO0302 compilation errors for programs that used arrays as
host variables in SQL statements has been fixed.

2864585 (1105039)
¢ OpenESQL now supports DESCRIBE CURSOR statements.

2863839 (1104939)

e A problem with HCOSS handling the SUBSTRING function when only three parameters are supplied
has been fixed.
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2862754 (1105122)
HCOSS now correctly handles the DB2 TRUNCATE scalar function when the function is called with only
one parameter.

2862064 (1104674)
HCOSS could sometimes report a SQL(CHECK) error as a warning instead of an error.

2861897 (1104668)
The ODBC pre-compiler now swaps array variables using DO UNTIL loops similarly to how it does this
for COBOL. This considerably reduces the number of statements generated for array variables.

2861580 (1104613)
HCOSS now correctly sets SQLCODE = 100 for a rowset fetch that retrieves fewer rows than the host
array size.

2861570 (1104629)
HCOSS now handles correctly FETCH FIRST and ORDER BY clauses in queries that use set
operators.

2861567 (1104751)

A problem with OpenESQL incorrectly handling DB CAST expressions that use FOR BIT DATA has
been fixed.

2861516 (1104689)
HCOSS no longer trims trailing spaces automatically from input host variables when
SQL(DIALECT=MAINFRAME) is set.

2859565 (1104692)
Previously, you could incorrectly receive truncation warnings for output parameters of Oracle stored
procedure calls that are character fields narrower than 19 characters.

2859200 (1104598)

Using MySQL ODBC 5.6 or later with OpenESQL in VC/ED 2.3 or later caused an RTS 114 error. This
has been fixed.

2858980 (1105338)
Problems with the OpenESQL Assistant that caused the "no columns in table" error have been fixed.

2856643 (1103936)
A problem with applications compiled with the SQL(INIT=PROT) directive caused Enterprise
Server .NET jobs to hang. This has been fixed.

2856198 (1104002)
HCOSS now supports DB2 RELEASE SAVEPOINT statements and problems with global temporary
table housekeeping and ROLLBACK TO SAVEPOINT statements have been fixed.

2856008 (1103831)

The SPTHROWEXCEPTION SQL compiler directive option has been added to improve diagnostics
returned to calling applications from COBOL SQL CLR stored procedures in the case of an implicit SQL
Server rollback on a transaction.

2854780 (1103670)
A problem with OpenESQL not allowing 'NO' to be used as an SQL identifier has been fixed.

2854592 (1103598)

A problem with the JDBC runtime incorrectly setting SQLCODE on repeat execution of EXECUTE
IMMEDIATE statements has been fixed.

2854393 (1103713)

A problem processing the EXEC ADO DATATABLE <name> BIND statement resulted in a COBES0100
error. This has been fixed.

2854004 (1103529)
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* Some problems with DB2-style result sets where allocated cursors are reused without being closed and
where cursors must remain open across multiple calls to the same stored procedure have been fixed.

2853859 (1103520)

» EXCEL table names enclosed in single quotes were incorrectly handled by the DCLGEN function of the
OpenESQL Assistant, resulting in an unhandled exception. This has been fixed.

2853832 (1103555)

* The COBOL Run-Time system now successfully loads the ODBCRW®64.DLL file when a native COBOL
application is being called from a C# application.

2853578 (1104167)

e The OpenESQL directives SQLCLRTRANS and SPDISPLAY now work correctly for Enterprise
Server.NET batch jobs.

2853439 (1103430)

* An HCOSS problem transforming SQL statements that contain both XML and CONCAT operators has
been fixed.

2853412 (1103426)

« The OpenESQL ODBC runtime has been updated to ensure that connections are closed after a
DISCONNECT.

2853341 (1103461)

* HCOSS now correctly handles WITH DEFAULT clauses in table definitions that do not specify a default
value.

2852996 (1103431)

e HCOSS now supports DB2 DECLARE GLOBAL TEMPORARY TABLE statements that use AS <query>
and LIKE <tableName>.

2850369 (1103793)

* The SQL(PROCOB) directive option for the OpenESQL preprocessor now supports Pro*COBOL's
syntax for calling database functions when SQL(DBMAN=ADO) is also set. In addition, a problem that
prevented DML from being executed in user-defined functions has been fixed.

2849318 (1102957)

« The SQL(PROCOB) directive option for the OpenESQL preprocessor has been updated to process
Oracle grouped host array syntax.

2849301 (1102956)

« To fix a problem with the DETECTDATE directive not allowing runtime control of datetime data
formatting, the OpenESQL SET <hostvariable> and SET OPTION statements have been enhanced to
allow datetime data formatting behavior equivalent to the OpenESQL DATE, TIME, DATEDELIM,
TIMEDELIM, TSTAMPSEP, and DETECTDATE directives.

« A problem with positioned update when using the latest release of the PostgreSQL ADO.NET provider
has been fixed.

* The namespace used by the JDBC runtime for OpenESQL has changed from
MicroFocus.COBOL.SqlJVM to com.microfocus.openesql.

e The 32-bit Windows DLL names used in OpenESQL JES program-alias mapping have been changed
as follows: SQLTP232 to SQLTP2 SQLUTB32 to SQLUTB.

e Using the CHARSET(EBCDIC) directive with OpenESQL sometimes caused the preprocessor to
generate incorrect code for converting SQLCA fields, resulting in CONNECT failures. This has been
fixed.

e The SET host-variable embedded SQL statement has been added to OpenESQL to enable you to
query the current connection name and database type.

» Cursor prefetch behavior in OpenESQL has been made more consistent with updates to the
PF_RO_CURSOR and PF_UPD_CURSOR primitive compiler directive options for BEHAVIOR, and the
MARS compiler directive option. See your product documentation for complete details.
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SQL Option for DB2
Back to the list

The SQLN value in SQLDA is no longer modified when a FETCH is performed using invalid SQLVAR
SQLDATA pointers.

2854157 (1103541)

A Run-Time System error "-84 UNACCEPTABLE SQL statement" could occur when there was a
VARCHAR host variable definition with an extra 49 level FILLER statement.

2867096 (1105432)

Modified the XDB precompiler to no longer generate COBSQO0413S errors if the program is compiled
with directive XDB(BEHAVIOR=STACKED).

2855151 (1103687)
The XDBSetup utility supports creating a user XDB.INI in the user's local application space.
2839228 (1101904)

An issue with scalar functions invoking aggregate functions invoking more scalar functions with
embedded host variables has been fixed.

2869971 (1105862)

A problem that resulted in XDB Server providing incorrect SORT results when using ROWSET
POSITIONING has been fixed.

2867209 (1105454)
Implicit casting is now carried out for SUBSTR() arguments in the V10 XDB engine.

2865204 (1105108)

A problem with uninitialized query common space generating an illegal decimal data error has been
resolved.

2860427 (1104449)

XDB Server has been updated to correctly return results from XDB SQL when certain statement
combinations are executed.

2856158 (1103932)

Some SQL queries that return data on the mainframe did not return data in XDB. These queries now
return data in XDB as well.

2853378 (1103442)

The XDB SQL optimizer has been updated to use a new compound index routine. This corrects a
problem that caused a thread access violation when processing a very large join restriction queue that
had overflowed to disk.

2853078 (1103385)

A problem with the XDB server corrupting a row after executing a program that uses a FOR UPDATE
cursor has been fixed.

2850725 (1103117)

Multiple issues that occurred when the reserved word SELECT was used as an identifier have been
resolved.

2849898 (1103024)

A problem causing the SQL result to be inconsistent when using the SELECT... IN clause has been
fixed.

2849892 (1103103)

A problem when creating a unique index, that resulted in an "x020: Syntax error. Last symbol read was
'INCLUDE™ error message, has been fixed.
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2847745 (1102766)
e SQL Option now supports PARTITION BY SIZE syntax for DB2 version 9.

2845161 (1102494)
< XDB no longer throws an X405 error message when it encounters a NOT operator that is part of a
compound predicate.

2640689 (1088784)

XML Syntax Support
Back to the list
* In some scenarios, XMLPARSE returned an RTS 114 error while parsing certain XML documents.

2851143 (1103185)
« When reading an empty XML document, the returned file status is now -7.

2851074 (1103216)
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Other Issues Resolved In This Release

The numbers listed are the Support Incident Numbers followed by the Reported Problem Incident (RPI)
number (in parentheses).

2865238 (1105114)
2871930 (1106185)
2866567 (1105346)
2865516 (1105153)
2865065 (1105097)
2857117 (1104003)
2872217 (1106234)
2864576 (1105124)
2855891 (1103807)
2864100 (1104959)
2867120 (1105479)
2865687 (1105211)
2864343 (1105019)
2858008 (1104163)
2858007 (1104161)
2835721 (1101500)
2835605 (1101499)
2858091 (1104136)
2865419 (1105238)
2864875 (1105074)
2861263 (1104753)
2859986 (1104407)
2855942 (1103906)
2679133 (1093595)
2852255 (1104353)
2856233 (1103855)
2867934 (1105578)
2867215 (1105455)
2866174 (1105419)
2858808 (1104227)
2855088 (1103672)
2853477 (1103462)
2852874 (1103543)
2839669 (1101704)
2836259 (1101305)
2808029 (1098883)
2790796 (1095836)
2854829 (1103653)
2854739 (1103627)
2866458 (1105348)
2865807 (1105205)
2864327 (1104989)
2862599 (1104785)
2848016 (1102774)
2843761 (1102734)
2841092 (1101887)

2865193 (1105135)
2864092 (1106070)
2859740 (1104343)
2859539 (1104350)
2856245 (1103972)
2855704 (1104105)
2855440 (1103871)
2853585 (1103448)
2852872 (1103696)
2852872 (1103930)
2852872 (1103931)
2851306 (1103352)
2840161 (1101839)
2799183 (1096680)
2863024 (1104786)
2853074 (1103489)
2848947 (1103100)
2816310 (1104173)
2859923 (1104371)
2650949 (1090062)
2854470 (1103640)
2857870 (1104107)
2809343 (1099937)
2858035 (1104156)
2856499 (1104222)
2857318 (1104188)
2858539 (1104204)
2856795 (1103963)
2840704 (1103249)
2863482 (1104862)
2861561 (1104610)
2860719 (1104512)
2858941 (1104253)
2858723 (1104229)
2856941 (1103977)
2856206 (1103880)
2861649 (1104679)
2853710 (1103578)
2867842 (1105600)
2865028 (1105119)
2860212 (1104480)
2854400 (1103587)
2852486 (1103340)
2842820 (1103533)
2855179 (1103705)
2855179 (1103707)

2819868 (1099861)
2865350 (1105129)
2864599 (1105025)
2853376 (1103486)
2855231 (1103701)
2870740 (1106000)
2858161 (1104152)
2864758 (1105772)
2856295 (1103875)
2839181 (1101830)
2864619 (1105054)
2861296 (1104593)
2860006 (1104387)
2854108 (1104290)
2848917 (1103264)
2838891 (1101791)
2648290 (1089566)
2864197 (1105004)
2852655 (1103333)
2869703 (1105832)
2869126 (1105760)
2852996 (1103913)
2859001 (1104312)
2869594 (1105948)
2867462 (1105499)
2866779 (1105567)
2865650 (1105214)
2865630 (1105243)
2865078 (1105100)
2865051 (1105317)
2865003 (1105132)
2863175 (1104845)
2860863 (1104746)
2860785 (1104563)
2859507 (1104314)
2859155 (1104316)
2859044 (1104282)
2857023 (1104176)
2857021 (1103995)
2856592 (1104053)
2852281 (1103298)
2818259 (1099422)
2865602 (1105177)
2863239 (1105044)
2861423 (1104585)
2858787 (1104233)
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Installation

Before Installing

Downloading the Product

You can download Visual COBOL from the Product Updates section of the Micro Focus SupportLine Web
site.

On Windows

System Requirements

Hardware Requirements

Visual COBOL has the following requirements in addition to the requirements of Microsoft Visual Studio.
See the Visual Studio documentation for details of the Microsoft requirements.

The maximum disk space requirements are, approximately:

Visual COBOL Sentinel RMS License Manager

1.2Gb 75MB

e This includes the space needed to cache information locally so that you can modify the installation
without the original source media.

« The disk space requirements include the versions of JRE and .NET Framework supplied with the setup
file.

Operating Systems Supported

For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

f Note:

You can produce both 32-bit or 64-bit applications with Visual COBOL installed on a 64-bit
operating system.

» Visual COBOL for Visual Studio is not supported on versions of Windows earlier than Windows 7.
e The Enterprise Server feature is not supported on Windows XP.

Software Requirements

The setup file will check your machine for whether the prerequisite software is installed and will install any
missing prerequisites and the product components.

f Note:

» Besides the software listed below, the setup file also installs the 32-bit Java 8 Update 51.
e This product includes OpenSSL version 1.0.1p.
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Visual Studio IDE
This product requires Microsoft's Visual Studio.

You need one of the advanced versions of Visual Studio listed below or the Visual Studio Integrated Shell
(only supported by Visual COBOL for Visual Studio 2012 or 2013):

Professional, Premium, or Ultimate (for Visual Studio 2012)
Professional, Premium, Ultimate or Community Edition (for Visual Studio 2013)
Professional, Enterprise or Community Edition (for Visual Studio 2015)

Microsoft's Visual Studio Express Edition is not supported.

If there is no Visual Studio installed on your machine, the setup file for Visual COBOL for Visual Studio
2012 or 2013 will install the Visual Studio Integrated Shell. Alternatively, you can download the Visual
Studio Integrated Shell from the Microsoft Download Center and install it before you install Visual COBOL.
If you choose to install the Shell, ensure you run the installer to complete the installation - run

vsi nt shel I . enu. exe from the location where you installed the download.

Note that some Visual Studio features might not be available with the Shell. This includes WCF or the
Visual Studio 2013 Connected IDE experience in the Visual Studio 2013 Shell - the help for more details.

/1, Important:

e A problem with Microsoft's Windows 10 prevents installing the Visual Studio 2013 Shell on that
version of the OS. You must install an advanced edition of Visual Studio 2013 on Windows 10
before you start the installation of Visual COBOL for Visual Studio 2013.

» Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a
number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the
setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that
there is an advanced edition of Visual Studio 2015 installed on your machine.

* On Windows 8.1 RT, Windows 8.1 or Windows Server 2012 R2, you must have the Windows
update KB 2919355 before you install Visual Studio 2015. Download KB 2919355 from the
Microsoft Download Center.

» Code generation issues in Microsoft's 64-bit JIT (just-in-time) compiler delivered as part of .NET
Framework version 4.6 can result in incorrect execution of some COBOL code compiled to .NET.
Version 4.6 of the .NET Framework is currently shipped as default with Visual Studio 2015 and
Microsoft's Windows 10. The problems include incorrect execution of MOVE and STRING
statements applied to alphanumeric operands, and incorrect execution of the ROUNDED phrase
for arithmetic statements.

Some of these issues only seem to be reproducible in COBOL language applications compiled
to .NET and some can be reproduced in other languages (C# or Visual Basic).

These problems have been reported and acknowledged by Microsoft and it is our belief that they
either have resolutions or are working on fixes for all of them. For further information about these
issues and guidelines on how to disable the latest version of the 64-bit JIT compiler, see RyuJIT
Bug Advisory and Troubleshooting RyuJIT.

As of October 2015, Microsoft have released the following updates that address these issues with
the .NET Framework 4.6:

» Hotfix rollup 3088955 for the .NET Framework 4.6 on Windows Server 2012 and Windows 8 -
see: http://lwww.microfocus.com/docs/links.asp?vc=mskb3088955.

» Hotfix rollup 3088956 for the .NET Framework 4.6 on Windows Server 2012 R2 and Windows
8.1 - see: http://www.microfocus.com/docs/links.asp?vc=mskb3088956

» Hotfix rollup 3088957 for the .NET Framework 4.6 on Windows 7 SP1, Windows Server 2008
SP2, Windows Server 2008 R2 SP1, and Windows Vista SP2 - see: http://
www.microfocus.com/docs/links.asp?vc=mskb3088957.
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e Cumulative update 3093266 for Windows 10: September 30, 2015 (available through Windows
Update) - see: http://www.microfocus.com/docs/links.asp?vc=mskb3093266.

The following software is also required:

« Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft
Download Center and search for Windows SDK.

* Microsoft NET Framework 4.5. This is included with Visual Studio 2012.

¢ Microsoft NET Framework 4.5.1. This is included with Visual Studio 2013.

» Microsoft .NET Framework 4.6. This is included with Visual Studio 2015.

Internet Explorer 10

Internet Explorer 10 (IE 10) is required by the installation of Visual Studio 2013. If you are installing Visual
COBOL on a machine that has no Visual Studio 2013 installed, the setup file installs Visual Studio 2013
Shell provided that IE 10 is installed beforehand. You can download IE 10 from Microsoft's Web site.

IIS Express

IIS Express is required if you want to use the Web development tools. You can download IIS Express from
the Microsoft Download Center.

Other Requirements

/1+, Important: This release requires version 10000.2.990 or later of the Micro Focus License
“~*= Administration tool. For local servers, you do not need to install it separately, as the setup file installs
a new Visual COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus License Administration tool.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

Additional Software Requirements

To ensure full functionality for some Visual COBOL features, you might be required to obtain and install
additional third-party software in addition to the prerequisite software installed automatically by the Visual
COBOL setup file.

See this information in the Micro Focus Infocenter, in the product help for Visual COBOL for Visual Studio
2012 (click here), Visual COBOL for Visual Studio 2013 (click here), and Visual COBOL for Visual Studio
2015 (click here).

Product Co-Existence

* Visual COBOL and COBOL Server cannot coexist on the same machine.

« Visual COBOL and Enterprise Developer cannot coexist on the same machine regardless of which IDE
(Visual Studio or Eclipse) you install.

Installation Restrictions and Requirements
Before starting the installation you should consider the following:

« Visual COBOL and Enterprise Developer cannot coexist on the same machine.

» If, when you install Visual COBOL for Visual Studio 2012 or 2013, the machine does not have Microsoft
Visual C++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL.
The installation of Microsoft Visual C++ Redistributable Runtime adds a number of . dl | files, without
digital signatures, into the wi nsxs directory.

Installation
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If, when you install Visual COBOL for Visual Studio 2015, the machine does not have Microsoft Visual C
++ 2013 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ Redistributable Runtime adds a number of . dl | files, without digital
signatures, into the wi nsxs directory.

You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.

Before installing this product, make sure that any existing Micro Focus Directory Server (MFDS) or
CCITCP2 Windows service (on Windows) from an existing product is stopped and uninstalled. On
Windows, do this as follows:

1. Stop the MFDS and CCITCP2, using either the Windows Service Management Console GUI
(servi ces. nsc) or from a command line prompt by typing:

net stop nf_ccitcp2

Only one instance of the MFDS or CCITCP2 service can run on a Windows machine.
2. Uninstall the MFDS or CCITCP2 service.

For MFDS, from a command line prompt enter: nf ds -u

For CCITCP2: ccitcp2 -u
To run an earlier version of MFDS as a service after you have installed a later version:

1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:

a. Open a Visual COBOL command prompt.
b. Install the service. Enter the following command: nf ds -1
c. Start the service. Enter the following command: net start nf_ccitcp2

Note: The two versions use different paths for environment and registry values, so the list of
configured enterprise servers might be different depending on which version has been started,
since, by default, different MFDS data repositories are used.

MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier
versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later
versions.

It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the
"mfcobol" port is used (86) and this can only be used by one process at a time

Basic Installation

Installation

The instructions in this section apply when you are performing a basic installation of this product for the
first time. If you are an administrator, you can perform a basic installation on a local machine before

performing a more advanced installation when rolling out the product to developers within your
organization.

For considerations when installing this product as an upgrade, for additional installation options or non-
default installations, see Advanced Installation Tasks in your product Help.

Installing

f Note:

» This version of the product is a full install.



» See Before Installing first for important information. Also, see Installing as an Upgrade, if you have
an earlier version of Visual COBOL installed on your machine.

To install this product:

1. Runthevcvs2012 232. exe file (or vevs2013_232.exe, vcvs2015 232.exe) and follow the wizard
instructions to install the prerequisite software and the product.

f Note:

When the installation has completed, on some editions of Windows you might receive a notification
that Visual Studio 2012 has compatibility issues. This is a known Microsoft issue. To resolve it,
follow the instructions in the notification for obtaining help online, or download the KB2781514
update for Visual Studio 2012 from the Microsoft Download Center.

« If you are installing onto a machine that has an existing Micro Focus product that uses an older
Sentinel RMS License Manager, you might be prompted to remove it and install the Micro Focus
License Administration. By doing this you maintain the existing Sentinel RMS license files while
adding the Micro Focus License Administration. If you are unsure about existing licenses on your
computer or removing the Sentinel RMS License Manager, consult your System Administrator. If
you want to proceed, remove Sentinel RMS License Manager by using Program and Features
(Windows Vista or later), and rerun the installation file.

« Trial licenses cannot be used with remote desktop services. If you want to use your product in this
way, please contact Micro Focus SupportLine to obtain a relevant license.

* We recommend that you install any updates for Visual Studio and the .NET Framework that are
available at the Microsoft Download site.

» If you install JDK you might be prompted to install the latest update. The latest update is not
required for use with Visual COBOL but you can install it if you wish.

Advanced Installation Tasks

This section includes instructions about how to perform a non-default installation, install this product as an
upgrade, or about how to install the additional components.

The advanced installation tasks include:

» Installing as an Upgrade - included in these Release Notes
e Command line installation options - included in these Release Notes

» Installing on Microsoft Terminal Server and Citrix - available in the product Help and in the Micro Focus
Infocenter

See this information in the Micro Focus Infocenter, in the product help for Visual COBOL for Visual Studio
2012 (click here), Visual COBOL for Visual Studio 2013 (click here), and Visual COBOL for Visual Studio
2015 (click here).

On Windows

Installing as an Upgrade

Installing this release as an upgrade will automatically uninstall any HotFixes of the older version of the
product you have installed on your machine.

« Before installing this release as an upgrade, ensure you create a back-up of your Enterprise Server
configuration. To do this, on the Enterprise Server Administration home page, click Export and then
select Export Enterprise Server configuration and Security Manager definitions. This creates a
backup folder inthe ¢: \ prograndat a\ m cro focus\Enterpri se Devel oper\ M-DS. You can
restore the Enterprise Server configuration after installing this release - click Import on the Enterprise
Server Administration home page.

Installation | 35


http://www.microfocus.com/docs/links.asp?nx=ctl1
http://www.microfocus.com/docs/links.asp?nx=ctl1
http://documentation.microfocus.com/help/topic/com.microfocus.eclipse.infocenter.visualcobol.vs2012/GUID-53E6C368-8E19-4E3E-8394-710B1DC55958.html
http://documentation.microfocus.com/help/topic/com.microfocus.eclipse.infocenter.visualcobol.vs2013/GUID-53E6C368-8E19-4E3E-8394-710B1DC55958.html
http://documentation.microfocus.com/help/topic/com.microfocus.eclipse.infocenter.visualcobol.vs2015/GUID-53E6C368-8E19-4E3E-8394-710B1DC55958.html

Visual COBOL Installation Options

To install Visual COBOL you run vcvs2012 232. exe which contains a number of product . msi files
(Windows Installer packages). When run, vevs2012_232. exe performs some initial system checks then
sequentially installs the . nsi files.

Note: The following applies to vevs2013_232. exe when installing the product for Visual Studio
2013. The following applies to vcvs2015_232. exe when installing the product for Visual Studio
2015.

vcvs2012_232. exe can take a number of parameters, enabling you to specify a number of different
types of installation:

+ Standard Installation

Format:
vcvs2012_232. exe
Summary:
Full installation including License Manager and Visual COBOL. During installation you can specify
options including the location to which the components are installed.
» Non-interactive Installation

Format:

vcvs2012 232. exe / passive

Summary:

Full installation, but the components are installed non-interactively using default options and
directories.

* Silent Installation

Format:
vcvs2012_232.exe /q
Summary:
Full installation, but the components are installed non-interactively with no user interface, using
default options and directories.
» Modified Silent Installation

Format:

vevs2012 232.exe /q I nstall Fol der=d:\otherdirectory

Summary:

Full installation, but the components are installed non-interactively with no user interface, and Visual
COBOL isinstalled to d: \ ot her di rect ory.

To see what parameters you can use, execute the following from the command line:
vcvs2012_232. exe /2.

y Note:

« Log files that are created during installation are saved in the folder specified by the TEMP
environment variable. To change the location or name of the files, use the / | og parameter on your
setup command line and specify the path and file name, for example: fi |l ename /1 og d:\tenp
\l og. t xt . This creates a log file, named | og. t xt , in the d: \ t enp directory.

After Installing

« See Changes in Behavior or Usage in your product documentation and in the Release Notes for
important information about changes in this release that might affect existing applications.
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» Check the Product Documentation section of the Micro Focus SupportLine Web site and the Micro
Focus Infocenter for any updates to the documentation which might have been uploaded.

On Windows

Starting the Product
You are now ready to run Visual COBOL:

* From the Windows taskbar, click Start > All Programs > Micro Focus Visual COBOL > Visual
COBOL for Visual Studio nnnn.

Note: The Start menu is not available on Windows 8, Windows 8.1, and Windows Server 2012. You
use the Start screen to invoke programs.

To view the documentation installed with your product:

« Ensure that the Visual Studio Help Library is pointing to local help - from the Visual Studio menu click
Help > Set Help Preferences > Launch in Help Browser.

For full details of the Visual Studio Help system, see the locally installed Microsoft Help Viewer Help, which
is available from Help menu in the IDE.

Note: On some Windows versions such as Windows 8 or Windows Server 2012, an issue with
Microsoft Help Viewer and Internet Explorer's security being turned on can cause the Help content to
be displayed as raw HTML code. To resolve the issue, you need to turn off the Internet Explorer
Enhanced Security Configuration (IE ESC) for both administrators and users. Check the Microsoft
Windows help for more information on how to do this.

Repairing

If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.

Uninstalling
To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs in Control Panel.
3. Select the product and click Remove or Uninstall as appropriate.

When you uninstall, the only files deleted are those that the installation software installed. If the product

directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.

Note: The installer creates separate installations for Micro Focus Visual COBOL and Micro Focus
License Administration. Uninstalling only Visual COBOL does not automatically uninstall the Micro
Focus License Administration or any of the prerequisite software.

To completely remove the product you must uninstall the Micro Focus License Administration as well.

You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Some registry entries are not removed by the uninstallation process and you need to manually delete
them.
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The following folders might not be removed:

e The M cro Focus Product Narme folder in the Start menu - you can delete it manually.

 OUsystendrive% Users\ Public\Docunent s\ M cro Focus - includes the binaries and the log
files of the samples which you have built.

e oFrogranbDat a% M cro Focus - includes some data files used by the Micro Focus licensing system.

e 9% rogram Fil es% M cro Focus - you can delete it manually.

To silently uninstall the product, you need the setup file and you need to execute the following at the
command line:

start /wait install-file.exe /quiet /uninstall

In addition, the following registry entries are not removed. These are created the first time that an
Enterprise Server that has been enabled for performance monitoring starts up:

* Micro Focus Server\Performance\Active Servers
¢ Micro Focus Server\Performance\PerflniFile
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When you activate Visual COBOL Personal Edition, you can use it for a limited period of 365 days.
After this period, you can either register a new Personal Edition license for 365 days or acquire a
valid license either for a 30-day trial or full license of Visual COBOL in order to continue using the
product.

If you have purchased licenses for a previous release of this product, those licenses will also
enable you to use this release.

Personal Edition licensing is only available with Visual COBOL for Visual Studio 2015

The latest version of the SafeNet licensing software is required. See the Software Requirements
section in this document for more details.

Your entitlement for using this product is governed by the Micro Focus End User License
Agreement and by your product order. If you are unsure of what your license entitlement is or if you
wish to purchase additional licenses, contact your sales representative or Micro Focus
SupportLine.

To activate Visual COBOL Personal Edition

To activate Personal Edition:

1. Start

Visual COBOL.

If you have not installed a license for Visual COBOL, starting the IDE and trying to create a COBOL

proje

ct opens the Micro Focus Visual COBOL Product Licensing dialog box. If you cancel this dialog

box, you can invoke it again from Help > Micro Focus Product Help > Product Licensing.

2. Click

| want to activate the free product.

3. Ensure that the email address used to register the product is in the Email address text entry field. If
you haven't registered your email address yet, click registration page and follow the instructions on
that page.

4. Select one of the following options:

Automatic Use this if you have Internet access.

1. Click Activate License to activate your copy of Visual COBOL Personal Edition.

Manual Use this if you are not connected to the Internet.

1. Click Send email.

This opens your default email client and creates a new email filled in with the details to
send to Micro Focus about activating your copy of the free Personal Edition of the
product.

f Note: If there is no mail client installed on your machine, click " next to Send
email, and click Display fields. You will be presented with a template that
includes the email address, the subject and the contents of an email to send to
Micro Focus using a mail client of your choice. Do not modify the details.

You will receive a response email with details about your authorization request.

2. Paste the contents of the response email in the designated field in the Micro Focus
Visual COBOL Product Licensing dialog box.

Licensing Information

39


http://supportline.microfocus.com/
http://supportline.microfocus.com/

3. Click Activate License.

This displays a message confirming your request for authorization has been
successful.
4. Click Close.

To request and activate a 30-day trial license for Visual
COBOL

1. Inthe IDE, click Help > Micro Focus Product Help > Product Licensing.

This opens the Micro Focus Visual COBOL Product Licensing dialog box.
2. Type your email address in the Email address text entry field.

You need to use the same email address you used for the registration.
3. Select one of the following options:

Automatic Use this if you have Internet access.
1. Click Activate License to activate the trial license for Visual COBOL.

A Important: After clicking Finish, if you click the Cancel button in the progress

—*~ dialog box to stop the activation process, the trial license might have registered on
Micro Focus servers but not yet be registered on your machine. If you request a trial
again then you can get a message saying that a trial license has already been
used. If this happens, you should contact a Micro Focus Sales representative to
obtain a new license.

You can do this by sending an email to VCBuyNow@microfocus.com, or selecting
Help > Micro Focus > Buy Now and using the contact options in the dialog box.

Manual Use this if you are not connected to the Internet.

1. Click Send email.

This opens your default email client and creates a new email filled in with the details to
send to Micro Focus about activating the trial license for Visual COBOL.

f Note: If there is no mail client installed on your machine, click " next to Send
email, and click Display fields. You will be presented with a template that
includes the email address, the subject and the contents of an email to send to
Micro Focus using a mail client of your choice. Do not modify the details.

2. Send the email.

You will receive a response email with details about your authorization request.

3. Paste the contents of the response email in the designated field in the Micro Focus
Enterprise Developer Product Licensing dialog box.

4. Click Activate License.

This displays a message confirming your request for authorization has been
successful.
5. Click Close.

After activation, you can see how many days your trial license has remaining by selecting Help > Micro
Focus > Product Licensing, or by using Micro Focus License Administration.
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To buy and activate a full unlimited license

To buy a license for Visual COBOL, contact your sales representative or Micro Focus SupportLine.

For instructions on using the Micro Focus Licensing Administration Tool, see Licensing in the Visual
COBOL help.

To start Micro Focus License Administration

From the Windows Taskbar click Start > All Programs >Micro Focus License Manager > License
Administration.

Note: On Windows 8, Windows 10, and Windows Server 2012, you use the Start screen to invoke
programs.

Installing licenses

If you have a license file

n

4.

Start Micro Focus License Administration.
Click the Install tab.
Do one of the following:

« Click Browse next to the License file field and select the license file (which has an extension
of .nflic).

» Drag and drop the license file from Windows Explorer to the License file field.

* Open the license file in a text editor, such as Notepad, then copy and paste the contents of the file
into the box below the License file field.

Click Install Licenses.

Alternatively, you can install the license file from within the IDE as follows:

1.
2.

o gk w

Start Visual COBOL.

Click Help > Micro Focus Product Help > Product Licensing to open the Product Licensing dialog
box.

Ensure | have a full Visual COBOL license is checked.

Click Browse next to the License file field.

Select the license file (which has an extension of . nf | i ¢), and then click Open.

Click Authorize to install the license.

You should see a dialog box with a confirmation that the licenses have been installed successfully.

If you have an authorization code

Licensing Information
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Authorizing your product when you have an Internet connection

The following procedure describes how to authorize your product using a local or network license server.
The license server is set up automatically when you first install the product.

whN e

4.

Start Micro Focus License Administration.

Click the Install tab.

Type the authorization code in the Enter authorization code field.
Click Authorize.

If you change the name of the machine running your license server after it has granted licenses, the
licenses stop working.

Authorizing your product when you don't have an Internet connection

This method of authorization is required if your machine does not have an Internet connection or if normal
(automatic) authorization fails.
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Start Micro Focus License Administration.

Click Manual Authorization on the Install page.

Make a note of the contents of the Machine ID field. You will need this later.
Do one of the following:

< If your machine has an Internet connection, click the SupportLine Web link in the Manual
Authorization Information window.

< If your machine does not have an Internet connection, make a note of the Web address and type it
into a Web browser on a machine that has an Internet connection.

The Micro Focus SupportLine Manual product authorization Web page is displayed.

Type the authorization code in the Authorization Code field. The authorization code is a 16-character
alphanumeric string supplied when you purchased your product.

Type the Machine ID in the Machine ID field.

Type your email address in the Email Address field.

Click Generate.

Copy the generated license string (or copy it from the email) and paste it into the box under the License
file field on the Install page.

10.Click Install Licenses.

To obtain more licenses

If you are unsure of what your license entitlement is or if you wish to purchase additional licenses for Visual
COBOL, contact your sales representative or Micro Focus SupportLine.

Licensing Information



Updates and SupportLine

Our Web site gives up-to-date details of contact numbers and addresses.

Further Information and Product Support

Additional technical information or advice is available from several sources.
The product support pages contain a considerable amount of additional information, such as:

« The Product Updates section of the Micro Focus SupportLine Web site, where you can download fixes
and documentation updates.

« The Examples and Utilities section of the Micro Focus SupportLine Web site, including demos and
additional product documentation.

* The Support Resources section of the Micro Focus SupportLine Web site, that includes troubleshooting
guides and information about how to raise an incident.

To connect, enter http://www.microfocus.com in your browser to go to the Micro Focus home page, then
click Support.

i Note: Some information may be available only to customers who have maintenance agreements.

If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web
site, www.microfocus.com. If you obtained the product from another source, such as an authorized
distributor, contact them for help first. If they are unable to help, contact us.

Also, visit:

e The Micro Focus Community Web site, where you can browse the Knowledge Base, read articles and
blogs, find demonstration programs and examples, and discuss this product with other users and Micro
Focus specialists. See http://community.microfocus.com.

e The Micro Focus YouTube channel for videos related to your product - see https://www.youtube.com/
user/MicroFocusintl.

Information We Need

However you contact us, please try to include the information below, if you have it. The more information
you can give, the better Micro Focus SupportLine can help you. But if you don't know all the answers, or
you think some are irrelevant to your problem, please give whatever information you have.

« The name and version number of all products that you think might be causing a problem.

e Your computer make and model.

* Your operating system version number and details of any networking software you are using.

* The amount of memory in your computer.

* The relevant page reference or section in the documentation.

* Your serial number. To find out these numbers, look in the subject line and body of your Electronic
Product Delivery Notice email that you received from Micro Focus.

On Windows, if you are reporting a protection violation you might be asked to provide a dump ( . dnp) file.
To produce a dump file you use the Unexpected Error dialog box that is displayed when a protection
violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as Nor ral
(recommended), click Dump, then specify a location and name for the dump file. Once the dump file has
been written you can email it to Micro Focus SupportLine.
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Alternatively, you might be asked to provide a log file created by the Consolidated Tracing Facility (CTF) - a
tracing infrastructure that enables you to quickly and easily produce diagnostic information detailing the
operation of a number of Micro Focus software components.

On Windows, you can use the Micro Focus SupportLine Support Scan Utility, MFSupportinfo, to create
either:

* a. |l ogfile that contains the details about your environment, Micro Focus SupportLine products, and
settings.

e a. zi p archive that includes the same information as the . | og file plus some product configuration
files from c:\ProgramData and the product installation log files.

M-Support | nf 0. exe is stored in <i nstal | -di r >\ bi n.
To run MFSupportinfo:

1. Start a 32-bit Enterprise Developer command prompt.
2. Enter MFSuppor ti nf o at the command prompt to start the utility.
3. Createa .| ogfile ora. zi p archive as follows:

a. To create a . | og file, click File > Save.

This prompts to save the . | og file, MFSupport | nf o_Log_Machi neNane_YYYY- MM DD_HH M\t
SS. | 0g, in the % enp%directory.

b. To create a. zi p archive, click Tools > Create Zip Package.

This creates a . zi p archive, M-Support | nfo_Log Machi neNanme_YYYY- M DD_HH MVt
SS. zi p, in the % enp%directory.

4. Send the diagnostic information to your Micro Focus SupportLine representative:
The following requires an Internet connection and an Email client:

a. Click Tools > Email Log to SupportLine to open the Email Log dialog box.
b. Fill in the required fields and click Send.

If the machine is not connected to the Internet or if there are no Email clients installed, copy either

the . | og file or the . zi p archive to a machine that is connected to the Internet. Use your Email client
to email the files to Micro Focus SupportLine at supportline@microfocus.com together with the Support
Incident (SI) number, if available, and any additional details that might be useful to diagnose the issues
that you are experiencing.

Creating Debug Files

If you encounter an error when compiling a program that requires you to contact Micro Focus SupportLine,
your support representative might request that you provide additional debug files (as well as source and
data files) to help us determine the cause of the problem. If so, they will advise you how to create them.
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Disclaimer

This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either
express or implied, including the warranties of merchantability and fithess for a particular purpose. In no
event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect,
incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers
have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation
of liability for consequential or incidental damages so the foregoing limitation may not apply.

Micro Focus is a registered trademark.

Copyright © Micro Focus 1984-2016. All rights reserved.
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